Go to advanced search

by jdb
Tue Aug 06, 2013 11:55 pm
Forum: Beginners
Topic: Recommended Size for SD Card
Replies: 14
Views: 5476

Re: Recommended Size for SD Card

I have 4 Pis running on 4Gb Class 4 cards. Is there a word for that? Alnumeration? The "speed" of an SD card really doesn't have much bearing on how fast the Pi actually performs. Class 10 has better sustained write speeds than class 4, but if you're running an operating system on it then your workl...
by jdb
Tue Aug 06, 2013 11:28 pm
Forum: Beginners
Topic: How many external Hard Drives can I hook up to a Pi?
Replies: 3
Views: 2374

Re: How many external Hard Drives can I hook up to a Pi?

I've managed 7 pendrives at once, and then ran out of hub ports. Slightly different to HDDs with big spinning power-hungry motors, but the principle is the same. Just be mindful that your total data bandwidth is going to be limited to a single USB2.0 bus speed of 480Mbit/s (on a good day with a foll...
by jdb
Tue Aug 06, 2013 11:17 pm
Forum: Beginners
Topic: Is my Pi broken? Or am I doing something wrong?
Replies: 11
Views: 1737

Re: Is my Pi broken? Or am I doing something wrong?

Welcome! Your kit has a preloaded SD card with a very, very old kernel + firmware. Lots of things have been fixed since that SD card was written more than a year ago. This is something that NOOBS was specifically created for. You should take that SD card and plug it into a PC/laptop with SD card rea...
by jdb
Tue Aug 06, 2013 9:34 pm
Forum: Troubleshooting
Topic: Destination Folder Access Denied Samba
Replies: 9
Views: 3985

Re: Destination Folder Access Denied Samba

Your umask/dmask is set to disallow group/everyone write access. If you change the fstab options umask to 0000 / dmask to 0000 then it should work, but let everyone access to everything. vfat isn't particularly useful with file permissions - it does not allow for unix style uid/gid except globally. ...
by jdb
Tue Aug 06, 2013 9:14 pm
Forum: Troubleshooting
Topic: Destination Folder Access Denied Samba
Replies: 9
Views: 3985

Re: Destination Folder Access Denied Samba

Can you post the output of mount
by jdb
Tue Aug 06, 2013 12:49 pm
Forum: Troubleshooting
Topic: Keep 'losing' one of two HD's
Replies: 62
Views: 7653

Re: Keep 'losing' one of two HD's

you could install smartmon tools sudo apt-get update sudo apt-get install smartmontools Smartmontools most often doesn't work on USB hard disks. The USB to sata / pata bridges inside external HDD caddies typically do not pass through the necessary commands for SMART because they abstract the drive ...
by jdb
Tue Aug 06, 2013 12:10 pm
Forum: Troubleshooting
Topic: Keep 'losing' one of two HD's
Replies: 62
Views: 7653

Re: Keep 'losing' one of two HD's

dmesg prints out the contents of the kernel log buffer. The kernel log starts at boot time and will print to the screen (so you can see if anything broke or the machine crashed) until the normal boot process stops the output from printing. The log will still fill up, but only in memory. The buffer w...
by jdb
Mon Aug 05, 2013 8:46 pm
Forum: Troubleshooting
Topic: Samba Install Problems
Replies: 13
Views: 9610

Re: Samba Install Problems

Don't really understand this. One of the common things to do with the Pi (apart from create an xbmc media centre) is to use it as a NAS drive. People say they have done this using the Raspbian Wheezy distro which is exactly what I am using. However, the truth is that Raspbian apparently uses a non-...
by jdb
Mon Aug 05, 2013 1:44 pm
Forum: Troubleshooting
Topic: Samba Install Problems
Replies: 13
Views: 9610

Re: Samba Install Problems

The error message "filesystem is read-only" does exactly what it says on the tin. You are using a filesystem that has no documentation publicly available as to the internal workings and therefore the default Linux driver will have read-only support in case it encounters something it doesn't understa...
by jdb
Mon Aug 05, 2013 1:33 pm
Forum: Troubleshooting
Topic: USB Soundcard Prevents Boot
Replies: 12
Views: 6646

Re: USB Soundcard Prevents Boot

What happens if you do this: a) Put dwc_otg.speed=1 in cmdline.txt b) Boot with the codec plugged in c) Unplug the device after the pi appears to "hang"? I've got something of a similar flavour on my desk - Behringer UCA202, which doesn't suffer from this problem. Bus 001 Device 004: ID 08bb:2902 Te...
by jdb
Thu Aug 01, 2013 6:52 pm
Forum: Troubleshooting
Topic: USB redux
Replies: 514
Views: 196722

Re: USB redux

A USB device failing, or the USB driver failing usually results in either - Kernel panic (no reboot, unless you have either panic=10 on the commandline or the watchdog set up) - Device becoming unresponsive, which may or may not have associated syslog spam - USB in general breaking and becoming unre...
by jdb
Wed Jul 31, 2013 1:45 pm
Forum: Troubleshooting
Topic: USB FIQ testing....
Replies: 181
Views: 70453

Re: USB FIQ testing....

I am afraid it is not. Using the above mentioned device, audacity via LAN-connection on a windows machine with XMING/Putty and fiq_split_enable=0 still has defects at 44.1 kHz stereo recording, although much less pronounced as compared to enabled fiq_split. That case falls under the catch-all that'...
by jdb
Tue Jul 30, 2013 11:39 pm
Forum: Troubleshooting
Topic: USB FIQ testing....
Replies: 181
Views: 70453

Re: USB FIQ testing....

An update is now available via rpi-update that should mitigate several of the issues that have appeared with USB sound devices since the fiq_split branch was merged. This should, at the very least, get audio playback to where it was before with some slight improvements. There are known limitations t...
by jdb
Mon Jul 29, 2013 11:03 pm
Forum: Troubleshooting
Topic: Excessive current usage
Replies: 17
Views: 4694

Re: Hub getting hot

Can you substitute the A-B connector from the Pi to the hubs for another? One possibility is a cable with a short in it. If not, then if you substitute the Pi for another, do the hubs still stay hot? If your problem goes away when substituting the Pi for another then the Pi is defective and should b...
by jdb
Thu Jul 25, 2013 9:38 pm
Forum: Troubleshooting
Topic: Smokey with computer PSU
Replies: 2
Views: 444

Re: Smokey with computer PSU

Was the polarity correct?
by jdb
Thu Jul 25, 2013 8:43 pm
Forum: Troubleshooting
Topic: USB/serial converters (not very) broken on Pi
Replies: 162
Views: 108265

Re: USB/serial converters (not very) broken on Pi

Both USB and LAN are dodgy on raspi not to mention SD card corruption problem. My advice to you is to buy a cheap Asus eee pc and run your card sharing server on it. I use it and it is rock-solid. You can buy a used one for around 60 euros. SD card corruption? https://github.com/raspberrypi/linux/c...
by jdb
Thu Jul 25, 2013 8:38 pm
Forum: Troubleshooting
Topic: Excessive current usage
Replies: 17
Views: 4694

Re: Hub getting hot

Weird. What is your TP1-TP2 voltage on the Pi with the Pi's power supply on? The only thing I can think of is internal and external power supplies fighting each other. Can you do a "loopback" power test? i.e. use hub external power, then plug one of the downstream hub ports with a USB A - micro B ca...
by jdb
Mon Jul 22, 2013 9:24 pm
Forum: Troubleshooting
Topic: Prevent SD-Card Corruption
Replies: 241
Views: 226293

Re: Prevent SD-Card Corruption

That sounds like I have to make sure that the PSU sense line needs more power take off then one raspberry pi. Where do I find this PSU sense lead? It should be on the 24pin header going to the motherboard? (I converted blindly an old PSU from a dell and hooked it up to a lacie nas server as that po...
by jdb
Sat Jul 20, 2013 9:18 pm
Forum: Troubleshooting
Topic: USB FIQ testing....
Replies: 181
Views: 70453

Re: USB FIQ testing....

I've identified two root causes of issues relating to USB audio DACs - one that was always there (caused by high interrupt loading), the other that was brought to the fore by the way the split-transaction allocation now works with the FIQ. These aren't going to be quick or simple fixes. For mitigati...
by jdb
Fri Jul 19, 2013 8:27 pm
Forum: Troubleshooting
Topic: USB External HDD Slow speed max 5.7 mb/s
Replies: 12
Views: 4458

Re: USB External HDD Slow speed max 5.7 mb/s

What does mount say?

NTFS (either ntfs-3g or kernel-mode driver) is CPU-intensive on Pi.
by jdb
Fri Jul 19, 2013 7:47 pm
Forum: Troubleshooting
Topic: USB FIQ testing....
Replies: 181
Views: 70453

Re: USB FIQ testing....

Oh - oops Yes, for single TT hubs they will only have one interface and so will omit the interface descriptor(s). bDeviceProtocol is the field to use. For comparison: sudo lsusb -v -d 1a40:0101 | grep bDeviceProtocol bDeviceProtocol 1 Single TT bDeviceProtocol 0 Full speed (or root) hub sudo lsusb -...
by jdb
Fri Jul 19, 2013 9:04 am
Forum: Troubleshooting
Topic: USB FIQ testing....
Replies: 181
Views: 70453

Re: USB FIQ testing....

GrayShade wrote:I only have the DAC and it seems it doesn't have asynchronous endpoints for playback:

dmesg output: http://pastebin.com/jVaZVNEd
lsusb output: http://pastebin.com/UsKWaZJF
What audio format are you playing? Sample rate/bitrate? I mean the source audio, not what you set ALSA to.
by jdb
Thu Jul 18, 2013 11:35 pm
Forum: Troubleshooting
Topic: USB/serial converters (not very) broken on Pi
Replies: 162
Views: 108265

Re: USB/serial converters (not very) broken on Pi

Jul 18 14:25:05 raspberrypi kernel: [ 7569.676554] NYET/NAK/ACK/other in non-error case, 0x00000002 Jul 18 14:57:25 raspberrypi kernel: [ 9509.790223] ERROR::handle_hc_chhltd_intr_dma:2579: handle_hc_chhltd_intr_dma: Channel 2, DMA Mode -- ChHltd set, but reason for halting is unknown, hcint 0x0000...
by jdb
Thu Jul 18, 2013 10:31 pm
Forum: Troubleshooting
Topic: USB FIQ testing....
Replies: 181
Views: 70453

Re: USB FIQ testing....

To anyone using USB audio DACs: The current FIQ implementation will make USB audio sound cards/DACs play very choppy/distorted/static sound if all of the following conditions are met: - You have a hub with a single Transaction Translator (cheap chip inside) - You plug another full speed/low speed de...
by jdb
Tue Jul 16, 2013 10:58 pm
Forum: Troubleshooting
Topic: USB dongle appears in lsusb but not in /dev
Replies: 25
Views: 12289

Re: USB dongle appears in lsusb but not in /dev

I have one of these. WorksForMe(tm) [ 28.788802] hub 1-1.3:1.0: state 7 ports 7 chg 0000 evt 0008 [ 28.789430] hub 1-1.3:1.0: port 3, status 0101, change 0001, 12 Mb/s [ 28.949241] hub 1-1.3:1.0: debounce: port 3: total 100ms stable 100ms status 0x101 [ 29.029226] usb 1-1.3.3: new high-speed USB dev...

Go to advanced search