Go to advanced search

by Mettauk
Wed Jul 25, 2018 9:16 pm
Forum: General discussion
Topic: PCB connector confusion
Replies: 7
Views: 643

Re: PCB connector confusion

The Traveler wrote:
Wed Jul 25, 2018 6:12 pm
Do you know what device this power supply is from? It looks like it came out of another device and knowing what it was would help a bit.
No idea what it is from, but it is a standard JY-72-18 PSU.
by Mettauk
Wed Jul 25, 2018 9:11 pm
Forum: General discussion
Topic: PCB connector confusion
Replies: 7
Views: 643

Re: PCB connector confusion

I only know molex as the old round pin connectors, usually in computers for connecting drives. These are square and a little smaller. Without a reference I'm finding it really hard to find the right thing!
Oh and in my case Zarg is currently in Brexitland!
by Mettauk
Wed Jul 25, 2018 5:59 pm
Forum: General discussion
Topic: PCB connector confusion
Replies: 7
Views: 643

PCB connector confusion

I am adapting an 18v DC supply for a project and it comes with 240v AC input and 18v DC output but I don't recognise the board connectors. I managed to find the male pins on ebay but cant find the female version to connect my wiring? Pins are approx 5mm pitch and are square 1.17mm x 1.17mm x 11mm hi...
by Mettauk
Tue Apr 17, 2018 11:00 am
Forum: Beginners
Topic: Lidar Lite V3 - Raspberry Pi - Python
Replies: 32
Views: 13593

Re: Lidar Lite V3 - Raspberry Pi - Python

Mettauk wrote:
Tue Apr 17, 2018 10:34 am
Can you expand/explane on the changes to get LLv3 working without rolling back?
I have rolled back the kernel to 4.4.50 from 20 Feb 2017 and it now seems to work but of course I loose so many changes inc Pi3b+ stuff
by Mettauk
Tue Apr 17, 2018 10:34 am
Forum: Beginners
Topic: Lidar Lite V3 - Raspberry Pi - Python
Replies: 32
Views: 13593

Re: Lidar Lite V3 - Raspberry Pi - Python

Can you expand/explane on the changes to get LLv3 working without rolling back? One does not need to roll back to an early 2017 or 2016 kernel to solve the problem. Check out the discussion of this problem on github. https://github.com/raspberrypi/firmware/issues/828 One simply needs to modify the I...
by Mettauk
Mon Mar 19, 2018 9:53 pm
Forum: Troubleshooting
Topic: Issue with XPT2046 5inch touchscreen on RPi3b+
Replies: 0
Views: 299

Issue with XPT2046 5inch touchscreen on RPi3b+

Just tried to add the 5inch touch screen to my new Pi 3b+ and can't get the touch screen to work at all, it does not seem to recognise it at all. sudo apt-get install xserver-xorg-input-evdev sudo apt-get install -y xinput-calibrator installs the calibration software but when run the touch screen is...
by Mettauk
Fri Feb 09, 2018 10:17 pm
Forum: Troubleshooting
Topic: Damaged GPIO 2 SDA
Replies: 5
Views: 706

Re: Damaged GPIO 2 SDA

Thank you, very useful for other projects but as I need the camera to, this is not an option on this occasion.
by Mettauk
Thu Feb 08, 2018 4:48 pm
Forum: Troubleshooting
Topic: Damaged GPIO 2 SDA
Replies: 5
Views: 706

Damaged GPIO 2 SDA

Think I may have fried a Pi3b as on testing GPIO 2 (Pin 3) SDA1 I2C as on test I get 0.60v which should be 3.3 ish. I need to use I2c and am wondering is there an alternative pin?

Wishful thinking or another £33?
by Mettauk
Wed Jan 17, 2018 7:27 pm
Forum: Troubleshooting
Topic: Reading GPIO states via web interface - php
Replies: 2
Views: 917

Re: Reading GPIO states via web interface - php

Thank you, it works sort of now, I am trying to use that result for something like... $status = shell_exec("/usr/local/bin/gpio -g read 17"); if $status = 0 ; echo "WOW its O"; else if $status = 1 ; echo "OH no its 1"; I Which does not work but I don't know the correct method EDIT... found it sort o...
by Mettauk
Wed Jan 17, 2018 5:31 pm
Forum: Troubleshooting
Topic: Reading GPIO states via web interface - php
Replies: 2
Views: 917

Reading GPIO states via web interface - php

I have the following code in a php page that will switch a relay on or off and tells me when its done. But, when I open the page I can't tell the current state (high or low, 0 or 1). Can someone guide me how to include a call to read and display current state of a GPIO? ... <p><form method="get" act...
by Mettauk
Mon May 22, 2017 9:18 pm
Forum: Advanced users
Topic: Linux kernel is now 4.4
Replies: 114
Views: 67650

Re: Linux kernel is now 4.4

I have some issues with the updates to numerious Pi that I updated/upgraded on 1st May 2017 and until today had not noticed that it had also affected I2C on a pi with motor controlers (PicoBorg Reverse). The issues remind me of when the Pi 3 came out and all sorts of software fell over with the upda...
by Mettauk
Mon May 22, 2017 5:11 pm
Forum: Troubleshooting
Topic: Since update can't access WebIOpi via http
Replies: 5
Views: 870

Re: Since update can't access WebIOpi via http

OK, a few weeks have passed and no solution to update/upgrade problem messing up WebIOpi and pan/tilt from mind sensors software. But now the update/upgrade also messes up I2C on PicoBorg Reverse (PiBorg) Reverting to an older kernal sorts it??? See https://www.piborg.org/node/2396 What is going on!
by Mettauk
Wed May 03, 2017 10:30 am
Forum: Troubleshooting
Topic: Since update can't access WebIOpi via http
Replies: 5
Views: 870

Re: Since update can't access WebIOpi via http

rpi-update is not recommended as it installs a testing and likely experimental kernel /firmware, yes things break. In Raspbian Jesssie a stable kernel is installed via apt-get update & dist-upgrade ;) On my 3B running Jessie fully updated "Linux raspberrypi 4.9.24-v7+ #993 SMP Wed Apr 26 18:01:23 B...
by Mettauk
Wed May 03, 2017 7:36 am
Forum: Troubleshooting
Topic: Since update can't access WebIOpi via http
Replies: 5
Views: 870

Re: Since update can't access WebIOpi via http

DougieLawson wrote:Are you running this version: http://webiopi.trouch.com/
Have been running updated version for some years, I run Rpi update about once a month on all Pi. No problems until 1st May.

Just tried reinstalling WebioPi but port still not opening yet WebioPi seems to be running
by Mettauk
Tue May 02, 2017 7:58 pm
Forum: Troubleshooting
Topic: Numerous failures after Rpi update
Replies: 0
Views: 287

Numerous failures after Rpi update

After sudo apt-get update && sudo apt-get dist-upgrade on 01/05/2017 a few Pi (Pi2, Pi3 and a 1b) all sorts of software is failing to work after the update (All were updated about a month ago without any problems, so whats changed in the last month? 1/ Adafruit DHT temp/humidity software failed (now...
by Mettauk
Tue May 02, 2017 7:35 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 4984
Views: 1254370

Re: RPi Cam Web Interface

RPi Cam Pan and Tilt fails after running sudo apt-get update && sudo apt-get dist-upgrade. Also having other problems unrelated to RPi Cam but all since updating a number of Pi on 1 May 2017

Anyone know whats going on? or has the same problem?
by Mettauk
Tue May 02, 2017 12:33 pm
Forum: Troubleshooting
Topic: After update DHT22 with read (Adafruit_DHT.read_retry..
Replies: 4
Views: 2507

Re: After update DHT22 with read (Adafruit_DHT.read_retry..

joan wrote:What has the Beaglebone Black got to do with the Raspberry Pi?
Very little except the Adafruit software works with both and throws an error if it can find either!
by Mettauk
Tue May 02, 2017 12:32 pm
Forum: Troubleshooting
Topic: After update DHT22 with read (Adafruit_DHT.read_retry..
Replies: 4
Views: 2507

Re: After update DHT22 with read (Adafruit_DHT.read_r.(FIXED

fredoll wrote:update to the latest version of the Adafruit library.
There was a change in the name of the CPU reported in /proc/cpuinfo
Ah, thank you. That fixed it. When did something change because I'm also having trouble we a web port and WEBiopi?
by Mettauk
Tue May 02, 2017 12:21 pm
Forum: Troubleshooting
Topic: After update DHT22 with read (Adafruit_DHT.read_retry..
Replies: 4
Views: 2507

After update DHT22 with read (Adafruit_DHT.read_retry..

After running sudo apt-get update && sudo apt-get dist-upgrade, Adafruit DHT no longer works? Its as though the software no longer recognises the pi? Error i get from running a python script to read DHT22 $ sudo python humtemp.py Traceback (most recent call last): File "humtemp.py", line 15, in <mod...
by Mettauk
Tue May 02, 2017 8:55 am
Forum: Troubleshooting
Topic: Since update can't access WebIOpi via http
Replies: 5
Views: 870

Since update can't access WebIOpi via http

Webiopi seems broken after RPI update/upgrade!

I can't access a web interface that controls some relays that was set up on port 8080 with WebIOPi. The port has been closed since the rpi update yesterday! PLUS all the relays come on at boot! Even though only one was set to high at boot!
Help!
by Mettauk
Tue Apr 18, 2017 8:10 am
Forum: Raspbian
Topic: Update package error
Replies: 1
Views: 418

Update package error

I get the following messages after running sudo apt-get update && sudo apt-get dist-upgrade I am unsure what to do to rectify the error? System: Linux MyPiComp 4.4.50+ #970 Mon Feb 20 19:12:50 GMT 2017 armv6l GNU/Linux NAME="Raspbian GNU/Linux" VERSION_ID="8" VERSION="8 (jessie)" Calculating upgrade...
by Mettauk
Mon Mar 27, 2017 10:49 pm
Forum: Raspbian
Topic: Error on Update/Upgrade
Replies: 0
Views: 273

Error on Update/Upgrade

When running sudo apt-get update && sudo apt-get dist-upgrade I get errors. I have tried Autoremove and Clean and don't know how to fix the following... ...Calculating upgrade... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 3 not fully installed or removed. Need to get 41.9 kB...
by Mettauk
Wed Mar 01, 2017 4:12 pm
Forum: General discussion
Topic: PI Zero W info
Replies: 80
Views: 12599

Re: PI Zero W - why no info on this site?

£9.50 is not a lot to pay for the convenience of integrated WiFi/BT ... A particular advantage is a Zero W can be a USB peripheral while using WiFi/BT. ... The only things which would make it better for me are an external antenna connector ( for which there seems to be solder pads already ), and ba...
by Mettauk
Mon Feb 13, 2017 10:56 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 4984
Views: 1254370

Re: RPi Cam Web Interface

I just upgraded to jessie lite and installed using the install script. All seems to be okay until I try on Chrome, I see the Index of / folder view". How do I go from here. I am used to seeing the camera interface with the live video. Can someone help. thanks, This is an issue I keep having on new ...
by Mettauk
Tue Dec 13, 2016 11:57 am
Forum: Camera board
Topic: Solution planned for the bad lenses of the V2 8MP RasPi cam?
Replies: 47
Views: 18795

Re: Solution planned for the bad lenses of the V2 8MP RasPi

jamesh wrote: The Sony camera works, it's not a failed replacement. It may not be great optically, but it does work.
That seems like a #PostTruth reply! It sort of works, but most things are out focus except either the edge or the centre, but not both. To name just one major issue.

Go to advanced search