Go to advanced search

by Mettauk
Mon Apr 25, 2016 9:35 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 4983
Views: 1251886

Re: RPi Cam Web Interface

Just waiting for the new 8mp camera module and wondering how RPi software will adjust to the changes in fov etc?

Also, a big thank you to 'him' that developed RPi Cam and to those that have continued to enhance and develop this fantastic software!
by Mettauk
Mon Apr 25, 2016 10:49 am
Forum: Camera board
Topic: New 8MP Camera - Q&A thread
Replies: 450
Views: 186276

Re: New 8MP Camera - Q&A thread

Anyone know what the light sensitivity or f is for the new 8mp camera/lens combo on the standard and IR models?
by Mettauk
Tue Apr 12, 2016 1:24 pm
Forum: Troubleshooting
Topic: Install error insserv: warning: missing LSB?
Replies: 5
Views: 1990

Re: Install error insserv: warning: missing LSB?

Thanks, yes, now working.
by Mettauk
Wed Apr 06, 2016 6:41 pm
Forum: Raspbian
Topic: apt-get update / install problem
Replies: 4
Views: 1586

Re: apt-get update / install problem

Problem with apt-get update...

Code: Select all

...
Fetched 9,252 kB in 16s (572 kB/s)
Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/dpkg/status
E: The package lists or status file could not be parsed or opened.
Anyone know how to fix this?
by Mettauk
Wed Apr 06, 2016 10:46 am
Forum: Troubleshooting
Topic: Install error insserv: warning: missing LSB?
Replies: 5
Views: 1990

Re: Install error insserv: warning: missing LSB?

Also just tried to do a update/dist-upgrade and get the following error... The following packages will be upgraded: apt apt-utils gnupg gpgv gtk2-engines-pixbuf imagemagick-common initramfs-tools libapache2-mod-php5 libapt-inst1.5 libapt-pkg4.12 libc-bin libc-dev-bin libc6 libc6-dbg libc6-dev libcai...
by Mettauk
Mon Apr 04, 2016 10:09 pm
Forum: Troubleshooting
Topic: Install error insserv: warning: missing LSB?
Replies: 5
Views: 1990

Install error insserv: warning: missing LSB?

I have Alexa Echo working almost perfectly and RPi camera, but when trying to get the pan and tilt system working for the camera I get the following error when installing pi-pan from Mindsensors pi@Pi3b:~/pi-pan $ sudo ./install-pi-pan.bash Updating config files... Updating PiPan and Pilight librari...
by Mettauk
Thu Mar 31, 2016 12:26 am
Forum: Automation, sensing and robotics
Topic: Running the Alexa Voice Service on the raspberry pi?
Replies: 5
Views: 2248

Re: Running the Alexa Voice Service on the raspberry pi?

I got this working on a Pi3b with a USB webcam mic and initially using a bluetooth speaker but once I installed Echo the bluetooth speaker failed (some of the time) so wired it in and had some success after getting some audio errors. I can ask Echo some fun questions though, now to get it switching ...
by Mettauk
Mon Mar 28, 2016 11:11 am
Forum: Networking and servers
Topic: Getting WebIOpi and PHP on the same port in apache2
Replies: 0
Views: 479

Getting WebIOpi and PHP on the same port in apache2

I'm trying to integrate gpio switching and the RPI camera interface using webiopi v 0.7.1 in Jessie on a Pi2b & 3b) so that I can see camera output, control pan and tilt etc, monitor temperature sensors AND switch stuff on and off within the same php served pages. It all works perfectly on seperate ...
by Mettauk
Sun Mar 27, 2016 4:54 pm
Forum: Raspbian
Topic: Mixing webioPI with RPi Cam Apache2 Jessie on ONE port
Replies: 0
Views: 336

Mixing webioPI with RPi Cam Apache2 Jessie on ONE port

I'm trying to integrate gpio switching within the RPI camera interface using webiopi (Jessie on Pi2b & 3b) so that I can see camera output and control it AND switch stuff on and off plus see temperature readings etc within the same php served pages. Both work perfectly on separate ports, So Rpi Cam ...
by Mettauk
Thu Mar 17, 2016 11:23 am
Forum: Troubleshooting
Topic: Jessie Network settings nightmare
Replies: 2
Views: 518

Re: Jessie Network settings nightmare

The "169.254.37.160/16" means it failed to acquire an address using DHCP so it assigned itself a local link address. Since the wireless connects it seems the router is up and assigning addresses, so most likely it's a bad ethernet cable, bent pin in a connector/jack, etc. Er, no bent pins, good cab...
by Mettauk
Thu Mar 17, 2016 10:25 am
Forum: Troubleshooting
Topic: Jessie Network settings nightmare
Replies: 2
Views: 518

Jessie Network settings nightmare

Updating numerous boards to Jessie. Most are networked on Ethernet with the router locking the IP address once established via dhcp. This works in Wheezy and SOMETIMES with Jessie! Jessie (all updated as at 17 Mar 2016) is very hit and miss. The router is say at 192.168.1.10 and has a range from say...
by Mettauk
Sat Mar 12, 2016 9:46 pm
Forum: General discussion
Topic: Webiopi doesn't work on Raspberry Pi 2
Replies: 38
Views: 38445

Re: Webiopi doesn't work on Raspberry Pi 2

I have the patched version now working with a Pi 3b so it is possible!! But, it does give errors on instalation so it might not be "fully" working?!
by Mettauk
Wed Mar 02, 2016 4:11 pm
Forum: Troubleshooting
Topic: Wheezy EOL... Bit soon surely RPF?
Replies: 2
Views: 555

Wheezy EOL... Bit soon surely RPF?

Just read another post saying Wheezy is no longer supported. Downloaded a copy from RPF just a few months ago. Now wondering about my pi setups that probably won't work with Jessie etc... How long will the RPF support its promoted distributions for the Pi and how much notice can people expect, espec...
by Mettauk
Wed Mar 02, 2016 10:37 am
Forum: Camera board
Topic: Disable camera led on Pi3
Replies: 19
Views: 12338

Disable camera led on Pi3

Apparently due to gpio changes on the Pi3 b disable_camera_led=1 no longer works.

Any ideas of anther way anyone?
by Mettauk
Wed Mar 02, 2016 12:18 am
Forum: Troubleshooting
Topic: Pi 3 & disable_camera_led=1 = cam crash
Replies: 11
Views: 2371

Pi 3 & disable_camera_led=1 = cam crash

Testing out RPi Cam on the Pi3 and if I put

Code: Select all

disable_camera_led=1
within /boot/config.txt it causes the camera to fail in the RPi software.

Running Jessie with latest update & dist-upgrade as at 23.30 on 1 Mar 2016.
by Mettauk
Wed Mar 02, 2016 12:03 am
Forum: General discussion
Topic: Webiopi doesn't work on Raspberry Pi 2
Replies: 38
Views: 38445

Re: Webiopi doesn't work on Raspberry Pi 2

Seems to patched version does not work on the Pi3 b either!
by Mettauk
Tue Jan 19, 2016 7:02 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 4983
Views: 1251886

Re: RPi Cam Web Interface

dspalton wrote:hi guys
trying to install on a 32Gb SD card, but getting device has run out of space...
how much space is needed to install?
Dave
Not that much space! I have RPi + loads of other stuff on an 8gb card with 3gb + left for more. Have you expanded the 32gb card

Code: Select all

sudo raspi-config 
by Mettauk
Fri Jan 08, 2016 9:52 am
Forum: Official Foundation Display
Topic: Pi Touch Screen falling apart - Contacting the Swag Store
Replies: 10
Views: 1149

Re: Pi Touch Screen falling apart - Contacting the Swag Stor

Hello Mettauk, Did you make any progress in this issue? Yesterday I noticed, too, that the glass lid separated itself from the LCD panel. It seems that the used glue is of poor quality. I read that the screen was a industrial-quality one... No comment. Can someone recommend an appropriate glue to r...
by Mettauk
Thu Jan 07, 2016 3:56 pm
Forum: Python
Topic: Sound to Bluetooth from python
Replies: 14
Views: 4419

Re: Sound to Bluetooth from python

-rst- wrote:And the Python code you use to call mplayer?
imports within script are

Code: Select all

#import
import RPi.GPIO as GPIO

#time
import time

#IP etc
import socket
import os

#DHT 
import Adafruit_DHT
I'm not sure how to import mplayer?
by Mettauk
Wed Jan 06, 2016 4:45 pm
Forum: Python
Topic: Capacitative touch switch(s)
Replies: 2
Views: 1303

Re: Capacitative touch switch(s)

Thank you,
I think I will attempt event_detected() as it looks like what I'm looking for, if I can get my head round it! :)
by Mettauk
Wed Jan 06, 2016 8:49 am
Forum: Windows 10 for IoT
Topic: Powering RPi and 12v device with single power cable
Replies: 3
Views: 684

Re: Powering RPi and 12v device with single power cable

You can buy 12v with 5v DC transformers, often used for old portable hard drives etc. You could split the cable or use an adaptor to split the 5 and 12 volts. Something like this http://m.ebay.co.uk/itm/12V-5V-AC-Power-Supply-Adapter-with-14-2-Cable-for-HDD-HARD-DISK-DRIVE-IDE-/171708566445?nav=SEAR...
by Mettauk
Mon Jan 04, 2016 3:09 pm
Forum: Python
Topic: Capacitative touch switch(s)
Replies: 2
Views: 1303

Capacitative touch switch(s)

I'm sort of teaching myself python... so please forgive this attempt #!/usr/bin/python #-------------------------------------- #import import RPi.GPIO as GPIO import time # Define GPIO mapping TOUCH = 17 LED_01 = 27 # Use BCM GPIO numbers GPIO.setmode(GPIO.BCM) # Use BCM GPIO numbers GPIO.setup(TOUC...
by Mettauk
Sun Jan 03, 2016 8:29 pm
Forum: Python
Topic: Sound to Bluetooth from python
Replies: 14
Views: 4419

Sound to Bluetooth from python

Hi I can play sound on a Bluetooth speaker via the command line with say mplayer -ao alsa:device=bluetooth /nums/32.wav but if I put this in a python file I get the following MPlayer svn r34540 (Raspbian), built with gcc-4.6 (C) 2000-2012 MPlayer Team mplayer: could not connect to socket mplayer: No...
by Mettauk
Tue Dec 22, 2015 2:24 pm
Forum: Official Foundation Display
Topic: Screen slid down
Replies: 2
Views: 819

Re: Screen slid down

I have had the official display in use for a few weeks, standing upright on one of the shorter sides. Not it seems to have slid down a few millimeters that way. I've attached a picture of it. Not only is part of the display now no longer visible, the touchscreen is no longer calibrated right. Can I...

Go to advanced search