Go to advanced search

by Joel_Mckay
Fri Jan 03, 2014 1:24 am
Forum: Troubleshooting
Topic: Dec 2013 Raspbian Wheezy firmware update often hangs system
Replies: 0
Views: 363

Dec 2013 Raspbian Wheezy firmware update often hangs system

tried with new Stable kernel & firmware, and hangs in around 24 hours sudo apt-get update sudo apt-get upgrade tried with Head kernel & firmware, and hangs in around 16 hours sudo rpi-update tried downgrading the kernel back, and still hangs in around 16 hours >uname -a Linux blueberrypi 3.6.11+ #47...
by Joel_Mckay
Wed Jun 12, 2013 8:40 am
Forum: Camera board
Topic: Camera module blocks access to second i2c bus on port5?
Replies: 13
Views: 6581

Re: Camera module blocks access to second i2c bus on port5?

Camera accesses the I2C via a I2C driver on the GPU. This code is closed source, but the I2C driver on the GPU is a very well tested bit of code. Camera driver itself isn't so well tested - I'll be looking at that when time allows. It is rumoured a V4L interface is in the development path as well, ...
by Joel_Mckay
Sun Jun 09, 2013 9:41 pm
Forum: Camera board
Topic: Camera module blocks access to second i2c bus on port5?
Replies: 13
Views: 6581

Re: Camera module blocks access to second i2c bus on port5?

Custom C program to enable io access with the i2c-0 kernel module character device (based on offset noted in this thread ). They can work when configured independently, but the camera seems to enter into a resource contention when the port 5 interface is enabled. For your situation, one could probe ...
by Joel_Mckay
Sun Jun 09, 2013 9:14 am
Forum: Camera board
Topic: Camera module blocks access to second i2c bus on port5?
Replies: 13
Views: 6581

Camera module blocks access to second i2c bus on port5?

Once the second i2c bus is enabled the camera becomes unusable: >raspistill -o image.jpg mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEM) mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (1) mmal: Failed to create camera component mmal...
by Joel_Mckay
Fri Jan 11, 2013 3:53 am
Forum: Beginners
Topic: Raspbian- Octave - installing packages
Replies: 25
Views: 15030

Re: Raspbian- Octave - installing packages

@randomvibe There are actually two ways to do this: 1. Create a loadable Octave C++ binary user lib. Andy seems quite knowledgeable in this area, and can likely offer guidance on how to avoid common issues. 2. Create a C++ program and use liboctave resources similar to this process: You will need to...
by Joel_Mckay
Thu Jan 10, 2013 5:04 am
Forum: Beginners
Topic: Raspbian- Octave - installing packages
Replies: 25
Views: 15030

Re: Raspbian- Octave - installing packages

@Andy, thanks for the comment... but I wouldn't answer if I hadn't tried it myself. Current repo for octave in wheezy is v3.6. And the octave "pkg" command uses the same compiler wrapper for custom octave C++ binary modules. Notably, randomvibe could create a custom module if the io permissions are ...
by Joel_Mckay
Mon Jan 07, 2013 4:17 am
Forum: Other programming languages
Topic: additional Octave packages for RasPi?
Replies: 3
Views: 3071

Re: additional Octave packages for RasPi?

1.) Check which kernel and OS you are running: pi@hosts ~/> uname -a Linux hosts 3.2.27+ #250 PREEMPT Thu Oct 18 19:03:02 BST 2012 armv6l GNU/Linux pi@hosts ~/> cat /etc/*-release PRETTY_NAME="Debian GNU/Linux 7.0 (wheezy)" NAME="Debian GNU/Linux" VERSION_ID="7.0" VERSION="7.0 (wheezy)" ID=debian AN...
by Joel_Mckay
Sat Jan 05, 2013 3:55 am
Forum: Other projects
Topic: PiCalc
Replies: 1
Views: 1106

Re: PiCalc

Have you tried:

Code: Select all

sudo apt-get install tiemu 
Note octave is very easy to learn too, and is free to use.
by Joel_Mckay
Sat Jan 05, 2013 2:27 am
Forum: Beginners
Topic: Raspbian- Octave - installing packages
Replies: 25
Views: 15030

Re: Raspbian- Octave - installing packages

Apt-get is the normal ideal way to handle the dependencies, but in this case there are packages for 3 different versions of octave with incompatibilities :shock: . Optionally, one could use the following to handle large dependency lists, and still use the up-to-date internal version matched octave p...
by Joel_Mckay
Fri Jan 04, 2013 7:40 am
Forum: Beginners
Topic: Raspbian- Octave - installing packages
Replies: 25
Views: 15030

Re: Raspbian- Octave - installing packages

In general, if you install some packages like NaN or the Matlab export tools it can cause inconsistent behavior. Additionally, some forge packages are not compatible after v3.0.5. I detail how to install octave 3.6 with stats packages here: http://www.raspberrypi.org/phpBB3/viewtopic.php?f=34&t=2734...
by Joel_Mckay
Fri Jan 04, 2013 5:06 am
Forum: Other programming languages
Topic: additional Octave packages for RasPi?
Replies: 3
Views: 3071

Re: additional Octave packages for RasPi?

Install on any Debian squeeze distro... sudo apt-get install liboctave-dev swig lpr pstoedit epstool transfig svn2cl sudo apt-get install octave libiodbc2-dev graphicsmagick-dbg liblcms-utils octave-fixed You need to run octave in a terminal, and be prepared to wait awhile... octave:1> pkg install -...
by Joel_Mckay
Fri Dec 07, 2012 4:51 am
Forum: General discussion
Topic: Using blender?
Replies: 30
Views: 28521

Re: Using blender?

Have you had any more success with this yet? Unfortunately, I've had to focus on other projects this month, but had looked at the generic OpenGL 2.0 wrapper for OpenGL ES 2.0 to port over some games/CAD to the Pi. http://code.google.com/p/gl-wes-v2/ However, quite some time ago a similar seg fault ...
by Joel_Mckay
Sat Nov 17, 2012 3:41 am
Forum: General discussion
Topic: Using blender?
Replies: 30
Views: 28521

Re: Using blender?

Update: Still no magic yet... However, we would appreciate feedback from anyone with a different build of Debian's wheezy libpython3.2. The info below has eliminated many of the build problems, but one issue remains which I suspect is a type error someplace due to the armhf environment ( libpython3....
by Joel_Mckay
Mon Nov 12, 2012 11:08 pm
Forum: General discussion
Topic: Using blender?
Replies: 30
Views: 28521

Re: Using blender?

Well now, I tried to get a minimal core to compile on the Pi without success. This build issue will need more coffee beans... ########################################### #dpkgs needed to build on wheezy sudo apt-get install openmpi-dev openmpi-bin openmpi-common libopenmpi-dev mpich2 mpich2python py...

Go to advanced search