Go to advanced search

by The_Raven
Mon Mar 04, 2019 12:56 pm
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

It is very difficult to debug because it's a sporadically error. :? I think i have to begin at the beginning and debug it. But ATM time is short. Edit: Observation 1: If i run the Pi on PSU, the kernel-dumps are gone but flickering is still there. Observation 2: There are 2 different problems. Probl...
by The_Raven
Thu Feb 28, 2019 7:46 am
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

Same as me. I often have Errors like this in the log: [319722.912587] WARNING: CPU: 0 PID: 22826 at fs/sysfs/group.c:237 sysfs_remove_group+0xa0/0xa4 [319722.912591] sysfs group 'power' not found for kobject 'event1' And this: [74231.031782] Under-voltage detected! (0x00050005) [74235.192165] Voltag...
by The_Raven
Tue Jan 29, 2019 7:35 am
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

I have now replaced the original Poe-Hat with an external PoE-Splitter (1Gbit/9$). The cameras run fine now, no flickering anymore. And i think with the original HAT, it triggers always motion which starts a recording. But for this i need longer testing. The PoE-Hat may be good for storage devices, ...
by The_Raven
Sun Jan 06, 2019 12:10 pm
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

It semes to be a PoE HAT problem. With a "stable" power (original pi power supply) this does not happen. I know that the hub can be a problem. With the pi 3 the cameras are not working stable, but with the 3+ it works. The problem is that this are no mjpeg cameras, which means a lot of data trough t...
by The_Raven
Fri Jan 04, 2019 3:44 pm
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

I have now 3 PI's with PoE HAT's and 2 cameras each (total 6 cameras). And all of them have sporadically flickering picture.
So yes it works, no errors in log, but something still disturbs the USB.
ATM i have no motivation to spend more time in it.
by The_Raven
Fri Nov 30, 2018 9:08 am
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)

Nice Job, the modded PoE-Hat works great! 8-)
Is it possible to buy/get the mod (daughter) board?
by The_Raven
Fri Nov 09, 2018 9:08 am
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current

jamesh wrote:
Fri Nov 09, 2018 8:48 am
There will be a blog post Monday.
Monday 7. june 2021? :P
Sarcasm OFF ;)
by The_Raven
Wed Oct 31, 2018 12:00 pm
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current

weust wrote:
Tue Oct 30, 2018 10:13 am
Just waiting for the blog now.
3 Months later... :P
by The_Raven
Mon Oct 29, 2018 7:25 am
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current

In the beginning of this topic there was the option (being looked into, iirc) to solder your own fix once the problem/solution had been found. Is that still a possibility now the solution has been found? On page 9 i posted a video how we fixed the hat. My hat runs since then fine. But a "official" ...
by The_Raven
Fri Oct 19, 2018 9:24 am
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current

Interesting. But i think if it works or not is not so important, important is the measuring. It is not a clean DC output, it has a lot of ripples. Devs sould have a focus on this and trya to remove the ripples and make a clean DC output.
Only with a clean DC output runs the pi stable. ;)
by The_Raven
Fri Oct 19, 2018 8:21 am
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current

We can talk now for a long time about it. But there are 2 things: 1. The PoE Hat ist faulty. Measuring shows this. And if you don't have USB-Devices, yes, it works, but what if you like to connect USB-Devices later? And what if you realize then that there is a problem? Yes, then your HAT is out of w...
by The_Raven
Tue Oct 16, 2018 8:30 am
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current

This is the story how we searched, isolated, found and solved the problem:
https://www.youtube.com/watch?v=DdVDiQXd1kc

Keep in mind that you loose warranty with this fix! You better wait for the official fix. ;)
by The_Raven
Mon Oct 08, 2018 6:16 pm
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current

ATM i am testing my solution with 2 caps and a coil.
So far it works well.
by The_Raven
Fri Oct 05, 2018 9:10 am
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current

If it "spams" the log and the log is on a SD it reduces the life of the SD dramatically. Not a good idea ;) I discovered that some part on the Hat running hot. Hope this does not reduce the life time. Ok it was measured away from the Pi and because of that without fan. Attached to the pi and with ru...
by The_Raven
Fri Sep 07, 2018 2:31 pm
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current

The coil whining is still present with my "work a round". And the fan is not working, don't know why. But ATM i have no time to fix it.
by The_Raven
Wed Sep 05, 2018 11:36 am
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current

So we fixed it by adding 2 capacitors and one coil.
Now i can pull 1A from the USB. 8-)
It has still some noise, but it looks much better than before.
Now testing how stable it is, if the fan works and so on.
by The_Raven
Wed Sep 05, 2018 9:10 am
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current

I added a second 1000uf capacitor between the 5V and the GND. And as expected it reduces the noise and i can pull more or less 500mA from the USB. To say it is a software-problem it's totally wrong. Of course, i would be happy if it would be a software-problem but. But it is hardware related! If you...
by The_Raven
Tue Sep 04, 2018 1:38 pm
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current

@Grozzie: But this is not a real fix. This is was i have done yesterday ;) @Blaster: You pointed me in the right direction. :!: The 5V output of this Pi-Hat is horrible! :o I measured the same as you. And have a look at the attached picture. This is measured on the same USB-Port, but with an externa...
by The_Raven
Tue Sep 04, 2018 12:29 pm
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current

I added the missing parts, but same problem. :(
My board rev is "A1 8C" if this is the revision.
Now i run out of ideas... :?
by The_Raven
Tue Sep 04, 2018 11:31 am
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current

Is it the physical distance that makes the difference, for example with long leads/wires attached if you move it close to the RPi does it start to fail. Or is it the length/resistance of the cables that are making a difference? Good question. I am not 100% sure. I think it is the distance. In the n...
by The_Raven
Tue Sep 04, 2018 9:31 am
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current

The picture is from my "first attempt". So maybe it was wrong to post it because it "confuses". We also tested it with all 40 pins connected trough a IDE-Cable and it works! Then we tested it with a short IDE cable (3cm) and it has NOT worked. Then we cut pin for pin beginning from the gpio side. An...
by The_Raven
Tue Sep 04, 2018 7:56 am
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86012

Re: PoE HAT - USB Ports not working - over-current

You have to move it far away (end of a 40pin cable and separate PoE-Cable). We have also tried to build a shield (like seen on TV-Tuners). But without success. And we have seen that there are missing electronic components on the Hat. For example it is recommended to put a 47uf and a 2,2uf capacitor....

Go to advanced search