Go to advanced search

by papous
Mon Oct 22, 2018 2:03 pm
Forum: Automation, sensing and robotics
Topic: Measuring UBEC output voltage
Replies: 2
Views: 1101

Re: Measuring UBEC output voltage

Thank you for the quick reply
I will do what you suggest and report back. I will also ask the UBEC peaple
Thanks again
by papous
Mon Oct 22, 2018 11:34 am
Forum: Automation, sensing and robotics
Topic: Measuring UBEC output voltage
Replies: 2
Views: 1101

Measuring UBEC output voltage

I received today this UBEC https://www.banggood.com/Hobbywing-3A-UBEC-5V-6V-Switch-Mode-BEC-For-RC-Models-p-915037.html?utm_design=41&utm_source=emarsys&utm_medium=Shipoutinform171129&utm_campaign=trigger-emarsys&utm_content=Winna&sc_src=email_2671705&sc_eh=130273cb35096df51&sc_llid=7033010&sc_lid=1...
by papous
Wed Oct 03, 2018 10:04 am
Forum: Automation, sensing and robotics
Topic: Experience with robot-core controller?
Replies: 5
Views: 1992

Experience with robot-core controller?

Has anyone used this board? https://secondrobotics.com/product/robot-core-v1-2/
It sounds extremely good for robotics and sensing but there is nothing much since 2017
by papous
Wed Sep 19, 2018 5:38 am
Forum: Networking and servers
Topic: Set the pi as AP
Replies: 9
Views: 1509

Re: Set the pi as AP

Well, it works now and I can see the pi on my Android phone and connect to it. But: 1.The pi becomes extremely slow or unresponsive (using VNC viewer) when connected using ethernet wire 2.Does not connect to 192.168.4.1 which is the suggested address using putty 3.The green led stays on permanently ...
by papous
Tue Sep 18, 2018 2:32 pm
Forum: Networking and servers
Topic: Set the pi as AP
Replies: 9
Views: 1509

Re: Set the pi as AP

Thank you.
I'll have a go at it later
by papous
Tue Sep 18, 2018 2:18 pm
Forum: Networking and servers
Topic: Set the pi as AP
Replies: 9
Views: 1509

Re: Set the pi as AP

There is no reply from sudo modprobe ip_tables
by papous
Tue Sep 18, 2018 2:07 pm
Forum: Networking and servers
Topic: Set the pi as AP
Replies: 9
Views: 1509

Re: Set the pi as AP

Thank you for the time taken to help.
This is the response:
Linux raspberrypi 4.14.69-v7+ #1141 SMP Mon Sep 10 15:26:29 BST 2018 armv7l GNU/Linux
by papous
Tue Sep 18, 2018 1:49 pm
Forum: Networking and servers
Topic: Set the pi as AP
Replies: 9
Views: 1509

Re: Set the pi as AP

this is the response:
modprobe: FATAL: Module iptables not found in directory /lib/modules/4.14.69-v7+
by papous
Mon Sep 17, 2018 4:38 pm
Forum: Networking and servers
Topic: Set the pi as AP
Replies: 9
Views: 1509

Set the pi as AP

I am trying to set my pi3B as an access point using the official docs ( https://www.raspberrypi.org/documentation/configuration/wireless/access-point.md I have proceeded to the point where I should execute sudo iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE . This produces the error iptables v...
by papous
Wed May 23, 2018 9:23 am
Forum: Python
Topic: Tornado, websockets and coroutines. Unsolvable problem?
Replies: 0
Views: 158

Tornado, websockets and coroutines. Unsolvable problem?

Consider this: I have created a robot car which is nicely controlled from a web page using Tornado, websockets and jquery . The problem arises when you want sensors to provide inputs to the program that will alter its behaviour (stop, turn etc.) How is this implemented? what if you have more than on...
by papous
Mon May 21, 2018 9:39 am
Forum: Python
Topic: Tornado web sockets and coroutines
Replies: 2
Views: 394

Re: Tornado web sockets and coroutines

Gerhard thank you very much for your assistance.
I will have a go implementing your suggestions and come back to you if successful. I suspect it will take me sometime
Thank you again
by papous
Wed May 16, 2018 9:17 am
Forum: Python
Topic: Tornado web sockets and coroutines
Replies: 2
Views: 394

Tornado web sockets and coroutines

I have created a nice UI to control a robot car using python websockets and it works. I would however like to have a "thread" that returns the distance from an object so that the car can stop instead of hitting a wall. It seems threading is not supported with Tornado and the best way is to use a cor...
by papous
Fri Mar 30, 2018 3:10 am
Forum: Python
Topic: web control robot: Latency times
Replies: 3
Views: 432

Re: web control robot: Latency times

Thank you OutoftheBOTS for this very quick reply. Do you mean Tornado and Websockets will be faster than Flask and Flask sockets? I think Flask sockets is very fast but not immediate possibly because of the threads running Also can you tell me if making the pi an access point will improve things? Ma...
by papous
Thu Mar 29, 2018 5:26 pm
Forum: Python
Topic: web control robot: Latency times
Replies: 3
Views: 432

web control robot: Latency times

I have finally programmed my robot car and it works. But the latency time when using an HTTP Flask server is too long. So I got my hands dirty and installed Flask SocketIO. Things improved but some times the latency time is around 4sec from web generated command to action and some times 1sec. (laten...
by papous
Wed Mar 28, 2018 4:30 am
Forum: Automation, sensing and robotics
Topic: Single power supply for all
Replies: 7
Views: 969

Re: Single power supply for all

Thank you every one that contributed.
I am sorry it took so long to reply as I was away
by papous
Tue Mar 20, 2018 10:38 am
Forum: Automation, sensing and robotics
Topic: Single power supply for all
Replies: 7
Views: 969

Re: Single power supply for all

What(?), nobody knows anything about this?
Not even an electrical diagram?
by papous
Fri Mar 16, 2018 2:51 pm
Forum: Automation, sensing and robotics
Topic: Single power supply for all
Replies: 7
Views: 969

Single power supply for all

Can someone suggest a single power supply for a rover? It will need to:
Power the Pi
power 2* 5v engines
power 2 or more servos
be rechargeable
charged from a wall outlet and (maybe) charged by a solar panel.

I would welcome internet catalogue entries and (simple) wiring instructions

Many Thanks
by papous
Thu Mar 15, 2018 3:46 pm
Forum: Automation, sensing and robotics
Topic: Odd Camjam engine behaviour
Replies: 11
Views: 1357

Re: Odd Camjam engine behaviour

OK, I solved it. This is for anyone that may have similar issues. It is not the hardware. It is the software and specifically the combination of Flask (its debugger) and threading. If you run the debugger ( export FLASK_DEBUG=1 ) it spawns it own thread. This - at least in my code- interrupts the ma...
by papous
Thu Mar 08, 2018 6:12 am
Forum: Automation, sensing and robotics
Topic: Odd Camjam engine behaviour
Replies: 11
Views: 1357

Re: Odd Camjam engine behaviour

Thanks again for taking the time to look at the project I will take your advice and look at the code again. I did notice that running just the 'motor' module the engines work fine. So it must be software. I also found this about the RPi.GPIO module: Note that this module is unsuitable for real-time ...
by papous
Wed Mar 07, 2018 12:52 pm
Forum: Automation, sensing and robotics
Topic: Odd Camjam engine behaviour
Replies: 11
Views: 1357

Re: Odd Camjam engine behaviour

One more thing that I feel it is important: There is a serious voltage drop on the engine terminals when the engines behave erratically. Maybe this is a clue
Frank
by papous
Wed Mar 07, 2018 12:37 pm
Forum: Automation, sensing and robotics
Topic: Odd Camjam engine behaviour
Replies: 11
Views: 1357

Re: Odd Camjam engine behaviour

Thank you again for the speedy reply.
I managed to create a github account (https://github.com/fsofras) and upload everything there including a readme fle with some help.
For a video, it will take a couple of days.
If I can do something else please ask.
All the best
Frank
by papous
Tue Mar 06, 2018 9:05 pm
Forum: Automation, sensing and robotics
Topic: Odd Camjam engine behaviour
Replies: 11
Views: 1357

Re: Odd Camjam engine behaviour

Dear Mike, Thank you for this very quick reply. The 'motor' library (code below) is basically a function to move the motors according to the duty cycle. Using sqlite3 was the only way to get the response returned from the Flask to other program sections. This was suggested to me in this post: https:...
by papous
Tue Mar 06, 2018 12:00 pm
Forum: Automation, sensing and robotics
Topic: Odd Camjam engine behaviour
Replies: 11
Views: 1357

Odd Camjam engine behaviour

I return to my previous post https://www.raspberrypi.org/forums/viewtopic.php?f=37&t=201657&p=1255442#p1254804 The problem of the engines running erratically persists and I never did get a proper answer. My questions today are: 1.Could it be due to poor voltage(I am using the 4 battery box with rech...
by papous
Sun Feb 18, 2018 6:29 pm
Forum: Troubleshooting
Topic: can not connect to my pi3
Replies: 2
Views: 270

Re: can not connect to my pi3

Many thanks for your reply
As I said, I knew it was going to happen but...
Anyway, I solved it by connecting a monitor and keyboard to the pi
Thank you again

Go to advanced search