Go to advanced search

by Roken
Sun Nov 18, 2018 8:29 pm
Forum: Beginners
Topic: if/else statement to run gui or no gui?
Replies: 5
Views: 854

Re: if/else statement to run gui or no gui?

You are confusing yourself. You can have a full desktop running without being plugged in to a display, you just can't see it. If you always boot the same way, and you have a GUI when a monitor is connected, then you always have a GUI.
by Roken
Sun Nov 18, 2018 7:55 pm
Forum: Troubleshooting
Topic: Update broke boot
Replies: 10
Views: 1250

Re: Update broke boot

As much as I'd like to simply downgrade, I've invested too much time in setting up that one to have to go through it again. I'm pleased to report that, having taken the hub out of the equation, and just using one drive (two would be too much power draw), and copying the one rootfs off the other driv...
by Roken
Sun Nov 18, 2018 5:01 pm
Forum: Troubleshooting
Topic: Update broke boot
Replies: 10
Views: 1250

Re: Update broke boot

It says "Waiting", and eventually times out with a halt. Even with just one drive plugged into the hub (and I've confirmed there are no UUID or PARTUUID conflicts). I'm positive that something in the update prevents it seeing through the hub, now. EDIT: And it's not Linux per se. My Desktop is runni...
by Roken
Sun Nov 18, 2018 2:48 pm
Forum: Troubleshooting
Topic: Update broke boot
Replies: 10
Views: 1250

Re: Update broke boot

I do have rootwait - and have reverted to PARTUUID for the direct connection. It seems something has happened to prevent the hub being recognised. Currently cloning Pi4 (which was on the other HD plugged into it) to the one drive now. Once that's done, hopefully, I can get all four booting again.
by Roken
Sun Nov 18, 2018 10:20 am
Forum: Troubleshooting
Topic: Update broke boot
Replies: 10
Views: 1250

Re: Update broke boot

Except here it was working just fine until yesterday's update.
by Roken
Sun Nov 18, 2018 9:28 am
Forum: Troubleshooting
Topic: Update broke boot
Replies: 10
Views: 1250

Re: Update broke boot

I've made some progress. It seems that the Pi no longer likes the drives through the hub. Connecting the drive with rootfs directly gets me booted. Connecting the drives via the hub to my desktop shows no problems, so obviously the hub is working. Any ideas why the Pi would suddenly not like it. Thi...
by Roken
Sat Nov 17, 2018 2:08 pm
Forum: Troubleshooting
Topic: Update broke boot
Replies: 10
Views: 1250

Update broke boot

I just updated the OS on Pi No.1 This Pi has two USB HDs connected via a powered hub. rootfs for this Pi (and the other 3) is on one of the HDs. /boot is on SDCard for all 4. After the update, I rebooted, and bam, it can't find rootfs. I've plugged the drive into my desktop and fsck'd it, clean. Che...
by Roken
Fri Nov 09, 2018 11:05 pm
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86100

Re: PoE HAT - USB Ports not working - over-current

Am I the only one that...a) did a quick Google search. b) found I could RMA, c) decided the V1 still suits my needs, and d) found an alternative where it doesn't? What's with all the aggression? This is an inexpensive addition to an inexpensive board, and only the early adopters will have been affec...
by Roken
Fri Nov 09, 2018 10:59 pm
Forum: Off topic discussion
Topic: "Nothing ever works"
Replies: 72
Views: 11460

Re: "Nothing ever works"

I honestly couldn't be bothered reading through the whole thread, but I can answer the original post. Nothing ever works, because "nothing" was never intended to work. Only "Something" can work.
by Roken
Thu Nov 01, 2018 7:56 pm
Forum: Networking and servers
Topic: owncloud client/server incompatibility after upgrade
Replies: 8
Views: 947

Re: owncloud client/server incompatibility after upgrade

Does this fix the Android client problem with the latest OwnClound? I have no problem from a PC (Windows and Linux) just Android.
by Roken
Wed Oct 31, 2018 8:54 pm
Forum: Advanced users
Topic: Access SD Card after booting from USB
Replies: 5
Views: 390

Re: Access SD Card after booting from USB

You can't access it directly. Having identified the /dev point, you need to mount it. https://manpages.debian.org/testing/mou ... .8.en.html
by Roken
Sun Oct 21, 2018 11:39 am
Forum: Troubleshooting
Topic: External drive not read - Dead USB port?
Replies: 3
Views: 245

Re: External drive not read - Dead USB port?

Never thought of that. Thumb drive is read just fine, but not the hub on that port.
by Roken
Sun Oct 21, 2018 10:54 am
Forum: Networking and servers
Topic: Can we use WiFi on the Pi for file sharing?
Replies: 6
Views: 1529

Re: Can we use WiFi on the Pi for file sharing?

You can set up an owncloud (or, as people seem to favour, now, nextcloud server). This has the advantage of being accessible outside of your home network.
by Roken
Sun Oct 21, 2018 10:50 am
Forum: Troubleshooting
Topic: External drive not read - Dead USB port?
Replies: 3
Views: 245

External drive not read - Dead USB port?

I have my system setup with 4 Pis. The first boots directly from a connected HD, and stores folders for the other three to boot from on NFS drives. There are two drives connected to the first, using a powered USB hub. I performed a reboot (they are pretty much on permanently, all being powered over ...
by Roken
Fri Oct 19, 2018 11:10 pm
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86100

Re: PoE HAT - USB Ports not working - over-current

A Google search for "raspberry Pi PoE HAT overcurrent" Oh, come on - there's no way anyone can run that search until they not only know there's a problem, but something about the specific nature of the problem. Someone who just wants a hat and has no idea why they're out of stock most places isn't ...
by Roken
Fri Oct 19, 2018 5:02 am
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86100

Re: PoE HAT - USB Ports not working - over-current

A quick google search brings this thread to number 1 position. I don't consider that "too hard".
by Roken
Thu Oct 18, 2018 9:13 pm
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86100

Re: PoE HAT - USB Ports not working - over-current

I have to say, I'm surprised by the negative comments. The original hat is not a dud, so to speak. It works headless, and with a minor config fix. There's a 9 page thread here about it, just in case anyone is hunting. Personally, I say, give the engineers a chance. Anyone who hasn't heard about the ...
by Roken
Tue Oct 09, 2018 8:50 pm
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86100

Re: PoE HAT - USB Ports not working - over-current

Not everyone who got one finds it useless. On a headless, no peripherals system, it's still just peachy.
by Roken
Tue Oct 09, 2018 8:47 pm
Forum: Off topic discussion
Topic: What was your first computer?
Replies: 408
Views: 151441

Re: What was your first computer?

Sinclair ZX80 - I'm ancient.
by Roken
Thu Oct 04, 2018 6:50 pm
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86100

Re: PoE HAT - USB Ports not working - over-current

I have rootfs on an 1TB NFS drive, too, so I can manually clean the logs periodically with no real problem.
by Roken
Thu Oct 04, 2018 6:46 pm
Forum: Networking and servers
Topic: Kodi headless server
Replies: 1
Views: 576

Kodi headless server

A google search takes me to links that don't answer my question, so here I go. One of my Pis is currently a headless Plex server, with the media on an NFS drive. My intention is to access the media from anywhere. But Plex is oh, so slow. I know that Kodi can be used as a media server, but can it be ...
by Roken
Thu Oct 04, 2018 6:36 pm
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86100

Re: PoE HAT - USB Ports not working - over-current

I assume if we are running the Pi without any USB devices connected, there's no harm in keeping it?

For the others, I picked up some PoE splitters which are working OK.
by Roken
Tue Oct 02, 2018 5:43 pm
Forum: Troubleshooting
Topic: removing static IP stops boot
Replies: 2
Views: 211

Re: removing static IP stops boot

I hadn't, and so did. No joy. However, it has stopped the conflict of the router trying to assign an address using dhcp, so cured one problem. Second problem was failure to find nameservers, so I pointed retropie to my pi-hole (ooer, missus), which has fixed that. Finally, a dead repository, which a...
by Roken
Mon Oct 01, 2018 6:36 pm
Forum: Troubleshooting
Topic: removing static IP stops boot
Replies: 2
Views: 211

removing static IP stops boot

I have four Pis all on wired network. I have retro on one, and set up dhcpcd.conf with a static IP. However, my router is getting confused and so I elected to re-set dhcpcd.conf and set the router to use a static IP. However, removing the static from dhcpcd causes the boot process to hang: A start j...
by Roken
Tue Sep 25, 2018 2:58 pm
Forum: HATs and other add-ons
Topic: PoE HAT - USB Ports not working - over-current (FIXED - New Hardware Release)
Replies: 327
Views: 86100

Re: PoE HAT - USB Ports not working - over-current

Sometimes. the problem is on the other side of the keyboard. Sigh!

Go to advanced search