Go to advanced search

by pauldy
Sat May 02, 2015 2:28 pm
Forum: Windows 10 for IoT
Topic: visual studio 2015 deploy error [solved]
Replies: 16
Views: 5434

Re: visual studio 2015 deploy error

I'm having the same issues, this trusted computing stuff is for the birds with an embedded device like this. Did you even figure out where the cert was or do you have to use a store signed cert?
by pauldy
Fri May 01, 2015 6:35 am
Forum: Windows 10 for IoT
Topic: Setup without Windows 10 PC
Replies: 32
Views: 20050

Re: Setup without Windows 10 PC

For what it's worth you do need a usb stick on mac desktops the internal will not work in any vm as it is connected to the PCIe bus. Laptops so far are on the use bus and should be fine. Distributing an installed image is against the Eula if you read it. Anyone can get up and going right now with wi...
by pauldy
Sun Apr 12, 2015 2:25 am
Forum: Other programming languages
Topic: Using C# and GPIO
Replies: 2
Views: 4441

Re: Using C# and GPIO

I took a quick glance at the specs for your zwave module and it looked like there were different revisions one at least used simple ttl rx/tx serial and you could just use the built in serial modules in .net The others might be more complicated and had c libraries to link against which allows you in...
by pauldy
Tue Mar 10, 2015 3:52 am
Forum: Other programming languages
Topic: PHP Sprinker Controller
Replies: 2
Views: 1093

Re: PHP Sprinker Controller

If all you want to do is run it as a simple script to toggle io lines then the easiest way to do it is just set a length of time to run for each zone and use a simple stjatemachine to control what zone you are on and done. <?php $maxZones = 8; $zoneTime = 60 * 15; disableZones(); for($zone=1;$zone<=...
by pauldy
Sat Feb 21, 2015 4:11 am
Forum: Other programming languages
Topic: C# on the Rpi
Replies: 30
Views: 52847

Re: C# on the Rpi

So with the raspi2 you can upgrade c# to a second class citizen, probably needs its own programing section at least for .net. It now appears to work flawlessly. I was able to run all my old test apps that broke thing and installed my home monitoring app and saw the transitions are more fluid and the...
by pauldy
Sat Feb 21, 2015 3:22 am
Forum: Other programming languages
Topic: How to autostart an .exe program
Replies: 43
Views: 13204

Re: How to autostart an .exe program

Assuming you app is actually located at the path /home/pi/Desktop/Program/WattsonIngestionTool.exe

Code: Select all

/usr/bin/sudo /usr/bin/mono /home/pi/Desktop/Program/WattsonIngestionTool.exe
by pauldy
Thu Feb 19, 2015 10:06 pm
Forum: Other programming languages
Topic: How to autostart an .exe program
Replies: 43
Views: 13204

Re: How to autostart an .exe program

Does the exe run under mono as well? What you are asking for really depends on what your end goal is and what you're working with. If the exe is a compiled application then running it on the pi won't do you much good if it is a mono app then you can run it but might need to invoke mono first passing...
by pauldy
Mon Feb 16, 2015 6:03 am
Forum: Other programming languages
Topic: C# on the Rpi
Replies: 30
Views: 52847

Re: C# on the Rpi

The one thing MS undoubtedly has right at this moment is Visual Studio. They have been the standard all other IDEs are trying to get to for some time and they themselves keep improving. Others are still functional and you can certainly get work done but none comes close to Visual Studio. That aside ...
by pauldy
Sat Jan 17, 2015 6:03 pm
Forum: Other programming languages
Topic: C# on the Rpi
Replies: 30
Views: 52847

Re: C# on the Rpi

C# is a third class citizen on the RPI for a variety of reasons. As you can see from the forms here, you are posting in "other languages" after all. That said for simple things it seems to work ok. I have a sprinkler system I did entirely in .net from toggling pins though to the wcf web services hos...
by pauldy
Fri Mar 21, 2014 12:16 am
Forum: Other programming languages
Topic: VB.NET problem
Replies: 13
Views: 3693

Re: VB.NET problem

Mono on the rpi under hard float builds is horrible, you need to find an older soft float distro and everything should work as expected. I wouldn't hold your breath on the hard float either as it's been almost 2 years now, and Miguel pretty much blew off the problem as a non issue since it seems to ...
by pauldy
Fri Jun 14, 2013 3:39 pm
Forum: Raspbian
Topic: Raspbian vs Wheezy (beta) Mono support
Replies: 225
Views: 84475

Re: Raspbian vs Wheezy (beta) Mono support

To clarify soft float wheezy runs windows.forms apps just fine. Hard float wheezy has a workaround but isn't just an install and go process. I am still using the soft float wheezy myself because its just less hastle at the moment.
by pauldy
Tue May 07, 2013 6:46 pm
Forum: Raspbian
Topic: Raspbian vs Wheezy (beta) Mono support
Replies: 225
Views: 84475

Re: Raspbian vs Wheezy (beta) Mono support

Today was the weirdest day of my Pi life. I had Mono running. Seriously. I had a SD card around, flashed maybe in January (maybe a month before), run apt-get update, apt-get upgrade, installed Mono and it worked! After trying some fancy stuff with partitions, I had a "bricked" Pi, so I downloaded t...
by pauldy
Mon Apr 01, 2013 4:49 pm
Forum: Raspbian
Topic: Soft Float Wheezy
Replies: 10
Views: 1614

Re: Soft Float Wheezy

That is the build I'm referring to and my personal apps are both winforms and an apache webservice. The two make extensive use of winforms and System.Drawing. I know I can probably hack around with it and get it running but it works fine right now in soft float so I'm sticking with that for now in h...
by pauldy
Sun Mar 31, 2013 6:05 am
Forum: Raspbian
Topic: Soft Float Wheezy
Replies: 10
Views: 1614

Re: Soft Float Wheezy

jamesh wrote:Someone has apparently produced a HF version of Mono - search the forum. Still in testing I believe.
I am aware of the HF patch but it is still very buggy with most things. But you can get dates now at least.
by pauldy
Fri Mar 29, 2013 8:18 pm
Forum: Raspbian
Topic: Soft Float Wheezy
Replies: 10
Views: 1614

Re: Soft Float Wheezy

BTW what languages are you having trouble with? The one I'm having trouble with at the moment on hard float wheezy is mono. I have a winforms app that shows a lot of home status items on my cctv setup it has a lot of graphics calls and I think those are what still aren't quite functional in the har...
by pauldy
Fri Mar 29, 2013 5:17 am
Forum: Beginners
Topic: apt-get update fails
Replies: 6
Views: 5628

Re: apt-get update fails

I had a similar issue only my url was http.debian.net. I modified it to an actual mirror in /etc/apt/sources.list of ftp.us.debian.org. This might help get you on the right track.
by pauldy
Fri Mar 29, 2013 5:00 am
Forum: Raspbian
Topic: Soft Float Wheezy
Replies: 10
Views: 1614

Re: Soft Float Wheezy

I think I have a temporary solution for my soft float wheezy problem on rpi 2.0. I was able to copy the fat partition off the hard float wheezy and put it on the fat partition for the soft float wheezy. When I booted everything came up as expected. I confirmed this worked with all the sd cards I tho...
by pauldy
Fri Mar 29, 2013 3:08 am
Forum: Raspbian
Topic: Soft Float Wheezy
Replies: 10
Views: 1614

Soft Float Wheezy

Are there any plans to update softfloat wheezy? I'm using mono for a lot of my current projects and I just received another pi to add to the collection. After hours of troubleshooting and reburning cards I discovered a thread clamming that the new hylinx chips require an updated version of Wheezy ap...
by pauldy
Fri Mar 29, 2013 2:58 am
Forum: Troubleshooting
Topic: Raspberry Pi won't give any output.. where to start?
Replies: 11
Views: 7346

Re: Raspberry Pi won't give any output.. where to start?

OK, this explains why my brand new rpi 2.0 won't boot off the same cards my other rpis boot from just fine. The problem I see right now is what if we want to use mono. There is a hard float alpha that breaks when you do anything ui related and the soft float wheezy is 8/8/2012? Any ideas if there is...
by pauldy
Tue Mar 19, 2013 10:00 pm
Forum: Other programming languages
Topic: C# Mono application with vnc
Replies: 6
Views: 3840

Re: C# Mono application with vnc

Are you starting it from some ssh terminal session or are you in the vnc session running it from an xterminal? In any event you might just try xhost +localhost. If I remember right that will allow pretty much anyone on localhost to connect to the xserver providing the DISPLAY path is set properly. D...
by pauldy
Mon Mar 18, 2013 8:43 pm
Forum: Other programming languages
Topic: C# Mono application with vnc
Replies: 6
Views: 3840

Re: C# Mono application with vnc

You might want to provide more detail about exactly what steps your taking here. Information you might be leaving out here is likely what is causing your problem here. For instance "I installed vnc server and started with -create parameter.(before -display :0)." Is not a succinct process and things ...
by pauldy
Tue Mar 05, 2013 4:34 pm
Forum: Other programming languages
Topic: Mono (C#) anyone?
Replies: 64
Views: 43918

Re: Mono (C#) anyone?

Anyone care to share steps to get it compiled. I followed the steps listed earlier and received asm errors regarding the selected processor does not support ARM mode 'dmb'. I downloaded mono using git, and then updated as follows. git clone git://github.com/directhex/mono-1.git cd mono-1 git checkou...
by pauldy
Thu Jan 31, 2013 8:42 pm
Forum: Raspbian
Topic: automatically reboot after crash?
Replies: 2
Views: 4988

Re: automatically reboot after crash?

Maybe this is what you're looking for?

http://binerry.de/post/28263824530/rasp ... hdog-timer
by pauldy
Thu Dec 27, 2012 10:12 pm
Forum: Other programming languages
Topic: A working Mono someday?
Replies: 15
Views: 6112

Re: A working Mono someday?

I got Mono working just fine with the latest Wheezy image. Just sudo apt-get install Mono-Complete and you should be good to go. I've had no issues with Mono (other than the normal issues when dealing with Mono on any other distro). Have you done anything but install it yet, and if so what?
by pauldy
Thu Dec 13, 2012 4:36 pm
Forum: Other programming languages
Topic: A working Mono someday?
Replies: 15
Views: 6112

Re: A working Mono someday?

There are ways to get working mono right now which may be why your not seeing more people moaning and groaning about how long it has taken to get the fixes integrated into raspbian with full hf comparability. You have two solutions run the software float wheezy or download compile and install on you...

Go to advanced search