Go to advanced search

by fbutler
Mon Jun 03, 2013 1:04 pm
Forum: Camera board
Topic: Installing Netcat?
Replies: 1
Views: 698

Re: Installing Netcat?

richard238 wrote:My AV prevents netcat being installed.

Is netcat a serious risk?

How do you get Norton to behave?!
You need to add the netcat executable to the exclusions in the Norton Settings.
by fbutler
Mon Jun 03, 2013 10:30 am
Forum: Media centres
Topic: GStreamer dvbsrc pipeline example.
Replies: 5
Views: 4624

Re: GStreamer dvbsrc pipeline example.

I've also tested the videotestsrc too, to make sure that I see the colour bars OK. And that works OK using this: gst-launch-1.0 videotestsrc ! textoverlay text="Hello" ! eglglessink So, the problem I am having must be somewhere in the pipeline relating to tuning and demuxing and decoding. Yeah, you...
by fbutler
Mon Jun 03, 2013 7:38 am
Forum: Camera board
Topic: trouble streaming video from raspberry pi to raspberry pi
Replies: 11
Views: 5790

Re: trouble streaming video from raspberry pi to raspberry p

Your problem appears to be that you haven't compiled the /opt/vc/src/hello_pi/hello_video/hello/video.bin program Have a look at the /opt/vc/src/hello_pi/README file for instructions on how to compile it. The buffer file can be created in any directory that you have permission to. Just create it in ...
by fbutler
Fri May 31, 2013 10:01 am
Forum: Camera board
Topic: Using EasyCap instead of camera
Replies: 7
Views: 6484

Re: Using EasyCap instead of camera

If anyone can suggest an example gstreamer command that will take a v4L2 and ALSA source and produce an H264 file or stream would help me considerably. Here is one that I have used. It may need some adjustment for your setup: gst-launch-1.0 -t -e -v avimux name=mux ! filesink location=test.avi alsa...
by fbutler
Tue May 28, 2013 6:08 pm
Forum: Raspbian
Topic: Gstreamer 1.0 for raspbian
Replies: 171
Views: 132532

Re: Gstreamer 1.0 for raspbian

Kentzo wrote:When playing 1080p (h264) fps is low. Is it known issue or I miss some parameters in my pipeline?
Could it be the throughput of your SD card that is causing a bottleneck?
by fbutler
Mon May 27, 2013 5:05 pm
Forum: Camera board
Topic: Streaming lag free 1080p 25fps video. Gstreamer
Replies: 11
Views: 34056

Re: Streaming lag free 1080p 25fps video. Gstreamer

The guide can be found at http://pi.gbaman.info/?p=150 Hi Gbaman, This pipeline doesn't work when I try it. Here's what I am seeing when attempting to use the sender pipe with no modifications other than using the IP address of the sending Pi: pi@raspi1 ~ $ raspivid -t 999999 -h 720 -w 1080 -fps 25...
by fbutler
Sat May 25, 2013 8:47 am
Forum: Troubleshooting
Topic: Config Utility Menu at Boot after Rasbian ReImage
Replies: 1
Views: 463

Re: Config Utility Menu at Boot after Rasbian ReImage

The config menu/utility runs at first boot after loading up a fresh Rasbian image. For some reason the kernel seems to be detecting my Logitech USB keyboard as a Novatech keyboard and the driver has some character mapping issues. Can I run the same config utility after bootup ( so I can select a di...
by fbutler
Fri May 24, 2013 7:25 pm
Forum: Camera board
Topic: socat, streaming, & broadcasting RPi-camera
Replies: 7
Views: 16312

Re: socat, streaming, & broadcasting RPi-camera

The next phase was to try broadcasting RPi camera to several receiver RPi's. Well, I did try netcat, but no joy :( I'm no networking expert, so if any of you know how to use it for such, please report back. Just curious, I haven't looked at this yet, but did you try netcat with the 192.168.1.255 br...
by fbutler
Fri May 24, 2013 7:16 pm
Forum: Camera board
Topic: Pi to Pi Bi-Directional Camera Streaming and Preview
Replies: 7
Views: 2238

Re: Pi to Pi Bi-Directional Camera Streaming and Preview

I don't know anything about the monitor auto-reconfiguration, but thanks for posting the video examples and screen shots! Good to see streaming both ways can work. Maybe not the place to discuss it here, but I think there should be some improvement possible with camera low-light performance. For ex...
by fbutler
Fri May 24, 2013 6:50 pm
Forum: Camera board
Topic: RPi Camera issues and status
Replies: 47
Views: 29143

Re: RPi Camera issues and status

jamesh wrote:Hmm, no changes that part of the code. -1 probably only worked by accident (I was surprised when people said they ewere using it). Just use 9999999.
It would be a handy setting for those people wanting to stream continuously. Any chance the accident could become a proper feature?
by fbutler
Fri May 24, 2013 6:39 pm
Forum: Camera board
Topic: Pi to Pi Bi-Directional Camera Streaming and Preview
Replies: 7
Views: 2238

Pi to Pi Bi-Directional Camera Streaming and Preview

Hi, I've got a couple of Pi cameras so I've started experimenting with streaming video between 2 Pi's in both directions at once. This appears to be quite feasible and I'm not seeing any high CPU usage whilst doing this. This screen capture best describes the setup: http://cloud-wr-eu1.acronis.com/l...
by fbutler
Fri May 24, 2013 4:18 pm
Forum: Media centres
Topic: GStreamer dvbsrc pipeline example.
Replies: 5
Views: 4624

Re: GStreamer dvbsrc pipeline example.

Hi, I need a little help getting a gst-launch-1.0 command to work on the RPi. I have a DVB-T USB adaptor, which I know works OK with the RPi because Kaffeine works - although it's too slow to be useful. So, I now have GStreamer 1.0 installed, and I need a little help getting to watch live DVB-T tel...
by fbutler
Thu May 23, 2013 1:09 pm
Forum: Camera board
Topic: Camera streaming with negligible delay
Replies: 6
Views: 9913

Re: Camera streaming with negligible delay

Hello all, I've been searching for a way to stream video without delay, and although I found some examples, I had problems getting it right, until I found the following commands to make it happen with gstreamer. Thought I would share it here: on the pi: /opt/vc/bin/raspivid -t 999999 -h 720 -w 1080...
by fbutler
Wed May 22, 2013 10:58 am
Forum: Media centres
Topic: GStreamer 1.0
Replies: 58
Views: 24239

Re: GStreamer 1.0

Think I need to go back to a completely fresh system :( If you are getting fed up with the amount of time it takes to recompile the libraries, you could always use Defiant's pre-compiled packages after going back to a fresh system. There's a blog post about using them here: http://theiopage.blogspo...
by fbutler
Wed May 22, 2013 10:37 am
Forum: Media centres
Topic: GStreamer 1.0
Replies: 58
Views: 24239

Re: GStreamer 1.0

nickon314 wrote:Think I need to go back to a completely fresh system :(
It does sound like that would be the best option :-(
by fbutler
Wed May 22, 2013 10:18 am
Forum: Media centres
Topic: GStreamer 1.0
Replies: 58
Views: 24239

Re: GStreamer 1.0

nickon314 wrote:Do you know which library holds the code for gst_mpeg_video_meta_api_get_type ?

'nm' shows that it's 'undefined' in libgstvideoparsersbad.so, so it must be in another one.

I can't find it.
It's defined in gst-plugins-bad/gst-libs/gst/codecparsers/gstmpegvideometa.c
by fbutler
Wed May 22, 2013 9:23 am
Forum: Media centres
Topic: GStreamer 1.0
Replies: 58
Views: 24239

Re: GStreamer 1.0

nickon314 wrote:Yes, I did that.
:? So near, and yet so far :-) The first thing I would do is reboot the Pi and run gst-inspect-1.0 again just to ensure that the environment is fully set up and works from boot.
by fbutler
Wed May 22, 2013 9:10 am
Forum: Media centres
Topic: GStreamer 1.0
Replies: 58
Views: 24239

Re: GStreamer 1.0

OK, I've now done that, to my .profile. And, now gst-inspect-1.0 shows 193 plugins, 971 features. And, 5 are now blacklisted (previously was 3). The blacklisted ones are: libgstomx.so libgstrtp.so libgstaudiofx.so libgstrtpmux.so libgstvideoparsersbad.so I wouldn't have expected that result. :? Did...
by fbutler
Wed May 22, 2013 8:25 am
Forum: Media centres
Topic: GStreamer 1.0
Replies: 58
Views: 24239

Re: GStreamer 1.0

I guess I next need to get libgstomx.so out of the blacklist somehow?!?! From memory the most common reason for this is GST_OMX_CONFIG_DIR not been defined correctly. What does your .profile look like? Have you done something like the following to setup your environment? cd $HOME echo -e \\n# Gstre...
by fbutler
Tue May 21, 2013 12:30 pm
Forum: Camera board
Topic: camera install woes
Replies: 5
Views: 1658

Re: camera install woes

abarbarian wrote:Network connection works fine. An I have the same problem for three days. 8-)
Just a thought. It could potentially be an issue with your ISP's DNS servers not resolving correctly for raspberrypi.org. It may be worth trying alternative DNS servers to see if that solves the issue.
by fbutler
Tue May 21, 2013 10:10 am
Forum: Camera board
Topic: How to add text-overlay with raspivid?
Replies: 31
Views: 29631

Re: How to add text-overlay with raspivid?

It's not going to be soon though. I'm having to do actual work at the moment. JBAnovling, In the meantime you may be able to do something with GStreamer pipelines and Overlays to do this. It's quite simple to do static text overlays using GStreamer, but dynamic ones look a bit more involved. Do a G...
by fbutler
Tue May 21, 2013 9:31 am
Forum: Camera board
Topic: Anyone who ordered from RS get their camera yet?
Replies: 49
Views: 6477

Re: Anyone who ordered from RS get their camera yet?

Parcelforce just delivered mine.
by fbutler
Tue May 21, 2013 5:48 am
Forum: Media centres
Topic: GStreamer 1.0
Replies: 58
Views: 24239

Re: GStreamer 1.0

Hi, It's not working. I cleared out all my local files - and used your script again. It's doesn't work - still failing with GST_EGL: checking for GST_EGL... configure: error: Package requirements (gstreamer-egl-1.0) were not met: I checked the whole file system and that .pc file isn't anywhere. I c...
by fbutler
Mon May 20, 2013 6:39 pm
Forum: Camera board
Topic: Anyone who ordered from RS get their camera yet?
Replies: 49
Views: 6477

Re: Anyone who ordered from RS get their camera yet?

hovisjovis wrote:
wilber wrote:Just this minute received my dispatch confirmation. From parcel force, not RS. Hopefully will arrive tomorrow.
Same here, hopefully here tomorrow! :D
Ditto: "You have a shipment being sent from RS COMPONENTS LTD that is due to be despatched on 20/05/2013 using our Express 24 service"
by fbutler
Mon May 20, 2013 6:12 pm
Forum: General discussion
Topic: Symantec's Norton Safe Web thinks there is something wrong o
Replies: 9
Views: 2449

Re: Symantec's Norton Safe Web thinks there is something wro

Malwarebytes calls it a "potentially unwanted program" rather than an explicit threat. The oddest thing is that Norton found it to be somehow linked to the Pi page. I wonder if it could be because there was a link to the download page the zip file for it in the camera announcement? http://www.raspb...

Go to advanced search