Go to advanced search

by lrhorer
Sun Nov 18, 2018 8:59 pm
Forum: Other programming languages
Topic: javascript not working on RPi 3
Replies: 32
Views: 8428

Re: javascript not working on RPi 3

If the page is never going to be served across any network I would be inclined to not use a webserver. Or at least not the likes of Apache etc. Rather, use that web page with Electron and have the "backend" done in node.js within the same Electron application. That sounds like an excellent idea! I ...
by lrhorer
Sun Nov 18, 2018 8:23 pm
Forum: Other programming languages
Topic: javascript not working on RPi 3
Replies: 32
Views: 8428

Re: javascript not working on RPi 3

Looks good! Despite you're not a webdeveloper, you did a great job! Well, thank you very much. You are quite kind. It's not fancy, and I have had a lot of help. As a matter of fact, we were told at high school that scientific method will work even if we're happen to live in a hologram, an existing ...
by lrhorer
Sun Nov 18, 2018 7:44 pm
Forum: Other programming languages
Topic: javascript not working on RPi 3
Replies: 32
Views: 8428

Re: javascript not working on RPi 3

Uh, oh, it seems I've sidetracked the topic How dare you !! ;) I don't want start a deep theoretical discusson about our universe if you don't mind. I concur. Two, small nits, however. You included math in the list of disciplines that require external validation, but it isn't. No mathematical form ...
by lrhorer
Sun Nov 18, 2018 7:24 pm
Forum: Other programming languages
Topic: javascript not working on RPi 3
Replies: 32
Views: 8428

Re: javascript not working on RPi 3

That's no excuse for sloppy security. It may not be connected today, it may be in the future. No, this is an embedded application. If the end user hacks the platform and opens up the network, that's his problem. Otherwise it sits on the wall and responds to button presses on the front panel and bro...
by lrhorer
Sun Nov 18, 2018 1:45 am
Forum: Other programming languages
Topic: javascript not working on RPi 3
Replies: 32
Views: 8428

Re: javascript not working on RPi 3

I'd like to add one thing on security side: you should use a POST method (add "method='POST'" to the form tag). I am aware of the implications for security, but since this page will never be available to the internet, or indeed across any network, the point is moot. Once the software development is...
by lrhorer
Sun Nov 18, 2018 12:23 am
Forum: Other programming languages
Topic: javascript not working on RPi 3
Replies: 32
Views: 8428

Re: javascript not working on RPi 3

Anyway, the postulates of science are spelled out here Correct, sort of, but if you will look closely, you will see every one of his categories have points that are derivative of the First Postulate. The 1st, 2md, 5th, and 10th postulates are actually derived from the First Postulate of Science. In...
by lrhorer
Sun Nov 18, 2018 12:04 am
Forum: Other programming languages
Topic: javascript not working on RPi 3
Replies: 32
Views: 8428

Re: javascript not working on RPi 3

Um, no. Of course, some of this boils down to semantics, but some is fundamental. First of all, I believe it was Kurt Gödel who showed that every formal system of dedction (mathematical, scientific, logical, whatever) must contain at least one assumption, also known as an axiom, a principle, or a po...
by lrhorer
Sat Nov 17, 2018 2:59 am
Forum: Other programming languages
Topic: javascript not working on RPi 3
Replies: 32
Views: 8428

Re: javascript not working on RPi 3

Yep. It's performing a GET to a CGI script which writes to wpa_supplicant.conf and completes by killing itself and its ancestors. Of course, on your machine, this does nothing, On the Raspberry Pi, it shuts down Chrome, because it is no longer useful, and brings the desktop back up.
by lrhorer
Fri Nov 16, 2018 6:38 pm
Forum: Other programming languages
Topic: javascript not working on RPi 3
Replies: 32
Views: 8428

Re: javascript not working on RPi 3

Nope, that wasn't an assumption, that's a fact. I made a well-educated guess based on many years of experience. A guess, stated as if it were fact, is the same thing as an assumption, with the same potential results. It is an implication, and any inference drawn upon it and acted upon as if it were...
by lrhorer
Wed Nov 14, 2018 8:11 pm
Forum: Other programming languages
Topic: javascript not working on RPi 3
Replies: 32
Views: 8428

Re: javascript not working on RPi 3

There is a good reason for this behavior and with a bit of though it makes sense. I understand the logic, I just don't quite agree with it. It creates a situation that in a case such as this is difficult to troubleshoot. Of course, now I know about it, I can avoid the pitfall in the future. When a ...
by lrhorer
Tue Nov 13, 2018 9:17 pm
Forum: Other programming languages
Topic: javascript not working on RPi 3
Replies: 32
Views: 8428

Re: javascript not working on RPi 3

Which is what I explained above. Glad you got it working. Yes, it was. As it happens, I didn't read your explanation until I had already fixed it, but your input would have led me directly there. Thank you. I'm very sure if you look in Apache's access.log No doubt. I have since restarted Apache, so...
by lrhorer
Mon Nov 12, 2018 7:52 pm
Forum: Other programming languages
Topic: javascript not working on RPi 3
Replies: 32
Views: 8428

Re: javascript not working on RPi 3

What I still don't quite understand is why Apache does not log 404 errors. Had it done so, I would have figured this out much earlier.
by lrhorer
Mon Nov 12, 2018 7:49 pm
Forum: Other programming languages
Topic: javascript not working on RPi 3
Replies: 32
Views: 8428

Re: javascript not working on RPi 3

OK, I fixed it. Depending on exactly how I specified the URLs, Apache either thought the JS files were scripts executable on the server, rather than the browser, or else they were in a location Apache refused to read. I moved everything not CGI related to /var/www/html/lib, and now it works.
by lrhorer
Mon Nov 12, 2018 7:18 pm
Forum: Other programming languages
Topic: javascript not working on RPi 3
Replies: 32
Views: 8428

Re: javascript not working on RPi 3

This does not appear to be a JQuery error nor a problem with the jkeyboard plugin. Note the issue is with the script not loading, not with the syntax of the script. Actually, I am not sure why Apache is not spawning an error, but from the HTTP stream: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN...
by lrhorer
Mon Nov 12, 2018 5:54 pm
Forum: Other programming languages
Topic: javascript not working on RPi 3
Replies: 32
Views: 8428

Re: javascript not working on RPi 3

First of all, your problem is not Raspberry related. That is an assumption, and making unnecessary and especially undocumented assumptions is a bad idea when troubleshooting. I admit it doesn't seem most likely to be an issue related to the RPi, or more properly Raspbian, but I have documented sign...
by lrhorer
Tue Nov 06, 2018 10:44 pm
Forum: Other programming languages
Topic: javascript not working on RPi 3
Replies: 32
Views: 8428

javascript not working on RPi 3

I have a Raspberry Pi 3 running java 1.8.0_65, apache 2.4.25, and chromium-browser 60.0.3112.89 under Raspbian 9.4, and I am having some trouble with some javascript running from a CGI script. I have never in my life worked with javascript, and I am no expert with HTML or CGI, so am pretty lost, her...
by lrhorer
Sun Oct 21, 2018 1:56 pm
Forum: Advanced users
Topic: Apache2 not working with CGI enabled
Replies: 4
Views: 808

Re: Apache2 not working with CGI enabled

I could have sworn I tried that already. Either I am mis-remembering, or else I had something else wrong, as well. In any case, thanks.
by lrhorer
Tue Oct 16, 2018 3:17 am
Forum: Advanced users
Topic: Apache2 not working with CGI enabled
Replies: 4
Views: 808

Re: Apache2 not working with CGI enabled

No, I don't, plus it fails before it even gets to scanning the body of the page.
by lrhorer
Mon Oct 15, 2018 2:32 pm
Forum: Advanced users
Topic: Apache2 not working with CGI enabled
Replies: 4
Views: 808

Apache2 not working with CGI enabled

I am running Apache2.4.25 under Raspbian. Prior to enabling CGI, everything was working fine, but I need to implement some scripts, so I ran a2enmod, and the system enabled CGI. Now I can't get anythng to work, however. I can't even get a flat html page to load. Apache thinks it is a script and comp...
by lrhorer
Fri Oct 12, 2018 1:36 am
Forum: Advanced users
Topic: Boot to alternate screen
Replies: 2
Views: 377

Re: Boot to alternate screen

'Got it, thanks! See my follow-up query in that thread.
by lrhorer
Fri Oct 12, 2018 1:35 am
Forum: Beginners
Topic: How to boot browser page from startup
Replies: 16
Views: 6394

Re: How to boot browser page from startup

It works for me, however it still brings up the desktop before loading the browser. 'Not a big deal, really, but is there any way to prevent the desktop from popping up at all? It would be nice if the system booted straight into the browser.
by lrhorer
Wed Oct 10, 2018 10:45 am
Forum: Advanced users
Topic: Boot to alternate screen
Replies: 2
Views: 377

Boot to alternate screen

I am working on an application which needs to boot to a web page rather than t he desktop. I would like the Pi to boot up to a specific full screen web page display with no visible desktop controls. Assume Apache 2.4x web server acting on a page on the local host.
by lrhorer
Tue Apr 04, 2017 12:15 am
Forum: Advanced users
Topic: [RESOLVED] Position matchbox-keyboard
Replies: 1
Views: 1096

[RESOLVED] Position matchbox-keyboard

I am using the matchbox-keyboard utility to provide input from a touchscreen display, but the system puts the keyboard at the top of the screen. I want it at the bottom. The utility is launched from a bash script. Is there a way to force the app to appear at the bottom of the display? Edit: I used w...
by lrhorer
Tue Apr 04, 2017 12:09 am
Forum: Advanced users
Topic: [Resolved] Need to use CE0
Replies: 7
Views: 1884

Re: Need to use CE0

Hey, that worked! Since the other pins change automatically, I did not even think of the possibility that pin would not. Thanks!
by lrhorer
Mon Apr 03, 2017 7:28 am
Forum: Advanced users
Topic: [Resolved] Need to use CE0
Replies: 7
Views: 1884

[Resolved] Need to use CE0

I am developing a board that uses a number of GPIO input pins, including Pin 24, which is defined as CE0 for the SPI bus. I am using a 5" HDMI monitor that employs SPI for its touch screen interface, but it is not attached to pin 24. I need to re-purpose that pin as GPIO wPi 10, but the system won't...

Go to advanced search