Go to advanced search

by cacophony555
Wed Jan 18, 2017 6:01 pm
Forum: Gaming
Topic: Script to generate Emulation Station xml (MAME/FBA/consoles)
Replies: 7
Views: 13469

Re: Script to generate Emulation Station xml (MAME/FBA/conso

wgtspook wrote:Can you repost mameGenXml. The link appears to be broken. Thank you.
Sure, here's a new location:
http://bobtailed-primes.000webhostapp.com/mame/

Hope it proves useful!
by cacophony555
Sun Mar 13, 2016 5:27 pm
Forum: Gaming
Topic: RetroArch on Raspbian: the tutorial
Replies: 204
Views: 152222

Re: RetroArch on Raspbian: the tutorial

I can't seem to get it to work. Followed the tutorial by the letter but RetroArch won't start. If I try to run it through a command I get no feedback at all. When I run it through the file manager nothing happens. And when I run it with terminal then the terminal immediately disappears. I'm quite n...
by cacophony555
Sat Mar 05, 2016 1:26 am
Forum: Gaming
Topic: Emulation on the Pi3: Initial Testing
Replies: 33
Views: 23164

Re: Emulation on the Pi3: Initial Testing

I'd really like to know how Mame 0.171 (which is the latest) performs on the pi 3:
http://choccyhobnob.com/mame-for-raspberry-pi2/
more info here: http://choccyhobnob.com/mame-0-171-for- ... -playable/

It should have far better compatibility and accuracy
by cacophony555
Thu Mar 03, 2016 7:53 am
Forum: Gaming
Topic: MAME 0.171 for Raspberry Pi2
Replies: 3
Views: 1460

Re: MAME 0.171 for Raspberry Pi2

I'm curious how this performs on the Pi 3. Would it benefit from a recompile or would most of the performance gain be achievable using the same executable?
by cacophony555
Thu Jul 09, 2015 4:56 pm
Forum: Gaming
Topic: STICKY: MAME4ALL for Pi
Replies: 435
Views: 257029

Re: MAME4ALL for Pi

"Is that to quit the frontend or MAME itself? For MAME you need to configure the buttons in the program itself, i.e. hit TAB." yes but when i tab to set controls in mame, there is no option to quit or exit the emulator. the keyboard esc key exits but there is no whee to set that within mame itself,...
by cacophony555
Thu Jul 09, 2015 4:53 pm
Forum: Gaming
Topic: RetroPie mame4all controls not working
Replies: 3
Views: 5237

Re: RetroPie mame4all controls not working

You solved it by switching to the mame4all retroarch core. The standalone core has significantly better performance/framerate than the retroarch core so I'd suggest switching back. To set the controls in standalone you just need to plug a keyboard in and press TAB after a game has loaded. This will ...
by cacophony555
Sat May 09, 2015 5:04 am
Forum: Troubleshooting
Topic: Unable to start service within script file initiated by cron
Replies: 5
Views: 831

Re: Unable to start service within script file initiated by

What I really should have used is:

pgrep --exact "deluged"

Then I would have been fine with the "deluged-watcher.sh" script name

:D
by cacophony555
Sat May 09, 2015 4:43 am
Forum: Troubleshooting
Topic: Unable to start service within script file initiated by cron
Replies: 5
Views: 831

Re: Unable to start service within script file initiated by

I figured it out. The watcher script I wrote had "deluged" as part of the title, so every time the script checked if "deluged" was running... it thought it was!
by cacophony555
Sat May 09, 2015 12:54 am
Forum: Troubleshooting
Topic: Unable to start service within script file initiated by cron
Replies: 5
Views: 831

Re: Unable to start service within script file initiated by

hmmm... looks like there is an issue with the logic. I don't understand why this isn't working. The full output from my console shows what I'm seeing: pi@raspberrypi ~/scripts $ more deluged-watcher.sh #!/bin/bash # Check if deluged is running if pgrep "deluged" > /dev/null then echo "Running" else ...
by cacophony555
Fri May 08, 2015 11:50 pm
Forum: Troubleshooting
Topic: Unable to start service within script file initiated by cron
Replies: 5
Views: 831

Unable to start service within script file initiated by cron

I've noticed that deluged has a tendency to crash so I was interested in monitoring the service and restarting if necessary via cron, but I can't get it to work. Here's the cron job: * * * * * /home/pi/scripts/deluged-watcher.sh I've verified that the cron job is firing and that the logic in the scr...
by cacophony555
Fri May 08, 2015 7:17 pm
Forum: Troubleshooting
Topic: Can't get USB drive to auto mount
Replies: 13
Views: 5494

Re: Can't get USB drive to auto mount

So I initially tried bootdelay=10 and it didn't work. I changed it to rootdelay=10 and it worked.
Thanks again for the help.
by cacophony555
Fri May 08, 2015 5:47 pm
Forum: Troubleshooting
Topic: Can't get USB drive to auto mount
Replies: 13
Views: 5494

Re: Can't get USB drive to auto mount

Ahh, sorry, didn't notice that you were referring to a slightly different mechanism. Did I get the file location correct?
by cacophony555
Fri May 08, 2015 5:28 pm
Forum: Troubleshooting
Topic: Can't get USB drive to auto mount
Replies: 13
Views: 5494

Re: Can't get USB drive to auto mount

The UUID thing is handy if you may have other storage devices connected as it uniquely identifies the device no matter what /dev/sdX name it is given. However, that is not your problem. It's an excellent thing when you accidentally leave a USB stick inserted when you reboot and the hard drive appea...
by cacophony555
Thu May 07, 2015 7:23 am
Forum: Troubleshooting
Topic: Can't get USB drive to auto mount
Replies: 13
Views: 5494

Re: Can't get USB drive to auto mount

That's a great suggestion rpdom, thanks for the response. I'll give that a try.
by cacophony555
Thu May 07, 2015 3:13 am
Forum: Troubleshooting
Topic: Can't get USB drive to auto mount
Replies: 13
Views: 5494

Re: Can't get USB drive to auto mount

I did try using the UUID by adding this to /etc/fstab, but it didn't make a difference: UUID=dad3727d-6b29-4f64-b7be-abacc0c90a23 /usbdrive auto defaults,noatime 0 1 As before, doing a "sudo mount -a" works, but following reboot the drive is not mounted. Perhaps the USB devices aren't even being rec...
by cacophony555
Wed May 06, 2015 5:23 pm
Forum: Troubleshooting
Topic: Can't get USB drive to auto mount
Replies: 13
Views: 5494

Re: Can't get USB drive to auto mount

There's also this output, which seems to indicate it is ext4: pi@raspberrypi ~ $ sudo blkid -c /dev/null /dev/mmcblk0p1: SEC_TYPE="msdos" LABEL="boot" UUID="140A-14B7" TYPE="vfat" /dev/mmcblk0p2: UUID="f24a4949-f4b2-4cad-a780-a138695079ec" TYPE="ext4" /dev/sda1: LABEL="downloads" UUID="dad3727d-6b29...
by cacophony555
Wed May 06, 2015 5:02 am
Forum: Troubleshooting
Topic: Can't get USB drive to auto mount
Replies: 13
Views: 5494

Can't get USB drive to auto mount

Short version: I can't get my new USB drive to mount automatically on boot, despite the fact that it mounts fine using "sudo mount -a". Long version: I have a new USB external hard drive plugged into my Pi 2. I created a mount directory and successfully formatted it to be EXT4 using : sudo mkdir /mn...
by cacophony555
Tue May 05, 2015 6:23 am
Forum: Networking and servers
Topic: Need help with bitorrent speed issues
Replies: 18
Views: 3190

Re: Need help with bitorrent speed issues

Update: So I bought a WD Elements 500GB portable hard drive and formatted it to be EXT4 using this tutorial: http://devtidbits.com/2013/03/21/using-usb-external-hard-disk-flash-drives-with-to-your-raspberry-pi/ Now I get a consistent 9.5MB/sec write within Deluge, which is basically maxing out my in...
by cacophony555
Thu Apr 30, 2015 1:34 am
Forum: Networking and servers
Topic: Need help with bitorrent speed issues
Replies: 18
Views: 3190

Re: Need help with bitorrent speed issues

I think you're mistaken to pursue sd card speed as the reason for super slow torrent download speeds. High speed sd cards are designed for long bursts of write operations to support hd video recording whereas an operating system performs many small i/o operations which, ironically, are often suppor...
by cacophony555
Wed Apr 29, 2015 4:57 pm
Forum: Networking and servers
Topic: Need help with bitorrent speed issues
Replies: 18
Views: 3190

Re: Need help with bitorrent speed issues

FWIW, I'm using a "SanDisk Ultra 32GB UHS-I/Class 10 Micro SDHC Memory Card Up to 48MB/s". I did a disk read/write test at some point and didn't see anywhere near 48MB/s. I can't recall the exact numbers, though I remember it as being around 10MB/s, and that might just be sequential reads. Perhaps w...
by cacophony555
Wed Apr 29, 2015 3:55 am
Forum: Networking and servers
Topic: Need help with bitorrent speed issues
Replies: 18
Views: 3190

Re: Need help with bitorrent speed issues

Interesting, thanks for the reply. I wonder if using an external hard drive would help.
by cacophony555
Tue Apr 28, 2015 3:11 am
Forum: Networking and servers
Topic: Need help with bitorrent speed issues
Replies: 18
Views: 3190

Need help with bitorrent speed issues

I'm trying to setup Deluge on my Raspberry Pi 2 using the following tutorial: http://www.howtogeek.com/142044/how-to-turn-a-raspberry-pi-into-an-always-on-bittorrent-box/ All the steps work fine, but when I actually add a torrent I see a wildly variable download speed that also appears cyclical. Whe...
by cacophony555
Sat Mar 21, 2015 8:57 pm
Forum: Gaming
Topic: RetroArch on Raspbian: the tutorial
Replies: 204
Views: 152222

Re: RetroArch on Raspbian: the tutorial

Since getting the Pi 2 Ive been using RetroPie. If I wanted to try retroarch with Dispmanx could I just modify the local params from the retroarch setup script to pass the suggested parameters:
https://github.com/petrockblog/RetroPie ... troarch.sh
?
by cacophony555
Sun Mar 15, 2015 6:41 pm
Forum: Troubleshooting
Topic: Raspberry Pi 2 shuts off unexpectedly
Replies: 0
Views: 343

Raspberry Pi 2 shuts off unexpectedly

I've been seeing an intermittent issue and I'd like thoughts on how I can diagnose. About 4 times in the past day my Rpi 2 shut off completely (and without any warning) following a pretty short session of usage. And no I didn't take a flash picture :mrgreen: Some info about my setup: I've been runni...
by cacophony555
Tue Mar 03, 2015 6:30 pm
Forum: Gaming
Topic: Which emulator setup you use/prefer?
Replies: 7
Views: 10543

Re: Which emulator setup you use/prefer?

When I first set up a pi or retro gaming about two years ago I started with RetroPie. I liked it but it felt somewhat suboptimal because it came with so much installed that I didn't want. I also wanted to ensure that everything was built/launched in the most optimized and performant way possible. So...

Go to advanced search