Go to advanced search

by leofric
Sat Jan 12, 2019 11:08 pm
Forum: Automation, sensing and robotics
Topic: XY-LPWM Signal generator [solved]
Replies: 7
Views: 2645

Re: XY-LPWM Signal generator [solved]

My code above reads ok. Are you using my code or have you put it into Python 2.7? There are encoding differences for strings. Make sure you are sending read in lower case.
by leofric
Fri Dec 28, 2018 2:36 pm
Forum: Automation, sensing and robotics
Topic: XY-LPWM Signal generator [solved]
Replies: 7
Views: 2645

Re: XY-LPWM Signal generator

Not very elegant but the code works OK. :D #!/usr/bin/env python3 import time import serial import sys #setup the serial port - the AMA0 part will need changing for later versions ser=serial.Serial( port='/dev/ttyAMA0', baudrate=9600, parity=serial.PARITY_NONE, stopbits=serial.STOPBITS_ONE, bytesize...
by leofric
Thu Dec 27, 2018 9:58 pm
Forum: Automation, sensing and robotics
Topic: XY-LPWM Signal generator [solved]
Replies: 7
Views: 2645

Re: XY-LPWM Signal generator

:D Prompted by somebody else being interested I have had another go. Got it working both from Cutecom and a skeleton python program! Will tidy up the code tomorrow and post it here. I don't think there was a problem with my old code. I was powering the xy-lpwm from the 5v output on the GPIO - althou...
by leofric
Thu Dec 27, 2018 11:40 am
Forum: Automation, sensing and robotics
Topic: XY-LPWM Signal generator [solved]
Replies: 7
Views: 2645

Re: XY-LPWM Signal generator

Pleased that someone else is also trying this. Not had time to get back to it but will do soon. I am wanting to use it to provide a pwm input to an MC2100 treadmill motor controller for use in a lathe - the front end being a pi touch screen. Had hoped this was an easy solution... My , not working, c...
by leofric
Mon Dec 10, 2018 9:21 am
Forum: Automation, sensing and robotics
Topic: XY-LPWM Signal generator [solved]
Replies: 7
Views: 2645

XY-LPWM Signal generator [solved]

Not sure where to post this. Has anyone linked a pi to the xy-lpwm signal generator? I am failing to get it to respond to signals from gpio Tx and not getting anything on Rx. Have tried linking pi Tx and Rx together and this confirms that my code sends and reads ok. Tried my code and a terminal prog...
by leofric
Fri Jan 17, 2014 5:09 pm
Forum: Camera board
Topic: issue with raspistill (&vid) saving to mounted network drive
Replies: 4
Views: 1628

Re: issue with raspistill (&vid) saving to mounted network d

problem solved .... !
:oops:
I thought I was at the root but wasn't.

sudo raspistill -o /mnt/PiPics/Testpic.jpg

works fine and saves the image directly to the mapped drive on the networked PC.
by leofric
Fri Jan 17, 2014 4:03 pm
Forum: Camera board
Topic: issue with raspistill (&vid) saving to mounted network drive
Replies: 4
Views: 1628

Re: issue with raspistill (&vid) saving to mounted network d

Thanks for the prompt reply.

I could do as you suggest but I don't understand why raspistill can't save directly to the drive as other apps can.
by leofric
Fri Jan 17, 2014 10:57 am
Forum: Camera board
Topic: issue with raspistill (&vid) saving to mounted network drive
Replies: 4
Views: 1628

issue with raspistill (&vid) saving to mounted network drive

Hi - been around computers for years but very new to raspberry pi and linux. Help please - going in circles. I have mounted the public folder on a wired network Windows PC as PiPics The folder has read/write access. On the Pi I can browse the contents of the PC folder by cd /mmt/PiPics and see the c...

Go to advanced search