Go to advanced search

by SurferTim
Wed Jan 02, 2019 11:36 am
Forum: Networking and servers
Topic: Raspberry pi3 access point !!
Replies: 9
Views: 1197

Re: Raspberry pi3 access point !!

timsan wrote:
Tue Jan 01, 2019 8:45 pm
That Alfa Network device looks really good.

Do you need to use a mini-usb to usb cable to connect it with the Raspberry Pi?

ta, t.
It comes with a standard usb cable.
by SurferTim
Tue Jan 01, 2019 1:03 am
Forum: Networking and servers
Topic: Raspberry pi3 access point !!
Replies: 9
Views: 1197

Re: Raspberry pi3 access point !!

I use the Alfa brand, and they work well with RPis. Plug-N-Play.
https://www.amazon.com/Alfa-Network-Wir ... op?ie=UTF8
by SurferTim
Wed Nov 21, 2018 2:56 pm
Forum: Troubleshooting
Topic: Wlan0 - Eth0 Bridge WITH DHCP AP
Replies: 5
Views: 1173

Re: Wlan0 - Eth0 Bridge WITH DHCP AP

You should have set up the RPi as a bridge, and used one subnet on both interfaces. Like 192.168.1.x/24.
by SurferTim
Tue Nov 20, 2018 12:29 pm
Forum: Troubleshooting
Topic: Wlan0 - Eth0 Bridge WITH DHCP AP
Replies: 5
Views: 1173

Re: Wlan0 - Eth0 Bridge WITH DHCP AP

1. Make my RPi a wi-fi hotspot (DHCP) in order to be able to connect to the devices at Eth0 from my laptop via wi-fi... of course I can use a bridge however this is my problem. :x The devices have IP addresses eg 192.168.1.XX so my network has to be (Wlan)192.168.0.X. A bridge will have the same ne...
by SurferTim
Mon Nov 19, 2018 8:06 pm
Forum: Networking and servers
Topic: Network sharing through cell phone
Replies: 2
Views: 999

Re: Network sharing through cell phone

You can do what you want. I use my cell as a hotspot for my RPi and have a AP on wlan0. The only caveat is the AP must be on wlan0. Follow the instructions on the link epoch1970 provided. Use this to assign wlan interface names if the interface you want to use for the AP doesn't boot as wlan0. Creat...
by SurferTim
Tue Nov 13, 2018 12:43 pm
Forum: Troubleshooting
Topic: how fix error update ?!
Replies: 1
Views: 173

Re: how fix error update ?!

Looks like a DNS problem.
by SurferTim
Thu Nov 08, 2018 12:45 pm
Forum: Troubleshooting
Topic: wpa_cli interface name p2p-dev-wlan0
Replies: 4
Views: 786

Re: wpa_cli interface name p2p-dev-wlan0

I would try changing this ACTION=="add", SUBSYSTEM=="net", SUBSYSTEM=="usb", DRIVERS=="?*", ATTR{address}=="?[014589cd]:*", KERNEL=="w*",NAME="wlan1" to this. Note the mac address and delete duplicate SUBSYSTEM. ACTION=="add", SUBSYSTEM=="net", DRIVERS=="?*", ATTR{address}=="ca:66:51:73:b9:02", KERN...
by SurferTim
Mon Nov 05, 2018 11:05 am
Forum: Troubleshooting
Topic: Why is my bridge br0 only IPv6??
Replies: 6
Views: 612

Re: Why is my bridge br0 only IPv6??

In /etc/network/interfaces you have this

Code: Select all

iface br0 inet dhcp
...then in /etc/dhcpcd.conf you have this

Code: Select all

denyinterfaces br0 tap0 eth0
You should use the denyinterfaces with members of the bridge, not the bridge.
by SurferTim
Fri Nov 02, 2018 12:21 pm
Forum: Networking and servers
Topic: Problem with "Wifi to Ethernet Bridge" HowTo -- solved!
Replies: 8
Views: 1153

Re: Problem with "Wifi to Ethernet Bridge" HowTo -- solved!

mohammedshafit wrote: Hi, I am looking for the same what you have accomplished here.
Can you please consolidate the steps you have done. That would be a great help for newbies like me.
Consider it done.
https://www.raspberrypi.org/documentati ... s-point.md
by SurferTim
Thu Oct 25, 2018 1:04 pm
Forum: Networking and servers
Topic: Create an access point on wlan1
Replies: 14
Views: 2285

Re: Create an access point on wlan1

Could you confirm that is the good procedure? Moreover, do I need to rename wpa_supplicant.conf to wpa_supplicant-wlan0.conf? Yes. I tested it several times myself on different devices. No, you do not need to rename wpa_supplicant.conf if you add the "nohook wpa_supplicant" line to /etc/dhcpcd.conf.
by SurferTim
Wed Oct 24, 2018 9:32 pm
Forum: Networking and servers
Topic: Create an access point on wlan1
Replies: 14
Views: 2285

Re: Create an access point on wlan1

I don't know if I understand right but when I read the first message of SurferTIm, I understand that it is not possible to add an access point on wlan1 (only on wlan0). Is it correct? That is correct. You must install your AP on wlan0. You can rename them as I explained above. Insure when you add t...
by SurferTim
Wed Oct 24, 2018 1:39 pm
Forum: Troubleshooting
Topic: Simultaneous access ethernet and wifi
Replies: 11
Views: 1004

Re: Simultaneous access ethernet and wifi

I can also, as long as the subnets are different. Are your wlan0 and eth0 subnets identical?
by SurferTim
Wed Oct 24, 2018 12:32 pm
Forum: Troubleshooting
Topic: Simultaneous access ethernet and wifi
Replies: 11
Views: 1004

Re: Simultaneous access ethernet and wifi

IMO the simplest solution is to use DHCP IP to MAC reservations in the router instead of static config on the RPi. Leave the RPi set to default DHCP setup. On the router assign one IP to the MAC address of the Ethernet and assign a different IP to the MAC of the WIFI. This method just works with no...
by SurferTim
Wed Oct 24, 2018 11:42 am
Forum: Troubleshooting
Topic: Simultaneous access ethernet and wifi
Replies: 11
Views: 1004

Re: Simultaneous access ethernet and wifi

The RPi is having routing problems due to the same localnet on both interfaces.

You have a choice.
1) Change the localnet on one of the interfaces.
or
2) Use routing marks to determine the routes.

#1 is by far the simplest solution.
by SurferTim
Tue Oct 23, 2018 8:21 pm
Forum: Networking and servers
Topic: Create an access point on wlan1
Replies: 14
Views: 2285

Re: Create an access point on wlan1

I had no luck setting up an AP on wlan1. Could it be wpa-supplicant trying to apply file wpa_supplicant.conf to wlan1, making it unavailable later on for AP configuration? To test that, I would try renaming wpa_supplicant.conf to wpa_supplicant-wlan0.conf (and perhaps also moving it to /etc/wpa_sup...
by SurferTim
Tue Oct 23, 2018 8:08 pm
Forum: Networking and servers
Topic: Create an access point on wlan1
Replies: 14
Views: 2285

Re: Create an access point on wlan1

I had no luck setting up an AP on wlan1. However, I found a way to rename the interfaces so you can install an AP on wlan0. Create file /etc/udev/rules.d/72-static-name.rules Add this: ACTION=="add", SUBSYSTEM=="net", DRIVERS=="?*", ATTR{address}=="00:c0:ca:96:d8:8b", KERNEL=="w*",NAME="wlan0" ACTIO...
by SurferTim
Mon Oct 22, 2018 1:30 pm
Forum: Troubleshooting
Topic: [SOLVED] Bridge wlan0 and eth0 - help needed
Replies: 55
Views: 30516

Re: [SOLVED] Bridge wlan0 and eth0 - help needed

What about the computer you are attempting to connect with? It doesn't show up as a dhcp lease? How does it get its IP?

Edit: Is your computer connected by ethernet or wifi?
by SurferTim
Mon Oct 22, 2018 1:00 pm
Forum: Troubleshooting
Topic: [SOLVED] Bridge wlan0 and eth0 - help needed
Replies: 55
Views: 30516

Re: [SOLVED] Bridge wlan0 and eth0 - help needed

Is the RPi getting network settings from a dhcp server? Normally, a "connection refused" message indicates there is no ssh daemon running on the destination device, or the firewall is preventing a connection.

Are you certain there is no other device using that IP?
by SurferTim
Mon Oct 22, 2018 11:30 am
Forum: Troubleshooting
Topic: [SOLVED] Bridge wlan0 and eth0 - help needed
Replies: 55
Views: 30516

Re: [SOLVED] Bridge wlan0 and eth0 - help needed

What is the IP/netmask on the computer that you are using to connect to the RPi?

Edit /etc/sysctl.conf and uncomment

Code: Select all

net.ipv4.ip_forward=1
by SurferTim
Sat Oct 20, 2018 3:41 pm
Forum: Troubleshooting
Topic: [SOLVED] Bridge wlan0 and eth0 - help needed
Replies: 55
Views: 30516

Re: [SOLVED] Bridge wlan0 and eth0 - help needed

Did you enable ssh in the rpi config? It is disabled by default.
by SurferTim
Sat Oct 20, 2018 12:23 pm
Forum: Troubleshooting
Topic: [SOLVED] Bridge wlan0 and eth0 - help needed
Replies: 55
Views: 30516

Re: [SOLVED] Bridge wlan0 and eth0 - help needed

I don't have a problem using ssh on a bridge.

Run ifconfig and insure the IP is assigned to br0, and both eth0 and wlan0 have no assignments.

Edit: Also use this. Note "manual", not "dhcp"

Code: Select all

auto br0
iface br0 inet manual
bridge_ports eth0 wlan0
by SurferTim
Fri Oct 19, 2018 5:56 pm
Forum: Networking and servers
Topic: Pi 3 as wiireless client and wireless AP?
Replies: 193
Views: 130069

Re: Pi 3 as wiireless client and wireless AP?

#1) Both the AP and client use the same radio and frequency. This causes delays and errors. #2) I use a usb dongle for wlan1 when I want to use a wireless device as the wan interface. The AP must be wlan0. #3) The only addition you must do is add a masquerade for wlan1 in the same fashion as you do ...
by SurferTim
Thu Oct 18, 2018 12:11 pm
Forum: Troubleshooting
Topic: My local website doesn't work and every time i ping localhost i see it's from ( : : 1), Help pls
Replies: 6
Views: 443

Re: My local website doesn't work and every time i ping localhost i see it's from ( : : 1), Help pls

Do you have another uSD card? If so, you should try a fresh install. If not, you should think about buying one.
by SurferTim
Thu Oct 18, 2018 1:03 am
Forum: Networking and servers
Topic: pi 3 access point with webservers
Replies: 9
Views: 980

Re: pi 3 access point with webservers

If you are going to assign a static IP to a bridge, it must be within the localnet, not already used by another device, and outside the dhcp range.
by SurferTim
Wed Oct 17, 2018 11:42 pm
Forum: Troubleshooting
Topic: My local website doesn't work and every time i ping localhost i see it's from ( : : 1), Help pls
Replies: 6
Views: 443

Re: My local website doesn't work and every time i ping localhost i see it's from ( : : 1), Help pls

These three lines explain a little. The lines aren't complete, but it appears you have some other service running that is taking that address and sockets.

Code: Select all

Active: failed (Result: exit-code) since Wed 2018-10-17 08:36:39 PDT; 7h ago
Address already in use:
no listening sockets available

Go to advanced search