Go to advanced search

by ZuLuuuuuu
Sun Apr 30, 2017 11:32 am
Forum: Automation, sensing and robotics
Topic: Error when reading data from USB touch screen controller
Replies: 1
Views: 480

Re: Error when reading data from USB touch screen controller

I guess I found the problem: the power going to my Raspberry Pi was insufficient. It was giving power warning at the corner of the screen. I plugged another power supply, both the warning disappeared and the touch controller started to work without giving any errors.
by ZuLuuuuuu
Thu Apr 27, 2017 5:45 pm
Forum: Automation, sensing and robotics
Topic: Error when reading data from USB touch screen controller
Replies: 1
Views: 480

Error when reading data from USB touch screen controller

Hello, I am trying to get absolute coordinates from a USB touch screen controller. I am using Python evdev library. The problem is that when I start the program, and start touching the screen, it reads a few events for a while and then gives a "No such device" error and quits. The lsusb output is: B...
by ZuLuuuuuu
Thu Apr 27, 2017 5:25 pm
Forum: Automation, sensing and robotics
Topic: How to get raw data from USB touch screen controller
Replies: 2
Views: 693

Re: How to get raw data from USB touch screen controller

I believe this post should put you in the right direction of how to disable it in X: http://unix.stackexchange.com/questions/17170/disable-keyboard-mouse-input-on-unix-under-x The raw data can be read by a program by opening the correct device in "/dev/input/", reading from it and interpret the inf...
by ZuLuuuuuu
Thu Apr 06, 2017 9:01 am
Forum: Automation, sensing and robotics
Topic: How to get raw data from USB touch screen controller
Replies: 2
Views: 693

How to get raw data from USB touch screen controller

Hello, I have a touch screen and I received a USB controller (EETI MER4040UPBG to be specific). I want to use the touch screen for a custom device controlled by Raspberry Pi. I don't want touch screen to control the Raspberry mouse, I want to get raw data from it. But when I plug the USB controller,...
by ZuLuuuuuu
Mon Nov 30, 2015 10:43 am
Forum: Advanced users
Topic: How safe is it to connect 2 GPIO pins without resistor?
Replies: 3
Views: 772

Re: How safe is it to connect 2 GPIO pins without resistor?

Thank you for your suggestions. You are presumably using this as a product. Do you expect your users to program either Pi? If so, then resistors are a must to protect the Pis and prevent you having to fix broken Pis in your product. If the Pis are running a pre-packaged, unchanging program then the ...
by ZuLuuuuuu
Sat Nov 28, 2015 5:54 pm
Forum: Advanced users
Topic: How safe is it to connect 2 GPIO pins without resistor?
Replies: 3
Views: 772

How safe is it to connect 2 GPIO pins without resistor?

Hello, we have a setup made with a PCB connecting 2 Raspberry Pi 2's to each other via GPIO ports. We connected the GPIO pins without a resistor in between, so a PCB route directly connects them to each other. I saw that a lot of messages advice to use a resistor in between to protect the pins in ca...
by ZuLuuuuuu
Sat Nov 28, 2015 5:48 pm
Forum: Advanced users
Topic: Backup SD card image to USB disk while Raspberry is running
Replies: 7
Views: 2591

Re: Backup SD card image to USB disk while Raspberry is runn

Thank you for your suggestions. Hello, for one of my projects I want to automate SD card backup, so I don't want to remove the SD card from Raspberry, plug it to my PC and back it up. I want it to be backed up automatically to a USB disk while Raspberry is still running. What do you want to back up?...
by ZuLuuuuuu
Fri Nov 27, 2015 6:03 pm
Forum: Advanced users
Topic: Backup SD card image to USB disk while Raspberry is running
Replies: 7
Views: 2591

Backup SD card image to USB disk while Raspberry is running

Hello, for one of my projects I want to automate SD card backup, so I don't want to remove the SD card from Raspberry, plug it to my PC and back it up. I want it to be backed up automatically to a USB disk while Raspberry is still running.

Is this possible?
by ZuLuuuuuu
Mon Sep 28, 2015 12:36 pm
Forum: Camera board
Topic: Is there a way to set analog and digital gain?
Replies: 1
Views: 479

Is there a way to set analog and digital gain?

Hello, we need to capture absolutely consistent photos using Raspberry cameras. We can set every property of Raspberry camera except analog and digital gain. We currently stop them after they settle around 1 as the documentation says but we need absolutely same values on every capture. Is there any ...
by ZuLuuuuuu
Fri Sep 25, 2015 12:28 pm
Forum: Advanced users
Topic: What is the hardware PWM frequency?
Replies: 3
Views: 1141

Re: What is the hardware PWM frequency?

My piscope will let you see the frequency. You don't say if you want a fixed or variable frequency. I.e. do you want to vary the frequency between 100 and 1000 Hz or do you want any fixed frequency within that range. wiringPi defaults to balanced mode rather than mark space which means the frequenc...
by ZuLuuuuuu
Fri Sep 25, 2015 11:52 am
Forum: Advanced users
Topic: What is the hardware PWM frequency?
Replies: 3
Views: 1141

What is the hardware PWM frequency?

Hello, I am trying to use Raspberry Pi 2's PWM pin to control an LED driver. I am using the wiringpi2 library. The driver needs a PWM frequency of 100Hz to 1KHz. Since I don't have an oscilloscope I cannot see which frequency PWM pin Raspberry Pi 2 is running. So can anybody tell me what the hardwar...
by ZuLuuuuuu
Mon Jul 06, 2015 7:46 am
Forum: Camera board
Topic: Getting consistent images (exposure-wise)
Replies: 2
Views: 1784

Getting consistent images (exposure-wise)

Hello, I am trying to get -very- consistent captures using Raspberry camera. Consistent in exposure/lightning. I wrote a test script to observe the consistency of consecutive captures. This script: 1) Opens the camera 2) Fixes the framerate, resolution, shutter_speed, iso and awb_gains. 3) Captures ...
by ZuLuuuuuu
Fri Mar 27, 2015 1:43 pm
Forum: Camera board
Topic: Images progressively blurry as the day goes on
Replies: 22
Views: 3812

Re: Images progressively blurry as the day goes on

Hello we are facing a similar problem: We are doing a calibration process which requires a very stable camera with fixed FOV. We can calculate the difference between two images of the same scene using our calibration software and we saw that after we first boot up Raspberry, while we are getting ima...
by ZuLuuuuuu
Mon Mar 02, 2015 9:01 pm
Forum: Camera board
Topic: capture_sequence captures first 3 images before "yield"
Replies: 3
Views: 614

Re: capture_sequence captures first 3 images before "yield"

You're using the video port, so entirely expected. In video mode the system will do its utmost to maintain the requested frame rate and fill up all buffering it has before dropping frames. The hope is that whatever is downstream will have got going before frames actually get dropped. There are 3 in...
by ZuLuuuuuu
Mon Mar 02, 2015 7:03 pm
Forum: Camera board
Topic: capture_sequence captures first 3 images before "yield"
Replies: 3
Views: 614

capture_sequence captures first 3 images before "yield"

Hello, I have a projector that I use to project several images onto a scene. I project several photos onto the scene sequentially and try to take 1 picture of every different image projected onto the scene. I am trying to capture photos of the scene using capture_sequence function and I enable video...
by ZuLuuuuuu
Wed Jan 14, 2015 6:06 pm
Forum: Camera board
Topic: Is full FoV possible when video port is enabled?
Replies: 0
Views: 314

Is full FoV possible when video port is enabled?

Hello, I have hard time understanding the table here: http://picamera.readthedocs.org/en/release-1.9/fov.html#camera-modes When it says FoV = Full, does that mean we can get full FoV both in image and video? Or does it mean full FoV only on image port? I cannot get full FoV when I set camera resolut...
by ZuLuuuuuu
Wed Jan 14, 2015 5:52 pm
Forum: Camera board
Topic: Can I get raw image data when use_video_port is set to True?
Replies: 2
Views: 596

Re: Can I get raw image data when use_video_port is set to T

Sorry, I was using picamera.array.PiYUVArray and I guess that was the reason of slowness. I am now using the regular way and yuv is actually faster than jpeg.
by ZuLuuuuuu
Mon Jan 12, 2015 2:41 pm
Forum: Camera board
Topic: Can I get raw image data when use_video_port is set to True?
Replies: 2
Views: 596

Can I get raw image data when use_video_port is set to True?

Hello, when I get jpeg format via capture method and set "use_video_port" to True, it executes very fast, but when I specify YUV as the format then it slows down significantly. Does the camera not use video port when I request raw data?
by ZuLuuuuuu
Fri Aug 01, 2014 1:12 pm
Forum: Automation, sensing and robotics
Topic: Raspberry Pi Type B+ and Kinect
Replies: 1
Views: 1375

Raspberry Pi Type B+ and Kinect

Hello, as you might know Kinect does not work on Raspberry Pi Type B: http://www.raspberrypi.org/forums/viewtopic.php?f=37&t=4530 Some claimed that it is because USB on Raspberry is not being able to handle the big data traffic. With a new USB controller chip present on Type B+, did anybody experime...
by ZuLuuuuuu
Thu Mar 13, 2014 8:31 am
Forum: Automation, sensing and robotics
Topic: Using Asus Xtion Pro Live with Raspberry Pi
Replies: 1
Views: 5211

Re: Using Asus Xtion Pro Live with Raspberry Pi

I followed the exact steps here: http://mewgen.com/Ge107_files/20120921%20Setting%20up%20Rasberry%20pi%20for%20the%20Xtion%20and%20kinect.html With OpenNI 1.5.2.23, Sensor 5.1.0.41, latest Raspbian and now it works. It didn't require a powered USB hub. I did the overclock via the setup screen (I don...
by ZuLuuuuuu
Wed Mar 12, 2014 3:12 pm
Forum: Automation, sensing and robotics
Topic: Using Asus Xtion Pro Live with Raspberry Pi
Replies: 1
Views: 5211

Using Asus Xtion Pro Live with Raspberry Pi

Hello, I just got Asus Xtion Live Pro camera and I try to make it work. I compiled OpenNI using tutorials on internet, I needed to change some parameters in RedistMaker but t compiled. Then I installed the sensor drivers. But when I try to run SimpleRead it says: "One or more of the following nodes ...
by ZuLuuuuuu
Thu Aug 22, 2013 9:23 am
Forum: General discussion
Topic: Is it possible to load .icc color profiles?
Replies: 2
Views: 1656

Is it possible to load .icc color profiles?

Hello, I wanted to know if anybody successfully loaded an .icc color profile and saw the effect on her monitor using Raspberry Pi. I have not tried it with Raspberry Pi but unfortunately I won't have access to a Raspbery Pi for a few days. The reason I ask this question is because the current embedd...
by ZuLuuuuuu
Sun Jul 14, 2013 8:13 am
Forum: Pidora / Fedora
Topic: No Mono on Pidora?
Replies: 2
Views: 1474

Re: No Mono on Pidora?

Hello, I am using Pidora on my Raspberry Pi. I wanted to install Mono (.Net on Linux) but can't find any packages about it. Is there no Mono on Pidora repositories? Hi ZuLuuuuuu, If you post a ticket on trac for pidora we will try to build that package for you. The Url to our trac is: http://zenit....
by ZuLuuuuuu
Thu Jul 11, 2013 11:02 am
Forum: Automation, sensing and robotics
Topic: Kinect depth stream doesn't work
Replies: 2
Views: 1062

Re: Kinect depth stream doesn't work

kpcamota wrote:hello! Any updates on this thread? I also want to use kinect depth on raspberry
I couldn't solve the problem.
by ZuLuuuuuu
Thu Jul 11, 2013 9:34 am
Forum: Pidora / Fedora
Topic: No Mono on Pidora?
Replies: 2
Views: 1474

No Mono on Pidora?

Hello, I am using Pidora on my Raspberry Pi. I wanted to install Mono (.Net on Linux) but can't find any packages about it. Is there no Mono on Pidora repositories?

Go to advanced search