Go to advanced search

by theoriginalxbrav
Mon Mar 19, 2018 9:36 pm
Forum: General discussion
Topic: PLC connecting to a PI with ethernet
Replies: 7
Views: 4133

Re: PLC connecting to a PI with ethernet

Siemens is quite proprietary to begin with. I mostly work with AB PLCs, but I have played with a S7-300 lately (sadly, it didn't have ethernet). Most of the comms are over ProfiNet, but you may be able to communicate if it's running a modbus server of some sort. Otherwise, you'll be bound with the p...
by theoriginalxbrav
Mon Mar 19, 2018 9:33 pm
Forum: General discussion
Topic: Barcode in New Pi 3 B+ Boxes?
Replies: 2
Views: 2418

Barcode in New Pi 3 B+ Boxes?

Conspiracies aside, is there any meaning to the barcode inside the new Pi 3 boxes? It's a CODE_128 that translates to UPKG00645. They used to ship with an anti-static bag, but now it seems to come on this cardboard insert instead. This is the RS / Allied version. Not sure if the Element 14 box is th...
by theoriginalxbrav
Mon Apr 24, 2017 3:37 pm
Forum: Camera board
Topic: Camera Producing Art (Or what the heck am I looking at?)
Replies: 4
Views: 576

Re: Camera Producing Art (Or what the heck am I looking at?)

Ok, sounds awesome. I have it dumping the raw RGBs, so we'll see what excitement comes up. I'm probably dealing with an I/O write timing issue... It's always a race condition I find.

Thanks for the info!
by theoriginalxbrav
Mon Apr 24, 2017 3:23 pm
Forum: Camera board
Topic: Camera Producing Art (Or what the heck am I looking at?)
Replies: 4
Views: 576

Re: Camera Producing Art (Or what the heck am I looking at?)

Sorry for the cropping, it is a result of the following code conversion I run from ImageMagick: os.system("/usr/bin/convert -depth 8 -size 3264x2464 " + tempDir + imageNumber + ".rgb -resize 1920x1442 -gravity center -crop 1920x1080+0+0 " + tempDir + imageNumber + ".jpg") informationCall = "/usr/bin...
by theoriginalxbrav
Mon Apr 24, 2017 1:38 pm
Forum: Camera board
Topic: Camera Producing Art (Or what the heck am I looking at?)
Replies: 4
Views: 576

Camera Producing Art (Or what the heck am I looking at?)

My v2.1 suddenly started having some interesting rainbow pics being thrown out on some of the captured images since my last code tweaks. My camera is capturing rgb captures to a BytesIO() stream to quickly unload to my image processing thread. The image is 3264x2464. I'm processing it via ImageMagic...
by theoriginalxbrav
Tue Apr 18, 2017 3:42 pm
Forum: Camera board
Topic: Interesting Exposure Defect?
Replies: 14
Views: 1884

Re: Interesting Exposure Defect?

I'll continue to monitor it and see. The stills shown are being captured every 15 seconds, 24/7 so it could saturate the Pi3 wifi if I pushed it that high (I'd have a 50GB directory of jpegs by the end of the day haha!) The Pi is inside a camera enclosure outdoors. The temperature noted on the expos...
by theoriginalxbrav
Mon Apr 17, 2017 10:16 pm
Forum: Camera board
Topic: Interesting Exposure Defect?
Replies: 14
Views: 1884

Re: Interesting Exposure Defect?

Currently using JPEG encoder through picamera: Initialization cameraObject.resolution = (3280, 2464) cameraObject.framerate = Fraction(1,5) cameraObject.sensor_mode = 2 time.sleep(3) cameraObject.exposure_mode = 'off' cameraObject.awb_mode = 'off' cameraObject.hflip = True cameraObject.vflip = True ...
by theoriginalxbrav
Mon Apr 17, 2017 9:23 pm
Forum: Camera board
Topic: Interesting Exposure Defect?
Replies: 14
Views: 1884

Interesting Exposure Defect?

So the past few days I've caught this obscure pixel line showing up randomly in exposures. It shows up as a double wide line for a few pixels, then fades off. It only ever shows for a single exposure, and no more than once a day. I'm using picamera with manual control of everything (WB, exposure, IS...
by theoriginalxbrav
Wed Apr 12, 2017 9:16 pm
Forum: Camera board
Topic: PiCamera Processing Times on capture()
Replies: 0
Views: 270

PiCamera Processing Times on capture()

Hey all, I'm constantly looking to see if there's a way to trim down the capture time with PiCamera, and I feel like I'm going down a rabbit hole with the MMAL. I have a global camera instance kept alive in the process, and I've done everything I can to reduce the processing time on the still to fre...
by theoriginalxbrav
Thu Mar 09, 2017 6:53 pm
Forum: Advanced users
Topic: USB OTG g_audio with the Pi Zero (W), output freezes aplay
Replies: 5
Views: 2686

Re: USB OTG g_audio with the Pi Zero (W), output freezes apl

In my case, I'm using the gadget operation on my vehicle. I have no interest in using the analog output to my vehicle's 3.5mm in. Either way, the USB gadget serves up an audio input and output with the g_audio module. I have some other ideas where I'd want the Pi to output audio rather than act as a...
by theoriginalxbrav
Thu Mar 09, 2017 4:01 pm
Forum: Advanced users
Topic: USB OTG g_audio with the Pi Zero (W), output freezes aplay
Replies: 5
Views: 2686

Re: USB OTG g_audio with the Pi Zero (W), output freezes apl

The gadget provides both an input and an output. Although it appears as a peripheral, it has an audio out on the Pi which corresponds with a mic input on the host system.

Aka

Pi OTG out to Host Mic In
Host OTG our to Pi Mic In
by theoriginalxbrav
Thu Mar 09, 2017 1:26 am
Forum: Advanced users
Topic: USB OTG g_audio with the Pi Zero (W), output freezes aplay
Replies: 5
Views: 2686

USB OTG g_audio with the Pi Zero (W), output freezes aplay

Hey all, Either I'm the guinea pig here, or everyone is keeping this grand secret from me haha. I received my Pi Zero W, and successfully enabled the USB audio driver. The device is fully detected: pi@RaspiAuto:~ $ cat /proc/asound/cards 0 [UAC2Gadget ]: UAC2_Gadget - UAC2_Gadget UAC2_Gadget 0 1 [AL...
by theoriginalxbrav
Mon Feb 27, 2017 1:12 pm
Forum: Advanced users
Topic: Pi 3 Always Throttled 0x50005
Replies: 5
Views: 2362

Re: Pi 3 Always Throttled 0x50005

Certainly won't need cooling for now. We'll see what happens come summer.

D-subs are completely heat shrunk, so no worries! Image
by theoriginalxbrav
Sat Feb 25, 2017 11:28 pm
Forum: Advanced users
Topic: Pi 3 Always Throttled 0x50005
Replies: 5
Views: 2362

Re: Pi 3 Always Throttled 0x50005

The 5V regulated output is being fed right onto the GPIO on pins 2 and 6 with your standard run-of-the-mill male to female jumpers . This might be your problem, if these cables are similar to the ones used for breadboarding, because those connectors are not really suitable for high loads. You know ...
by theoriginalxbrav
Sat Feb 25, 2017 2:18 am
Forum: Advanced users
Topic: Pi 3 Always Throttled 0x50005
Replies: 5
Views: 2362

Pi 3 Always Throttled 0x50005

Hey everyone, I'm trying to dig further into why the Pi is seemingly locking itself in a full throttling state. My Pi 3 has been running outdoors continuously, and occasionally has a good crash where it runs out of memory. During my last opportunity to drag it indoors (due to a filesystem issue with...
by theoriginalxbrav
Wed Dec 28, 2016 4:56 am
Forum: Troubleshooting
Topic: Pi3 Freezes, all services seem to fail, still pings
Replies: 1
Views: 455

Pi3 Freezes, all services seem to fail, still pings

So I'm having an issue I simply cannot track down currently. The Pi3 runs outdoors taking photos every 10 seconds, and unloading the image processing and uploads to a separately spawned process. Now, lately, it seems to run for several hours before crashing the whole Pi. Problem is, since it is outd...
by theoriginalxbrav
Mon Nov 14, 2016 12:46 am
Forum: Troubleshooting
Topic: USB Boot Stops Working after apt-get upgrade
Replies: 1
Views: 406

Re: USB Boot Stops Working after apt-get upgrade

Ok, got this sorted out (at least to the point of returned functionality). Thought I'd share my learnings. IF you get stuck with the non-compatible boot options, this is an option. You'll need a way to write to the EXT4 file system to inject new kernel modules. 1) Download the latest NEXT branch fir...
by theoriginalxbrav
Sun Nov 13, 2016 11:21 pm
Forum: Troubleshooting
Topic: USB Boot Stops Working after apt-get upgrade
Replies: 1
Views: 406

USB Boot Stops Working after apt-get upgrade

I've been dealing with this unfortunate headache with my Pi 3. Every time there's a kernel update, the following files on /boot are modified: - kernel.img - kernel7.img - start.elf - start_cd.elf - start_db.elf - start_x.elf - bootcode.bin Unfortunately, each time I reboot after upgrading, the syste...
by theoriginalxbrav
Mon Oct 10, 2016 2:43 am
Forum: Troubleshooting
Topic: Pi3 USB Not Booting after upgrade
Replies: 1
Views: 878

Re: Pi3 USB Not Booting after upgrade

Ok, figured it now. My mistake.

So in order to get it to work, I had to upgrade the SD card to the 'next' branch, then copy all 4 ELF's plus the kernel .IMG files to the USB drive to get it to boot again.

Now I just need to figure out why I can't reboot my Pi without power cycling...
by theoriginalxbrav
Mon Oct 10, 2016 1:40 am
Forum: Troubleshooting
Topic: Pi3 USB Not Booting after upgrade
Replies: 1
Views: 878

Pi3 USB Not Booting after upgrade

I've been dealing with some weird bugs lately where my Pi wasn't completing reboots, and poweroff wasn't triggering the hardware watchdog reset, and this happened: I ran apt-get update && apt-get upgrade, followed by an rpi-update (forgetting the BRANCH=next flag, d'oh!). Obviously, the USB boot fai...
by theoriginalxbrav
Wed Jan 01, 2014 10:05 pm
Forum: Troubleshooting
Topic: DS18B20 + Camera module; modprobe breaks camera
Replies: 25
Views: 21906

Re: DS18B20 + Camera module; modprobe breaks camera

Memory is fine as long as your split is adequate (I'd say do a 384/128 split for CPU/GPU). Here's my config for future reference. I changed my 1-wire pin to GPIO 18. Also, I can confirm it works both with raspistill and w1-therm simultaneously. /boot/cmdline.txt: dwc_otg.lpm_enable=0 console=ttyAMA0...
by theoriginalxbrav
Tue Dec 31, 2013 5:18 pm
Forum: Troubleshooting
Topic: DS18B20 + Camera module; modprobe breaks camera
Replies: 25
Views: 21906

Re: DS18B20 + Camera module; modprobe breaks camera

Gents, I believe you've found the solution! The camera seems to be struggling with closing the connection, but (see below) I'm not encountering the ENOSPC error anymore. See below: root@raspberry-node05:~# cd /sys/bus/w1/devices root@raspberry-node05:/sys/bus/w1/devices# ls 28-00000484df4e 28-000004...
by theoriginalxbrav
Tue Dec 31, 2013 5:15 pm
Forum: Automation, sensing and robotics
Topic: Source code to w1-therm?
Replies: 41
Views: 33985

Re: Source code to w1-therm?

Good morning Dubravko, The solution posted here works! Indeed, it is a loading order. It works with your commits (I changed my pin to 18, don't want to crawl out in the cold and change it!). I'll post my findings in the thread below. http://www.raspberrypi.org/forums/viewtopic.php?f=28&t=61922 Thank...
by theoriginalxbrav
Tue Dec 31, 2013 7:28 am
Forum: Automation, sensing and robotics
Topic: Source code to w1-therm?
Replies: 41
Views: 33985

Re: Source code to w1-therm?

Ok, the code change seems to work. However, it's killing the camera module again. Here's the verbose output: raspistill Camera App v1.3.5 Width 2592, Height 1944, quality 85, filename (null) Time delay 5000, Raw no Thumbnail enabled Yes, width 64, height 48, quality 35 Link to latest frame enabled n...
by theoriginalxbrav
Mon Dec 30, 2013 5:45 pm
Forum: Automation, sensing and robotics
Topic: Source code to w1-therm?
Replies: 41
Views: 33985

Re: Source code to w1-therm?

Oh, you are amazing! I was wondering why the code wasn't committing as before. I'll give it a try. Thanks!

Go to advanced search