Go to advanced search

by bullen
Sun Sep 15, 2019 12:18 pm
Forum: Advanced users
Topic: Pi4 64-bit raspbian kernel for testing - Focus on Pi4
Replies: 105
Views: 9925

Re: Pi4 64-bit raspbian kernel for testing - Focus on Pi4

Does Minecraft 1.14.4 work out-of-the-box on this?

You need 64-bit Java: http://move.rupy.se/file/jdk-8u181-linu ... flt.tar.gz

And the new Java launcher: http://move.rupy.se/file/launcher.jar
by bullen
Thu Sep 05, 2019 3:17 pm
Forum: Java
Topic: Rasbperry, JVM, Java and Arm Jazelle #HELP#
Replies: 8
Views: 2989

Re: Rasbperry, JVM, Java and Arm Jazelle #HELP#

Eventually all secrets are known.
by bullen
Thu Sep 05, 2019 1:22 pm
Forum: Java
Topic: Rasbperry, JVM, Java and Arm Jazelle #HELP#
Replies: 8
Views: 2989

Re: Rasbperry, JVM, Java and Arm Jazelle #HELP#

Because if I can learn it and compile it myself I can also improve it.

Image

I need to use the Zero because it's small and consumes relatively (compared to the Banana Pi M2 Zero) little energy.
by bullen
Wed Sep 04, 2019 10:42 am
Forum: Java
Topic: Rasbperry, JVM, Java and Arm Jazelle #HELP#
Replies: 8
Views: 2989

Re: Rasbperry, JVM, Java and Arm Jazelle #HELP#

I'm looking at this too, but more from a "compile my own OS and Java" point of view, here's how far I got: You can download the sources for Java ME 1.1 (CLDC KVM) on this page: https://www.oracle.com/technetwork/java/javasebusiness/downloads/java-archive-downloads-javame-419430.html Minix has been p...
by bullen
Sat Aug 24, 2019 4:36 pm
Forum: General discussion
Topic: Why moving to 64bit?
Replies: 259
Views: 17828

Re: Why moving to 64bit?

Ok, when is the 64-bit Raspbian coming out then?

Zzzz...
by bullen
Sat Aug 24, 2019 4:15 pm
Forum: General discussion
Topic: Why moving to 64bit?
Replies: 259
Views: 17828

Re: Why moving to 64bit?

Current Minecraft requires 64-bit OS.
Pimaxin wrote:
Sat Aug 24, 2019 5:24 am
so should I download a 32 bit or 64 bit OS for the 4B?

Where can I download the 64-bit version?
by bullen
Thu Jul 25, 2019 9:38 am
Forum: General discussion
Topic: Toshiba 256GB SD have bad latency
Replies: 15
Views: 797

Re: Performance Buster on Pi 2 Edit: Toshiba 256GB SD are bad

Just a finishing comment on this issue: The Toshiba cards are legit. They are 2 orders of magnitude slower in terms of latency than a old 32GB SanDisc. They are 1 order of magnitude slower in terms of latency than brand new 256/128/64GB SanDisc. I have contacted Toshiba, and they are not replying af...
by bullen
Thu Jul 25, 2019 9:08 am
Forum: General discussion
Topic: cant update rasbien
Replies: 5
Views: 316

Re: cant update rasbien

Ah, thanx...
by bullen
Wed Jul 24, 2019 5:58 pm
Forum: Troubleshooting
Topic: Can't apt-get install on Wheezy
Replies: 2
Views: 97

Re: Can't apt-get install on Wheezy

Ah thanx...
by bullen
Wed Jul 24, 2019 5:45 pm
Forum: Troubleshooting
Topic: Can't apt-get install on Wheezy
Replies: 2
Views: 97

Can't apt-get install on Wheezy

http://mirrordirector.raspbian.org/raspbian/pool/main/l/lm-sensors/libsensors4_3.3.2-2+deb7u1_armhf.deb Returns a 404. I did apt-get update first. If you look in the folder: http://mirrordirector.raspbian.org/raspbian/pool/main/l/lm-sensors/ You will see the 3.3.2-2 is missing as the versions are: l...
by bullen
Mon Jul 22, 2019 4:00 pm
Forum: General discussion
Topic: Toshiba 256GB SD have bad latency
Replies: 15
Views: 797

Re: Performance Buster on Pi 2

I'm building a distributed cluster database, no wifi involved. Also the reason I know the SD cards are to blame (unless there is some really weird thing with the Buster release) is that I have my old test cluster with 3x SanDisk 32GB cards performing flawlessly on the same network. The Toshiba clust...
by bullen
Mon Jul 22, 2019 3:21 pm
Forum: General discussion
Topic: Toshiba 256GB SD have bad latency
Replies: 15
Views: 797

Re: Performance Buster on Pi 2

Ok, I can now almost 100% say the Toshiba cards are to blame. Don't buy these cards, spend 2x the money on SanDisk instead, unless it's a process problem and then we're out of luck for SD cards larger than 64/128GB. I will have to go through the very painful process of custom partitioning another 6x...
by bullen
Sat Jul 20, 2019 6:40 pm
Forum: General discussion
Topic: Toshiba 256GB SD have bad latency
Replies: 15
Views: 797

Re: Performance Buster on Pi 2

The CID seems legit TOSHIBA 256 manufactured 11/18 and I think the SD cards work fine because if I SSH from another computer it works fine. So hopefully I just sniped a good deal since the seller is one of the largest in Europe and the price dipped the same day and went up 50% the day after I bought...
by bullen
Sat Jul 20, 2019 5:38 am
Forum: General discussion
Topic: Toshiba 256GB SD have bad latency
Replies: 15
Views: 797

Re: Performance Buster on Pi 2

Funny you would say that, I replaced the Ethernet cable yesterday from my main Windows PC because PUBG was lagging out too! But it seems it's actually Windows and/or the Network card on my main PC that is the culprit! Narrowing this down...
by bullen
Fri Jul 19, 2019 11:17 pm
Forum: General discussion
Topic: Toshiba 256GB SD have bad latency
Replies: 15
Views: 797

Re: Performance Buster on Pi 2

Ok, I think my router is starting to give way... or something else on the network but I don't know yet... will post back when I replace it.
by bullen
Fri Jul 19, 2019 12:13 am
Forum: General discussion
Topic: Toshiba 256GB SD have bad latency
Replies: 15
Views: 797

Re: Performance Buster on Pi 2

Hm, ok thanks for feedback, I guess the SD cards I bought are not that good then. I bought 6x TOSHIBA 256GB for 40$ each so I guess that might make sense that they are crap... :(

But it's only sometimes, so I'll let things run for a couple of weeks and see how things pan out.
by bullen
Thu Jul 18, 2019 10:20 pm
Forum: General discussion
Topic: Toshiba 256GB SD have bad latency
Replies: 15
Views: 797

Toshiba 256GB SD have bad latency

Has anyone noticed how laggy it feels in the ssh session. Many commands block for several seconds.
by bullen
Thu Jul 04, 2019 10:27 am
Forum: Java
Topic: java is not supported any more on Pi0 with OS buster
Replies: 8
Views: 4216

Re: java is not supported any more on Pi0 with OS buster

Ok, but how does one fix a broken installation? Uninstall the non -zero jre? Nope! Ok, it's obviously time for us to learn how to compile Java from scratch! Just had a google and what do you know: https://stackoverflow.com/questions/31153584/why-is-there-such-a-performance-difference-on-raspberry-pi...
by bullen
Thu Jul 04, 2019 10:21 am
Forum: Java
Topic: Why are Raspberry Pi still using Java 8 when Java 11 is available?
Replies: 26
Views: 18506

Re: Why are Raspberry Pi still using Java 8 when Java 11 is available?

Ok, so what is the fix?

Edit: openjdk-11-jre-zero apparently, if you want speed use an old oracle-java8-jdk because it was compiled with soft-float for ARMv6.

But but but, how does one fix a broken installation?

This is so messy.
by bullen
Wed Jul 03, 2019 8:31 pm
Forum: Gaming
Topic: How to setup Minecraft 1.12.2 on Pi3 or Pi4
Replies: 77
Views: 13826

Re: How to setup Minecraft 1.12.2 on Pi3 or Pi4

Ok, but why?
by bullen
Wed Jul 03, 2019 3:15 pm
Forum: Gaming
Topic: How to setup Minecraft 1.12.2 on Pi3 or Pi4
Replies: 77
Views: 13826

Re: How to setup Minecraft 1.12.2 on Pi3 or Pi4

rpiMike wrote:
Wed Jul 03, 2019 7:16 am
Because 1.13 and above requires a 64 bit OS which is not yet available for the Pi4.
Do you know what requires 64 bit OS?
by bullen
Tue Jul 02, 2019 10:33 pm
Forum: Gaming
Topic: Aeon Alpha
Replies: 12
Views: 5083

Re: Aeon Alpha

Sometimes the game just freezes X when started on the new Pi 4. Maybe it has something to do with audio: AL lib: (EE) oss_open_playback: Could not open /dev/dsp: No such file or directory Installing alsa-oss fixes that problem, the lockup still occurs. This is what happens in Xorg.log, I'm pretty su...
by bullen
Tue Jul 02, 2019 10:30 pm
Forum: Gaming
Topic: How to setup Minecraft 1.12.2 on Pi3 or Pi4
Replies: 77
Views: 13826

Re: How to setup Minecraft 1.12.2 on Pi3 or Pi4

How come we can't get this working with 1.14.3 and OpenJDK 11?

I'm pretty sure LWJGL 3 has ARM binaries by now?
by bullen
Tue Jul 02, 2019 7:22 pm
Forum: General discussion
Topic: twm startx fails silently with buster .img
Replies: 2
Views: 131

Re: twm startx fails silently with buster .img

.xsession-errors had

x-window-manager: unable to open fontset "-adobe-helvetica-bold-r-normal--*-120-*-*-*-*-*-*"

looking at fixing it now...

OKokok this bug happened last time too... if you just execute "LANG=C" before startx it works... sheesh!
by bullen
Tue Jul 02, 2019 7:12 pm
Forum: General discussion
Topic: twm startx fails silently with buster .img
Replies: 2
Views: 131

twm startx fails silently with buster .img

How do I debug this?

Go to advanced search