Go to advanced search

by jolosan
Wed Apr 10, 2019 8:06 am
Forum: Weather station
Topic: I2C bus seems not to work
Replies: 6
Views: 2767

Re: I2C bus seems not to work

Thank you very much for your help. after cleaning several times the connectors, it seems to work properly! pi@raspberrypi:~ $ sudo i2cdetect -y 1 0 1 2 3 4 5 6 7 8 9 a b c d e f 00: -- -- -- -- -- -- -- -- -- -- -- -- -- 10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 20: -- -- -- -- -- -- -- --...
by jolosan
Fri Mar 15, 2019 9:35 am
Forum: Weather station
Topic: I2C bus seems not to work
Replies: 6
Views: 2767

I2C bus seems not to work

Hello, after trying to do some tests with the Weather hat, The output of the command sudo i2cdetect -y 1 shows all the matrix empty: 0 1 2 3 4 5 6 7 8 9 a b c d e f 00: -- -- -- -- -- -- -- -- -- -- -- -- -- 10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 20: -- -- -- -- -- -- -- -- -- -- -- -- ...
by jolosan
Tue Nov 27, 2018 4:38 pm
Forum: Troubleshooting
Topic: Configure the boot process from the USB in the Pi3
Replies: 1
Views: 145

Configure the boot process from the USB in the Pi3

Hello, It's possible to configure the raspberry PI 3 to boot from the USB stick without the need of an SD card?
The problem is that the sd card reader is broken and the raspberry pi can't boot from it.

Is there any way to configure it without the need of an SD card?

Regards,
by jolosan
Mon May 28, 2018 10:10 am
Forum: Camera board
Topic: PiCamera rolling shutter problem
Replies: 13
Views: 2687

Re: PiCamera rolling shutter problem

Hello, we are doing a School project with a raspberry pi camera mounted on a drone. The problem we are facing now is the jello effect because of the rolling shutter sensor of the picamera. Exactly the same problem of this topic. https://www.dropbox.com/s/vgo7p1thvboui ... 1.jpg?dl=0 Here is the code...
by jolosan
Thu Jun 15, 2017 9:30 am
Forum: Weather station
Topic: read_temperature doesn't work
Replies: 18
Views: 3080

Re: read_temperature doesn't work [SOLVED]

Thank you for your help Fillip5, I've changed the RJ11 connector, but the result is the same.

Finally I've separated the hat from the raspberry pi and cleaned the contacts withan special liquid.

Now it works fine!!!

Solved!!!
by jolosan
Thu Jun 08, 2017 7:45 am
Forum: Weather station
Topic: read_temperature doesn't work
Replies: 18
Views: 3080

Re: read_temperature doesn't work

It's possible to buy an air sensor in any place?

Thanks,
by jolosan
Wed Jun 07, 2017 10:25 am
Forum: Weather station
Topic: read_temperature doesn't work
Replies: 18
Views: 3080

Re: read_temperature doesn't work

Hello, the output of the first command is: pi@weatherstation:~ $ ls -la /sys/bus/w1/devices/ total 0 drwxr-xr-x 2 root root 0 jun 7 12:19 . drwxr-xr-x 4 root root 0 jun 7 12:18 .. lrwxrwxrwx 1 root root 0 jun 7 12:18 00-110000000000 -> ../../../devices/w1_bus_master1/00-110000000000 lrwxrwxrwx 1 roo...
by jolosan
Mon Jun 05, 2017 8:55 am
Forum: Weather station
Topic: read_temperature doesn't work
Replies: 18
Views: 3080

Re: read_temperature doesn't work

Hello again, yes the file /boot/config.txt is good, and the output of the dmesg command is the same than yours. Regrettably the output of the log_all_sensors.py script still is the same: Error accessing 0x77: Check your I2C address Traceback (most recent call last): File "./log_all_sensors.py", line...
by jolosan
Tue May 30, 2017 9:45 am
Forum: Weather station
Topic: read_temperature doesn't work
Replies: 18
Views: 3080

Re: read_temperature doesn't work

Hello, the answers to these commands are: $sudo i2cdetect Error: No i2c-bus specified! Usage: i2cdetect [-y] [-a] [-q|-r] I2CBUS [FIRST LAST] i2cdetect -F I2CBUS i2cdetect -l I2CBUS is an integer or an I2C bus name If provided, FIRST and LAST limit the probing range. $sudo python HTU21D.py Temp: 29....
by jolosan
Mon May 29, 2017 5:00 pm
Forum: Weather station
Topic: read_temperature doesn't work
Replies: 18
Views: 3080

Re: read_temperature doesn't work

I've installed fron scratch a new image of raspbian and I've followed all the steps in order to set up the software, but the error is the same than before: pi@weatherstation:~/weather-station $ ./log_all_sensors.py Traceback (most recent call last): File "./log_all_sensors.py", line 6, in <module> t...
by jolosan
Mon May 22, 2017 7:46 am
Forum: Weather station
Topic: read_temperature doesn't work
Replies: 18
Views: 3080

Re: read_temperature doesn't work

Everything is connected in the right way (I'll show you a pair of pictures)

Moreover, there's an error message (see picture) when the rapsberry pi is powered on and has completely initialized.

Regards,
by jolosan
Thu May 11, 2017 11:06 am
Forum: Weather station
Topic: read_temperature doesn't work
Replies: 18
Views: 3080

Re: read_temperature doesn't work

Thanks for your answer... In the file /boot/config.txt I have this at the end: # Enable audio (loads snd_bcm2835) dtparam=audio=on dtoverlay=w1-gpio dtoverlay=pcf8523-rtc dtoverlay=w1-gpio dtoverlay=pcf8523-rtc enable_uart=1 start_x=0 The WS HAT pins are all connected. If I run the script, this is t...
by jolosan
Wed May 10, 2017 10:53 am
Forum: Weather station
Topic: read_temperature doesn't work
Replies: 18
Views: 3080

read_temperature doesn't work

Hello, when I run $python log_all_sensors.py , the output is: Traceback (most recent call last): File "log_all_sensors.py", line 6, in <module> temp_probe = ds18b20_therm.DS18B20() File "/home/pi/weather-station/ds18b20_therm.py", line 10, in __init__ self.device_file = glob.glob("/sys/bus/w1/device...
by jolosan
Thu Feb 23, 2017 3:46 pm
Forum: Weather station
Topic: Delete a weather station from the Oracle Database
Replies: 2
Views: 675

Delete a weather station from the Oracle Database

Hi, I'm not able to delete an old definition of a weathe rstation inside the the oracle website.

It's possible to do this?

Regards,
by jolosan
Thu Feb 23, 2017 3:37 pm
Forum: Weather station
Topic: There's no local webpage
Replies: 1
Views: 496

There's no local webpage

Hi, I've recently re-installed from scratch the raspbian OS and the weather station software. The thing is that inside the /var/www/html directory, there's no demo subdirectory as in the previous version of the weather station software. Everything works fine except the local webpage for showing the ...
by jolosan
Fri Dec 16, 2016 9:47 am
Forum: Weather station
Topic: Don't show graphs
Replies: 5
Views: 1039

Re: Don't show graphs

Yes! It shows a lot of numbers ;-) [[1481792101000,1018.23],[1481792401000,1018.29],[1481792701000,1018.4],[1481793002000,1018.44],[1481793302000,1018.57],[1481793601000,1018.57],[1481793901000,1018.6],[1481794202000,1018.68],[1481794501000,1018.86],[1481794801000,1018.8],[1481795102000,1018.86],[14...
by jolosan
Fri Dec 16, 2016 7:41 am
Forum: Weather station
Topic: Don't show graphs
Replies: 5
Views: 1039

Re: Don't show graphs

Hi again!
In the error.log apache file there's nothing strange.

In the database tests yu suggested to me, the weather information is displayed, so it works fine.

Instead, the graphical information doesn't appear.

Thanks!
by jolosan
Wed Dec 14, 2016 11:57 am
Forum: Weather station
Topic: Don't show graphs
Replies: 5
Views: 1039

Don't show graphs

Our raspberry pi weather station has stopped showing graphs. All of them are in blank. Maybe it's been a problem of random power loss, but now the raspberry pi works fine. The scripts work but there's no graphical information shown at the web page, that is, the boxes of the different sensors appear ...
by jolosan
Tue Nov 01, 2016 4:06 pm
Forum: Weather station
Topic: Graphs doesn't display the time correctly
Replies: 3
Views: 1315

Re: Graphs doesn't display the time correctly

Ok, thank you for your answer, but there's no way to change the default setting?

Regards,
by jolosan
Wed Oct 26, 2016 10:44 am
Forum: Weather station
Topic: Graphs doesn't display the time correctly
Replies: 3
Views: 1315

Graphs doesn't display the time correctly

Hollow, our weather station graphs doesn't display the current time correctly, they are delayed 2h more or less.

I show you some screenshots about the current time in the machine and the last measure in the temperature graph.

How can we solve this?

Regards,

Go to advanced search