Go to advanced search

by Ridrok
Sun Dec 04, 2016 9:04 pm
Forum: Gaming
Topic: STICKY: MAME4ALL for Pi
Replies: 435
Views: 261898

Re: MAME4ALL for Pi

Hi, You can find new binary with fastest speed of this with some fixes included here: For Pi 1 For Pi 2 For Pi 3 You can also see My Git I tested the Pi3 version. Pinball Action (set 2) crashes (runs with the old version). It's fixed and binaries are updated too. If you use your mame.cfg, just add ...
by Ridrok
Sun Dec 04, 2016 11:25 am
Forum: Gaming
Topic: STICKY: MAME4ALL for Pi
Replies: 435
Views: 261898

Re: MAME4ALL for Pi

Hi Ridrok, thank you for creating this fork of MAME4ALL Pi. Here there are some issues with some games: - "Golden Axe", "Moonwalker", "Riot city", "Altered beast" and "Alien Storm" (all Sega System 16B games) run well, but audio samples (voices) are crackling, and with a higher volume than music. -...
by Ridrok
Fri Dec 02, 2016 7:43 pm
Forum: Gaming
Topic: STICKY: MAME4ALL for Pi
Replies: 435
Views: 261898

Re: MAME4ALL for Pi

Hi,

You can find new binary with fastest speed of this with some fixes included here:
For Pi 1
For Pi 2
For Pi 3

You can also see My Git
by Ridrok
Sun Oct 11, 2015 2:07 pm
Forum: C/C++
Topic: QT4 umount usb drive
Replies: 0
Views: 371

QT4 umount usb drive

Hello, I wrote a full QT4 front-end application which runs on my Raspberry Pi B+ with a 4.5" screen for a web-radio + reading from USB pens. I never add a problem coding C++/QT4 on Raspberry Pi, but this time I am stuck. This is what it looks like (here running on my Windows Host to take screenshot)...
by Ridrok
Thu Feb 12, 2015 5:17 pm
Forum: Graphics, sound and multimedia
Topic: Custom resolution for an old projector
Replies: 2
Views: 864

Re: Custom resolution for an old projector

Thank you, I did not see it.
by Ridrok
Wed Feb 11, 2015 6:53 pm
Forum: Graphics, sound and multimedia
Topic: Custom resolution for an old projector
Replies: 2
Views: 864

Custom resolution for an old projector

Hello all, After several years using a Raspberry Pi B on my TV with Raspbmc + custom changes, I had the opportunity to install back a projector which was sleeping in his box for several years due to no place to put it. Now I have a proper room for this, I can use my old JVC dila DLA-HX2E which use a...
by Ridrok
Sat Feb 07, 2015 11:44 am
Forum: Gaming
Topic: STICKY: Emulation on the RPi: Updated 29/06/2017
Replies: 148
Views: 412874

Re: Emulation on the Raspberry Pi/Pi2 (Updated 06/2/2015)

Hello About mame4all-pi, I did a fork a bit more than 1 year ago to fix some "speech" sound problem on Golden Axe and updated Z80, 68k and i8089 emulation a bit. I will try a get a Pi 2 in coming weeks and see if I can enable YM2151 full code instead of simplified one on Pi2. Here is the source tree...
by Ridrok
Sat Jan 03, 2015 10:59 am
Forum: Graphics, sound and multimedia
Topic: [Fixed] Problem to play 96+Khz with I2S DAC
Replies: 4
Views: 1306

[Fixed] Problem and solution to play 96+Khz with I2S DAC

Please note that popcornmix pushed a fixed kernel for this problem.

So as of now a simple

Code: Select all

sudo rpi-update
will fix this problems with I2S Dac and high frequency FLAC files.

Again many thanks for the support.
by Ridrok
Fri Dec 12, 2014 6:56 pm
Forum: Graphics, sound and multimedia
Topic: [Fixed] Problem to play 96+Khz with I2S DAC
Replies: 4
Views: 1306

Re: Please fix: Problem and solution to play 96+Khz with I2S

popcornmix did find a solution with latest kernel 3.12.34+ :D Just add "dma.dmachans=0x0035" to the list of kernel parameters set in /boot/cmdline.txt Anyway popcornmix said there will be a firmware update that will fix it soon I love the Raspberry PI and all people around related project like HiFib...
by Ridrok
Fri Dec 12, 2014 2:19 pm
Forum: Graphics, sound and multimedia
Topic: [Fixed] Problem to play 96+Khz with I2S DAC
Replies: 4
Views: 1306

Re: Please fix: Problem and solution to play 96+Khz with I2S

Done using my GitHub account: Neo2003. Let's hope I did report in the proper place :D

Many thanks
Stéphane
by Ridrok
Fri Dec 12, 2014 12:49 pm
Forum: Graphics, sound and multimedia
Topic: [Fixed] Problem to play 96+Khz with I2S DAC
Replies: 4
Views: 1306

[Fixed] Problem to play 96+Khz with I2S DAC

Hello, I want to report an issue with all kernel >3.12.26+ with Raspbian and I2S DACs on top of PI B+. With any kernel above the one listed above, it's impossible to play FLAC files with 16bits/176+KHz or 24bits/88+KHz, all you get is music playing far to fast and clipping. With 24bits/176KHz, this ...
by Ridrok
Mon Dec 09, 2013 3:11 pm
Forum: Gaming
Topic: STICKY: MAME4ALL for Pi
Replies: 435
Views: 261898

Re: MAME4ALL for Pi

I think I can't fix the crackling problem in the voices just because it is a very low frequency sound in the roms. I did test Mame 151 (latest) on Windows and I feel the voices in Golden Axe is like the one on the PI now, meaning still cracking. I can't remember well if it was the same in the Arcane...
by Ridrok
Fri Dec 06, 2013 1:07 pm
Forum: Gaming
Topic: STICKY: MAME4ALL for Pi
Replies: 435
Views: 261898

Re: MAME4ALL for Pi

Hi Ridrok, thank you for creating this fork of MAME4ALL Pi. Here there are some issues with some games: - "Golden Axe", "Moonwalker", "Riot city", "Altered beast" and "Alien Storm" (all Sega System 16B games) run well, but audio samples (voices) are crackling, and with a higher volume than music. ....
by Ridrok
Fri Nov 29, 2013 3:35 pm
Forum: Gaming
Topic: STICKY: MAME4ALL for Pi
Replies: 435
Views: 261898

Re: MAME4ALL for Pi

Hello, Just to let you know: https://github.com/Neo2003/mame4all-pi-adv.git It's my git where I forked mame4all-pi (I hate googlecode, sorry). There is nothing in this git yet usable. The master branch is just a plain fork of mame4all-pi at current version while the model1 branch is the branch I use...
by Ridrok
Sun Nov 24, 2013 6:06 pm
Forum: Gaming
Topic: STICKY: MAME4ALL for Pi
Replies: 435
Views: 261898

Re: MAME4ALL for Pi

welshy Thank you for all the explanation. MAME4ALL, that is always based on MAME 0.37b5, is used in a lot of devices like tablet, smartphone, portable console, and now Raspberry. Strange that nobody attempted to "fork" MAME 0.3765 to fix these small imperfection in emulation, or the sound missing i...
by Ridrok
Sun Nov 24, 2013 5:52 pm
Forum: Gaming
Topic: RetroArch Emulator Frontend
Replies: 475
Views: 194327

Re: RetroArch Emulator Frontend

Thank you petrockblog, I updated a bit my scripts because of some small problems. In ~/.bashrc, I did change the line to this in order to work in case you "source ~/bashrc" from another directory ~/_startup.sh And the ~/_startup.sh changed a bit too to not try to launch emulationstation when connect...
by Ridrok
Thu Nov 21, 2013 11:17 pm
Forum: Gaming
Topic: STICKY: MAME4ALL for Pi
Replies: 435
Views: 261898

Re: MAME4ALL for Pi

Hello all and thank you very much for this release. :) It works very well and I can finally play the Arcade Outrun with the PI connected to my TV and an old Guillemot Race leader racing wheel plugged on a USB port :D Now I wonder if it is possible to get the events generated by the roms to make out ...
by Ridrok
Wed Nov 20, 2013 2:06 pm
Forum: Gaming
Topic: RetroArch Emulator Frontend
Replies: 475
Views: 194327

Re: RetroArch Emulator Frontend

Ok, thank-you to both of you.

Retroarch-setup did pull the November 17th version of Mupen64plus-Rpi from ric_rpi git repository, then I think I have to pull the November 19th commits and compile it again :)

Ridrok
by Ridrok
Wed Nov 20, 2013 1:18 pm
Forum: Gaming
Topic: RetroArch Emulator Frontend
Replies: 475
Views: 194327

Re: RetroArch Emulator Frontend

Hello all, I have setup retroarch with the "from source" setup on my PI for me and my children :) This setup took 20H approximately. I post here because I did have a hard time make it run properly and had to change many things in RetroArch configurations for this to work. My plan was to run Arcade g...
by Ridrok
Fri Dec 21, 2012 5:15 pm
Forum: Troubleshooting
Topic: permission issue on a headless MPD server (on Raspbian)
Replies: 3
Views: 6760

Re: permission issue on a headless MPD server (on Raspbian)

I have the exact same issue. If I "sudo mpd" then it says it has no configuration file, detect the sound card and volume control is working. If I "sudo mpd /etc/mpd.conf"', I have no volume control. mpc says "n/a" as status and an error message if I try to adjust the volume, but the rest works, it u...

Go to advanced search