Go to advanced search

by Gert
Fri Feb 21, 2020 6:18 am
Forum: Networking and servers
Topic: Nginx config fails to exclude bots
Replies: 5
Views: 186

Re: Nginx config fails to exclude bots

@rpdom, Thanks for taking a look at this. The RPI is just doing very simple things running my weather sensors. I am not going to take the risk of changing the OS, as maybe there will be side effects on my interfacing code. The functionality to support this log file issue was probably only introduced...
by Gert
Thu Feb 20, 2020 4:40 am
Forum: Networking and servers
Topic: Nginx config fails to exclude bots
Replies: 5
Views: 186

Re: Nginx config fails to exclude bots

Hi rpdom, Which version of nginx are you running? dpkg -s nginx Version: 1.2.1-2.2+wheezy4+deb7u1 I did an update + upgrade sequence but no success. (Note this is an older OS. I've interest of doing a full revamp of the OS. This RPI is just running my weather sensor and is doing that just fine. Chee...
by Gert
Mon Feb 17, 2020 1:02 am
Forum: Networking and servers
Topic: Nginx config fails to exclude bots
Replies: 5
Views: 186

Nginx config fails to exclude bots

Hi All, I am trying to exclude logging for bot access to nginx on my RPI. But so far my edits of the conf file have all failed. The config file: user www-data; worker_processes 2; pid /var/run/nginx.pid; events { worker_connections 768; } http { sendfile on; tcp_nopush on; tcp_nodelay on; types_hash...
by Gert
Fri Jan 24, 2020 3:01 am
Forum: Troubleshooting
Topic: Debug messages from apt-get update
Replies: 2
Views: 129

Re: Debug messages from apt-get update

@GlowInTheDark : Way cool!
Thanks,
Gert
by Gert
Fri Jan 24, 2020 2:01 am
Forum: Troubleshooting
Topic: Debug messages from apt-get update
Replies: 2
Views: 129

Debug messages from apt-get update

Hello All, I have an old RPI2 Mod B running (possibly) on an even older OS version. It's task is to run a weather station and put nice temperature plots on a webpage. It does its job nicely. Just today I accidentally typed 'apt-get update' and got below message. Just wondering if there is any major ...
by Gert
Thu Jan 09, 2020 3:54 am
Forum: Troubleshooting
Topic: Copy paste in VNC xterm not working
Replies: 2
Views: 106

Re: Copy paste in VNC xterm not working

Hi pi-anazazi,

autocutsel is deployed. Must be something else. :-(

Cheers,
Gert
by Gert
Tue Jan 07, 2020 4:39 am
Forum: Troubleshooting
Topic: Copy paste in VNC xterm not working
Replies: 2
Views: 106

Copy paste in VNC xterm not working

Hi All, Using a headless RPI with vnc from win7 PC. Turns out that copy paste is behaving oddly. * Not working from vnc xterm to vnc xterm * Working from win7 editor to vnc xterm I've captured the issue in this little screen grab: http://skywatcher.space/download/rpi_vnc_copy_paste_bug_2020-01-06_20...
by Gert
Fri Nov 29, 2019 3:08 am
Forum: Graphics, sound and multimedia
Topic: Please suggest HW SW combo for simple OTA DVR on RPI3B
Replies: 0
Views: 231

Please suggest HW SW combo for simple OTA DVR on RPI3B

Hi All, I have an old Win7 PC which I only keep alive because of the Windows Media Center of which I pretty much only use the OTA DVR recording feature. In 2020 TV guide service in Media Center is discontinued and I want to have a similar functionality with RPI. I read a lot online of client server ...
by Gert
Mon Oct 07, 2019 1:45 am
Forum: Troubleshooting
Topic: How to mount usb stick with ext4 for all users
Replies: 3
Views: 331

How to mount usb stick with ext4 for all users

Hi All, Is it a good idea to use ext4 on a USB stick for a RPI4 as occasional storage? Using gparted I went ahead and partitioned and formatted the USB stick accordingly. Mounting via fstab I found 'somewhere' a line that was supposed to be 'good' for USB stick. (maybe as a side question someone can...
by Gert
Thu Sep 19, 2019 10:14 pm
Forum: Troubleshooting
Topic: Can fstab be adjusted for time delay when spin-up of disk takes longer ?
Replies: 5
Views: 270

Re: Can fstab be adjusted for time delay when spin-up of disk takes longer ?

OK, I have put a mount -a into crontab with a 30sec wait after boot. Kind of awkward but works and nothing else is slowed down. Was just wondering if there is a flag in fstab to wait for a device to be ready (or ready+xx sec) to execute the mounting.
Cheers,
Gert
by Gert
Wed Sep 18, 2019 12:19 am
Forum: Troubleshooting
Topic: Can fstab be adjusted for time delay when spin-up of disk takes longer ?
Replies: 5
Views: 270

Can fstab be adjusted for time delay when spin-up of disk takes longer ?

Hello All, To build a mini-NAS I have bought a new Seagate 5T 2.5inch disk and attached the USB to the RPI3. (Yes, it's slow and I plan to upgrade this rig to RPI4 with USB3) Seems the spin-up and self test of the disk take longer during the boot sequence than the point in time when mount is called....
by Gert
Tue Sep 17, 2019 12:33 am
Forum: Networking and servers
Topic: More disks on RPI4B -> Powered HUB or bigger supply ?
Replies: 5
Views: 515

Re: More disks on RPI4B -> Powered HUB or bigger supply ?

Hi, The 5V USB power is limited to 1.2A by the USB controller chip. That is usually enough to run 1 HDD only. Providing more Amps to the RPi power input will not help. In prev. thread rpdom said : " Unless things have changed on the Pi4, all the power pins for the USB ports are connected together. T...
by Gert
Tue Sep 17, 2019 12:18 am
Forum: Networking and servers
Topic: More disks on RPI4B -> Powered HUB or bigger supply ?
Replies: 5
Views: 515

More disks on RPI4B -> Powered HUB or bigger supply ?

Hello All, Follow-up on the thread : https://www.raspberrypi.org/forums/viewtopic.php?f=36&t=251437 The Seagate 5T disk powers up and works fine on the RPI4B with the 3A AC adapter (Came as part of the 'Vilros' Kit from Amazon). Now the stretch-goal was to have both the 2T and the 5T disk attached a...
by Gert
Mon Sep 16, 2019 2:49 pm
Forum: Troubleshooting
Topic: Headless PI VNC 'No session for pid ...'
Replies: 0
Views: 103

Headless PI VNC 'No session for pid ...'

Hello All, I'm running a headless RPI4B 'buster' with access via VNC. When I establish VNC connection on the client for the first time after booting the RPI I get this error message popup saying "No session for pid 858". The pip has following info: ps -eaux | grep 858 gottsch 858 0.2 0.4 49612 19024...
by Gert
Sun Sep 15, 2019 9:41 pm
Forum: Networking and servers
Topic: Generic storage benchmark on RPI
Replies: 2
Views: 392

Generic storage benchmark on RPI

Hi Folks, There's a lot of disk benchmarking done for SSD / SD etc and other storage using CrystalDiskMark which runs on PC. Is there an equivalent running natively on RPI raspian? It will be a better 'whole-system' test for storage performance that just testing the media on a PC without taking inte...
by Gert
Sun Sep 15, 2019 8:59 pm
Forum: Troubleshooting
Topic: Samba uses machine name instead of netbios name.
Replies: 4
Views: 539

Re: Samba uses machine name instead of netbios name.

Hi, There is a valid reason why this is happening, the NetBIOS name MUST be the computers hostname, you cannot change what is displayed on Windows by setting the 'netbios name' parameter. It works for the other RPIs. See below example vs above screen copy. There must be a subtle version change that ...
by Gert
Sat Sep 14, 2019 10:47 pm
Forum: Troubleshooting
Topic: Mount usb drive changes access permission of mount point to root
Replies: 6
Views: 521

Re: Mount usb drive changes access permission of mount point to root

Yes, that fixed it. What's the difference between the ntfs (that comes with the distribution) and ntfs-3g (that is an add-on install) ?
Cheers,
Gert
DougieLawson wrote:
Sat Sep 14, 2019 8:03 pm
What's the format of the filesystem? If it's NTFS run sudo apt install ntfs-3g before doing anything else.
by Gert
Sat Sep 14, 2019 9:13 pm
Forum: Troubleshooting
Topic: Samba uses machine name instead of netbios name.
Replies: 4
Views: 539

Samba uses machine name instead of netbios name.

Hello All, Using samba on RPI4B with buster. I'm giving a netbios name for the server, but windows 7 PC decides to use the machine name instead. The shares themselves are OK and access permissions work fine. Just the PC ignoring of the name I've given to the server is annoying. smb.conf #===========...
by Gert
Sat Sep 14, 2019 7:41 pm
Forum: Troubleshooting
Topic: Mount usb drive changes access permission of mount point to root
Replies: 6
Views: 521

Mount usb drive changes access permission of mount point to root

Hi All, I decided against the system mount point of a USB disk /media/pi/<name> and wanted to do it myself. Esp. I want R/W access to the storage for my own non-root account (and possibly any other non-root account) (probably not pi-account, I don't like it) I made mount point and adjusted permissio...
by Gert
Wed Mar 20, 2019 4:26 pm
Forum: Automation, sensing and robotics
Topic: RPI + INA219 with off grid solar panel
Replies: 5
Views: 983

Re: RPI + INA219 with off grid solar panel

Thank you Gavinmc42,

That's great material. I'll look into the ADM3260. I only need it between the RPI I2C bus and the INA219 sensor (for the solar panel). Do you know of anybody making a small project PCB for the chip? I don't want to do the smd soldering.

Thanks,
Gert
by Gert
Tue Mar 19, 2019 5:20 am
Forum: Automation, sensing and robotics
Topic: RPI + INA219 with off grid solar panel
Replies: 5
Views: 983

Re: RPI + INA219 with off grid solar panel

Hi Gavinmc42

Can you give some advice how to connect VDD GND between the RPI / INA219 / ADUM1250 ? Where is GND connected to what?

Thanks,
Gert
by Gert
Mon Mar 18, 2019 5:49 am
Forum: Automation, sensing and robotics
Topic: RPI + INA219 with off grid solar panel
Replies: 5
Views: 983

RPI + INA219 with off grid solar panel

Hi All, I need your help understanding how the INA219 measures the voltage. Of course the current is from the shunt resistor. But where is the 0 point of the voltage? I assume it's the bus GND pin vs. the Vin+ pin at the shunt. That's fine. But what if the GND is galvanically isolated?? Let me expla...
by Gert
Thu Mar 14, 2019 5:46 am
Forum: General discussion
Topic: 4G Modem on RPI in rural area
Replies: 5
Views: 2007

Re: 4G Modem on RPI in rural area

Hello All, Update on the project. I got a 20W solar panel, charge controller, 12V gel cell battery, 5V RPI adapter. I will run this at my place to find out if the 20W solar and 12V 7Ah battery are enough to run the RPI 24/7. The RPI is of course headless and has no external disk etc. to power. I've ...
by Gert
Fri Nov 30, 2018 5:22 am
Forum: General discussion
Topic: 4G Modem on RPI in rural area
Replies: 5
Views: 2007

Re: 4G Modem on RPI in rural area

Hi all, I found this company offering a piggyback board for the Raspberry that adapts to mini PCIe modem modules. Board $39 : https://sixfab.com/product/raspberry-pi-3g-4glte-base-shield-v2/ Modem 4G LTE $69 : https://sixfab.com/product/quectel-ec25-mini-pcle-4glte-module/ The tricky part is what da...
by Gert
Thu Nov 22, 2018 1:11 am
Forum: General discussion
Topic: 4G Modem on RPI in rural area
Replies: 5
Views: 2007

4G Modem on RPI in rural area

Hi All, Our astronomy club has a small observatory shed in a rural area with no wired connectivity. Solar panel and marine battery are there for limited power. There is data coverage by 'Verizon'. What is the best way to have an RPI 24/7 active at the shed with USB 4G modem (recommendations?). The g...

Go to advanced search