Go to advanced search

by bulletmark
Thu Aug 24, 2017 1:56 am
Forum: Troubleshooting
Topic: Problem with SPI after updating to Stretch - RESOLVED
Replies: 7
Views: 3800

Re: Problem with SPI after updating to Stretch - RESOLVED

I'm not a hardware guy either sorry so can't comment. Google seems to give plenty of links about SPI speed and MCP3008 though.
by bulletmark
Thu Aug 24, 2017 1:34 am
Forum: Troubleshooting
Topic: Problem with SPI after updating to Stretch - RESOLVED
Replies: 7
Views: 3800

Re: Problem with SPI after updating to Stretch

I looked at the data sheet for the MCP23S17 chip I am using and see that it is spec'd for up to 10 MHz so used that.
by bulletmark
Thu Aug 24, 2017 12:53 am
Forum: Troubleshooting
Topic: Problem with SPI after updating to Stretch - RESOLVED
Replies: 7
Views: 3800

Re: Problem with SPI after updating to Stretch

I use Arch Linux, not Raspbian but I bet your problem is the same as I experienced due to the recent upgrade to kernel version 4.9.43. I fixed my problem with https://github.com/bulletmark/pifaceio/commit/34ddceb72f2c8562d66b5f395227d9785221ff21. You don't say what SPI library you are using but it n...
by bulletmark
Wed Aug 23, 2017 11:57 pm
Forum: Troubleshooting
Topic: Problem with SPI after updating to Stretch - RESOLVED
Replies: 7
Views: 3800

Re: Problem with SPI after updating to Stretch

What kernel version and what SPI library are you using with your python app?
by bulletmark
Thu Nov 19, 2015 7:51 am
Forum: Python
Topic: Vehicle Counting with IR Sensor
Replies: 8
Views: 2647

Re: Vehicle Counting with IR Sensor

I could not install pifacedigitalio on my Rpi2 probably because I use Arch, not Raspbian. I am interested to know however how much CPU it uses at that .01 sec poll rate so would you mind installing htop package, then run it in another terminal while your app is running and let me know the CPU % it u...
by bulletmark
Wed Nov 18, 2015 12:52 pm
Forum: Python
Topic: Vehicle Counting with IR Sensor
Replies: 8
Views: 2647

Re: Vehicle Counting with IR Sensor

OK, I have put a modified version of your code at http://pastebin.com/GeZCmcN2. Comments and changes are: You were mixing up the classes and static function pifacedigitalio interfaces. See https://piface.github.io/pifacedigitalio/example.html. So you don't want that pfd = pio.PiFaceDigital() line at...
by bulletmark
Tue Nov 17, 2015 11:33 pm
Forum: Python
Topic: Vehicle Counting with IR Sensor
Replies: 8
Views: 2647

Re: Vehicle Counting with IR Sensor

@rebootnet, I'll help you but please fix up the indentation in your posted code first so I know exactly what you are trying to do.
by bulletmark
Sat Oct 31, 2015 2:48 am
Forum: Troubleshooting
Topic: PiFace problems
Replies: 4
Views: 850

Re: PiFace problems

Actually, I just installed the current Raspbian Jessie 2015-09-24-raspbian-jessie.img image to my RPi model 2 and apart from a single character typo I had in the script it works fine. I could read and write to my PiFace board. I fixed the script and push the updated package to github and PyPI. I not...
by bulletmark
Fri Oct 30, 2015 9:17 pm
Forum: Troubleshooting
Topic: PiFace problems
Replies: 4
Views: 850

Re: PiFace problems

KevinA wrote: Doesn't work on Jessie, no longer uses backlist or spi_bcm2708 or modprobe I'm trying to find how to install spidev
If it doesn't work can you please paste the script output here (in code tags). Thanks.
by bulletmark
Sun Oct 11, 2015 11:18 pm
Forum: Troubleshooting
Topic: PiFace problems
Replies: 4
Views: 850

Re: PiFace problems

No one has answered so I'll offer this .. I created a script to install the spidev stuff for the piface board which you could try. I have not tried it on Raspbian Jessie but it worked on Wheezy and it works on Arch which is now what I run with my Piface. Download it from https://raw.githubuserconten...
by bulletmark
Wed May 13, 2015 10:37 pm
Forum: HATs and other add-ons
Topic: Piface Digital Outputs
Replies: 1
Views: 404

Re: Piface Digital Outputs

No, the PiFace board only has 8 outputs maximum. The 2 relays are just in parallel with the first 2 outputs. I think the documentation is pretty good. Start at http://www.piface.org.uk/products/piface_digital/. Also check the element14 site at http://www.element14.com/community/docs/DOC-52857/l/pifa...
by bulletmark
Tue Apr 21, 2015 12:42 am
Forum: Python
Topic: Raspberry Pi Freezes after running Python script
Replies: 6
Views: 3098

Re: Raspberry Pi Freezes after running Python script

melona380 wrote: How long of a sleep, would 5-10 sec work? I need to minimize main loop down time.
No, that would be too slow to see your button presses. You need to think about and understand your code better. Also, use 4 spaces instead of 8 and get rid of redundant code and variables.
by bulletmark
Mon Apr 20, 2015 11:31 pm
Forum: Python
Topic: Raspberry Pi Freezes after running Python script
Replies: 6
Views: 3098

Re: Raspberry Pi Freezes after running Python script

melona380 wrote: Note I have changed the code to check every 2 minuets.
Yes you have but the overall while loop is still run flat out on the CPU. You need a small time.sleep() in there.
by bulletmark
Sat Apr 18, 2015 11:04 pm
Forum: Beginners
Topic: PiFace Digital CE-Pin
Replies: 5
Views: 654

Re: PiFace Digital CE-Pin

@Lunte, note you can plug the PiFace board into a PiRack to swap it to CE1 if you need.
by bulletmark
Sat Mar 21, 2015 8:49 am
Forum: Beginners
Topic: Raspi 2 and Piface
Replies: 10
Views: 2220

Re: Raspi 2 and Piface

meddyliol wrote:But the stacking header is 26 pin, the new Pi is 40 pin. What am I missing?
The original PiFace board is only 26 pin and they are exactly compatible with the first 26 pins of the new Pi 2.
by bulletmark
Fri Mar 20, 2015 10:19 pm
Forum: Beginners
Topic: Raspi 2 and Piface
Replies: 10
Views: 2220

Re: Raspi 2 and Piface

I connected my original PiFace board to my new model 2 B using a $2 stacking header like this http://www.adafruit.com/products/1112. Propped the other side of the board up and put a couple of cable ties around the 2 boards to keep them together. Works well.
by bulletmark
Fri Mar 13, 2015 11:29 pm
Forum: HATs and other add-ons
Topic: Piface2 setup - no spi_bcm2708 (solved)
Replies: 15
Views: 6911

Re: Piface2 setup - no spi_bcm2708

Sorry, I don't know anything about BerryBoot. Perhaps you should raise an issue at http://github.com/maxnet/berryboot/issues?

Ultimately you probably just need to add "dtparam=spi=on" to BerryBoot's config.txt, which I presume is in the root folder on your USB drive? Maybe try that first.
by bulletmark
Fri Mar 13, 2015 12:53 pm
Forum: HATs and other add-ons
Topic: Piface2 setup - no spi_bcm2708 (solved)
Replies: 15
Views: 6911

Re: Piface2 setup - no spi_bcm2708

The version of Raspbian (from uname -r) is 3.18.6-v7i-aufs That's quite a different kernel to the one on my RPis and from reading other recent posts around here (with similar problems, e.g. http://www.raspberrypi.org/forums/viewtopic.php?t=15787&p=717710) it seems you installed Raspbian via BerryBo...
by bulletmark
Fri Mar 13, 2015 9:06 am
Forum: HATs and other add-ons
Topic: Piface2 setup - no spi_bcm2708 (solved)
Replies: 15
Views: 6911

Re: Piface2 setup - no spi_bcm2708

DougieLawson wrote: Have you enabled SPI in /boot/config.txt?
My script does that, with everything else that is required. But, of course that only gets enabled after a reboot.
by bulletmark
Fri Mar 13, 2015 6:02 am
Forum: HATs and other add-ons
Topic: Piface2 setup - no spi_bcm2708 (solved)
Replies: 15
Views: 6911

Re: Piface2 setup - no spi_bcm2708

That script would have told you to reboot when it finished. Did you do that?

Are you running raspbian, and if so is it up to date?

Please run that "sudo install-spidev.sh" command again and post the complete output here (in code tags).
by bulletmark
Thu Mar 12, 2015 10:18 pm
Forum: HATs and other add-ons
Topic: Piface2 setup - no spi_bcm2708 (solved)
Replies: 15
Views: 6911

Re: Piface2 setup - no spi_bcm2708

Since no-one has answered, you could try my installer:

Code: Select all

sudo apt-get install python-pip
sudo pip install pifaceio
sudo install-spidev.sh
by bulletmark
Fri Feb 27, 2015 9:51 pm
Forum: HATs and other add-ons
Topic: Piface & Rapberry Pi 2
Replies: 2
Views: 860

Re: Piface & Rapberry Pi 2

Yes, I moved my original PiFace board from a model B to a new model 2 B from soon after the new model appeared and it has been running fine 24x7. My LED stays steady on red. Note that I originally purchased a normal 2x13 extender which did not work reliably. I then bought an "extra tall" extender (s...
by bulletmark
Thu Feb 12, 2015 10:50 pm
Forum: HATs and other add-ons
Topic: RPi 2 and the PiFace Digital 2 [solved]
Replies: 14
Views: 6110

Re: RPi 2 and the PiFace Digital 2 [solved]

dahl wrote:Hope we get an update on pifacecommon that fix this permanent.
It was fixed there a few days ago -
https://github.com/piface/pifacecommon/ ... b3f4bfa9b3
by bulletmark
Sun Feb 08, 2015 10:24 pm
Forum: Beginners
Topic: error in running a command
Replies: 7
Views: 886

Re: error in running a command

Look at the very first line in that script. If it's a shebang line (i.e. starts with #!) then likely that program does not exist.
by bulletmark
Tue Jan 20, 2015 11:26 pm
Forum: Beginners
Topic: VNC Copy and Paste
Replies: 3
Views: 1543

Re: VNC Copy and Paste

You may already know this but if you just want to open terminal windows then by far the best, simplest, and most efficient way is to ssh directly in to the RPi using an ssh client like KiTTY from windows, or natively from a Mac or Linux PC. Copy and paste work without issue then also. I've never onc...

Go to advanced search