Go to advanced search

by macca
Thu Sep 05, 2019 10:10 am
Forum: Italiano
Topic: crontab non esegue script
Replies: 7
Views: 349

Re: crontab non esegue script

Se la riga che hai messo nel crontab è esattamente quella che hai riportato sono certo che non funziona: dove si trova lo script ?
Metti sempre i percorsi completi degli script e dei programmi lanciati quando li esegui da cron, l'ambiente potrebbe non essere impostato come ti aspetti.
by macca
Wed Jul 17, 2019 5:53 am
Forum: Italiano
Topic: Collegamento a ponte tramite due porte lan.
Replies: 1
Views: 1065

Re: Collegamento a ponte tramite due porte lan.

Per collegare le due porte LAN direttamente, senza un router in mezzo, devi usare come minimo un cavo incrociato (o crossover), se gli adattatori non riconoscono automaticamente la connessione. Poi devi creare una sottorete apposita tra l'RPi e il TV e impostare il routing sull'RPi in modo che i pac...
by macca
Thu Jul 04, 2019 9:08 am
Forum: Italiano
Topic: Problema pulsante/led Rasp+Python
Replies: 3
Views: 1286

Re: Problema pulsante/led Rasp+Python

Posta anche il circuito per avere un'idea precisa di quello che hai fatto.
by macca
Wed May 22, 2019 12:51 pm
Forum: Italiano
Topic: [RISOLTO] Schermo non si accende se collegato dopo avvio raspbian
Replies: 4
Views: 567

Re: Schermo non si accende se collegato dopo avvio raspbian

Prova con

Code: Select all

hdmi_force_hotplug=1
by macca
Wed Apr 03, 2019 11:28 am
Forum: Italiano
Topic: Accendere e spegnere LED con interrupt con GPIO.add_event_detect()
Replies: 14
Views: 1179

Re: Accendere e spegnere LED con interrupt con GPIO.add_event_detect()

Quanto ai resistori (in base agli esperimenti che sto facendo) ho provato dapprima ad usare 1K Ohm per i pulsanti, ma il segnale in input non veniva rilevato. Occorrono come limite 220-470 Ohm, altrimenti il programma non rileva l’EDGE (il cambio di stato da 0 a 1 del pulsante premuto). Io non sono...
by macca
Thu Feb 28, 2019 3:21 pm
Forum: Italiano
Topic: Player per .mov
Replies: 5
Views: 1243

Re: Player per .mov

Hai provato anche con --play-and-pause ?
Vedi https://forum.videolan.org/viewtopic.php?t=99554
by macca
Tue Feb 26, 2019 12:50 pm
Forum: Italiano
Topic: volevo solo fare il Karaoke...
Replies: 3
Views: 742

Re: volevo solo fare il Karaoke...

Il raspberry ha già un'uscita audio analogica, non sarà il massimo ma forse per quello che vuoi fare va bene. Riguardo le schede USB, si tratta di un sistema Linux quindi dovrebbero funzionare tutte quelle che sono supportate da Linux e non richiedono l'installazione di driver proprietari che, al 99...
by macca
Tue Feb 26, 2019 12:43 pm
Forum: Italiano
Topic: Player per .mov
Replies: 5
Views: 1243

Re: Player per .mov

Il raspberry è in grado di riprodurre video H264 con accelerazione hardware (e anche MPEG2 se hai acquistato il codec), tutto il resto è decodificato via software. A quanto ne so, omxplayer dovrebbe essere in grado di riprodurre i file .mov senza problemi a patto che il video sia codificato H264.
by macca
Tue Feb 12, 2019 4:03 pm
Forum: Italiano
Topic: Sd con immagine sistema retropie emulastation su altro raspberry
Replies: 4
Views: 692

Re: Sd con immagine sistema retropie emulastation su altro raspberry

Ti sei spiegato, ma il discorso non cambia. Evidentemente la versione dell'emulatore che c'è su quella SD card preconfezionata non è adatta al nuovo modello, devi andare sul sito del produttore (retropie ?), vedere qual'è l'ultima versione e se supporta il Pi 3B+ e aggiornare seguendo le istruzioni ...
by macca
Tue Feb 12, 2019 7:37 am
Forum: Italiano
Topic: Sd con immagine sistema retropie emulastation su altro raspberry
Replies: 4
Views: 692

Re: Sd con immagine sistema retropie emulastation su altro raspberry

Di solito si va sul sito del produttore del software e si controlla se ci sono aggiornamenti o altre notizie sui modelli più recenti supportati. L'hai fatto ?
by macca
Mon Feb 11, 2019 11:26 am
Forum: Italiano
Topic: LCD e processi paralleli
Replies: 20
Views: 1477

Re: LCD e processi paralleli

Ripeto: so per certo che la misura non è precisa, ma, facendo gare di regolarità, ho una buona dimestichezza con le fotocellule e con i cronometri. So stimare un ritardo o un anticipo sulla fotocellula nell'ordine dei decimi di secondo. Sono piuttosto sicuro della mia affermazione. Qua si parla di ...
by macca
Mon Feb 11, 2019 9:51 am
Forum: Italiano
Topic: LCD e processi paralleli
Replies: 20
Views: 1477

Re: LCD e processi paralleli

Ora, se poco prima dello scattare il secondo io faccio scattare la fotocellula, il tempo segnato è sempre successivo a quanto atteso. Scusa, ma chi sei, l'uomo bionico ? Come fai ad essere certo che non sei tu a muoverti troppo lentamente di fronte alla fotocellula (suppongo sia tu a far scattare l...
by macca
Wed Feb 06, 2019 9:10 am
Forum: Italiano
Topic: LCD e processi paralleli
Replies: 20
Views: 1477

Re: LCD e processi paralleli

Domanda: ma come posso io fare due operazioni in contemporanea senza usare i thread? Una dopo l'altra ? L'esempio che hai postato usa ben tre thread che perdono la maggior parte del tempo ad aspettare qualcosa: set_display_clock aspetta che passi un secondo, set_new_time aspetta due secondi, il ter...
by macca
Tue Feb 05, 2019 3:40 pm
Forum: Italiano
Topic: LCD e processi paralleli
Replies: 20
Views: 1477

Re: LCD e processi paralleli

La soluzione più semplice è non utilizzare i thread! A meno che il tuo programma finale non sia estremamente complesso, l'uso dei thread si può benissimo evitare. Se proprio vuoi usare due thread, il problema probabilmente è che ad un certo punto entrambi vogliono pilotare il display e quindi lo inc...
by macca
Mon Jan 28, 2019 5:53 pm
Forum: Italiano
Topic: raspberry pib3+ bug?
Replies: 5
Views: 729

Re: raspberry pib3+ bug?

I video fanno un uso intensivo della GPU, possibile che si surriscaldi ? Lo tieni chiuso in un case ? Hai provato a tenere in funzione un Raspberry con il sistema operativo appena installato senza alcuna modifica o aggiornamento per vedere cosa succede ? Puoi provare a mettere una piccola ventola pe...
by macca
Sat Oct 20, 2018 10:27 am
Forum: Italiano
Topic: trasferimanto ftp su server aruba
Replies: 5
Views: 3050

Re: trasferimanto ftp su server aruba

Hai provato ad usare un client ftp da linea di comando ?
Se non funziona è probabile che sia un problema di permessi sul server.

Posta anche i messaggi che ti ritornano così magari si capisce meglio il problema.
by macca
Thu Sep 27, 2018 9:25 am
Forum: Italiano
Topic: Problema con I2C
Replies: 15
Views: 2837

Re: Problema con I2C

man i2cdetect

UU significa indirizzo riservato.

Questo forse può aiutarti:
https://www.raspberrypi.org/forums/view ... hp?t=96838

In altre parole... Google!
by macca
Tue Sep 18, 2018 6:27 am
Forum: Italiano
Topic: Molte domande... poche risposte :)
Replies: 7
Views: 1886

Re: Molte domande... poche risposte :)

Grazie per la dritta sul libro... tralasciando le questioni di python, il problema comunque resta con adafruit che anche seguendo le indicazioni mi ritrovo nella situazione che mostro nell'immagine. [img][/https://imgur.com/rBJbn76] Non le hai seguite proprio bene, nell'immagine si vede che manca u...
by macca
Tue Sep 04, 2018 8:06 am
Forum: Italiano
Topic: Alimentazione esterna sensori GPIO
Replies: 6
Views: 1040

Re: Alimentazione esterna sensori GPIO

nel circuito in figura l'alimentazione del controlStepper è dato da una fonte esterna e il negativo di Raspberry è messo in comune con il negativo dell'alimentazione esterna..... è corretto questo circuito? Si, direi che è corretto. Unico avvertimento, i pin di I/O funzionano solo a 3.3v quindi ass...
by macca
Tue Sep 04, 2018 7:42 am
Forum: Italiano
Topic: Alimentazione esterna sensori GPIO
Replies: 6
Views: 1040

Re: Alimentazione esterna sensori GPIO

La mia domanda (forse questo è stato il mio errore) è: Visto che ai pin Vcc e Gnd di raspberry si possono collegare dispositivi che assorbono in totale 50mA posso alimentare un sensore o qualunque altra cosa connessa ai pin GPIO con un alimentatore esterno senza prendere l'alimentazione dai pin del...
by macca
Tue Jun 12, 2018 8:26 am
Forum: Italiano
Topic: La chiocciola non funziona da CLI con tastiera italiana
Replies: 3
Views: 883

Re: La chiocciola non funziona da CLI con tastiera italiana

matteoraggi wrote:
Mon Jun 11, 2018 9:56 pm
The content of /etc/default/keyboard is:

Code: Select all

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="it"
XKBVARIANT=""
XKBOPTIONS="compose:ralt" 

BACKSPACE="guess"
Prova a togliere compose:ralt da XKBOPTIONS, lascialo vuoto come KBVARIANT.
by macca
Mon Jun 11, 2018 10:49 am
Forum: Italiano
Topic: Programmare avvio video su display
Replies: 37
Views: 5300

Re: Programmare avvio video su display

Allora in primis ho provato ad avviare il video con OMXPLAYER e il video girava ( si tratta di un video di 20-30 sec). Successivamente ho provato far partire il video con un Pushbutton prendendo spunto da un video su Youtube e non mi aveva dato problemi. Poi ho messo il REED e quando ho posizionato...
by macca
Mon Jun 11, 2018 10:00 am
Forum: Italiano
Topic: Programmare avvio video su display
Replies: 37
Views: 5300

Re: Programmare avvio video su display

Riallego le immagini del progetto e del codice al momento utilizzato che però non funziona mi manda il display in bianco e mi si blocca raspberry e sono costretto a staccare l'alimentazione... Qualcuno mi aiuta? Quando ci sono diverse parti che interagiscono tra loro, la cosa migliore da fare è pro...
by macca
Thu May 31, 2018 1:36 pm
Forum: Italiano
Topic: ERRORE su /etc/apt/sources.list.d/pms.list
Replies: 4
Views: 819

Re: ERRORE su /etc/apt/sources.list.d/pms.list

la guida mi chiede di mettere questo codice: sudo​ ​apt-get​ ​install​ ​apt-transport-https​ ​-y --force-yes E...non so come compilarlo..se devo separare le due righe o se scriverlo come fosse una riga sola...il problema maggiore e che inserendo quel comando mi esce questo... E: Tipo "sudo" non ric...

Go to advanced search