Go to advanced search

by pax
Fri Sep 28, 2012 1:31 pm
Forum: Automation, sensing and robotics
Topic: ROS (Robot Operating System) on RPi
Replies: 124
Views: 43449

Re: ROS on RPi

Has anyone built the OpenCV stacks in ROS on Wheezy? I'm running into some type definition problems with the cv_bridge package, because Fuerte seems to depend on opencv 2.4.0, while the Wheezy repositories only have 2.3.1. Do I need to install 2.4.0 from source, or is there a workaround to get Fuert...
by pax
Thu Sep 06, 2012 1:43 am
Forum: Automation, sensing and robotics
Topic: Kinect - Would it ever work with a Raspberry Pi?
Replies: 117
Views: 74915

Re: Kinect - Would it ever work with a Raspberry Pi?

I'd really love not to build a product that needs cheap Win7 notebooks to run it. The Asus Xtion is not an option as its range is too small (3.5m vs. 8m/Kinect) and the maximum resolution of the color camera is also lower. Hi Alex, I suggest you check your specs. The official range of the Kinect is...
by pax
Thu Sep 06, 2012 1:32 am
Forum: Automation, sensing and robotics
Topic: ROS (Robot Operating System) on RPi
Replies: 124
Views: 43449

Re: ROS on RPi

Is there any chance of a binary package for ROS on Raspbian?
by pax
Wed Aug 29, 2012 3:01 am
Forum: Automation, sensing and robotics
Topic: Kinect - Would it ever work with a Raspberry Pi?
Replies: 117
Views: 74915

Re: Kinect - Would it ever work with a Raspberry Pi?

I should report that I now have SimpleRead working well. I have the RPi, the Xtion and an Edimax mini wireless dongle all powered from an i-Rocks powered hub (Genesys 05e3:0606 chipset). There have been no error messages concerning the USB so far. The lsusb and usb-devices above are correct (lsusb d...
by pax
Fri Aug 24, 2012 1:11 pm
Forum: Automation, sensing and robotics
Topic: ROS (Robot Operating System) on RPi
Replies: 124
Views: 43449

Re: ROS on RPi

I successfully installed ROS Fuerte ROS-Full layer on Raspbian. Here is an image of my SD card : ROS Fuerte - Raspbian It comes just with ROS-Full and its dependencies installed. Because the build process is really long I thought it could help some of us to have a basic just-ROS-Full installation i...
by pax
Wed Aug 22, 2012 1:35 am
Forum: Automation, sensing and robotics
Topic: Kinect - Would it ever work with a Raspberry Pi?
Replies: 117
Views: 74915

Re: Kinect - Would it ever work with a Raspberry Pi?

May be a stupid question, but you have compiled and installed both OpenNI and the Sensor driver right? I only ask and your posts read like you have compiled one thing and you mention running Sample-NiSimpleRead which comes with OpenNI not the Sensor driver. I had the same thought when I first saw t...
by pax
Tue Aug 21, 2012 2:32 pm
Forum: Automation, sensing and robotics
Topic: Kinect - Would it ever work with a Raspberry Pi?
Replies: 117
Views: 74915

Re: Kinect - Would it ever work with a Raspberry Pi?

Thanks for the suggestion, Dom, but the result is the same. usb-devices looks like this: T: Bus=01 Lev=03 Prnt=04 Port=00 Cnt=01 Dev#= 5 Spd=480 MxCh= 0 D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1 P: Vendor=1d27 ProdID=0600 Rev=00.01 S: Manufacturer=PrimeSense S: Product=PrimeSense De...
by pax
Tue Aug 21, 2012 8:56 am
Forum: Automation, sensing and robotics
Topic: Kinect - Would it ever work with a Raspberry Pi?
Replies: 117
Views: 74915

Re: Kinect - Would it ever work with a Raspberry Pi?

Ok, I managed to get it compiled with CFLAGS += -mtune=arm1176jzf-s -mfpu=vfp -mfloat-abi=hard Now I'm trying to run the SimpleRead example. I am getting this error right now: Reading config from: '../../../../Data/SamplesConfig.xml' One or more of the following nodes could not be enumerated: dmesg|...
by pax
Mon Aug 20, 2012 4:41 pm
Forum: Automation, sensing and robotics
Topic: Kinect - Would it ever work with a Raspberry Pi?
Replies: 117
Views: 74915

Re: Kinect - Would it ever work with a Raspberry Pi?

I have just got the ASUS Xtion sensor working on the raspberry pi using OpenNI. .... Edit CFLAGS in Build/Common/Platform.Arm for the raspberry pi: CFALGS += -mtune=arm1176jzf-s -mfpu=vfp -mfloat-abi=softfp (and remove the line referring to armv9 and cortex-a8) Hi theunit (or anyone else who has th...

Go to advanced search