Go to advanced search

by kkremitzki
Sat Oct 12, 2019 12:39 am
Forum: Raspbian
Topic: FreeCAD on PI4 and Raspbian Buster.
Replies: 55
Views: 6713

Re: FreeCAD on PI4 and Raspbian Buster.

Hello all, I just wanted to give an update. I've finally got my Raspberry Pi 4—this thing is amazing! After some further troubleshooting, we've hit a dead end on fixing the segmentation fault problem. However, it looks like it isn't present when FreeCAD is built with the Python 2, Qt 4 configuration...
by kkremitzki
Mon Aug 12, 2019 4:06 pm
Forum: Raspbian
Topic: FreeCAD on PI4 and Raspbian Buster.
Replies: 55
Views: 6713

Re: FreeCAD on PI4 and Raspbian Buster.

The default source build config is Qt 4 + Python 2, but the package is built with Qt 5 and Python 2 + 3, so if you did for example sudo apt build-dep freecad you have the Qt 5 dependencies. In order to build with Qt 5 you need to include -DBUILD_QT5=ON when you call cmake. For Python 3, you need -DP...
by kkremitzki
Thu Aug 08, 2019 9:56 pm
Forum: Raspbian
Topic: FreeCAD on PI4 and Raspbian Buster.
Replies: 55
Views: 6713

Re: FreeCAD on PI4 and Raspbian Buster.

Thank you very much for joining and providing the insights. Would backporting 0.18.3 to stretch without rebuilding the dependencies be a sensible thing to try or would you expect the issue to still be there? The archive.raspberrypi.org repo is fairly flexible, so if there's anything we can do to fi...
by kkremitzki
Wed Aug 07, 2019 10:01 pm
Forum: Raspbian
Topic: FreeCAD on PI4 and Raspbian Buster.
Replies: 55
Views: 6713

Re: FreeCAD on PI4 and Raspbian Buster.

Hi all, I'm the maintainer of FreeCAD on Debian. The issue in the first post was likely caused by having freecad-doc installed; the old version of freecad-doc is no longer co-installable with the new package, because it installs files on a path that is now a symlink managed by the alternatives syste...

Go to advanced search