Go to advanced search

by cmason
Sun Jan 06, 2013 8:45 pm
Forum: Troubleshooting
Topic: qemu always hangs on macos 10.8.2
Replies: 7
Views: 5262

Re: qemu always hangs on macos 10.8.2

I tried using VNC as suggested with: qemu-system-arm -nographic -M versatilepb -kernel vmlinuz-2.6.32-5-versatile -initrd initrd.img-2.6.32-5-versatile -hda debian_squeeze_armel_standard.qcow2 -append "root=/dev/sda1 console=ttyAMA0" -vnc 127.0.0.1:5500,reverse and I still see the hang/crash. Which ...
by cmason
Mon Dec 31, 2012 8:35 pm
Forum: Bare metal, Assembly language
Topic: QEMU patches for RPi emulation - Initial release
Replies: 149
Views: 57928

Re: QEMU patches for RPi emulation - Initial release

Oh, I wasn't sure if it was Linux or QEMU that locked, but it seems that it's QEMU... There are many references about similar issues on the net, but indeed the real reason isn't very clear. If you can provide a trace, that would surely help. Meanwhile, I will check my code... If by chance QEMU is s...
by cmason
Mon Dec 31, 2012 1:15 pm
Forum: Troubleshooting
Topic: qemu always hangs on macos 10.8.2
Replies: 7
Views: 5262

Re: qemu always hangs on macos 10.8.2

http://xecdesign.com/qemu-emulating-raspberry-pi-the-easy-way/ I tried the kernel listed in the above post with: qemu-system-arm -kernel kernel-qemu -cpu arm1176 -m 256 -M versatilepb -no-reboot -serial stdio -append "root=/dev/sda2 panic=1" -hda 2012-12-16-wheezy-raspbian.img and I see the same be...
by cmason
Mon Dec 31, 2012 6:33 am
Forum: Troubleshooting
Topic: qemu always hangs on macos 10.8.2
Replies: 7
Views: 5262

qemu always hangs on macos 10.8.2

I'm trying to get qemu working on my Mac running 10.8.2 so I can cross compile compilers and various other things for the raspberry. I've followed instructions: http://www.rpiforum.net/forum/tutorials/article/16-a-raspberry-pi-emulated-environment-on-osx-lion/ http://igor.gold.ac.uk/~mas01mjy/wp/?p=...
by cmason
Tue Nov 13, 2012 7:18 am
Forum: Graphics, sound and multimedia
Topic: US ATSC TV Partial Success
Replies: 11
Views: 18391

Re: US ATSC TV Partial Success

I've still had basically no luck with tvheadend. It finds services but never the names for them, it never creates any channels and when I try to stream, I get odd error messages. I'm still following up with them, but I've basically given up hope of it ever working. I really have three use cases: One...
by cmason
Wed Nov 07, 2012 7:40 am
Forum: General discussion
Topic: confused about H264 encoding
Replies: 60
Views: 27006

Re: confused about H264 encoding

However someone has to write and debug the OpenMAX pipeline, and whilst that is a small amount of code, it needs a good understanding of the spec, and is tricky to get right. Any pointers to sample code about how to do decode and encode without displaying the video? I'd also like to be able to scal...
by cmason
Wed Nov 07, 2012 7:16 am
Forum: Graphics, sound and multimedia
Topic: US ATSC TV Partial Success
Replies: 11
Views: 18391

US ATSC TV Partial Success

I've had some success playing OTA HDTV (over the air) here in the States on my Raspberry PI. I'm in Portland, OR. I wanted to share some tips for folks because it seems like most people doing this stuff are in the UK or Europe (see how I made that distinction :) and I think perhaps the DVB hardware ...

Go to advanced search