Go to advanced search

by alexf
Tue Nov 20, 2012 10:48 pm
Forum: Raspbian
Topic: hciattach failing
Replies: 11
Views: 7152

Re: hciattach failing

Hi Geoff, Sorry for the slow reply. I'm afraid I didn't get it going. I got a little further but no success, if anyone else manages I'd be very pleased to hear what they did. I'll detail here what I can remember of what I did to see if it is of any use to anyone else. I stopped ttyAMA0 being used by...
by alexf
Fri Oct 05, 2012 9:51 pm
Forum: Other projects
Topic: STICKY: The projects list. Look here for some ideas.
Replies: 233
Views: 395050

Re: The projects list. Look here for some ideas.

Mini project I've been playing with: I often fall asleep whilst putting my daughter to bed, I find this annoying so I created a dead man's handle. My pi serves a couple of simple webpages, page1 has a start button which takes you to page2. page2 has a large restart button and 3 small OK buttons. The...
by alexf
Fri Aug 10, 2012 11:01 pm
Forum: Raspbian
Topic: hciattach failing
Replies: 11
Views: 7152

Re: hciattach failing

It looks like I don't have the hci_uart kernel module. It doesn't appear to be part of Raspbian. I can't work how to add this module. I guess I need to get the source and compile it but I can't find that. Can anyone help me with that? Sorry Wendo I didn't see the second half of your first post. If I...
by alexf
Fri Aug 10, 2012 9:19 am
Forum: Raspbian
Topic: hciattach failing
Replies: 11
Views: 7152

Re: hciattach failing

The hciattach man page says you can drop the /dev/ part but it is worth trying anyway, I'll give it a go later. Checking that the modules are compiled and loaded is definitely something I want to try. It looks (from your link) like I should try modprobe. hci_uart I think is the important one here. I...
by alexf
Fri Aug 10, 2012 7:55 am
Forum: Raspbian
Topic: hciattach failing
Replies: 11
Views: 7152

Re: hciattach failing

I'm running this as 'pi'. I think I also had a go with using sudo and got the same but I'm not sure.
by alexf
Thu Aug 09, 2012 10:21 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Connecting bluetooth module to UART
Replies: 1
Views: 1806

Re: Connecting bluetooth module to UART

I managed to get a little further with this by using a module I have a little more control over the initial conditions of. I am now stuck with the error message 'Can't set line discipline'. Questions about this seem to be more suited to the Raspbian forum so I have stared another topic http://www.ra...
by alexf
Thu Aug 09, 2012 10:16 am
Forum: Raspbian
Topic: hciattach failing
Replies: 11
Views: 7152

Re: hciattach failing

Hi, I'm using the Raspbian image on the downloads page of raspberrypi.org. I've installed the bluetooth package with 'aptitude install bluetooth'. I downloaded the bluez libs and tools from the bluez website and have built those (I realise this is unnecessary at this point but I want to tinker later...
by alexf
Wed Aug 08, 2012 9:52 pm
Forum: Raspbian
Topic: hciattach failing
Replies: 11
Views: 7152

hciattach failing

Hi, I'm trying to use hciattach to connect to a bluetooth module over UART but I am getting an error message: Can't set line discipline: Invalid argument Can't initialize device: Invalid argument It looks like this is because /* Set TTY to N_HCI line discipline */ is failing. I think N_HCI is someth...
by alexf
Tue Aug 07, 2012 2:45 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Connecting bluetooth module to UART
Replies: 1
Views: 1806

Connecting bluetooth module to UART

Hi, I'm trying to connect a CSR bluetooth module to my pi over the UART but I'm not having much success. I use the command hciattach ttyAMA0 bcsp 115200 noflow but get a timeout. I've stopped ttyAMA0 being used by getty by following the instructions in http://www.raspberrypi.org/phpBB3/viewtopic.php...

Go to advanced search