Go to advanced search

by Chimneyfactory
Fri Nov 29, 2019 12:06 am
Forum: Advanced users
Topic: DVFS Firmware
Replies: 58
Views: 5177

Re: DVFS Firmware

This might be 100% expected behavior of this test firmware, but it caught me out - and if it isn't expected/known, can I bring it to your attention : new firmware doesn't seem to change voltage / frequency behavior if 64 bit kernel is enabled. Pi 4 4gb initial boot from SD then Raspbian on USB3 SSD....
by Chimneyfactory
Mon Oct 21, 2019 7:55 pm
Forum: Networking and servers
Topic: Suggested USB3 to SATA adaptors (without power!) - what works well for you?
Replies: 3
Views: 815

Suggested USB3 to SATA adaptors (without power!) - what works well for you?

I've got a NAS I built some time back with (originally) a Pi B and 2x salvaged 3.5" HDD. I used some ebay USB2 to SATA adaptors, and it was powered with a separate 5volt and 12 volt supply. Over the years it's been tweaked and upgraded, ended up being a Pi 2 B+ with same USB adaptors, power from buc...
by Chimneyfactory
Wed Sep 18, 2019 7:40 pm
Forum: Troubleshooting
Topic: VLI firmware v2.0 - powersaving features enabled
Replies: 113
Views: 18343

Re: VLI firmware v2.0 - powersaving features enabled

If you're running the original 00013701 firmware, using the vl805 utility does not cause the pi to hang when shutting down. If you're running the new firmware 000137ab, the pi will consistently hang when shutting down after using the vl805 utility. Are you using the same vl805 binary for both flash...
by Chimneyfactory
Sun Sep 15, 2019 10:00 am
Forum: Troubleshooting
Topic: VLI firmware v2.0 - powersaving features enabled
Replies: 113
Views: 18343

Re: VLI firmware v2.0 - powersaving features enabled

In my post of Wed Sep 11, 2019 4:01 pm, https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=250990&start=25#p1534499 I noted that I could sometimes get the Pi to hang when shutting down, but it didn't seem repeatable. In my post of Thu Sep 12, 2019 1:43 pm https://www.raspberrypi.org/forums/view...
by Chimneyfactory
Thu Sep 12, 2019 1:43 pm
Forum: Troubleshooting
Topic: VLI firmware v2.0 - powersaving features enabled
Replies: 113
Views: 18343

Re: VLI firmware v2.0 - powersaving features enabled

I've found a sequence that, for me anyway, will consistently cause the shutdown freeze problem. Setup : Pi 4 4gb Full Raspbian install on SSD Boot from SD New VLI firmware 000137ab already installed VLI805 command and firmware is unzipped in Downloads directory Pi boots to CLI Login, then type these...
by Chimneyfactory
Wed Sep 11, 2019 5:46 pm
Forum: Troubleshooting
Topic: VLI firmware v2.0 - powersaving features enabled
Replies: 113
Views: 18343

Re: VLI firmware v2.0 - powersaving features enabled

Mem=3072? Perf Gov? firmware speed (ave) Reps Difference (MB/sec) 00013701 364.516 3 -9.40 00013701 367.770 5 -6.15 Y 00013701 367.424 5 -6.49 00013701 366.410 5 -7.51 Y 00013701 372.390 5 -1.53 Y 00013701 371.880 5 -2.04 Y Y 00013701 373.918 5 0.00 000137ab 353.610 3 -20.31 000137ab 354.048 5 -19....
by Chimneyfactory
Wed Sep 11, 2019 4:01 pm
Forum: Troubleshooting
Topic: VLI firmware v2.0 - powersaving features enabled
Replies: 113
Views: 18343

Re: VLI firmware v2.0 - powersaving features enabled

I've been trying to get the hanging on shutdown problem to come back, which I did, but not repeatably. Running new firmware. sudo shutdown -h now OK reboot flash firmware (original) sudo shutdown -h now HANGS reboot sudo shutdown -h now OK reboot sudo shutdown -h now OK reboot flash firmware (new) s...
by Chimneyfactory
Wed Sep 11, 2019 3:12 pm
Forum: Troubleshooting
Topic: VLI firmware v2.0 - powersaving features enabled
Replies: 113
Views: 18343

Re: VLI firmware v2.0 - powersaving features enabled

Flashed my pi4 4gb, working fine with the caveat that there's a slight performance hit in USB SSD speed. pi@pi4:~/Downloads $ sudo ./vl805 VL805 FW version: 00013701 pi@pi4:~ $ sudo hdparm -t /dev/sda1 /dev/sda1: Timing buffered disk reads: 1100 MB in 3.00 seconds = 366.48 MB/sec pi@pi4:~ $ sudo hdp...
by Chimneyfactory
Tue Aug 27, 2019 7:36 pm
Forum: Raspbian
Topic: VLC hard crashes
Replies: 53
Views: 6155

Re: VLC hard crashes

ShiftPlusOne wrote:
Tue Aug 27, 2019 5:39 pm
We normally don't update packages for previous releases, but given how recent Buster is, I've pushed out a VLC update for Stretch as well.

It should be public within about an hour.
Thank you, that's working great now - cpu load 10 - 15% instead of 100% when playing video in VLC.
by Chimneyfactory
Sat Aug 24, 2019 6:45 pm
Forum: Raspbian
Topic: VLC hard crashes
Replies: 53
Views: 6155

Re: VLC hard crashes

Hmm, Since the update to VLC a few days ago, it has broken VLC on my Pi 3B+ running stretch. VLC opens, but playback takes a long time to start, and when it does it's 100% CPU and one or two frames a second. pi@mypi3:~ $ uname --a Linux mypi3 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l...
by Chimneyfactory
Sun Jul 14, 2019 7:07 pm
Forum: Troubleshooting
Topic: A problem with Chromium after last update (bad rendered content)
Replies: 18
Views: 1065

Re: A problem with Chromium after last update (bad rendered content)

On my RPi 4GB with up to date firmware and software, running Raspbian Buster : pi@pi4:~ $ uname -a Linux pi4 4.19.57-v7l+ #1244 SMP Thu Jul 4 18:48:07 BST 2019 armv7l GNU/Linux (Chromimum About...) Version 74.0.3729.157 (Official Build) Built on Raspbian , running on Raspbian 10 (32-bit) I can confi...
by Chimneyfactory
Fri Jul 12, 2019 10:20 pm
Forum: Troubleshooting
Topic: RPi4 USB3 SSD / HDD partitioning & formatting causes mouse fail
Replies: 1
Views: 159

Re: RPi4 USB3 SSD / HDD partitioning & formatting causes mouse fail

I retested this again earlier using the SD card from 4th July, problem still repeatedly occurs. I then updated the Pi 4 sudo apt-get update --allow-releaseinfo-change && sudo apt-get upgrade Which pulled in a few updates. The problem has now been fixed :) I can repeatedly re-partition and reformat a...
by Chimneyfactory
Sun Jul 07, 2019 2:33 pm
Forum: Troubleshooting
Topic: Pi 4 fails to boot when active USB switch attached
Replies: 16
Views: 1585

Re: Pi 4 fails to boot when active USB switch attached

I can confirm my Pi4 4gb does this as well.

Doesn't even attempt to boot if a powered USB hub is connected.

The moment the hub is disconnected, the pi starts booting.
by Chimneyfactory
Thu Jul 04, 2019 10:40 am
Forum: Troubleshooting
Topic: RPi4 USB3 SSD / HDD partitioning & formatting causes mouse fail
Replies: 1
Views: 159

RPi4 USB3 SSD / HDD partitioning & formatting causes mouse fail

I've mentioned this elsewhere, but wanted to log what I've found so far. Setup : Rpi4 4GB, Official PSU, Keyboard, Mouse, 1xHDMI screen, External Orico USB3 powered Caddy with Seagate Video 500gb HDD. Raspbian fully updated. sudo gdisk /dev/sda d n (take defaults) w sudo mke2fs -t ext4 -L rootfs /de...
by Chimneyfactory
Tue Jul 02, 2019 8:35 pm
Forum: Troubleshooting
Topic: Raspberry Pi 4 - new VLI firmware issues
Replies: 69
Views: 21467

Re: Raspberry Pi 4 - new VLI firmware issues

I tried the new firmware, and it went badly wrong for me. Flashing the firmware to version 0137a8 returned the error "* Data mismatch". I retried, got the same error. I rebooted, and saw errors on the screen at boot. Once booted, the USB keyboard and mouse weren't working. SSH into the Pi, freshly d...
by Chimneyfactory
Tue Jul 02, 2019 3:55 pm
Forum: Troubleshooting
Topic: Raspberry Pi 4 - new VLI firmware issues
Replies: 69
Views: 21467

Re: Raspberry Pi 4 - new VLI firmware issues

The issue you are experiencing is unrelated to the new VLI firmware. Also, I am unable to reproduce it. That's curious you can't reproduce it - apart from the Pi4 and the PSU (Official Pi one), I've swapped everything else out and it still happens. I've found a way around it (gparted) but its just ...
by Chimneyfactory
Tue Jul 02, 2019 2:23 pm
Forum: Troubleshooting
Topic: Raspberry Pi 4 - new VLI firmware issues
Replies: 69
Views: 21467

Re: Raspberry Pi 4 - new VLI firmware issues

I'm not sure if it's relevant, but in case it is : I've had some very strange things going on with USB3 & SSD / HDD on a Stock firmware Pi 4. Prepping the disk : sudo gdisk /dev/sda d n (take defaults) w then formatting : sudo mke2fs -t ext4 -L rootfs /dev/sda1 Causes the mouse icon to stop moving w...
by Chimneyfactory
Sun Jun 30, 2019 3:45 pm
Forum: Troubleshooting
Topic: Pi4 - formatting external 2.5 HDD causes mouse issues
Replies: 6
Views: 487

Re: Pi4 - formatting external 2.5 HDD causes mouse issues

I've found a workaround - I'm now convinced it's a bug somewhere. If I prepare the partition on the external disk with gdisk, then format the partition either with sudo mke2fs -t ext4 -L rootfs /dev/sda1 or sudo mkfs.ext4 -L rootfs /dev/sda1 then the mouse pointer will stop moving as described previ...
by Chimneyfactory
Sun Jun 30, 2019 3:25 pm
Forum: Troubleshooting
Topic: Pi4 - formatting external 2.5 HDD causes mouse issues
Replies: 6
Views: 487

Re: Pi4 - formatting external 2.5 HDD causes mouse issues

It's doing it again, and it's repeatable. I'm messing about with external HDD because I want to boot the Pi 4 from it, using the method explained in this sticky here https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=44177 - so the initial boot is from the FAT partition on the SD, then booting ...
by Chimneyfactory
Sat Jun 29, 2019 10:34 pm
Forum: Troubleshooting
Topic: Raspberry Pi 4 temperature
Replies: 564
Views: 200893

Re: Raspberry Pi 4 temperature

4Gb Pi4 with official PSU and an external (mechanical) USB HDD with Raspbian installed on it (but booting from SD). After ~15 mins idling in desktop, temperature is drifting between 58 - 60C with an ambient of 24C and no fan https://i.imgur.com/ZQw90I4.jpg The Pi is installed on an official Raspberr...
by Chimneyfactory
Sat Jun 29, 2019 9:57 pm
Forum: Troubleshooting
Topic: Pi4 - formatting external 2.5 HDD causes mouse issues
Replies: 6
Views: 487

Re: Pi4 - formatting external 2.5 HDD causes mouse issues

k-pi wrote:
Sat Jun 29, 2019 5:43 pm
If it does come back, maybe try a different mouse.
Yeah, that was the next thing I was going to try, but it all started working fine!

Heavy load on the disk (ie benchmarking, including writes) didn't cause the problem, but formatting did. Bizarre!
by Chimneyfactory
Sat Jun 29, 2019 4:04 pm
Forum: Troubleshooting
Topic: Pi4 - formatting external 2.5 HDD causes mouse issues
Replies: 6
Views: 487

Re: Pi4 - formatting external 2.5 HDD causes mouse issues

The problem has now gone away :evil:

Earlier, it was repeatable across reboots and power cycles.

Now it's working fine. :?
by Chimneyfactory
Sat Jun 29, 2019 2:29 pm
Forum: Advanced users
Topic: How to span one volume across multiple drives?
Replies: 5
Views: 654

Re: How to span one volume across multiple drives?

Many thanks for the replies. @rpdom : LVM2 is probably the setup I had read about, thanks. My chief interest was a setup that I could remove a disk from and read separately elsewhere if the need arose (eg a failure) which is why I wanted to keep it simple. But having read the recommendations for BTR...
by Chimneyfactory
Sat Jun 29, 2019 2:22 pm
Forum: Troubleshooting
Topic: Pi4 - formatting external 2.5 HDD causes mouse issues
Replies: 6
Views: 487

Pi4 - formatting external 2.5 HDD causes mouse issues

I've just received a 4gb Pi4 and am naturally delighted :D Tinkering about, I discovered a curious problem. Formatting an external 2.5" HDD causes the mouse to stop working properly. Before you leap onto "aha! It's a power issue!" (perhaps it is, but bear with me) here's the setup : pi4, with offici...
by Chimneyfactory
Thu Jun 20, 2019 8:59 pm
Forum: Advanced users
Topic: How to span one volume across multiple drives?
Replies: 5
Views: 654

How to span one volume across multiple drives?

I've got a Pi that's been used for about 5 years as a NAS with a 2TB hard disk attached. That disk is now almost full, and rather than just replace it for a larger disk (as I've done before) I'd like to set up a volume that spans multiple disks. (The multiple disks will all be new disks, I'll copy t...

Go to advanced search