Go to advanced search

by Chimneyfactory
Sat Feb 22, 2020 10:08 am
Forum: Troubleshooting
Topic: Pi4 wireless USB keyboard and mouse problem - mouse intermittently stops responding
Replies: 1
Views: 55

Pi4 wireless USB keyboard and mouse problem - mouse intermittently stops responding

I've a Pi4 4gb , no overclock, boots from SD then up to date Raspbian Buster located on SSD on a USB3 port. Logitech keyboard and mouse use the same USB dongle, plugged into pi's USB 2 port. VERY intermittently, the mouse will stop responding. Initially I thought the pi had crashed, but keyboard con...
by Chimneyfactory
Sat Feb 22, 2020 9:48 am
Forum: Advanced users
Topic: How best to log 12 volt lead acid battery voltage with a Raspberry Pi?
Replies: 5
Views: 587

Re: How best to log 12 volt lead acid battery voltage with a Raspberry Pi?

Many thanks for the replies, the INA226 sounds exactly what I want, especially with the code examples to work from.

I've not yet tried this out - been busy with other things - but want to test it soon. Will post back here when I've done so

Thanks
by Chimneyfactory
Fri Feb 14, 2020 6:48 pm
Forum: Troubleshooting
Topic: Issues since kernel got updated to 4.19.93
Replies: 159
Views: 8965

Re: Issues since kernel got updated to 4.19.93

OK, I can't now replicate the problem using the same image as before. :?

All seems to work well. So.. who knows?

Ian
by Chimneyfactory
Fri Feb 14, 2020 5:37 pm
Forum: Troubleshooting
Topic: Issues since kernel got updated to 4.19.93
Replies: 159
Views: 8965

Re: Issues since kernel got updated to 4.19.93

I've just retried the original image from this morning, which I flashed onto a different SD card.. and it worked. Reboot after update didn't hang. As far as I can see, everything was the same as before. Same Pi, which has had the latest firmware on it for some time now. I'm reflashing the card again...
by Chimneyfactory
Fri Feb 14, 2020 5:00 pm
Forum: Troubleshooting
Topic: Issues since kernel got updated to 4.19.93
Replies: 159
Views: 8965

Re: Issues since kernel got updated to 4.19.93

@JamesH @dom It was just the first reboot after the update. After a power cycle it all booted fine and sudo reboot works fine as well. The Pi4 is one I've had since launch week, and use often. It had the latest firmware onboard already from the existing installation. Today I used a new Kingston 32GB...
by Chimneyfactory
Fri Feb 14, 2020 2:35 pm
Forum: Troubleshooting
Topic: Issues since kernel got updated to 4.19.93
Replies: 159
Views: 8965

Re: Issues since kernel got updated to 4.19.93

Hi, Just a heads up in case you weren't aware : there still seems to be a problem with hanging at the rainbow splash screen on reboot after updating. This happened on my pi4 4GB ther other day, power cycle fixed it. But today I downloaded latest Raspbian Desktop, put it on a new SD card. Initial reb...
by Chimneyfactory
Mon Feb 10, 2020 5:23 pm
Forum: Troubleshooting
Topic: Issues since kernel got updated to 4.19.93
Replies: 159
Views: 8965

Re: Issues since kernel got updated to 4.19.93

[...]Also, could this have caused an issue where some, not all, devices stopped working intermittently? I have a wireless keyboard and mouse combo that will stop responding randomly. Simply unplugging the dongle and reinserting it has always worked. The problem has never affected my USB Storage dev...
by Chimneyfactory
Thu Jan 30, 2020 12:26 am
Forum: Advanced users
Topic: How best to log 12 volt lead acid battery voltage with a Raspberry Pi?
Replies: 5
Views: 587

How best to log 12 volt lead acid battery voltage with a Raspberry Pi?

I've got some solar panels that charge a lead acid battery via a cheap solar charge controller. This battery then runs some low voltage items in the house, such as the router, a Pi based NAS and soon a few lights. I've also got an emergency backup that cuts in if the battery voltage drops below 11.5...
by Chimneyfactory
Tue Jan 14, 2020 4:56 pm
Forum: Advanced users
Topic: VL805 firmware release 0137ad - fixes for Isochronous streams
Replies: 65
Views: 7440

Re: VL805 firmware release 0137ad - fixes for Isochronous streams

I have a USB3-to-mSATA-converter-board with an uPD720231A from Renesas Electronics (NEC). I use it with an SAMSUNG 860EVO mSATA SSD. With the firmware release 0137ad the performance is nearly back to normal as it was with the first version (013701). I always test the SSD performance with https://ww...
by Chimneyfactory
Fri Nov 29, 2019 12:06 am
Forum: Advanced users
Topic: DVFS Firmware
Replies: 85
Views: 11176

Re: DVFS Firmware

This might be 100% expected behavior of this test firmware, but it caught me out - and if it isn't expected/known, can I bring it to your attention : new firmware doesn't seem to change voltage / frequency behavior if 64 bit kernel is enabled. Pi 4 4gb initial boot from SD then Raspbian on USB3 SSD....
by Chimneyfactory
Mon Oct 21, 2019 7:55 pm
Forum: Networking and servers
Topic: Suggested USB3 to SATA adaptors (without power!) - what works well for you?
Replies: 3
Views: 941

Suggested USB3 to SATA adaptors (without power!) - what works well for you?

I've got a NAS I built some time back with (originally) a Pi B and 2x salvaged 3.5" HDD. I used some ebay USB2 to SATA adaptors, and it was powered with a separate 5volt and 12 volt supply. Over the years it's been tweaked and upgraded, ended up being a Pi 2 B+ with same USB adaptors, power from buc...
by Chimneyfactory
Wed Sep 18, 2019 7:40 pm
Forum: Troubleshooting
Topic: VLI firmware v2.0 - powersaving features enabled
Replies: 111
Views: 23922

Re: VLI firmware v2.0 - powersaving features enabled

If you're running the original 00013701 firmware, using the vl805 utility does not cause the pi to hang when shutting down. If you're running the new firmware 000137ab, the pi will consistently hang when shutting down after using the vl805 utility. Are you using the same vl805 binary for both flash...
by Chimneyfactory
Sun Sep 15, 2019 10:00 am
Forum: Troubleshooting
Topic: VLI firmware v2.0 - powersaving features enabled
Replies: 111
Views: 23922

Re: VLI firmware v2.0 - powersaving features enabled

In my post of Wed Sep 11, 2019 4:01 pm, https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=250990&start=25#p1534499 I noted that I could sometimes get the Pi to hang when shutting down, but it didn't seem repeatable. In my post of Thu Sep 12, 2019 1:43 pm https://www.raspberrypi.org/forums/view...
by Chimneyfactory
Thu Sep 12, 2019 1:43 pm
Forum: Troubleshooting
Topic: VLI firmware v2.0 - powersaving features enabled
Replies: 111
Views: 23922

Re: VLI firmware v2.0 - powersaving features enabled

I've found a sequence that, for me anyway, will consistently cause the shutdown freeze problem. Setup : Pi 4 4gb Full Raspbian install on SSD Boot from SD New VLI firmware 000137ab already installed VLI805 command and firmware is unzipped in Downloads directory Pi boots to CLI Login, then type these...
by Chimneyfactory
Wed Sep 11, 2019 5:46 pm
Forum: Troubleshooting
Topic: VLI firmware v2.0 - powersaving features enabled
Replies: 111
Views: 23922

Re: VLI firmware v2.0 - powersaving features enabled

Mem=3072? Perf Gov? firmware speed (ave) Reps Difference (MB/sec) 00013701 364.516 3 -9.40 00013701 367.770 5 -6.15 Y 00013701 367.424 5 -6.49 00013701 366.410 5 -7.51 Y 00013701 372.390 5 -1.53 Y 00013701 371.880 5 -2.04 Y Y 00013701 373.918 5 0.00 000137ab 353.610 3 -20.31 000137ab 354.048 5 -19....
by Chimneyfactory
Wed Sep 11, 2019 4:01 pm
Forum: Troubleshooting
Topic: VLI firmware v2.0 - powersaving features enabled
Replies: 111
Views: 23922

Re: VLI firmware v2.0 - powersaving features enabled

I've been trying to get the hanging on shutdown problem to come back, which I did, but not repeatably. Running new firmware. sudo shutdown -h now OK reboot flash firmware (original) sudo shutdown -h now HANGS reboot sudo shutdown -h now OK reboot sudo shutdown -h now OK reboot flash firmware (new) s...
by Chimneyfactory
Wed Sep 11, 2019 3:12 pm
Forum: Troubleshooting
Topic: VLI firmware v2.0 - powersaving features enabled
Replies: 111
Views: 23922

Re: VLI firmware v2.0 - powersaving features enabled

Flashed my pi4 4gb, working fine with the caveat that there's a slight performance hit in USB SSD speed. pi@pi4:~/Downloads $ sudo ./vl805 VL805 FW version: 00013701 pi@pi4:~ $ sudo hdparm -t /dev/sda1 /dev/sda1: Timing buffered disk reads: 1100 MB in 3.00 seconds = 366.48 MB/sec pi@pi4:~ $ sudo hdp...
by Chimneyfactory
Tue Aug 27, 2019 7:36 pm
Forum: Raspbian
Topic: VLC hard crashes
Replies: 54
Views: 8193

Re: VLC hard crashes

ShiftPlusOne wrote:
Tue Aug 27, 2019 5:39 pm
We normally don't update packages for previous releases, but given how recent Buster is, I've pushed out a VLC update for Stretch as well.

It should be public within about an hour.
Thank you, that's working great now - cpu load 10 - 15% instead of 100% when playing video in VLC.
by Chimneyfactory
Sat Aug 24, 2019 6:45 pm
Forum: Raspbian
Topic: VLC hard crashes
Replies: 54
Views: 8193

Re: VLC hard crashes

Hmm, Since the update to VLC a few days ago, it has broken VLC on my Pi 3B+ running stretch. VLC opens, but playback takes a long time to start, and when it does it's 100% CPU and one or two frames a second. pi@mypi3:~ $ uname --a Linux mypi3 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l...
by Chimneyfactory
Sun Jul 14, 2019 7:07 pm
Forum: Troubleshooting
Topic: A problem with Chromium after last update (bad rendered content)
Replies: 18
Views: 1305

Re: A problem with Chromium after last update (bad rendered content)

On my RPi 4GB with up to date firmware and software, running Raspbian Buster : pi@pi4:~ $ uname -a Linux pi4 4.19.57-v7l+ #1244 SMP Thu Jul 4 18:48:07 BST 2019 armv7l GNU/Linux (Chromimum About...) Version 74.0.3729.157 (Official Build) Built on Raspbian , running on Raspbian 10 (32-bit) I can confi...
by Chimneyfactory
Fri Jul 12, 2019 10:20 pm
Forum: Troubleshooting
Topic: RPi4 USB3 SSD / HDD partitioning & formatting causes mouse fail
Replies: 1
Views: 180

Re: RPi4 USB3 SSD / HDD partitioning & formatting causes mouse fail

I retested this again earlier using the SD card from 4th July, problem still repeatedly occurs. I then updated the Pi 4 sudo apt-get update --allow-releaseinfo-change && sudo apt-get upgrade Which pulled in a few updates. The problem has now been fixed :) I can repeatedly re-partition and reformat a...
by Chimneyfactory
Sun Jul 07, 2019 2:33 pm
Forum: Troubleshooting
Topic: Pi 4 fails to boot when active USB switch attached
Replies: 16
Views: 2212

Re: Pi 4 fails to boot when active USB switch attached

I can confirm my Pi4 4gb does this as well.

Doesn't even attempt to boot if a powered USB hub is connected.

The moment the hub is disconnected, the pi starts booting.
by Chimneyfactory
Thu Jul 04, 2019 10:40 am
Forum: Troubleshooting
Topic: RPi4 USB3 SSD / HDD partitioning & formatting causes mouse fail
Replies: 1
Views: 180

RPi4 USB3 SSD / HDD partitioning & formatting causes mouse fail

I've mentioned this elsewhere, but wanted to log what I've found so far. Setup : Rpi4 4GB, Official PSU, Keyboard, Mouse, 1xHDMI screen, External Orico USB3 powered Caddy with Seagate Video 500gb HDD. Raspbian fully updated. sudo gdisk /dev/sda d n (take defaults) w sudo mke2fs -t ext4 -L rootfs /de...
by Chimneyfactory
Tue Jul 02, 2019 8:35 pm
Forum: Troubleshooting
Topic: Raspberry Pi 4 - new VLI firmware issues
Replies: 69
Views: 24589

Re: Raspberry Pi 4 - new VLI firmware issues

I tried the new firmware, and it went badly wrong for me. Flashing the firmware to version 0137a8 returned the error "* Data mismatch". I retried, got the same error. I rebooted, and saw errors on the screen at boot. Once booted, the USB keyboard and mouse weren't working. SSH into the Pi, freshly d...
by Chimneyfactory
Tue Jul 02, 2019 3:55 pm
Forum: Troubleshooting
Topic: Raspberry Pi 4 - new VLI firmware issues
Replies: 69
Views: 24589

Re: Raspberry Pi 4 - new VLI firmware issues

The issue you are experiencing is unrelated to the new VLI firmware. Also, I am unable to reproduce it. That's curious you can't reproduce it - apart from the Pi4 and the PSU (Official Pi one), I've swapped everything else out and it still happens. I've found a way around it (gparted) but its just ...

Go to advanced search