Go to advanced search

by nigelbartlett1
Sun Sep 29, 2019 2:44 pm
Forum: Networking and servers
Topic: Setting up a Nginx server using xxx.asuscomm.com
Replies: 2
Views: 463

Re: Setting up a Nginx server using xxx.asuscomm.com

Sorry, I know nothing about nginx set-up, so feel free to ignore if the following is not helpful! If I understand correctly, from the Internet you can reach http://abc.xyz but not https://abc.xyz So http traffic is being accepted but not https. I would guess that this is because either you have a fi...
by nigelbartlett1
Tue Sep 24, 2019 3:29 pm
Forum: General discussion
Topic: VNC Viewer on school network
Replies: 5
Views: 186

Re: VNC Viewer on school network

See if you can establish an ssh session between the machines. If so, you can tunnel RealVNC over the ssh connection.
by nigelbartlett1
Thu Sep 19, 2019 4:01 pm
Forum: Troubleshooting
Topic: Wordpress not accessible
Replies: 3
Views: 90

Re: Wordpress not accessible

Are you running a firewall on the client that cannot connect to Wordpress? If so, disable it and try again. For ufw the command is sudo ufw disable If that doesn’t fix it please report what you type on the browser on the Pi running Wordpress to display the site, and also what you type on the browser...
by nigelbartlett1
Wed Sep 18, 2019 9:21 am
Forum: General discussion
Topic: Raspberry Pi and Fotek SSR-25
Replies: 4
Views: 186

Re: Raspberry Pi and Fotek SSR-25

The Fotek should be either off or on, with no in-between state, but it sounds like yours is not. I wonder if you have a genuine part, because there are an awful lot of fake Fotek devices on the market. I bought 2 SSR-40DA devices on eBay and they work fine with standard GPIO pin 17 (in my case). But...
by nigelbartlett1
Sun Sep 08, 2019 4:31 pm
Forum: Troubleshooting
Topic: Buster / Apache2 missing package - libapache2-mod-fcgi(d)
Replies: 4
Views: 255

Re: Buster / Apache2 missing package - libapache2-mod-fcgi(d)

Please try (Note: it's fcgid not fastcgid) sudo apt -y install libapache2-mod-fcgid Results for me nigelb@rlcvps:~ $ sudo apt -y install libapache2-mod-fcgid Reading package lists... Done Building dependency tree Reading state information... Done The following NEW packages will be installed: libapac...
by nigelbartlett1
Sun Sep 08, 2019 8:08 am
Forum: Troubleshooting
Topic: Buster / Apache2 missing package - libapache2-mod-fcgi(d)
Replies: 4
Views: 255

Re: Buster / Apache2 missing package - libapache2-mod-fcgi(d)

I have been running WordPress (now at 5.2.3 thanks to auto-updating) on Buster for over a month without installing this module. The block editor and auto-updates both run fine. I don't know about the REST API as I block this. Perhaps a silly question, but did you try to install libapache2-mod-fastcg...
by nigelbartlett1
Sat Sep 07, 2019 5:00 pm
Forum: Networking and servers
Topic: wordpress host
Replies: 9
Views: 466

Re: wordpress host

@Andyroo: No, ufw does not block ports on local host in my experience, so this doesn’t account for what the OP is seeing.
by nigelbartlett1
Sat Sep 07, 2019 8:25 am
Forum: Networking and servers
Topic: wordpress host
Replies: 9
Views: 466

Re: wordpress host

The first problem to address is your site not working when you access it as local host from your Pi. Run these commands on your Pi. First, is Apache running? sudo systemctl status apache2 If not, try restarting it sudo systemctl start apache2 If this fails report the results of sudo journal to -xe
by nigelbartlett1
Sun Sep 01, 2019 7:36 am
Forum: Troubleshooting
Topic: Having problems with the wordpress LAMP tutorial
Replies: 3
Views: 154

Re: Having problems with the wordpress LAMP tutorial

1. Pi-hole is very likely responsible for the lack of styling.
2. I would expect links to go to local host/(link location). Why do you expect something different?
by nigelbartlett1
Sun Aug 25, 2019 10:12 am
Forum: Networking and servers
Topic: install Mysql-Server and client, php5, apache
Replies: 8
Views: 1936

Re: install Mysql-Server and client, php5, apache

What you will get is the version of the package available in the version of Raspbian you have installed. For Buster this is PHP 7.3 as stated in my original response. This is the latest version of PHP, but probably not the latest sub-release eg 7.3.x where x differs between latest and that installed...
by nigelbartlett1
Sun Aug 25, 2019 8:55 am
Forum: Raspbian
Topic: MySQL or MariaDB on RPi4 with Buster?
Replies: 15
Views: 1757

Re: MySQL or MariaDB on RPi4 with Buster?

Please don’t ask the same question in multiple places.
https://www.raspberrypi.org/forums/view ... 6&t=248062
by nigelbartlett1
Sun Aug 25, 2019 7:48 am
Forum: Networking and servers
Topic: install Mysql-Server and client, php5, apache
Replies: 8
Views: 1936

Re: install Mysql-Server and client, php5, apache

The advice from different people often differs because there are different ways to achieve the same result. I believe that either of the proffered suggestions would result in the same level of MariaDB being installed. Also, I suggest you pick one set of instructions and try it. If it doesn’t work th...
by nigelbartlett1
Thu Aug 22, 2019 9:29 am
Forum: General discussion
Topic: Garish display on RPi4 with Buster in VNC
Replies: 3
Views: 275

Re: Garish display on RPi4 with Buster in VNC

Undo your changes to config.txt, re-boot, then start VNCserver like this:

Code: Select all

vncserver -randr 1920x1080
by nigelbartlett1
Wed Aug 21, 2019 9:14 am
Forum: Raspbian
Topic: Apache virtual hosts
Replies: 2
Views: 728

Re: Apache virtual hosts

I think the more usual use case for virtual hosts is named ones. I appreciate that this isn't your intention but you may be able to implement a scheme like the following in your own network. You would, typically, have one virtual host per website, each one looking similar to this: # ----------------...
by nigelbartlett1
Sun Aug 18, 2019 2:15 pm
Forum: General discussion
Topic: RealVNC server in virtual mode - Enterprise license required?
Replies: 12
Views: 1562

Re: RealVNC server in virtual mode - Enterprise license required?

Most software that we use is licensed. That does not mean that you have to pay to use it.

In the case of RealVNC on the Pi it is free for “non-commercial use” according to https://www.realvnc.com/en/raspberrypi/
by nigelbartlett1
Sun Aug 18, 2019 7:23 am
Forum: Advanced users
Topic: Avoiding circular symlinks in an install script
Replies: 18
Views: 1535

Re: Avoiding circular symlinks in an install script

First make your script a Bash script by adding, as first line

Code: Select all

#!/bin/bash
Then, prior to creating a symlink, test whether it (doesn’t) exist and create it in that event only

Code: Select all

if [ ! -L linkname ]; then
  sudo ln ...
fi
by nigelbartlett1
Sat Aug 17, 2019 7:13 am
Forum: General discussion
Topic: Installing pyplate
Replies: 6
Views: 1000

Re: Installing pyplate

It sounds as though something went wrong during your Apache install. Please try the following. sudo apt -y purge libapache2-mod-wsgi sudo apt -y install libapache2-mod-wsgi sudo systemctl restart apache2 If this doesn't resolve the problem post the output of the second command here and also this com...
by nigelbartlett1
Fri Aug 16, 2019 9:28 am
Forum: General discussion
Topic: Installing pyplate
Replies: 6
Views: 1000

Re: Installing pyplate

OK so mod_wsgi isn't enabled. It may or may not be installed. Try these commands:

Code: Select all

sudo apt update
sudo apt -y install libapache2-mod-wsgi
sudo a2enmod wsgi
sudo systemctl restart apache2
by nigelbartlett1
Thu Aug 15, 2019 1:16 pm
Forum: General discussion
Topic: Installing pyplate
Replies: 6
Views: 1000

Re: Installing pyplate

Nothing stands out as being obviously wrong in that file. Do you have mod_wsgi enabled? Have you tried, at the time of failure, the command

Code: Select all

sudo journalctl -xe
by nigelbartlett1
Sat Aug 10, 2019 3:50 pm
Forum: General discussion
Topic: Remmina
Replies: 13
Views: 841

Re: Remmina

Just to be clear, VNC Server is the component that runs on the (presumed headless) Pi. VNC Viewer is the component that runs on the device that has the screen, keyboard and mouse. VNC is not the same protocol as RDP and will not work with it. If you absolutely require RDP then I suggest you investig...
by nigelbartlett1
Wed Aug 07, 2019 5:44 am
Forum: Networking and servers
Topic: install Mysql-Server and client, php5, apache
Replies: 8
Views: 1936

Re: install Mysql-Server and client, php5, apache

You don’t say, but I assume you are trying to install on Raspbian Buster. If so:

Code: Select all

sudo apt update
sudo apt -y install default-mysql-client default-mysql-server apache2 php php-mysql
Buster comes with PHP 7.3. Version 5 is no longer maintained.
by nigelbartlett1
Mon Aug 05, 2019 6:00 pm
Forum: Networking and servers
Topic: Help with Rasp 4 and wordpress
Replies: 1
Views: 177

Re: Help with Rasp 4 and wordpress

How do you access your website over the internet? If you do so by navigating to http://example.com then you should be able to access the WordPress admin page by navigating to http://example.com/wp-admin However, if WordPress thinks that your site's name is localhost then I am rather doubtful that yo...
by nigelbartlett1
Sun Aug 04, 2019 7:38 am
Forum: Networking and servers
Topic: Do I really need to modify iptables if I just want to connect via Wifi?
Replies: 8
Views: 418

Re: Do I really need to modify iptables if I just want to connect via Wifi?

No, you do not need to do anything with IPtables to connect a Pi wirelessly to another computer. The. URL you posted takes you to a page titled “Setting up a Raspberry Pi as a Wireless Access Point”. You do not need or want to do this so you are better off ignoring the whole tutorial. To connect via...
by nigelbartlett1
Sun Jul 28, 2019 11:45 am
Forum: Troubleshooting
Topic: Enable php-apcu on Raspbian Buster with apache2 (nextcloud)
Replies: 3
Views: 413

Re: Enable php-apcu on Raspbian Buster with apache2 (nextcloud)

I haven't tried nextcloud but I don't have any trouble with PHP on Buster, and PHP 7.2 is not installed by default. I did the following: Started with a clean install of the latest Raspbian Buster Did an "apt full-upgrade" after an "apt update" Did an "apt -y install apache2" Did an "apt -y install p...
by nigelbartlett1
Sun Jul 07, 2019 9:08 am
Forum: Networking and servers
Topic: A way to redirect http traffic to https
Replies: 10
Views: 1118

Re: A way to redirect http traffic to https

Oops! It turns out my suggestion wasn't doing what you wanted. I've spent some more time playing with the Apache forward proxy, and, in every configuration I tried, it didn't work. What was happening was that the first HTTP GET request from my client was being answered with HTTP status 301 (permanen...

Go to advanced search