Go to advanced search

by ottsm
Fri Jun 14, 2019 12:50 am
Forum: Networking and servers
Topic: password protection for owfs (owhttpd)
Replies: 0
Views: 122

password protection for owfs (owhttpd)

I'm kind of new to Apache2. I figured out how to setup password protection for all my CGI files and web pages, however, I have a dallas one wire system with OWFS running. I'd like to have password protection to restrict access to port 2121. If I do port forwarding in my router to port 2121 I current...
by ottsm
Sat May 18, 2019 2:08 pm
Forum: Networking and servers
Topic: Apache stalling when running CGI but eventually allows access
Replies: 0
Views: 102

Apache stalling when running CGI but eventually allows access

I'm accessing several cgi programs on my Raspberry PI. I access as the localhost at the PI itself and also remotely with Safari on my cell phone and also with Firefox on my PC. The PC accesses just using the local network IP settings and the cell phone has a port setup and is going through a DDNS se...
by ottsm
Sat Mar 09, 2019 8:43 pm
Forum: Networking and servers
Topic: Apache stalling when running CGI
Replies: 0
Views: 167

Apache stalling when running CGI

Below is a CGI script that I have random problems with. If I reboot the Raspberry Pi Apache will execute the CGI file fine. After awhile if I go back and try it again it will just stall. Sometimes it will set for say 30 or more seconds and finally come up, other times it times out and shows a broken...
by ottsm
Thu Feb 28, 2019 4:51 am
Forum: General discussion
Topic: Measure a well depth
Replies: 18
Views: 975

Re: Measure a well depth

Ideally a good old bubbler level sensor will work but you don't have any continuous source of air close by unless you bring a small electric or manual pump with you each time. Place a Tee fitting in the line and a Schrader tire pressure fitting or some other one way valve to keep the air in but allo...
by ottsm
Tue Feb 26, 2019 1:55 am
Forum: Beginners
Topic: Default Password for Cacti not working
Replies: 3
Views: 237

Re: Default Password for Cacti not working

Figured it out from the following;
https://www.cacti.net/downloads/docs/html/faq.html

Had to do the following;

Code: Select all

sudo mysql -u root -p cacti
Then the following;

Code: Select all

update user_auth set password=md5('admin') where username='admin';
by ottsm
Tue Feb 26, 2019 1:45 am
Forum: Beginners
Topic: Default Password for Cacti not working
Replies: 3
Views: 237

Default Password for Cacti not working

Ok, I installed cacti on my Raspberry pi 3 B+ with raspbian installed. I used the ADD/REMOVE Software versus using the command line. I had never setup mysql before and when I looked at the /etc/mysql/dabian.cnf file it has root as the user and nothing that shows up as the password (I'm assuming it's...
by ottsm
Sat Feb 09, 2019 12:27 am
Forum: Other programming languages
Topic: Reset 1-wire Bus - DS18B20
Replies: 18
Views: 11230

Re: Reset 1-wire Bus - DS18B20

Using a pull-up resistor will work for an experiment or for one sensor directly on the gpio. To start using long cable lengths and multiple sensors you need to use the DS2482-100 with a strong pull-up circuit. Also use a level shifter and get to 5VDC.
by ottsm
Thu Feb 07, 2019 4:37 am
Forum: Beginners
Topic: how to get CGI scripts working for rrdcgi
Replies: 0
Views: 60

how to get CGI scripts working for rrdcgi

I'm using OWFS to read temperatures. Next I store them in an RRD file. This all works. I already know how to use the normal rrdtool graph command to make .png files and display them on a web page. What I can't figure out is how to get rrdcgi to run as a cgi script correctly. What I currently have do...

Go to advanced search