Go to advanced search

by M1LKYWVY
Fri Jul 19, 2019 3:51 pm
Forum: Compute Module
Topic: Unable to flush emmc. CM3.
Replies: 10
Views: 1223

Re: Unable to flush emmc. CM3.

Problem suddenly has gone long time ago. Today is appeared again. Any news about this issue?
by M1LKYWVY
Mon Jun 17, 2019 1:21 pm
Forum: Compute Module
Topic: CM3+ 64bit OS
Replies: 2
Views: 522

Re: CM3+ 64bit OS

Tell please for what reasons u need 64 bit version OS?
by M1LKYWVY
Mon Jun 17, 2019 9:11 am
Forum: Compute Module
Topic: UARt Alternate fucntion and dpi conflict
Replies: 0
Views: 393

UARt Alternate fucntion and dpi conflict

I am using both uarts on my CM3. Everything works fine. Uarts were configured with listed below method (/boot/config.txt) enable_uart=1 dtoverlay=uart0,txd0_pin=32,rxd0_pin=33,pin_func=7 dtoverlay=uart1,txd1_pin=40,rxd1_pin=41 I configured dpi. Added this lines to the end of /boot/config.txt dtoverl...
by M1LKYWVY
Tue May 28, 2019 9:52 am
Forum: Networking and servers
Topic: Getting coordinates
Replies: 1
Views: 246

Getting coordinates

Hi all!

I have successfully connected CM3 to internet via ppp and gsm modem over serial. So, AT commands is unavailable now.

Is there any way to get signal strength and coordinates using this method?

Thanks in advance for your replies.
by M1LKYWVY
Thu May 16, 2019 6:50 pm
Forum: Compute Module
Topic: GPIO Alternate Functions
Replies: 1
Views: 388

GPIO Alternate Functions

Hi all! I faced strange behavior of alternate pins functions. So, I have enabled SPI. config.txt dtparam=spi=on set it up to alternative pins gpio=35-39=a0 also tested this setting up sudo raspi-gpio set 35 a0 sudo raspi-gpio set 36 a0 sudo raspi-gpio set 37 a0 sudo raspi-gpio set 38 a0 sudo raspi-g...
by M1LKYWVY
Fri Feb 22, 2019 9:24 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: 1wire bus send and get data
Replies: 0
Views: 495

1wire bus send and get data

Hi everyone! I am using ds1961s+f5 device, it is connected to rpi through 1wire interface. I did not find any solution how to send to this device command (0x33, for example) and get reply. I found in linux kernel documentation only this informaton: rw - (optional) created for slave devices which do ...
by M1LKYWVY
Thu Feb 07, 2019 10:34 am
Forum: Compute Module
Topic: Connect display to CM via DSI
Replies: 3
Views: 701

Re: Connect display to CM via DSI

I have already seen this links...

Lets imagine that i have written my own driver according to my display.
Tell me please how can I debug it or simply run and test with my display on CM?
by M1LKYWVY
Thu Feb 07, 2019 8:28 am
Forum: Compute Module
Topic: Connect display to CM via DSI
Replies: 3
Views: 701

Connect display to CM via DSI

Hello! As I understood, DSI is still closed architecture in raspberry, so we can not connect non official raspberry display directly without any manipulations. Am I right? I have cultivated a lot of pages on forum and make a conclusion that there is way to connect non official display via DSI by rew...
by M1LKYWVY
Mon Jan 14, 2019 1:33 pm
Forum: Compute Module
Topic: IO board and CM compatibility!
Replies: 0
Views: 568

IO board and CM compatibility!

Good afternoon! I have troubles with flashing emmc of CM. I have old IO board (it does not has slot for sd card), CM1 and CM3. CM1 is not detectable with this IO board totally, CM3 has troubles with flashing https://www.raspberrypi.org/forums/viewtopic.php?f=98&t=230849&p=1416104#p1416104 . So i hav...
by M1LKYWVY
Mon Jan 14, 2019 1:24 pm
Forum: Compute Module
Topic: Unable to flush emmc. CM3.
Replies: 10
Views: 1223

Re: Unable to flush emmc. CM3.

May be problem in IO board? I have old IO board (it does not has slot for sd card), CM1 and CM3. CM1 is not detecting totally, but CM3 falls with errors while flashing.
by M1LKYWVY
Thu Jan 10, 2019 8:25 am
Forum: Compute Module
Topic: Unable to flush emmc. CM3.
Replies: 10
Views: 1223

Re: Unable to flush emmc. CM3.

1. Did the undervoltage errors go away with the 2.5A supply? 2. Try to just write zeroes to the CM3: sudo dd if=/dev/zero of=/dev/sdb bs=4MiB If it fails, does it fail at the same sector (407648)? 3. Similar to 2, but starting part-way (400MB) through the EMMC: sudo dd if=/dev/zero of=/dev/sdb bs=4...
by M1LKYWVY
Wed Jan 09, 2019 12:31 pm
Forum: Compute Module
Topic: Unable to flush emmc. CM3.
Replies: 10
Views: 1223

Re: Unable to flush emmc. CM3.

PhilE wrote:
Wed Jan 09, 2019 12:01 pm
Please try using different USB cables - you'd be amazed how often a bad cable can cause an issue.
I took all usb - microsub cables that I had. 6 different cables. Tried vary them. No results :shock:
by M1LKYWVY
Wed Jan 09, 2019 11:37 am
Forum: Compute Module
Topic: Unable to flush emmc. CM3.
Replies: 10
Views: 1223

Re: Unable to flush emmc. CM3.

PhilE wrote:
Wed Jan 09, 2019 11:11 am
For a Pi 3B or 3B+ we specify a minimum of 5V@2.5A.
Have checked one minute ago with 5V@2.5A. Still facing this problem. Took raspbian stretch without recommended software, flushed 242 mb...
dd says " '/dev/sdb': Input/output error "
by M1LKYWVY
Wed Jan 09, 2019 11:07 am
Forum: Compute Module
Topic: Unable to flush emmc. CM3.
Replies: 10
Views: 1223

Re: Unable to flush emmc. CM3.

I tried 5V 2A, 5V 0.7A. Error stays....
by M1LKYWVY
Wed Jan 09, 2019 10:43 am
Forum: Compute Module
Topic: Unable to flush emmc. CM3.
Replies: 10
Views: 1223

Unable to flush emmc. CM3.

Hi, guys! I am trying to flush emmc with os. I tried 3 different images. My problem is that i can not flush full image. I see that it flushed small part of image (when tried lite version of raspbian, it flushed 200mb) and it seems to me that cm3 reboots or just reconnects. I followed instructions de...

Go to advanced search