Go to advanced search

by DavidAtanasoski
Sat Mar 09, 2019 5:37 pm
Forum: C/C++
Topic: How to interface gyro and accelerometer sensor with Raspberry Pi in C++ ( MPU6050 )
Replies: 1
Views: 200

How to interface gyro and accelerometer sensor with Raspberry Pi in C++ ( MPU6050 )

Recently I've received a gyro/accelerometer sensor and I am wondering how can I use it with my Raspberry Pi but in C++. I want to measure the angle ( X, Y, Z axis ) and to be able to turn car 90 degrees left or right. Is there anyone who knows how can I interface this sensor with C++ on RPi? The sen...
by DavidAtanasoski
Sat Mar 09, 2019 11:22 am
Forum: Troubleshooting
Topic: How to interface gyro and accelerometer sensor with Raspberry Pi in C++ ( MPU6050 )
Replies: 1
Views: 58

How to interface gyro and accelerometer sensor with Raspberry Pi in C++ ( MPU6050 )

Recently I've received a gyro/accelerometer sensor and I am wondering how can I use it with my Raspberry Pi but in C++. I want to measure the angle ( X, Y, Z axis ) and to be able to turn car 90 degrees left or right. Is there anyone who knows how can I interface this sensor with C++ on RPi? The sen...
by DavidAtanasoski
Sun Jan 06, 2019 5:16 pm
Forum: Troubleshooting
Topic: Booting problem ( red LED on, green off )
Replies: 7
Views: 314

Re: Booting problem ( red LED on, green off )

In my case none of the examples given in this topic didn't match my situation. I've started checking the voltage on the pin 1 of the GPIOs ( which is supposed to give 3.3V ) and there was no voltage. Then, I googled the mark of the voltage regulator ( which is MxL7704 ) and checked the pins for the ...
by DavidAtanasoski
Sat Jan 05, 2019 7:49 pm
Forum: Troubleshooting
Topic: Booting problem ( red LED on, green off )
Replies: 7
Views: 314

Re: Booting problem ( red LED on, green off )

If someone had this problem and didn't know what the problem is I will tell you. I figured out that the voltage regulator is dead and you have to replace it.

That's it from me. :roll:
by DavidAtanasoski
Fri Jan 04, 2019 2:02 pm
Forum: Troubleshooting
Topic: Booting problem ( red LED on, green off )
Replies: 7
Views: 314

Re: Booting problem ( red LED on, green off )

Probably the voltage regulator is dead.
by DavidAtanasoski
Fri Jan 04, 2019 8:34 am
Forum: Troubleshooting
Topic: Booting problem ( red LED on, green off )
Replies: 7
Views: 314

Re: Booting problem ( red LED on, green off )

I measured the voltage on the 3.3V GPIO pin and there isn't any voltage. Also, I've checked the voltage on the capacitor (marked below on the picture) and there isn't any voltage either.
Image
by DavidAtanasoski
Thu Jan 03, 2019 7:57 pm
Forum: Troubleshooting
Topic: Booting problem ( red LED on, green off )
Replies: 7
Views: 314

Booting problem ( red LED on, green off )

I haven't used my Pi for 2 weeks. Today I've connected on the power supply and unfortunately only the red LED light up ( the green LED was off no matter what I did ). I've formatted the SD card and installed a new OS, but nothings changed. Also, I've tried with another SD card, but still there wasn'...
by DavidAtanasoski
Sat Oct 13, 2018 6:40 pm
Forum: Troubleshooting
Topic: Problem with Blynk/Node.js/npm
Replies: 1
Views: 190

Re: Problem with Blynk/Node.js/npm

Does anybody know?
by DavidAtanasoski
Thu Oct 11, 2018 7:24 pm
Forum: Troubleshooting
Topic: Problem with Blynk/Node.js/npm
Replies: 1
Views: 190

Problem with Blynk/Node.js/npm

Hello everyone! Recently I've installed Blynk/Nodejs/npm on my Raspberry Pi 3 B+, according to this article: http://help.blynk.cc/how-to-connect-different-hardware-with-blynk/raspberry-pi/how-to-install-nodejs-library-on-linux The installation went okey, but unfortunately when I run the default Blyn...
by DavidAtanasoski
Thu Aug 30, 2018 10:01 am
Forum: Troubleshooting
Topic: Raspberry PI 3B overheating
Replies: 10
Views: 413

Re: Raspberry PI 3B overheating

Is there any way to solve this?
by DavidAtanasoski
Wed Aug 29, 2018 9:18 pm
Forum: Troubleshooting
Topic: Raspberry PI 3B overheating
Replies: 10
Views: 413

Re: Raspberry PI 3B overheating

In the last 2 or 3 months I'm working just with the software of the rpi, so I haven't connected any wires to the pins, but I have worked with them earlier.

@LTolledo I have installed heatsinks. Yes, I know that is toast, but I'm not able to buy a new one right now. So ..
by DavidAtanasoski
Wed Aug 29, 2018 8:32 pm
Forum: Troubleshooting
Topic: Raspberry PI 3B overheating
Replies: 10
Views: 413

Re: Raspberry PI 3B overheating

It's overheating while I'm not using it and there is nothing connected to the pins. I have tried to reinstall the OS several times, but I'm having the same problem over and over. It reaches 100 degrees in several minutes.
by DavidAtanasoski
Wed Aug 29, 2018 6:00 pm
Forum: Troubleshooting
Topic: Raspberry PI 3B overheating
Replies: 10
Views: 413

Raspberry PI 3B overheating

Recently I noticed that my Raspberry Pi is overheating. I don't know what the reason is. Even when I'm not using it, but it's on ( just on Desktop ) it reaches 100 Celsius degrees and shut down itself. I've checked it with the next command: /opt/vc/bin/vcgencmd measure_temp I haven't this problem ea...
by DavidAtanasoski
Tue Aug 14, 2018 6:19 pm
Forum: Wanted
Topic: Need Raspberry Pi
Replies: 4
Views: 5228

Re: Need Raspberry Pi

Are you still interested?
by DavidAtanasoski
Mon Aug 13, 2018 7:44 pm
Forum: Wanted
Topic: Need Raspberry Pi
Replies: 4
Views: 5228

Re: Need Raspberry Pi

I'm from Macedonia, that's Europe. Maybe I can pay the shipping if it's not expensive.
by DavidAtanasoski
Sun Aug 12, 2018 6:45 pm
Forum: Wanted
Topic: Need Raspberry Pi
Replies: 4
Views: 5228

Need Raspberry Pi

Dear anyone on this forum,
Does anyone have a Raspberry Pi for giving away? Because, I broke mine and I need one. If anyone wants to give away a Raspberry Pi, please contact me. Thanks.
by DavidAtanasoski
Sat Jul 21, 2018 4:06 pm
Forum: Troubleshooting
Topic: Problem with a library
Replies: 20
Views: 950

Re: Problem with a library

...
by DavidAtanasoski
Fri Jul 20, 2018 12:27 pm
Forum: Troubleshooting
Topic: Problem with a library
Replies: 20
Views: 950

Re: Problem with a library

There you have

Image
by DavidAtanasoski
Fri Jul 20, 2018 10:23 am
Forum: Troubleshooting
Topic: Problem with a library
Replies: 20
Views: 950

Re: Problem with a library

Compile it by hand. pi@raspberrypi:~$ g++ -o hello hello.cpp pi@raspberrypi:~$ ./hello Hello World pi@raspberrypi:~$ ldd ./hello linux-vdso.so.1 (0x7eb14000) /usr/lib/arm-linux-gnueabihf/libarmmem.so (0x76f45000) libstdc++.so.6 => /usr/lib/arm-linux-gnueabihf/libstdc++.so.6 (0x76e57000) libm.so.6 =...
by DavidAtanasoski
Thu Jul 19, 2018 12:21 pm
Forum: Troubleshooting
Topic: Problem with a library
Replies: 20
Views: 950

Re: Problem with a library

.
by DavidAtanasoski
Wed Jul 18, 2018 8:51 pm
Forum: Troubleshooting
Topic: Need help about PWM on RPi with WiringPi library
Replies: 3
Views: 204

Re: Need help about PWM on RPi with WiringPi library

How can I implement this? I need example, please.
by DavidAtanasoski
Wed Jul 18, 2018 6:13 pm
Forum: Troubleshooting
Topic: Problem with a library
Replies: 20
Views: 950

Re: Problem with a library

I've checked the versions of the Pi's Raspbian and I realized that they're different, as you can see on the images below:

This one is from academy:

Image

And this is mine:

Image
by DavidAtanasoski
Wed Jul 18, 2018 5:23 pm
Forum: Troubleshooting
Topic: Need help about PWM on RPi with WiringPi library
Replies: 3
Views: 204

Need help about PWM on RPi with WiringPi library

Dear all members of this forum, I need PWM control for DC motor. I'm using L293d motor driver. The code should be written in C++. I've made one in C++ for controlling DC motor, but now I got stuck to make it PWM. I need your help. I can't find anything on the internet. Here is the code in C++ for th...
by DavidAtanasoski
Wed Jul 18, 2018 11:50 am
Forum: Troubleshooting
Topic: Problem with a library
Replies: 20
Views: 950

Re: Problem with a library

I've just realized that the problem isn't my code. I've write this simple * Hello World * code and I get the same error. Even I reinstalled the Code Blocks and there were not improvements.

Image

Go to advanced search