Go to advanced search

by vybhav
Tue Aug 14, 2018 8:47 am
Forum: Troubleshooting
Topic: Data capture via GPIO
Replies: 7
Views: 410

Re: Data capture via GPIO

by vybhav
Tue Aug 14, 2018 8:18 am
Forum: Troubleshooting
Topic: Data capture via GPIO
Replies: 7
Views: 410

Re: Data capture via GPIO

I wish i could share the datasheet ,but due to confidentiality clause i am not allowed to share. Please let me know the specific details you are looking for ,i will try my best to share it.
by vybhav
Tue Aug 14, 2018 8:04 am
Forum: Troubleshooting
Topic: Data capture via GPIO
Replies: 7
Views: 410

Re: Data capture via GPIO

Hi Here are the details on the ADC i am using when interfaced with RPi The ADC works in two modes : Master and Slave mode to configure the ADC in the respective mode i am using SPI0 i.e register write/read using SPI0. If the ADC is configured in master mode it generated clock,chip_select and data. T...
by vybhav
Tue Aug 14, 2018 7:53 am
Forum: Troubleshooting
Topic: Data capture via GPIO
Replies: 7
Views: 410

Data capture via GPIO

Hi
I have been working on this project where i have interfaced the RPi-3 with the ADC and ADC is generating clock,chipselect and data .
how to capture this data at the falling of the clock via the GPIO?
by vybhav
Tue Aug 14, 2018 7:48 am
Forum: Beginners
Topic: Frame frequency in SPI
Replies: 0
Views: 89

Frame frequency in SPI

Hi
In the SPI protocol implementation we can set the SCLK frequency and its mode of operation can be set ,is it possible to set the frequency of the frame (chip select) ?
Help is appreciated

Thank you
Vybhav jayaraman
by vybhav
Thu Jun 21, 2018 7:39 am
Forum: Troubleshooting
Topic: [Solved] Stuck in loop asking for password before desktop. Check your .profile
Replies: 14
Views: 31087

Re: [Solved] Stuck in loop asking for password before desktop. Check your .profile

Hi
I am facing the same problem ,could anyone help me out please .

Thank You
Vybhav
by vybhav
Thu Mar 22, 2018 7:19 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: SPI1 works, but CS0 not
Replies: 6
Views: 1959

Re: SPI1 works, but CS0 not

Hi
I made the above changes (dtoverlay=spi1=1cs) in the config.txt.
In the program when i wrote spi.open(1,0) i am getting an error "[Errorno2] no such file or directory "
can anyone help me out in using spi1(python code)

Thank you

Go to advanced search