Go to advanced search

by hitcher404
Tue Nov 27, 2012 10:05 pm
Forum: Automation, sensing and robotics
Topic: Kinect - Would it ever work with a Raspberry Pi?
Replies: 117
Views: 74925

Re: Kinect - Would it ever work with a Raspberry Pi?

Hi, I also have this working on both Arch and Raspian. Can get registered qvga depth and rgb @ 3-4 fps. VGA depth only @ 30fps with minimal dropped frames. If you're happy with just depth data then this seems to work well. I used the cross-compiler toolkit to build openni for Arm using unstable bra...
by hitcher404
Sun Nov 04, 2012 9:00 pm
Forum: Automation, sensing and robotics
Topic: MEMS location tracking/recording integration with GPS
Replies: 4
Views: 2161

Re: MEMS location tracking/recording integration with GPS

Not something easy to do with gyroscopes and accelerometers. To go from acceleration to displacement you have to integrate twice, which means errors/noise get amplified, even a small zero offset causes large erroneous measured distance. Sebastian Madgwick (guy who wrote THE sensor fusion algorithm) ...
by hitcher404
Wed Aug 22, 2012 1:56 am
Forum: Automation, sensing and robotics
Topic: Kinect - Would it ever work with a Raspberry Pi?
Replies: 117
Views: 74925

Re: Kinect - Would it ever work with a Raspberry Pi?

I had the same thought when I first saw the error, but both are definitely installed. Ah, good! :D Shot in the dark as I thought it was only required for kinect, but you could try running niLicense. Have seen the 'nodes could not be enumerated' error before when I had not added the primesense licen...
by hitcher404
Tue Aug 21, 2012 5:31 pm
Forum: Automation, sensing and robotics
Topic: Kinect - Would it ever work with a Raspberry Pi?
Replies: 117
Views: 74925

Re: Kinect - Would it ever work with a Raspberry Pi?

Thanks for the suggestion, Dom, but the result is the same. usb-devices looks like this: T: Bus=01 Lev=03 Prnt=04 Port=00 Cnt=01 Dev#= 5 Spd=480 MxCh= 0 D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1 P: Vendor=1d27 ProdID=0600 Rev=00.01 S: Manufacturer=PrimeSense S: Product=PrimeSense D...
by hitcher404
Thu Aug 16, 2012 9:13 pm
Forum: Automation, sensing and robotics
Topic: ROS (Robot Operating System) on RPi
Replies: 124
Views: 43453

Re: ROS on RPi

Started down that road. Warning frame rate on the kinect is crazy slow. I am using a 530 converted over to a turtlebot platform. It the 3rd one in my house so it is a way back burner project. Sorry for OT, but are you saying you have the kinect working on rpi? Care to share what voodoo you used ove...
by hitcher404
Fri Jul 20, 2012 12:13 am
Forum: Automation, sensing and robotics
Topic: Kinect - Would it ever work with a Raspberry Pi?
Replies: 117
Views: 74925

Re: Kinect - Would it ever work with a Raspberry Pi?

Maybe if I explain my reasoning. The PrimeSense Sensor driver defaults to using bulk endpoint transfers when compiled on arm, from GlobalDefaults.ini: ; USB interface to be used. 0 - FW Default, 1 - ISO endpoints, 2 - BULK endpoints. Default: Arm - 2, other platforms - 1 ;UsbInterface=2 The output o...
by hitcher404
Thu Jul 19, 2012 5:30 pm
Forum: Automation, sensing and robotics
Topic: Kinect - Would it ever work with a Raspberry Pi?
Replies: 117
Views: 74925

Re: Kinect - Would it ever work with a Raspberry Pi?

Could either of you with Xtions post the output of lsusb -vv?

Many thanks.
by hitcher404
Sun Jul 15, 2012 11:24 pm
Forum: Troubleshooting
Topic: Firmware not working since Jul 1 commit
Replies: 10
Views: 1706

Re: Firmware not working since Jul 1 commit

try boot_delay=2 Are you overclocking? Ah! Should have tried that after 1, seems to have fixed the issue. Many thanks to you both! :D Now I see the color tile and the system starts, but my HDMI output is fuzzy, the brightness changes all the time and the screen goes blank from time to time. I'm usi...
by hitcher404
Sun Jul 15, 2012 8:33 pm
Forum: Troubleshooting
Topic: Firmware not working since Jul 1 commit
Replies: 10
Views: 1706

Re: Firmware not working since Jul 1 commit

Thanks for the response! Changing just start.elf doesn't cause a problem, i.e. it still reboots fine with old firmware with latest start.elf copied in. Once it has been rebooted/power cycled once it will not boot again, even after power cycling. Though it seems if I write data to the card from anoth...
by hitcher404
Sun Jul 15, 2012 1:16 am
Forum: Automation, sensing and robotics
Topic: Kinect - Would it ever work with a Raspberry Pi?
Replies: 117
Views: 74925

Re: Kinect - Would it ever work with a Raspberry Pi?

Have experienced similar.... libfreenect can control leds and motor, but seems the callbacks in examples never get run, just end up with empty arrays where there should be depth/rgb data. Compiled OpenNI and SensorKinect on Raspbian, but again no progress, running SampleNiSimpleRead just gives: Upda...
by hitcher404
Sun Jul 15, 2012 12:07 am
Forum: Troubleshooting
Topic: Firmware not working since Jul 1 commit
Replies: 10
Views: 1706

Firmware not working since Jul 1 commit

A few days ago I updated the kernel/firmware on one of my raspbian installs using hexxeh's script, all seemed well after a reboot, but after the next it hung at the colour tile. I thought it must have been a corrupted download or similar, so just copied over known working binaries/kernel/modules fro...

Go to advanced search