Go to advanced search

by bnmc_
Wed Feb 21, 2018 7:18 am
Forum: Beginners
Topic: 10K Trimpot with Raspberry Pi
Replies: 4
Views: 597

Re: 10K Trimpot with Raspberry Pi

There is a method which uses a capacitor to measure resistance by charging up the capacitor until the level reads high and then letting it discharge through the resistance until it reads low and using the time taken to work out the resistance value. Could you please share that method with me? I hav...
by bnmc_
Wed Feb 21, 2018 6:35 am
Forum: Beginners
Topic: 10K Trimpot with Raspberry Pi
Replies: 4
Views: 597

10K Trimpot with Raspberry Pi

Hello everyone,

I would like to know if it is possible to wire up a 10K trimpot to the Raspberry Pi and use it to control the brightness/dimness of an LED. I have a Pi 3. My research, however, shows that the Raspberry Pi does not support PWM.
by bnmc_
Tue Jan 16, 2018 1:34 pm
Forum: Python
Topic: Cannot install Cython
Replies: 2
Views: 1314

Cannot install Cython

Hey guys,

I have tried to install Cython using pip only to get the message:

Code: Select all

Unable to find pgen, not compiling formal grammar.
Then the terminal freezes. What is causing this problem? I am using Raspbian Jessie.
by bnmc_
Wed Jan 03, 2018 7:07 pm
Forum: Troubleshooting
Topic: Issue when setting up RaspAP
Replies: 9
Views: 4595

Re: Issue when setting up RaspAP

SurferTim wrote:
Wed Jan 03, 2018 6:59 pm
In Stretch you don't use /etc/network/interfaces to assign network settings. That is done in /etc/dhcpcd.conf.
How is this done?
by bnmc_
Wed Jan 03, 2018 5:02 pm
Forum: Troubleshooting
Topic: Issue when setting up RaspAP
Replies: 9
Views: 4595

Re: Issue when setting up RaspAP

It is probable that you have a service fail somewhere. I will presume that the app uses dnsmasq for dhcp. Try these: sudo service dhcpcd status sudo service dnsmasq status ifconfig The two services should show active (running) . Post the output of those if you have questions. The output of the firs...
by bnmc_
Wed Jan 03, 2018 2:36 pm
Forum: Troubleshooting
Topic: Issue when setting up RaspAP
Replies: 9
Views: 4595

Re: Issue when setting up RaspAP

If it helps, my wifi adapter is a Ralink RT5370.
by bnmc_
Wed Jan 03, 2018 1:40 pm
Forum: Troubleshooting
Topic: Issue when setting up RaspAP
Replies: 9
Views: 4595

Issue when setting up RaspAP

Hey everyone, I have just downloaded RaspAP onto my Pi 2 Model B. Upon rebooting, I am now able to see the "raspi-webgui" network on my mobile phone. However, when I enter the default password ChangeMe, it does not seem to connect. Also, when I hover over the Wi-Fi button on the top right corner of ...
by bnmc_
Sat Dec 30, 2017 4:48 pm
Forum: Troubleshooting
Topic: Cannot install Python packages using pip
Replies: 10
Views: 4793

Re: Cannot install Python packages using pip

I would like to thank you all for your support. Everything is working perfectly now. I was able to successfully install both packages, and as a silver lining, my Pi now runs more smoothly with the new Raspbian.
by bnmc_
Sat Dec 30, 2017 7:57 am
Forum: Troubleshooting
Topic: Cannot install Python packages using pip
Replies: 10
Views: 4793

Re: Cannot install Python packages using pip

I have finished reinstalling Raspbian, although when I booted my Pi, it remains at a command line environment. How do I switch to the desktop?
by bnmc_
Fri Dec 29, 2017 11:56 am
Forum: Troubleshooting
Topic: Cannot install Python packages using pip
Replies: 10
Views: 4793

Re: Cannot install Python packages using pip

mattmiller wrote:
Fri Dec 29, 2017 11:39 am
maybe your SD had NOOBS pre-installed on it?
That is most likely the case because the SD card came with the kit. However, I will try re-installing anyway.
by bnmc_
Fri Dec 29, 2017 11:26 am
Forum: Troubleshooting
Topic: Cannot install Python packages using pip
Replies: 10
Views: 4793

Re: Cannot install Python packages using pip

mattmiller wrote:
Fri Dec 29, 2017 11:16 am
re-install Stretch from a new image and start again
And how do I do that? I am using a Pi 2 Model B.
by bnmc_
Fri Dec 29, 2017 9:47 am
Forum: Troubleshooting
Topic: Cannot install Python packages using pip
Replies: 10
Views: 4793

Cannot install Python packages using pip

Hey everyone, I am having a recurring problem on my Raspberry Pi 2 Model B. Every time I install a package using pip, I am given the error "No distributions found at all for package-name." In particular, I am trying to install piui and plotly. What I have tried (all to no avail): Reconnecting to the...
by bnmc_
Wed Dec 27, 2017 4:09 pm
Forum: General discussion
Topic: How to make a mobile UI with Raspberry Pi?
Replies: 1
Views: 456

How to make a mobile UI with Raspberry Pi?

Hello everyone, I am not sure where this thread should go, so I will post it in the general discussion. I am interested in developing a mobile UI for a Raspberry Pi project. I found something called PiUi, but it does not seem to work and apparently development on it has been suspended. Are there any...
by bnmc_
Sun Dec 24, 2017 5:57 am
Forum: Troubleshooting
Topic: Problem with DS18B20
Replies: 4
Views: 494

Re: Problem with DS18B20

Alright, here is a photo of my breadboard:
Image
The orange wire is connected to GPIO pin 4. The resistor is 4.7K Ohms.
by bnmc_
Sat Dec 23, 2017 3:40 pm
Forum: Troubleshooting
Topic: Problem with DS18B20
Replies: 4
Views: 494

Problem with DS18B20

I have recently purchased a DS18B20 temperature sensor for my Pi 2. It is the long version of the sensor (not sure of the technical name). I have followed all of the configuration steps, however every time I run ls –l /sys/bus/w1/devices/ , the device ID is given as a long string of zeroes. Is there...

Go to advanced search