Go to advanced search

by monkijohnni
Fri Dec 01, 2017 4:10 pm
Forum: Troubleshooting
Topic: STICKY:I2C, SPI, I2S, LIRC, PPS, stopped working? Read this.
Replies: 335
Views: 367009

Re: STICKY:I2C, SPI, I2S, LIRC, PPS, stopped working? Read this.

My last post was incorrect. Setting the bus speed DID fix the SPI problem, I just was getting incorrect results because of a wiring error (was working remotely). Seems that any bus speed under 10,000,000 works well. Thank you so much for your help, PhilE! I really appreciate it. -John #!/usr/bin/pyt...
by monkijohnni
Thu Nov 30, 2017 11:36 pm
Forum: Troubleshooting
Topic: STICKY:I2C, SPI, I2S, LIRC, PPS, stopped working? Read this.
Replies: 335
Views: 367009

Re: STICKY:I2C, SPI, I2S, LIRC, PPS, stopped working? Read this.

EDITED: lowering bus speed fixed it. Increasing the bus speed seem to fix it. I included the spi.max_speed_hz=1000000 in my code, and got feedback from SPI. #!/usr/bin/python3 import spidev import time import os spi = spidev.SpiDev() spi.open(0,0) spi.max_speed_hz=1000000 .... Seems that going over ...
by monkijohnni
Thu Nov 30, 2017 8:06 pm
Forum: Troubleshooting
Topic: STICKY:I2C, SPI, I2S, LIRC, PPS, stopped working? Read this.
Replies: 335
Views: 367009

Re: STICKY:I2C, SPI, I2S, LIRC, PPS, stopped working? Read this.

Thank you for the fast reply! 1. I'm just using an MCP3008 AD chip, so nothing too complicated. A PT100 thermistor is talking to it on CH0. 2. Here is my code: #!/usr/bin/python3 import spidev import time import os spi = spidev.SpiDev() spi.open(0,0) # Function to read SPI data from MCP3008 chip # C...
by monkijohnni
Thu Nov 30, 2017 5:10 pm
Forum: Troubleshooting
Topic: STICKY:I2C, SPI, I2S, LIRC, PPS, stopped working? Read this.
Replies: 335
Views: 367009

Re: STICKY:I2C, SPI, I2S, LIRC, PPS, stopped working? Read this.

I'm having trouble with SPI failing to work after upgrading my Pi Zero W. I am running Stretch and SPI stops working after I run apt-get upgrade and reboot. SPI function works fine before upgrading, works fine after updating, but after upgrading, fails to read the voltage on my AD chip. SPI and VNC ...
by monkijohnni
Tue Nov 28, 2017 7:22 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: spi test doesn't work anymore
Replies: 1
Views: 509

Re: spi test doesn't work anymore

Yeah, I am having the same problem. I was able to identify that SPI was broken after running

Code: Select all

  apt-get dist-upgrade 
and restarting.

Also, I am only seeing this problem on the RPi zero W, not on the RPi 3.

Any thoughts?

Go to advanced search