Go to advanced search

by riph72-lumi
Thu May 16, 2019 2:19 pm
Forum: Troubleshooting
Topic: Splash screen with u-boot
Replies: 0
Views: 76

Splash screen with u-boot

Hi all, I've compiled u-boot and am booting it on a pi3. I am now trying to display a 24-bit splash screen but nothing is happening - I type: bmp display ${loadaddr} ...and nothing happens. No errors, nothing. Anyone have any ideas? I'm using u-boot directly via keyboard/monitor, rather than over a ...
by riph72-lumi
Fri May 10, 2019 3:42 pm
Forum: Troubleshooting
Topic: SD-card data loss - "0-byte" files
Replies: 2
Views: 92

Re: SD-card data loss - "0-byte" files

I'll take a look at that, thanks for the suggestion. I do recall seeing that option a while back but hoped "data=journal" would suffice. It is worth mentioning that the problem isn't the loss of the data being written (I can cope with loading an older version of the file) - the problem is the loss o...
by riph72-lumi
Fri May 10, 2019 3:02 pm
Forum: Troubleshooting
Topic: SD-card data loss - "0-byte" files
Replies: 2
Views: 92

SD-card data loss - "0-byte" files

Hello all, This certainly won't surprise anyone, but I'm seeing issues with sudden power loss and files on an SD-card being "0-byte"'d (if they were in the process of being updated around the time of power loss). I did a fair bit of reading up on this and it sounded like a common issue with ext4 goi...
by riph72-lumi
Wed Feb 20, 2019 4:35 pm
Forum: Troubleshooting
Topic: Setting up IPv6
Replies: 3
Views: 1570

Re: Setting up IPv6

Do you mean ipv6.conf?

Mine just has the line:

alias net-pf-10 off

So do you think this needs to be #'d out?

I seem unable to load (local) webpages using IPv6 format, so hoping this might be a solution...
by riph72-lumi
Tue Jan 29, 2019 8:19 am
Forum: Raspbian
Topic: Getting source code to rebuild a specific kernel version
Replies: 8
Views: 442

Re: Getting source code to rebuild a specific kernel version

Ah, that is a very good point :)

Ok, will bear that in mind then, certainly explains why I've had trouble tracking down the specific code - it isn't labelled because it wasn't a release as such...

Thanks!
by riph72-lumi
Mon Jan 28, 2019 3:37 pm
Forum: Raspbian
Topic: Getting source code to rebuild a specific kernel version
Replies: 8
Views: 442

Re: Getting source code to rebuild a specific kernel version

There are plenty of commits between such makefile changes though, still makes it hard to know *exactly* which commit was used? Granted though, it will probably do the job?!
by riph72-lumi
Mon Jan 28, 2019 3:03 pm
Forum: Raspbian
Topic: Getting source code to rebuild a specific kernel version
Replies: 8
Views: 442

Re: Getting source code to rebuild a specific kernel version

I'm not sure - how I can tell which of those, if any, relates to released kernel 4.14.52 ?
by riph72-lumi
Mon Jan 28, 2019 1:43 pm
Forum: Raspbian
Topic: Getting source code to rebuild a specific kernel version
Replies: 8
Views: 442

Re: Getting source code to rebuild a specific kernel version

I don't seem to have a /boot/.firmware_version ?

uname -a shows I am using 4.14.52-v7+ #1123... which is the kernel version I am trying to build.

vcgencmd version gives me a commit number, but I can't see it (visually) at that link you gave?
by riph72-lumi
Fri Jan 25, 2019 3:10 pm
Forum: Raspbian
Topic: Getting source code to rebuild a specific kernel version
Replies: 8
Views: 442

Getting source code to rebuild a specific kernel version

Hello all,

I want to rebuild (with modification) a specific released version of the Pi kernel. I have looked at the git repo, I cannot seem to find the specific commit that was used to build the kernel I have. Is there a way to determine this? The tags don't seem to be specific!

Thanks,
Richard.
by riph72-lumi
Mon Dec 17, 2018 1:46 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: Cannot install geany
Replies: 1
Views: 608

Cannot install geany

I had this installed but there was an issue during a recent package upgrade, so it was removed - I didn't have time to investigate at the time. Now I am trying to install it, but am seeing this: Some packages could not be installed. This may mean that you have requested an impossible situation or if...
by riph72-lumi
Tue Oct 30, 2018 3:05 pm
Forum: Raspbian
Topic: Silent boot with Stretch Lite
Replies: 0
Views: 644

Silent boot with Stretch Lite

Hello all, I've done a lot of Googling and have tried various things, but still cannot get Stretch Lite to boot silently, i.e. no boot text. I've tried "quiet", "loglevel=0/3", "tty3" instead of "tty1" in /boot/cmdline.txt - some made an impact, but never solved the problem entirely. I've tried chan...
by riph72-lumi
Tue Oct 16, 2018 8:07 am
Forum: Raspberry Pi Desktop for PC and Mac
Topic: Raspian alternative to run on Windows laptop
Replies: 14
Views: 3350

Re: Raspian alternative to run on Windows laptop

Absolutely to all that. I think the key point (that I wanted to make) is that Raspberry Pi Desktop & Raspbian are actually essentially the same OS, from a user's point-of-view anyway. I've been using Raspbian daily for over a year on Pi's, and have just started using Raspberry Pi Desktop on my lapto...
by riph72-lumi
Mon Oct 15, 2018 3:42 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: Raspian alternative to run on Windows laptop
Replies: 14
Views: 3350

Re: Raspian alternative to run on Windows laptop

Oh oh, well since I didn't read it properly and it looks like Raspbian i didn't even notice. It's confusing, because it even calls itself Raspbian when using it, but the underlying OS is Debian GNU/Linux with just the desktop GUI that is used in Raspbian. Raspbian OS is highly customized to run on ...
by riph72-lumi
Mon Oct 15, 2018 3:24 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: Encrypted installation
Replies: 3
Views: 1647

Re: Encrypted installation

If I boot without splash screen (raspi-config), then it is clear that something needs to be entered.
by riph72-lumi
Mon Oct 15, 2018 3:23 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: Encrypted installation
Replies: 3
Views: 1647

Re: Encrypted installation

Splash screen without any text.

Ironically, now I know what the situation is, it is actually pretty good security - pretend to be broken on boot :lol:
by riph72-lumi
Sat Oct 13, 2018 4:49 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: 'Sudo' apps require 'root' password
Replies: 7
Views: 1647

Re: 'Sudo' apps require 'root' password

Thanks klricks, I've sorted it now, but if I hadn't then your post would have set me on the path I eventually followed... "pkexec" was the key. I could see from the journal that it and "polkitd" were involved in the authentication process, so a bit of digging took me to /etc/polkit-1/localauthority....
by riph72-lumi
Sat Oct 13, 2018 4:03 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: 'Sudo' apps require 'root' password
Replies: 7
Views: 1647

Re: 'Sudo' apps require 'root' password

Ah, ok, thanks. Crap indeed, I think the easiest way out is to just reinstall again but not remove the pi user completely this time! Or maybe even just *use* the pi user... very crap!
by riph72-lumi
Sat Oct 13, 2018 3:33 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: 'Sudo' apps require 'root' password
Replies: 7
Views: 1647

Re: 'Sudo' apps require 'root' password

Just to emphasise - I've completely removed the 'pi' user. I've set up non-GUI systems without a 'pi'user with no issues, this does seem to be a specific issue with certain apps, and only when launched via a GUI...
by riph72-lumi
Sat Oct 13, 2018 3:13 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: 'Sudo' apps require 'root' password
Replies: 7
Views: 1647

Re: 'Sudo' apps require 'root' password

I've tried root without password, it doesn't work. I've also tried "raspberry", it also doesn't work. I've even tried the password for my new user in desperation, didn't work either! How can I tell these apps to authenticate using my new user? (When you say root is enabled but has no password, does ...
by riph72-lumi
Sat Oct 13, 2018 2:51 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: Encrypted installation
Replies: 3
Views: 1647

Encrypted installation

Hello all, This is not an actual problem for me (now) but I've noticed that if you install with an encrypted drive, upon power-up you reach the "Welcome to Raspbian" screen and then everything stops - it looks like it has hung, but it is waiting for the decrypt password! Thought it would be worth fl...
by riph72-lumi
Sat Oct 13, 2018 2:48 pm
Forum: Raspberry Pi Desktop for PC and Mac
Topic: 'Sudo' apps require 'root' password
Replies: 7
Views: 1647

'Sudo' apps require 'root' password

Hello all, I've installed the desktop OS, then replaced the pi user with my own (I have sudo permissions on the new account). When I try to run a program such as synaptic, which requires root permissions, I am asked to enter the root password (i.e. the root user is listed and the password is require...
by riph72-lumi
Fri Jul 13, 2018 3:39 pm
Forum: Compute Module
Topic: [SOLVED] PWM0 on GPIO40 - can't export due to permissions?
Replies: 2
Views: 627

Re: PWM0 on GPIO40 - can't export due to permissions?

Option 1 sorted it - thanks!!
by riph72-lumi
Fri Jul 13, 2018 2:59 pm
Forum: Compute Module
Topic: [SOLVED] PWM0 on GPIO40 - can't export due to permissions?
Replies: 2
Views: 627

[SOLVED] PWM0 on GPIO40 - can't export due to permissions?

Hello all, I'm trying to use PWM0 on GPIO40 (on CM3) - I am using the following overlay: dtoverlay=pwm,pin=40,func=4 This does appear to work, since "raspi-gpio get" shows: GPIO 40: level=0 fsel=4 alt=0 func=PWM0 So far, so good. But, in /sys/class/pwm/pwmchip0, I seem unable to "export", I note tha...
by riph72-lumi
Fri May 25, 2018 8:09 am
Forum: General discussion
Topic: Wi-Fi adapter for Access Point
Replies: 0
Views: 210

Wi-Fi adapter for Access Point

Can anyone recommend a Wi-Fi adapter that can be used as an Access Point? I've got this working successfully on a Pi3 with its built-in Wi-Fi hardware, but now I am trying to use the same configuration (i.e. SD-card) in a CM3 with a USB Wi-Fi adapter (lsusb shows "Ralink Technology, Corp. RT5370 Wir...
by riph72-lumi
Thu May 17, 2018 9:04 am
Forum: Troubleshooting
Topic: DPI video signals
Replies: 1
Views: 165

DPI video signals

Hello all, I'm trying to get a 320 * 240 LCD display working via the DPI interface, and have stumbled across a strange problem - if I use the following for testing the Pi3 video signal output: #1920x1080 60Hz dpi_group=2 dpi_mode=82 ...I see signals on PCLK, HSYNC, VSYNC. But if I use this: #640x480...

Go to advanced search