Go to advanced search

by michthom
Wed Feb 28, 2018 7:51 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: STICKY: Device Tree Q&A
Replies: 23
Views: 21658

Re: STICKY: Device Tree Q&A

Thanks - as with most technical things these days it's the helpful community putting the right info under inquisitive or just plain stubborn noses to make progress happen. By all means reuse the info above and I'll try to report back on the project later if any significant differences develop.
by michthom
Wed Feb 28, 2018 6:44 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: STICKY: Device Tree Q&A
Replies: 23
Views: 21658

Re: STICKY: Device Tree Q&A

By George, I think he's got it! With approximately 21dB of gain on the MEMS microphone I'm getting some hiss but not horrendous clipping. Driving it to the maximum (max_dB can be set to arbitrary numbers but 30dB seems to be an enforced limit) results in audio breaking up - possibly due to DC offset...
by michthom
Tue Feb 27, 2018 9:32 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: STICKY: Device Tree Q&A
Replies: 23
Views: 21658

Re: STICKY: Device Tree Q&A

PhilE, your suggested .asoundrc isn't immediately producing a Boost control, so I'll read the links in more depth and see if I can come up with a variation that does. Thanks for the super-swift replies though! I did get help from the Alsa docs you referenced - at least the dnsoop page ( https://alsa...
by michthom
Tue Feb 27, 2018 8:40 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: STICKY: The I2S sound thread.
Replies: 925
Views: 453912

Re: STICKY: The I2S sound thread.

I've just posted on the end of the Device Tree Q&A thread https://www.raspberrypi.org/forums/viewtopic.php?f=44&t=99784&p=1278971#p1278971 as that threw down the gauntlet for a combined I2S capture and playback overlay. It may get moved to its own thread but I'm crossposting here (naughty?) to see i...
by michthom
Tue Feb 27, 2018 8:29 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: STICKY: Device Tree Q&A
Replies: 23
Views: 21658

Re: STICKY: Device Tree Q&A

This may be better moved to its own topic / thread, but it's in reply to those above, so I thought I'd gamble. I took PhilE's comment on getting both an I2S microphone and amplifier working together as a challenge: "Combining the two [overlays] is an exercise for the reader." I was unhappy with the ...
by michthom
Thu Dec 13, 2012 5:17 pm
Forum: RISCOS
Topic: The Disc Drive is Empty
Replies: 13
Views: 4048

Re: The Disc Drive is Empty

Well, I have my new version RasPi, and can confirm that the exact same power supply, USB hub, mouse keyboard and importantly RiscOS SD card, booted perfectly just now. So there's another data point that early versions of the RasPi have some compatibility issues when faced with RiscOS! Now to get Eli...
by michthom
Wed Nov 28, 2012 7:38 pm
Forum: RISCOS
Topic: The Disc Drive is Empty
Replies: 13
Views: 4048

Re: The Disc Drive is Empty

Thanks Nigel. I tried the Pi powered from a 10W iPad USB adapter (2A max current) and the rest of the peripherals hanging off a powered Logic USB adapter, also 2A rated but with no more joy.
by michthom
Tue Nov 27, 2012 7:51 pm
Forum: RISCOS
Topic: The Disc Drive is Empty
Replies: 13
Views: 4048

Re: The Disc Drive is Empty

And now I've tried with a new SD card preinstalled from RiscOS Open Ltd - same problem.
Looks like my particular Raspberry Pi board is not going to play nice with RiscOS. Boo!
Any ideas or do I just have to man up and buy a Model B 512M and hope that the latest boards have the bugs all squished...
by michthom
Sat Nov 24, 2012 9:44 pm
Forum: RISCOS
Topic: The Disc Drive is Empty
Replies: 13
Views: 4048

Re: The Disc Drive is Empty

I can confirm that in my case, reformatting the SD Card with the tool mentioned above made no difference.
by michthom
Sat Nov 24, 2012 6:10 pm
Forum: RISCOS
Topic: The Disc Drive is Empty
Replies: 13
Views: 4048

Re: The Disc Drive is Empty

Fab information, thanks. I've also found a number of related threads, collected here to help others on this quest: http://www.raspberrypi.org/phpBB3/viewtopic.php?p=214506#p214506 http://www.raspberrypi.org/phpBB3/viewtopic.php?f=55&t=22173 http://www.raspberrypi.org/phpBB3/viewtopic.php?f=28&t=2250...
by michthom
Sat Nov 24, 2012 5:06 pm
Forum: RISCOS
Topic: The Disc Drive is Empty
Replies: 13
Views: 4048

Re: The Disc Drive is Empty

I'm having very similar problems, and have tried several SD cards, including one brand new from the PiHut that I'm using for BerryBooting multiple OSs with no issues. Every time I only get as far into RiscOS as the OP. I've ordered a RiscOS Open SD card but if that fails too, I'll have to conclude I...
by michthom
Sun Jul 01, 2012 10:55 am
Forum: Troubleshooting
Topic: Logik LP4HUB10 power problem fixed
Replies: 29
Views: 12361

Re: Logik LP4HUB10 power problem fixed

I've done a mildly improved version of this fix; I added a diode in series with the +5V line, to block current flow up to the host but still allowing the LP4HUB10 to be used as an unpowered hub in other circumstances. The 0.5V forward drop might be an issue in some cases, but I'll take that chance!

Go to advanced search