Go to advanced search

by komarek
Wed Aug 15, 2018 11:32 pm
Forum: Troubleshooting
Topic: Raspi stuck after some python script in background
Replies: 7
Views: 509

Re: Raspi stuck after some python script in background

it might not be a memory problem i made a script to monitor the free memory and i saw that when the raspi disconnected from my terminal and became unresponsive there was 320mb still free of memory. at that time 4 python script were running what do you suggest me to do? where should i find something ...
by komarek
Sun Aug 12, 2018 12:54 pm
Forum: Troubleshooting
Topic: Raspi stuck after some python script in background
Replies: 7
Views: 509

Re: Raspi stuck after some python script in background

DirkS wrote:
Sun Aug 12, 2018 12:46 pm
komarek wrote:
Sun Aug 12, 2018 12:35 pm
do you mean i should make a script that logs out the memory level every xx minutes?
Whatever works best for you...
Although I do think you should also keep an eye on the per-process memory use
can you please suggest me which command i should use for that?
by komarek
Sun Aug 12, 2018 12:35 pm
Forum: Troubleshooting
Topic: Raspi stuck after some python script in background
Replies: 7
Views: 509

Re: Raspi stuck after some python script in background

I think it's a memory issue but i'm not sure... what u think it will be the solution and where do you think i should watch to find some useful log about it? Well if you think it's a memory problem then you should probably start to monitor that regularly... Most likely solution is to correct your pr...
by komarek
Sun Aug 12, 2018 9:28 am
Forum: Troubleshooting
Topic: Raspi stuck after some python script in background
Replies: 7
Views: 509

Raspi stuck after some python script in background

hello i am using a raspi 3b+ to run a few script in python (5 or 6) These scripts are running some bot about twitter (with tweepy).. i take control of it through the vnc to launch scripts - every script in a single terminal window cause i need to debug the output) it happens always after 3 or 4 days...
by komarek
Mon Feb 12, 2018 3:37 pm
Forum: Python
Topic: python and relay module
Replies: 9
Views: 5750

Re: python and relay module

if i disconnect the wire from gpio15 the relay turn off... if i connect it to GND the relay turn ON when conected to gpio15 the realy always stay ON (despite the state of the gpio 15 LOW or HIGH) No quite the tests I asked for, I wanted to prove 5v turned it off, also asked for link to board you ha...
by komarek
Mon Feb 12, 2018 3:29 pm
Forum: Python
Topic: python and relay module
Replies: 9
Views: 5750

Re: python and relay module

you know what.... i connected the gpio15 at the Gate of a IRFZ44N then the Source of the IRFZ44N at GNF of raspi... and Drain of IRFZ44N at the "IN" of the relay module and now it's working perfectly can you please explain me why i have to use a mosfet to make it work... and it's not working directl...
by komarek
Mon Feb 12, 2018 3:15 pm
Forum: Python
Topic: python and relay module
Replies: 9
Views: 5750

Re: python and relay module

Paul Hutch wrote:
Mon Feb 12, 2018 3:09 pm
Since you're using BCM mode make sure you are connecting to the correct physical pin, GPIO 15 is on pin #10 (pin #15 is GPIO 22)
yes i m sure :)
by komarek
Mon Feb 12, 2018 3:14 pm
Forum: Python
Topic: python and relay module
Replies: 9
Views: 5750

Re: python and relay module

First thing to do is post a link to the board you have . second what happens is you disconnect the wire from gpio 15 but leaving it connected to relay IN then connect it to 5v pin on pi result = ? then connect it to Gnd pin on pi result = ? if i disconnect the wire from gpio15 the relay turn off......
by komarek
Mon Feb 12, 2018 2:09 pm
Forum: Python
Topic: python and relay module
Replies: 9
Views: 5750

python and relay module

hello i have a simple and inexpensive relay module connected to my raspberry pi zero w the module has 3 pin and i connect them like this: GND -> raspi gnd VCC -> raspi 5v IN -> raspi gpio 15 i am running a simple python code like this: import RPi.GPIO as GPIO import time GPIO.setmode(GPIO.BCM) GPIO....
by komarek
Sat Jan 13, 2018 2:51 am
Forum: General discussion
Topic: APT great pain
Replies: 4
Views: 1030

Re: APT great pain SOLVED

i had a wrong repo of debian
and i installed a wrong version of Mosquitto

so had to reinstall it again.

now my problem is:
i deleted apt-listchanges

cause it was bad configured
shall i reinstall it again?
by komarek
Fri Jan 12, 2018 9:53 pm
Forum: General discussion
Topic: APT great pain
Replies: 4
Views: 1030

Re: APT great pain

i fixed it removing apt-listchanges
but now i install mosquitto and doesnt start
by komarek
Fri Jan 12, 2018 8:22 pm
Forum: General discussion
Topic: APT great pain
Replies: 4
Views: 1030

APT great pain

i was installing mosquitto i made some mess and now anything i try to install (apt-get install) i get this: Illegal instruction E: subprocess /usr/bin/apt-listchanges --apt || test $? -lt 10 returned error code (1) E: Failure running script /usr/bin/apt-listchanges --apt || test $? -lt 10 please hel...
by komarek
Thu Nov 16, 2017 7:26 pm
Forum: General discussion
Topic: unknown problem with node-red (SOLVED)
Replies: 3
Views: 6489

found the FIX (SOLVED)

Changed the line

Environment="NODE_OPTIONS=--max-old-space-size=128"

to

Environment="NODE_OPTIONS=--max_old_space_size=128"
now working good
by komarek
Thu Nov 16, 2017 4:25 pm
Forum: General discussion
Topic: unknown problem with node-red (SOLVED)
Replies: 3
Views: 6489

Re: unknown problem with node-red

btw if i make: node-red-start i have this: Once Node-RED has started, point a browser at http://192.168.1.3:1880 On Pi Node-RED works better with the Firefox or Chrome browser Use node-red-stop to stop Node-RED Use node-red-start to start Node-RED again Use node-red-log to view the recent log output...
by komarek
Thu Nov 16, 2017 3:56 pm
Forum: General discussion
Topic: unknown problem with node-red (SOLVED)
Replies: 3
Views: 6489

unknown problem with node-red (SOLVED)

hi guys i have a terrible problem i wonder if you can help i am running node-red which is handled by this service: # systemd service file to start Node-RED [Unit] Description=Node-RED graphical event wiring tool. Wants=network.target Documentation=http://nodered.org/docs/hardware/raspberrypi.html [S...
by komarek
Tue Oct 31, 2017 7:09 pm
Forum: Troubleshooting
Topic: jessie and Networking problem
Replies: 3
Views: 360

Re: jessie and Networking problem

epoch1970 wrote:
Tue Oct 31, 2017 6:27 pm


This being said, if the Pi behind the range extender only has an auto-ip address, it means something goes wrong when communicating with the DHCP server.
I would avoid using a wifi range extender, and prefer using powerline communication or multiple APs.
thanks
by komarek
Tue Oct 31, 2017 6:02 pm
Forum: Troubleshooting
Topic: jessie and Networking problem
Replies: 3
Views: 360

Re: jessie and Networking problem

it could be my TP-Link range extender that creates a double set of ip...
how can i fix this?
by komarek
Tue Oct 31, 2017 5:52 pm
Forum: Troubleshooting
Topic: jessie and Networking problem
Replies: 3
Views: 360

jessie and Networking problem

Hi i have a Raspi Zero W connected to a WIFI... when the line is strong no problem.. it takes the ip 192.168.1.29 from the router but when the line is not that good from the GUI i see on the symbol of the WIFI it's having a double ip: 192.168.1.29/24 and 169.254.3.181/16 this is the ifconfig: lo Lin...
by komarek
Fri Aug 11, 2017 12:35 pm
Forum: General discussion
Topic: python script at startup
Replies: 81
Views: 10480

AND FINALLY-...... SOLVED

all i did was to add these line to the .service file:

WorkingDirectory=/home/pi
ExecStart=/home/pi/analitico.sh

i just put the shell file in the home directory and now it's running like charm
thanks everyone
it took me weeks to understand this stupid things
:)
by komarek
Fri Aug 11, 2017 11:59 am
Forum: General discussion
Topic: python script at startup
Replies: 81
Views: 10480

Re: python script at startup

... (like a browser, you cannot launch a browser with rc.local or systemd service, but you can autolaunch it with a desktop).... actually you can , but it's gets a bit more complex it's is usually easier to start with the x autostart method re - setting home directories umm maybe the use of AssertP...
by komarek
Fri Aug 11, 2017 10:21 am
Forum: General discussion
Topic: python script at startup
Replies: 81
Views: 10480

HEY GUYS i found what the problem was

the python script to run properly actually need to be launched from a directory where a file called "analytics.dat" is.
so... how can i fix this on systemd level?
cheers
by komarek
Thu Aug 03, 2017 9:50 pm
Forum: General discussion
Topic: Bricked my Pi. don't know why
Replies: 121
Views: 12336

Re: Bricked my Pi. don't know why

ok so... probably the best way to fix this would be to intercept the line that trigger the relay that opens the gate... and to connect through an opto-isolator to another gpio of the PI... when this gpio is True obviously the other gpio input (the one triggered by the bell) is ignored. CORRECT? sou...
by komarek
Thu Aug 03, 2017 8:57 pm
Forum: General discussion
Topic: Bricked my Pi. don't know why
Replies: 121
Views: 12336

Re: Bricked my Pi. don't know why

you suggest me to trigger another gpio to tell the Pi that the gate is being opened? and then to inhibit that part of the script... Yes, exactly that. The MQTT signal will probably work just as well, should be able to catch that on the gate Pi. ok so... probably the best way to fix this would be to...
by komarek
Thu Aug 03, 2017 8:51 pm
Forum: General discussion
Topic: Bricked my Pi. don't know why
Replies: 121
Views: 12336

Re: Bricked my Pi. don't know why

ok this thing is a pain in the *** i tried to fix it via software i've made a complicate loop, bell-picture system and MQTT client together: apriCancello = False def on_connect(client, userdata, flags, rc): #print("Connected with result code "+str(rc)) client.subscribe("aa/bb") def on_message(client...

Go to advanced search