Go to advanced search

by l0calH0st
Sun Jan 14, 2018 5:15 am
Forum: Raspbian
Topic: How to create personal custom image?!
Replies: 2
Views: 13013

Re: How to create personal custom image?!

Or you can just use pigen https://github.com/RPi-Distro/pi-gen

Find more info here viewtopic.php?f=66&t=187850
by l0calH0st
Sun Jan 14, 2018 5:11 am
Forum: Raspbian
Topic: OpenVPN DNS Leak
Replies: 4
Views: 2368

Re: OpenVPN DNS Leak

Wise decision indeed since you are not able to get what you want, and remeber boi, never try to find the culprit (shitty guides maybe ?) that's not smart at all :lol: or maybe checking some actual manuals of openvpn, nahhhh that's hard right ?
by l0calH0st
Thu Jan 04, 2018 2:39 am
Forum: Raspbian
Topic: Hw accl supported ffmpeg in Raspbian repo
Replies: 10
Views: 1674

Re: Hw accl supported ffmpeg in Raspbian repo

Send a PM ?
Or make a pull request on the raspbian repo ?
by l0calH0st
Sat Jul 15, 2017 5:47 pm
Forum: Raspbian
Topic: Help with pi-gen
Replies: 27
Views: 7432

Re: Help whit pi-gen

Thanks !
by l0calH0st
Fri Jul 14, 2017 10:30 pm
Forum: Raspbian
Topic: Help with pi-gen
Replies: 27
Views: 7432

Re: Help whit pi-gen

Yeah, it's expected that you clone the pi-gen repo rather than download the archive. It uses the git commit id to fingerprint itself in /etc/rpi-issue. I guess you found my mistake then, trying again. Edit Yes now works fine thanks for the help. Some questions about adding/removing packages, what's...
by l0calH0st
Fri Jul 14, 2017 9:21 pm
Forum: Raspbian
Topic: Help with pi-gen
Replies: 27
Views: 7432

Re: Help whit pi-gen

It looks like you had a different error at the end there: "git: command not found" Already tryed whit git installed, it give another kind of error and i still have 1 img instead of 3 :( Edit This is the last msg whit git installed "fatal: Not a git repository (or any of the parent directories): .git"
by l0calH0st
Fri Jul 14, 2017 6:25 pm
Forum: Raspbian
Topic: Help with pi-gen
Replies: 27
Views: 7432

Re: Help whit pi-gen

ShiftPlusOne wrote:Are you using the docker build script?
https://github.com/RPi-Distro/pi-gen/is ... -315398671

If so, then that will use a jessie base to build from, which won't work regardless of what you run it on.
I'm using "build.sh" to start the build process.
by l0calH0st
Wed Jul 12, 2017 11:22 pm
Forum: Raspbian
Topic: Help with pi-gen
Replies: 27
Views: 7432

Re: Help whit pi-gen

ShiftPlusOne wrote:Without having the problem in front of me, I think I am out of ideas.
If can help here is the build.log https://pastebin.com/VnCPk4r1
and the console output https://pastebin.com/1hprUEAF

All noobs exports was removed and stage5 skipped in that logs
by l0calH0st
Wed Jul 12, 2017 10:06 pm
Forum: Raspbian
Topic: Help with pi-gen
Replies: 27
Views: 7432

Re: Help whit pi-gen

Testing on vmware/debian9 now, it have a newer version of e2fsprogs (1.43.4-2), it was failing on virtualbox, same problem as xubuntu lts/17.04 (whitout telling me "Invalid filesystem option set: ^metadata_csum,^huge_file") Edit Same problem :( whit more then one EXPORT_IMAGE it create only the firs...
by l0calH0st
Wed Jul 12, 2017 8:44 pm
Forum: Raspbian
Topic: Help with pi-gen
Replies: 27
Views: 7432

Re: Help whit pi-gen

Ah, that's a fairly recent change and would require a recent e2fsprogs package. I may have the name of it wrong. Currently I build in debian stretch. I always did an apt-get update/apt-get dist-upgrade on all tested distros, it report 1.42.13-1ubuntu1 for e2fsprogs whit xubuntu lts Will try again w...
by l0calH0st
Wed Jul 12, 2017 3:21 pm
Forum: Raspbian
Topic: Help with pi-gen
Replies: 27
Views: 7432

Re: Help whit pi-gen

I've been running it on mint, debian jessie, and recently stretch without any problems. Could you explain what you mean by "xubuntu hangs when unmounting disks". Hangs how? On what command? For what reason? Hello I'll try to explain better because english is not my first language, if i launch the s...
by l0calH0st
Tue Jul 11, 2017 2:53 am
Forum: Raspbian
Topic: Help with pi-gen
Replies: 27
Views: 7432

Re: Help whit pi-gen

Tested xubuntu lts, xubuntu 17.04, debian 9, all have the unmount problem, once the first *.img is created all later exports don't work, why ? someone that managed to run pi-gen whitout issues can tell me how you did and distro used please ?
by l0calH0st
Sun Jul 09, 2017 9:16 pm
Forum: Raspbian
Topic: Help with pi-gen
Replies: 27
Views: 7432

Re: Help whit pi-gen

Yes, the problem was unmounting the boot/rootfs disks used to create the img, deleting the other 2 img-export fixed this, but i still have to unmount the disks manually when the script end, no errors in build.log
by l0calH0st
Sun Jul 09, 2017 8:31 pm
Forum: Raspbian
Topic: Help with pi-gen
Replies: 27
Views: 7432

Re: Help whit pi-gen

No (error) messages in the console window? Have you checked the build log to see at which stage the script ends? Could it be that you're running out of disk space in your Virtualbox instance? If you don't want to generate the Lite image you can delete stage2/EXPORT_IMAGE and stage2/EXPORT_NOOBS Tha...
by l0calH0st
Sun Jul 09, 2017 6:27 pm
Forum: Raspbian
Topic: Help with pi-gen
Replies: 27
Views: 7432

Re: Help whit pi-gen

And i got again a nice raspbian lite image, no full image :( like the first time i have 2 mounted partitons on my desktop (no idea if they are from the full or lite image but the script never unmount them)
ps
if it matters i'm using xubuntu amd64 inside virtualbox
by l0calH0st
Sun Jul 09, 2017 5:33 am
Forum: Raspbian
Topic: Help with pi-gen
Replies: 27
Views: 7432

Re: Help whit pi-gen

Setting the img name that way wasn't really ok, now i have done as described in "Stage specification" :
echo "IMG_NAME='Raspbian'" > config
sudo ./build.sh

Started and working :geek: hope is the good one :roll:

Next thing on the list, understand how to remove/add stuff i want for a custom build
by l0calH0st
Sat Jul 08, 2017 4:28 am
Forum: Raspbian
Topic: Help with pi-gen
Replies: 27
Views: 7432

Help with pi-gen

Hello I'm trying to build official raspbian updated images using pi-gen I managed to start build.sh but once the job is done i only get the light image ??? I'm missing something, the readme is a bit cryptyk for me. Someone could explain what i should do to build both images please ? To make the scri...
by l0calH0st
Sun Sep 11, 2016 6:47 pm
Forum: Beginners
Topic: Power Supply question
Replies: 5
Views: 857

Re: Power Supply question

Thanks everyone.
I do not wish to burn my Pi, just bought the official PSU for 12e shipping incl. :), easyer then building a 12to5v adapter for me.
by l0calH0st
Sun Sep 11, 2016 3:06 am
Forum: Beginners
Topic: Power Supply question
Replies: 5
Views: 857

Power Supply question

Hello
What is this LPS 15v mode ?? This will fry my pi ?

Image

Thanks

Go to advanced search