Go to advanced search

by sahab
Sun Mar 10, 2019 2:19 pm
Forum: Raspbian
Topic: How to deal with linux ?
Replies: 1
Views: 194

How to deal with linux ?

My experience with linux has always been full of headaches. Latest one has prompted me to write this, and ask if someone knows a method to somehow deal with linux, incompatibilities, broken dependencies, bad guides and more. Current issue: trying to install python-lirc. "pip3 install python-lirc " ....
by sahab
Sat Mar 09, 2019 6:34 pm
Forum: Automation, sensing and robotics
Topic: Issues with adding an IR receiver .
Replies: 3
Views: 429

Re: Issues with adding an IR receiver .

Added resistor. remote recorded. configuring pythong. It works!

FYI I only added the one resistor as written in that link. A 22k resistor between the power and data pins.
by sahab
Sat Mar 09, 2019 2:42 pm
Forum: Automation, sensing and robotics
Topic: Issues with adding an IR receiver .
Replies: 3
Views: 429

Re: Issues with adding an IR receiver .

Got a new IR receiver vs1838b, but still no go. Output from `mode2 -d /dev/lirc0` have increased, but irrecord still doesn't generate any output on pressing remote buttons :( . Any help please? Edit: Asked and I received! According to http://what-when-how.com/Tutorial/topic-2446rrd/Experimenting-wit...
by sahab
Mon Feb 18, 2019 8:16 am
Forum: Automation, sensing and robotics
Topic: Issues with adding an IR receiver .
Replies: 3
Views: 429

Issues with adding an IR receiver .

Adding an IR receiver to my pi zero. Followed this guide . It kind of works, but is not usable. The command `mode2 -d /dev/lirc0` shows 'pulse' and 'space' outputs.. Pressing remote buttons also show response, but sometimes. Recording with `irrecord` with pressing several buttons should show 2 lines...
by sahab
Sun Dec 16, 2018 6:09 pm
Forum: HATs and other add-ons
Topic: Add sensors with a HAT ? [Solved]
Replies: 8
Views: 1717

Re: Add sensors with a HAT ? [Solved]

This is super late. But I finally have it working :) . 18 C here in my room in delhi. online shows 12C Some info for others: Exact pin layout for AIY (version 1) is on this page: https://aiyprojects.withgoogle.com/voice-v1/ . I used GPIO04 (yellow) for the data cable. GND (black) and 3.3 (Orange) fo...
by sahab
Thu Nov 29, 2018 1:37 pm
Forum: HATs and other add-ons
Topic: Add sensors with a HAT ? [Solved]
Replies: 8
Views: 1717

Re: Add sensors with a HAT ?

Thanks @bensimmo for confirming that the resistor connects the data wire and the power wire. btw this link - https://wp.josh.com/2014/06/23/no-external-pull-up-needed-for-ds18b20-temp-sensor/ shows how it can work without the 4.7k resistor. Apparently some processors "built-in internal pull-ups on t...
by sahab
Thu Nov 29, 2018 12:14 pm
Forum: HATs and other add-ons
Topic: Add sensors with a HAT ? [Solved]
Replies: 8
Views: 1717

Re: Add sensors with a HAT ?

Does the 4.7k resistor connects the power and data wires ? Looks like it, doesn't it? Here's a nice answer: https://arduino.stackexchange.com/a/30824 It does look like it. Does it connect like it looks ? But I am none the wiser even after looking at that link :( . I can't really decipher the follow...
by sahab
Wed Nov 28, 2018 10:37 am
Forum: HATs and other add-ons
Topic: Add sensors with a HAT ? [Solved]
Replies: 8
Views: 1717

Re: Add sensors with a HAT ?

Great to know. I have ordered a sensor: DS18B20 Question on using: Found several guides, which only have breadboard diagrams and follow along guides. No even explains adding a 4.7k resistor without breadboard. Like this: https://thepihut.com/blogs/raspberry-pi-tutorials/18095732-sensors-temperature-...
by sahab
Tue Nov 27, 2018 4:03 pm
Forum: HATs and other add-ons
Topic: Add sensors with a HAT ? [Solved]
Replies: 8
Views: 1717

Add sensors with a HAT ? [Solved]

I have a Pi Zero , to which Google VoiceHat is attached. Possible to add sensors to this setup ? In particular I am looking to add temperature/humidity sensor.

Thanks
by sahab
Tue Oct 16, 2018 3:56 am
Forum: General discussion
Topic: Increase Alsa recording volume over 100 ?
Replies: 0
Views: 170

Increase Alsa recording volume over 100 ?

pactl can increase the volume over 100% and arecord confirms the increase. But I am using a python library, pyaudio which works with alsa and is unable to record in volume over 100% . ~ $ pactl set-source-volume 1 450% :- ~ $ amixer sget Capture Simple mixer control 'Capture',0 Front Left: Capture 2...
by sahab
Wed Jul 11, 2018 3:58 pm
Forum: AIY Projects
Topic: Assmebling original voice kit with pi zero w ?
Replies: 4
Views: 1351

Re: Assmebling original voice kit with pi zero w ?

Yes. I am running voice kit on pi zero W. This is late, I know.

However I may not be able to provide instructions for running it :( . For one, its been a long time. Second I installed/removed way too many packages , tinkered around a lot. Most of it wasn't necessary though.
by sahab
Wed Jul 11, 2018 2:21 pm
Forum: AIY Projects
Topic: What do these audio settings mean ?
Replies: 2
Views: 359

Re: What do these audio settings mean ?

hmm, I hadn't considered the possibility of slow net . Am getting 500 KB / sec (kilo BYTES) , with

Code: Select all

wget --output-document=/dev/null http://releases.ubuntu.com/18.04/ubuntu -18.04-desktop-amd64.iso

This should be enough?
Ping is 150ms to ubuntu.com And 8ms to embeddedassistant.googleapis.com
by sahab
Wed Jul 11, 2018 11:10 am
Forum: AIY Projects
Topic: What do these audio settings mean ?
Replies: 2
Views: 359

What do these audio settings mean ?

pi zero + aiy v1 + google assistant sdk. Audio output is stuttering, as google assistant outputs these messages: Connecting to %s embeddedassistant.googleapis.com INFO:snowboy:Keyword 1 detected at time: 2018-07-11 10:53:14 WARNING:root:SoundDeviceStream read overflow (3200, 6400) WARNING:root:Sound...
by sahab
Sun May 13, 2018 3:34 pm
Forum: Troubleshooting
Topic: Detect GPIO pins, to check for a bad solder job ?
Replies: 7
Views: 692

Re: Detect GPIO pins, to check for a bad solder job ?

GPIO were NOT soldered correctly ! Used multimeter to find 8 points with no connection. Soldered those pins, and speaker is actually working ! Mic is also working, but with loads of disturbance
by sahab
Sun May 13, 2018 8:36 am
Forum: Troubleshooting
Topic: Detect GPIO pins, to check for a bad solder job ?
Replies: 7
Views: 692

Re: Detect GPIO pins, to check for a bad solder job ?

2 scripts exists named gpiotest. Correct one to use: http://abyz.co.uk/rpi/pigpio/code/gpiotest.zip .

This also gives a green light to the pins . Really strange.
by sahab
Sun May 13, 2018 8:33 am
Forum: AIY Projects
Topic: AIY Demo and Pi Zero W Help
Replies: 17
Views: 3984

Re: AIY Demo and Pi Zero W Help

Edit: Ignore my post . I could be partially wrong.
Steps from HACKING.md no longer work. Some scripts , such as install-deps.sh have been removed.
by sahab
Sat May 12, 2018 9:40 pm
Forum: Troubleshooting
Topic: Detect GPIO pins, to check for a bad solder job ?
Replies: 7
Views: 692

Re: Detect GPIO pins, to check for a bad solder job ?

Tried this Rpi.GPIO module >>> import RPi.GPIO as GPIO >>> GPIO.setmode(GPIO.BCM) >>> GPIO.setup(3, GPIO.IN, pull_up_down=GPIO.PUD_UP) __main__:1: RuntimeWarning: A physical pull up resistor is fitted on this channel! >>> GPIO.input(3) 1 But again I have no idea what this value means, or even if thi...
by sahab
Sat May 12, 2018 9:27 pm
Forum: Troubleshooting
Topic: Detect GPIO pins, to check for a bad solder job ?
Replies: 7
Views: 692

Re: Detect GPIO pins, to check for a bad solder job ?

> pintest The main 8 GPIO pins 0: 7: OK The 5 SPI pins 10:14: OK The serial pins 15:16: OK The I2C pins 8: 9: OK Not sure how much I can rely upon these.. It says This test only tests the original pins present on the Rev A and B. It does not test the extra pins on the Revision A2, B2 nor the A+ or B...
by sahab
Sat May 12, 2018 8:07 pm
Forum: Troubleshooting
Topic: Detect GPIO pins, to check for a bad solder job ?
Replies: 7
Views: 692

Detect GPIO pins, to check for a bad solder job ?

Hi, Soldered GPIO pins strip on a ' Pi zero wireless ' > Attached Google voice aiy hat > cat /proc/device-tree/hat/product , shows it being detected "Google AIY audioHAT Board v1" . BUT chances are, some PIN did not get soldered right. First time soldered anything in like 5 years of trying. :oops: W...
by sahab
Sat May 12, 2018 7:55 pm
Forum: AIY Projects
Topic: Assmebling original voice kit with pi zero w ?
Replies: 4
Views: 1351

Re: Assmebling original voice kit with pi zero w ?

ya thanks, I should have read the full instructions.

Anyway, I got the GPIO pin strip, soldered it, and voice kit is detected :)

Code: Select all

> cat /proc/device-tree/hat/product

Google AIY audioHAT Board v1
Still installing dependencies though...
by sahab
Sat May 12, 2018 11:02 am
Forum: AIY Projects
Topic: Assmebling original voice kit with pi zero w ?
Replies: 4
Views: 1351

Assmebling original voice kit with pi zero w ?

It seems some GPIO pins will need to be added/soldered to the pi w.
I can't find any specific instructions if something else is required for connecting the original voice kit with Pi zero w.

Help ?
by sahab
Thu May 10, 2018 8:16 am
Forum: AIY Projects
Topic: Offline voice recognition ?
Replies: 0
Views: 707

Offline voice recognition ?

Possible to have offline voice recognition ? using some accent sensitive service , like google ?

hotword is irrelevant

This is for the original voice kit (v1) and pi zero.
by sahab
Sat Jun 25, 2016 4:44 pm
Forum: Troubleshooting
Topic: Can't fix pulseaudio. Doesn't run (SOLVED)
Replies: 5
Views: 7425

Re: Can't fix pulseaudio. Doesn't run, screwed the settings

It came preinstalled in the latest full raspbian. Found an answer to the problem btw: http://raspberrypi.stackexchange.com/a/50326/48496 create a file .config/autostart/pulseaudio.desktop [Desktop Entry] Version=1.0 Name=PulseAudio Sound System Exec=/bin/sh -c "sleep 10; pulseaudio --start" Terminal...
by sahab
Fri Jun 24, 2016 10:47 am
Forum: Troubleshooting
Topic: Can't fix pulseaudio. Doesn't run (SOLVED)
Replies: 5
Views: 7425

Re: Can't fix pulseaudio. Doesn't run, screwed the settings

Just to be clear pulseaudio does run on command after reinstall ! But does not autostart.
by sahab
Fri Jun 24, 2016 8:14 am
Forum: Troubleshooting
Topic: Can't fix pulseaudio. Doesn't run (SOLVED)
Replies: 5
Views: 7425

Re: Can't fix pulseaudio. Doesn't run, screwed the settings

well thats what I evntually ended up doing-- Reinstall . HOWEVER the problem remains! :( So it seems that pulseaudio doesn't run by default ? $ pulseaudio E: [pulseaudio] bluez4-util.c: org.bluez.Manager.GetProperties() failed: org.freedesktop.DBus.Error.UnknownMethod: Method "GetProperties" with si...

Go to advanced search