Go to advanced search

by Koepi
Sun Aug 11, 2019 11:28 am
Forum: Troubleshooting
Topic: Pi Zero W - onboard Wifi crashing
Replies: 5
Views: 127

Re: Pi Zero W - onboard Wifi crashing

I didn't think of a "diagnostic run" with a fresh image. Will try that, thank you!
by Koepi
Sun Aug 11, 2019 9:29 am
Forum: Troubleshooting
Topic: Pi Zero W - onboard Wifi crashing
Replies: 5
Views: 127

Re: Pi Zero W - onboard Wifi crashing

Oh sorry, I got the versions wrong. It was Stretch before of course, not Jessie. Thank you for the suggestion. I am a bit reluctant to do a clean install as I had some time-consuming changes in the config (temporary web folders for rendering graphs in RAM to reduce SD-card wear, setting up cronjobs ...
by Koepi
Sun Aug 11, 2019 6:46 am
Forum: Troubleshooting
Topic: Pi Zero W - onboard Wifi crashing
Replies: 5
Views: 127

Pi Zero W - onboard Wifi crashing

Hi there, the last few days I had struggles with the onboard Wifi of my Pi Zero W. I find some messages in the logfile, after which Wifi is crashed and will restart - if at all - hours later. Since I use the Pi as central monitoring server for tmperaturs/humidity, this is a showstopper. I now put an...
by Koepi
Mon May 30, 2016 4:38 am
Forum: Camera board
Topic: Blue tint on edges
Replies: 5
Views: 1133

Re: Blue tint on edges

Did you upgrade firmware/kernel and the raspistill-tool?
This looks like not using a proper adopted driver which would be the case if you didn't update your software.
by Koepi
Sun May 29, 2016 4:52 am
Forum: Camera board
Topic: CamV2: raspistill stops working after some time ENOSPC
Replies: 62
Views: 10196

Re: CamV2: raspistill stops working after some time ENOSPC

Just some feedback a week later: The fix is working great in my case. pi@CamPi:~ $ uptime 06:47:21 up 4 days, 7:39, 1 user, load average: 0,20, 0,16, 0,14 Uptime would be bigger - but I had to reboot once just to figure out that the Pi had no problem but my router lost its port forward settings. The...
by Koepi
Sat May 21, 2016 4:19 am
Forum: Camera board
Topic: CamV2: raspistill stops working after some time ENOSPC
Replies: 62
Views: 10196

Re: CamV2: raspistill stops working after some time ENOSPC

Upgraded the firmware, will report back if I stumble upon an error.
by Koepi
Wed May 18, 2016 3:40 am
Forum: Camera board
Topic: CamV2: raspistill stops working after some time ENOSPC
Replies: 62
Views: 10196

Re: CamV2: raspistill stops working after some time ENOSPC

I can confirm as well that the fix seems to work. For nearly about 48 hours running straight on the test firmware, continously taking pictures every minute. Unfortunately I don't log error output from my cron jobs so we can't see if the initial error occured again at all, but it most likely will. (N...
by Koepi
Mon May 16, 2016 2:03 pm
Forum: Camera board
Topic: -awb auto in raspistill does not work ideally
Replies: 3
Views: 825

Re: -awb auto in raspistill does not work ideally

What do you think is wrong in that picture?
The white balance looks very well to me, the colours are natural as far as I can tell.
by Koepi
Mon May 16, 2016 11:31 am
Forum: Camera board
Topic: CamV2: raspistill stops working after some time ENOSPC
Replies: 62
Views: 10196

Re: CamV2: raspistill stops working after some time ENOSPC

Ok, replaced the files in /boot, sync'ed and rebooted. Starts up, so far all ok. :)

From dmesg:

Code: Select all

[    0.664928] raspberrypi-firmware soc:firmware: Attached to firmware from 2016-05-16 12:14
Thank you all for your efforts!
by Koepi
Mon May 16, 2016 11:10 am
Forum: Camera board
Topic: CamV2: raspistill stops working after some time ENOSPC
Replies: 62
Views: 10196

Re: CamV2: raspistill stops working after some time ENOSPC

That's great news! Looking forward to test the patched kernel/firmware. Thank you for getting to the bottom of this issue! :)
by Koepi
Mon May 16, 2016 9:52 am
Forum: Camera board
Topic: CamV2: raspistill stops working after some time ENOSPC
Replies: 62
Views: 10196

Re: CamV2: raspistill stops working after some time ENOSPC

Sorry for reporting back so late, but the problem has to occur so I can do the tests. After some reboots on saturday and a rpi-update yesterday we finally arrived at the point where raspistill stops working. pi@CamPi:~ $ uptime 11:47:49 up 22:00, 1 user, load average: 0,26, 0,12, 0,13 ... and pi@Cam...
by Koepi
Mon May 16, 2016 3:31 am
Forum: Camera board
Topic: raspberrp pi camera version 2
Replies: 6
Views: 1472

Re: raspberrp pi camera version 2

Gavin, I need to repeat myself: you're not working with RAW that way. ImageMagick just works on the JPG that prepands the RAW data. You need to use dcraw! @Yorum, just take your photo with: raspistill --raw -o my_test_raw.jpg Compile dcraw like explained in the thread I linked to. Use it like explai...
by Koepi
Sun May 15, 2016 6:52 pm
Forum: Camera board
Topic: Pi Camera V2 raw bayer data
Replies: 56
Views: 24476

Re: Pi Camera V2 raw bayer data

Of course! That's why I wrote "a few" and "a bit". It's not much, this is clear.
Maybe raspistill could get an option for setting denoising level low/normal or something along those lines. Or is --sharpness already doing this?
by Koepi
Sun May 15, 2016 2:31 pm
Forum: Camera board
Topic: raspberrp pi camera version 2
Replies: 6
Views: 1472

Re: raspberrp pi camera version 2

Did you compile a new dcraw.exe which supports the new RAW format of the new sensor?
6by9 added the new cam here:
viewtopic.php?p=970865#p970865
by Koepi
Sun May 15, 2016 11:38 am
Forum: Camera board
Topic: Pi Camera V2 raw bayer data
Replies: 56
Views: 24476

Re: Pi Camera V2 raw bayer data

Gavin, Did you strip the JPG "header" from your raspistill-raw picture? It has the whole JPG and just attaches the RAW data afterwards. Image software like GIMP or ImageMagick do some MIME magic and decode simply the JPG with which the file starts. You have to strip off the RAW data to use it! (Or n...
by Koepi
Sun May 15, 2016 8:24 am
Forum: Camera board
Topic: CamV2: raspistill stops working after some time ENOSPC
Replies: 62
Views: 10196

Re: CamV2: raspistill stops working after some time ENOSPC

Do you mean I should do a rpi-update? Or something else?
by Koepi
Sun May 15, 2016 8:09 am
Forum: Camera board
Topic: Pi Camera V2 raw bayer data
Replies: 56
Views: 24476

Re: Pi Camera V2 raw bayer data

Thank you for the "hacked" dcraw! :) While I tried to fine tune the focus, I also took some raw images. Now that I snipped the raw part out, I could open the PPM with GIMP, save as PNG and use that in RawTherapee. I'm still getting used to that program, so bare with me. Here is the result of toying ...
by Koepi
Fri May 13, 2016 1:06 pm
Forum: Camera board
Topic: CamV2: raspistill stops working after some time ENOSPC
Replies: 62
Views: 10196

Re: CamV2: raspistill stops working after some time ENOSPC

I'm on a Pi A+, but the pins should be identical. Toggling a pin I'll do. Thank you! Concerning the hardware and periphery: Nothing on the DSI bus. Just the Cam on CSI, DS3231 RTC, BH1750 Illumincance Sensor and BME280 Humidity/Temperature/Pressure sensors on I2C1 (all extreme low power ICs), and on...
by Koepi
Fri May 13, 2016 7:34 am
Forum: Camera board
Topic: Camera Module V2 ENOSPC Error
Replies: 7
Views: 2666

Re: Camera Module V2 ENOSPC Error

Sounds similar to the problem I reported as well: https://www.raspberrypi.org/forums/viewtopic.php?f=43&t=147744 Which distribution and kernel are you using? Did you do -> sudo rpi-update and is you distribution up-to-date? -> sudo apt-get update -> sudo apt-get upgrade Some debug output would help....
by Koepi
Fri May 13, 2016 6:00 am
Forum: Camera board
Topic: New 8MP Camera - Q&A thread
Replies: 450
Views: 191671

Re: New 8MP Camera - Q&A thread

Just for you kajak, on page 5 of the thread, only 20 posts back ;)
viewtopic.php?p=965037#p965037
by Koepi
Fri May 13, 2016 4:50 am
Forum: Camera board
Topic: CamV2: raspistill stops working after some time ENOSPC
Replies: 62
Views: 10196

Re: CamV2: raspistill stops working after some time ENOSPC

I just added the GPIO config from the "working state" as second coloumn for direct comparison. No difference to the state when the cam isn't accessable anymore.
by Koepi
Thu May 12, 2016 12:43 pm
Forum: Camera board
Topic: New 8MP Camera - Q&A thread
Replies: 450
Views: 191671

Re: New 8MP Camera - Q&A thread

A magnifier lense will add to the sharpness issue.

When you loosen the lens you can refocus it in such a way that you get usable results for your purpose (if it worked that way with V1.3 lens before at least, I'm really unsure how the magnifier will influence the whole scenario.)
by Koepi
Thu May 12, 2016 8:34 am
Forum: Camera board
Topic: CamV2: raspistill stops working after some time ENOSPC
Replies: 62
Views: 10196

Re: CamV2: raspistill stops working after some time ENOSPC

It crashed again ... I also tried another power supply to definately rule that out as source. Edit : Left coloumn after crash, right coloumn from "working state". pi@CamPi:~ $ sudo raspi-gpio get BANK0 (GPIO 0 to 27): GPIO 00: level=1 fsel=0 alt= func=INPUT GPIO 00: level=1 fsel=0 alt= func=INPUT GP...
by Koepi
Wed May 11, 2016 8:35 pm
Forum: Camera board
Topic: New 8MP Camera - Q&A thread
Replies: 450
Views: 191671

Re: New 8MP Camera - Q&A thread

I can only recommend to dare the modification - it's simple and with just a little care you can't break anything. I was impressed by the night shots before, but have a look at his picture ... a cyclist driving by, which can be seen as light stripe (4s shutter time). And the moon between the trees. A...
by Koepi
Wed May 11, 2016 12:57 pm
Forum: Camera board
Topic: CamV2: raspistill stops working after some time ENOSPC
Replies: 62
Views: 10196

Re: CamV2: raspistill stops working after some time ENOSPC

Thank you. Those devices are on standard i2c-1 bus on GPIO 2+3. From my experience with µCs independant, separated i2c busses don't interfere, thus I agree with 6by9: Safe. Interestingly, i2c-0 doesn't seem to be available / exposed at all: sudo i2cdetect -y 0 Error: Could not open file `/dev/i2c-0'...

Go to advanced search