Go to advanced search

by planteg
Fri May 10, 2019 3:50 pm
Forum: Raspbian
Topic: How to get latest apache2 and php versions on Raspbian Os
Replies: 21
Views: 2315

Re: How to get latest apache2 and php versions on Raspbian Os

Hi, using the latest Noobs (April 2019) I installed Raspbian, the I ran the first commands. All was well but for the last one: Err:5 https://packages.sury.org/php $ Release 404 Not Found E: The repository 'https://packages.sury.org/php $ Release' does not have a Release file. N: Updating from such a...
by planteg
Tue May 07, 2019 10:31 pm
Forum: Networking and servers
Topic: Apache2 error about ${APACHE_RUN_DIR} not set
Replies: 3
Views: 192

Re: Apache2 error about ${APACHE_RUN_DIR} not set

Dougie, I found out here https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=879571 that now we must use apacthe2ctrl as you noted. Does that mean that the installation is wrong stating that the variable is not set ? Running apache2ctrl -S states that ServerRoot: "/etc/apache2" Thanks Gilles Plante
by planteg
Tue May 07, 2019 8:32 pm
Forum: Networking and servers
Topic: Apache2 error about ${APACHE_RUN_DIR} not set
Replies: 3
Views: 192

Apache2 error about ${APACHE_RUN_DIR} not set

Hi, on latest Raspbian stretch, April 2018, I got this error after installing apache2: [Tue May 07 16:07:12.221849 2019] [core:warn] [pid 1067] AH00111: Config variable ${APACHE_RUN_DIR} is not defined apache2: Syntax error on line 80 of /etc/apache2/apache2.conf: DefaultRuntimeDir must be a valid d...
by planteg
Sun May 05, 2019 11:36 pm
Forum: Networking and servers
Topic: MySQL, interactive configuration not executed after installation
Replies: 1
Views: 194

MySQL, interactive configuration not executed after installation

Hi, I just installed the latest Raspbian from Noobs 3.0.1 (April 2019). I ran sudo apt-get install mysql-server That resulted in strange things: This is what I now have: pi@joomla3:~ $ dpkg -l| grep mysql ii default-mysql-server 1.0.2 all MySQL database server binaries and system database setup (met...
by planteg
Sun Jun 11, 2017 12:10 am
Forum: Python
Topic: PyDev & Eclipse help please
Replies: 1
Views: 1292

Re: PyDev & Eclipse help please

Hi, did you succeed installing PyDev ? I just tried... I am waiting for completion of the third attempt. Installing eclipse was real slow, and it's not any faster for PyDev. eclipse version is 5.8.1. I followed the same path you did. And it's the same as instructed in a course on Python on Learning ...
by planteg
Tue May 09, 2017 7:44 pm
Forum: Python
Topic: Managing WiFi programatically
Replies: 2
Views: 1202

Re: Managing WiFi programatically

Thanks HCAB, I haven't found that one. My issue is now solved. The code has to run under root (sudo puthon3 program .py does it). If not under root, the the only listed network should be the one you are connected to. I still try with WiFi, but will give python-wifi a try if I get blocked. python-wif...
by planteg
Mon May 08, 2017 9:15 pm
Forum: Python
Topic: Managing WiFi programatically
Replies: 2
Views: 1202

Managing WiFi programatically

Hi fellows, I am looking for a way to manage the 'wlan0' connection from within a Python program. I need to present a list of networks available, have the user pick a network and type the key. So I looked for a Python library, and found... only one. The library is wifi (information at https://wifi.r...
by planteg
Thu Oct 27, 2016 8:52 pm
Forum: Troubleshooting
Topic: CAN Loopback test no Rx, Tx works, Seeed Canbus shield
Replies: 2
Views: 1549

Re: CAN Loopback test no Rx, Tx works, Seeed Canbus shield

Hi, to those who wish the seeedstudio CAN-BUS shield, here is how I have it worked. Since this shield is made for Arduino, I first plugged an ARPI600 card (it let you connect an Arduino shield to a Raspberry Pi) and then connected the CAN-Bus shield. The Chip Select 0 is routed to the proper pin of ...
by planteg
Mon Oct 03, 2016 9:57 pm
Forum: General programming discussion
Topic: i2c with bcm2835 and libbcm2835 wrapper
Replies: 0
Views: 505

i2c with bcm2835 and libbcm2835 wrapper

Hi, did someone succeeded using the i2c bus on a Raspberry Pi zero, with the libbcm2835 wrapper for the bcm2835 library ? The issue I get is that bcm2835_i2c_begin() always fails. I know that i2c and SPI needs access to /dev/mem, so I set all access to everyone from the file manager (strangely that ...
by planteg
Tue Sep 13, 2016 3:35 pm
Forum: C/C++
Topic: Geany: issues with version and plugins
Replies: 0
Views: 291

Geany: issues with version and plugins

Hi developpers, on a Raspberry Pi zero, I wish to develop in C. The package manager includes Geany version 1.24.1 although 1.28 has been released - no way to install 1.28. So I decided to add some plugins of interest. I selected them, had them installed... but they do not show up in Geany when I got...
by planteg
Wed Aug 10, 2016 11:37 pm
Forum: Other programming languages
Topic: Someone had success developing with mono on the Pi ?
Replies: 1
Views: 686

Someone had success developing with mono on the Pi ?

Hello everyone, I am looking for a toll to develop application for the Pi with a GUI. Since I discovered on can create application in C# with mono, I installed mon runtime, developer, Gtk#, etc, Thing is I can't create a new project, getting "File Widget couldn't be created...". Did one of you succe...
by planteg
Sun May 01, 2016 9:49 pm
Forum: Raspbian
Topic: Raspberry Pi 3, can't connect to my Router
Replies: 4
Views: 986

Re: Raspberry Pi 3, can't connect to my Router

Hi DirkS and DougieLawson, Thanks for your posts. I tried to bring back to original content both interfaces and wpa_supplicant.conf and modifying network block, but that didn't work. So first I booted again, hold Shift and re-installed Raspbian. Second I enabled SSID broadcasting, my SSID was discov...
by planteg
Sat Apr 30, 2016 11:54 pm
Forum: Raspbian
Topic: Raspberry Pi 3, can't connect to my Router
Replies: 4
Views: 986

Raspberry Pi 3, can't connect to my Router

Hi all, brand new to Raspberry world, not so proficient with Linux, but may years in IT, under Windows. My router does not broadcast the SSID, so I need, as far as I can see, to manually configure my connection. I googled a lot, tried a few procedures, but none worked :oops: . My router is setup thi...

Go to advanced search