Go to advanced search

by welshgeekboy
Wed Nov 01, 2017 12:28 pm
Forum: HATs and other add-ons
Topic: PiTFT 5V divided to 3.3V for PiTFT 3.3V input power?
Replies: 3
Views: 828

Re: PiTFT 5V divided to 3.3V for PiTFT 3.3V input power?

To answer my own question- the PiTFT creates extra GPIO that can be accessed from the Pi using simple code.

https://learn.adafruit.com/adafruit-pit ... ht-control

Thank you for your help.
by welshgeekboy
Sat Oct 28, 2017 5:45 pm
Forum: HATs and other add-ons
Topic: PiTFT 5V divided to 3.3V for PiTFT 3.3V input power?
Replies: 3
Views: 828

Re: PiTFT 5V divided to 3.3V for PiTFT 3.3V input power?

Sorry, I didn't properly RTFM. It looks like the backlight is set to be on automatically- I presumed I had to have a pin controlling it at all times. So in theory I could have a spare pin on the 10 pin connector, but though I don't need to be able to set the brightness of the screen, but I would lik...
by welshgeekboy
Sat Oct 28, 2017 4:28 pm
Forum: HATs and other add-ons
Topic: PiTFT 5V divided to 3.3V for PiTFT 3.3V input power?
Replies: 3
Views: 828

PiTFT 5V divided to 3.3V for PiTFT 3.3V input power?

Hello, I have a 10 pin connector which I'd like to use as the connector between a Pi Zero and a PiTFT 3.5". I've already desoldered the PiTFT headers, and will use a 10 pin header soldered to the PiTFT with a 10 pin connector bridging the gap between Pi and screen. PiTFT pinout here: https://pinout....
by welshgeekboy
Mon Feb 27, 2017 8:17 pm
Forum: HATs and other add-ons
Topic: Looking to get my Adafruit PiTFT working
Replies: 1
Views: 421

Re: Looking to get my Adafruit PiTFT working

Oh hang on, at the bottom of the page it says "Last updated 2016" so maybe it is current. Don't always believe Google, folks.
by welshgeekboy
Mon Feb 27, 2017 8:10 pm
Forum: HATs and other add-ons
Topic: Looking to get my Adafruit PiTFT working
Replies: 1
Views: 421

Looking to get my Adafruit PiTFT working

Hi all, I recently bought an Adafruit PiTFT 3.2" screen. I now want to set it up so it's working with a Pi Zero. I've looked at the Adafruit setup guide, but I noticed it's from 2013- four years old. Before I jump in and start downloading massive .img files etc, I just wanted to double check that th...
by welshgeekboy
Fri Nov 04, 2016 3:19 pm
Forum: Troubleshooting
Topic: [SOLVED] Just another "SD card won't boot" post...
Replies: 5
Views: 1438

Re: Just another "SD card won't boot" post...

Ok. Thanks for the help. I'll just rewrite the card.
by welshgeekboy
Mon Oct 31, 2016 9:04 pm
Forum: Troubleshooting
Topic: [SOLVED] Just another "SD card won't boot" post...
Replies: 5
Views: 1438

Re: Just another "SD card won't boot" post...

Hi, thanks for the replies. The card still had Wheezy on it but I had been updating occasionally. So I probably updated after the Pi Zero came out, but since I was updating from Wheezy I don't know if the OS would work with the Pi Zero / if the foundation still updates Wheezy at all. Sounds like I s...
by welshgeekboy
Sat Oct 29, 2016 7:05 pm
Forum: Troubleshooting
Topic: [SOLVED] Just another "SD card won't boot" post...
Replies: 5
Views: 1438

[SOLVED] Just another "SD card won't boot" post...

Hello, I have a problem with one of my Pi SD cards. I use it in a Pi A+ on my robot. My problem is that the SD card does not boot. On a Pi A+ when no SD card is plugged in, the green 'ACT' LED glows brightly when the power is plugged in. This is how the Pi responds when I power it on with the bad SD...
by welshgeekboy
Sat Jul 09, 2016 7:35 am
Forum: Raspbian
Topic: Detecting USB hotplug event - maybe with udev?
Replies: 1
Views: 1205

Re: Detecting USB hotplug event - maybe with udev?

Hmm... I may have solved it. RUN+="/usr/bin/udevattempt.sh &" Runs it in the background and creates a file in /tmp/ Here's my current rules file (in /etc/udev/rules.d/ ): SUBSYSTEM=="usb", ATTRS{idVendor}=="0781", ATTRS{idProduct}=="557d", RUN+="/usr/bin/udevattempt.sh &" Found this from another Pi ...
by welshgeekboy
Sat Jul 09, 2016 6:48 am
Forum: Raspbian
Topic: Detecting USB hotplug event - maybe with udev?
Replies: 1
Views: 1205

Detecting USB hotplug event - maybe with udev?

Hi all, I'm trying to create a setup where you simply plug a USB storage device into the Pi and this initiates a program which copies across files in a specific folder on the Pi to the USB stick. This is aimed at an A+ board on a robot. The Pi A+ has only one USB port, so I could plug in my wireless...
by welshgeekboy
Wed Jun 22, 2016 6:40 am
Forum: Graphics, sound and multimedia
Topic: Open GL driver overrides screen size settings?
Replies: 5
Views: 1557

Re: Open GL driver overrides screen size settings?

OK, a little update- with or without the driver enabled, the Pi didn't show any of the booting text. The only thing it showed was the log in text before it loaded X. I changed the option in the Raspberry Pi Configuration menu to disable sending messages as the Pi boots over serial and now all the bo...
by welshgeekboy
Tue Jun 14, 2016 7:49 pm
Forum: Graphics, sound and multimedia
Topic: Open GL driver overrides screen size settings?
Replies: 5
Views: 1557

Re: Open GL driver overrides screen size settings?

Okay, with video=1280x800 added to the end of the single line in /boot/cmdline.txt, the Pi boots with no change (screen output resolution is still 1920x1080) except at no point is the console displayed. I have the Pi boot to desktop so I can see the destop, but during boot and if I change (I apologi...
by welshgeekboy
Mon Jun 13, 2016 7:27 pm
Forum: Graphics, sound and multimedia
Topic: Open GL driver overrides screen size settings?
Replies: 5
Views: 1557

Re: Open GL driver overrides screen size settings?

Thanks both, this sounds promising. I'll try what you say. Editing /boot/cmdline.txt sounds like it ought to work.
by welshgeekboy
Mon Jun 13, 2016 1:55 pm
Forum: Graphics, sound and multimedia
Topic: Open GL driver overrides screen size settings?
Replies: 5
Views: 1557

Open GL driver overrides screen size settings?

Hi, I've just started using the Open GL driver on my Pi 3. It seems to override settings in /boot/config.txt file? I have four settings that make the Pi output correctly for my HDMIPi regarding screen size (1280x800) etc. and when the driver is enabled the output screen resolution is 1920x1080. I wa...
by welshgeekboy
Thu Jun 09, 2016 6:27 pm
Forum: Graphics, sound and multimedia
Topic: HDMIPi settings don't work with Open GL enabled?
Replies: 3
Views: 696

HDMIPi settings don't work with Open GL enabled?

Hi, I've just booted my Pi 3 for the first time (I have used Pis before, just never a Pi 3 :) ) and I found that the settings in /boot/config.txt for HDMIPi optimisation (1280x800 pix, 60 Hz I think) seem to be ignored when I enable the Open GL support. So my file looks like this: # /boot/config.txt...
by welshgeekboy
Mon Apr 04, 2016 3:45 pm
Forum: Camera board
Topic: Short circuit fried my Pi - has it damaged my PiCam?
Replies: 1
Views: 651

Short circuit fried my Pi - has it damaged my PiCam?

Hi, a while back one of my Pi installations short circuited. The ribbon cable that connects the Pi camera to my Pi A+ was touching a sharp point of solder near the Pi and so the plastic outer was scratched away. The solder point connected to PB0 or pin 8 on a RasPiO Duino, and the cable track it con...
by welshgeekboy
Mon Apr 04, 2016 6:34 am
Forum: Raspbian
Topic: [RESOLVED] Partition trouble on NOOBS card.
Replies: 14
Views: 2275

Re: Partition trouble on NOOBS card.

Thank you all very much for your help, but I have now erased the card with NOOBS and reimaged Raspbian. I spent a good few hours trying to get it to work but kept running into problems. When I got the first partition (sda5) in the right place according to rpdom, the next wouldn't go in the right pla...
by welshgeekboy
Thu Mar 24, 2016 8:13 pm
Forum: Raspbian
Topic: [RESOLVED] Partition trouble on NOOBS card.
Replies: 14
Views: 2275

Re: I deleted my boot partition.

Hello again, I'm sorry to be slack with this, you've all been a great help so far. Unfortunately you still have not given me enough information to be able to follow out your advice. Could you pretty much hold my hand through every step? Also the partition layout right from the beginning appears to b...
by welshgeekboy
Thu Mar 10, 2016 10:21 am
Forum: Raspbian
Topic: [RESOLVED] Partition trouble on NOOBS card.
Replies: 14
Views: 2275

Re: I deleted my boot partition.

I'm really sorry I haven't replied sooner. I have not been focusing on Pi at all since my last posts, I haven't even been on the Pi forum until now. I'll do what you saythis evening, hopefully.
by welshgeekboy
Tue Feb 23, 2016 11:33 pm
Forum: Raspbian
Topic: [RESOLVED] Partition trouble on NOOBS card.
Replies: 14
Views: 2275

Re: I deleted my boot partition.

Okay, I'm working on it now. Progress so far: Deleted old partition 5 Created new (correctly positioned) partition 5 Failed to create partition 6- the start sector is already allocated? pi@hdmipi ~ $ sudo fdisk /dev/sda Welcome to fdisk (util-linux 2.25.2). Changes will remain in memory only, until ...
by welshgeekboy
Mon Feb 22, 2016 8:21 pm
Forum: Raspbian
Topic: STICKY: How to upgrade a Wheezy image to Jessie (both defunct and replaced versions of Raspbian)
Replies: 88
Views: 217814

Re: How to upgrade a Wheezy image to Jessie

Note for those following this guide: Don't copy and paste the instructions to type into the terminal for after the first boot. Or if you do, make sure you edit them so that whenever you see a long '-' replace it with the standard minus symbol. So... cp –ax /usr/share/themes/PiX ~/.themes sudo rm /et...
by welshgeekboy
Mon Feb 22, 2016 7:33 pm
Forum: Raspbian
Topic: [RESOLVED] Partition trouble on NOOBS card.
Replies: 14
Views: 2275

Re: I deleted my boot partition.

Thank you for your help. So what you are suggesting I do will undo the damage I caused, but not remove the data partition? Is that right? First you are focusing on sorting out the problem, then afterwards I can remove the data partition (probably using a different tool) if the damage is undone succe...
by welshgeekboy
Mon Feb 22, 2016 8:03 am
Forum: Raspbian
Topic: [RESOLVED] Partition trouble on NOOBS card.
Replies: 14
Views: 2275

Re: I deleted my boot partition.

Ah! Really? That is good news. I really ought to stop fiddling with what I don't properly understand. :lol: pi@hdmipi ~ $ sudo fdisk -l /dev/sda Disk /dev/sda: 7948 MB, 7948206080 bytes 4 heads, 16 sectors/track, 242560 cylinders, total 15523840 sectors Units = sectors of 1 * 512 = 512 bytes Sector ...
by welshgeekboy
Mon Feb 22, 2016 12:09 am
Forum: Raspbian
Topic: [RESOLVED] Partition trouble on NOOBS card.
Replies: 14
Views: 2275

[RESOLVED] Partition trouble on NOOBS card.

I have unfortunately deleted my boot partition using fdisk. I was trying to delete the 512MB partition that you can add with NOOBS which I created ages ago but never used, but I seem to have selected the wrong partition to delete. I had my SD card I damaged in a reader and was accessing it with anot...

Go to advanced search