Go to advanced search

by Marekkon5
Sat Oct 05, 2019 9:12 pm
Forum: Gaming
Topic: Minecraft On RPI3 Buster
Replies: 3
Views: 183

Re: Minecraft On RPI3 Buster

Try running sudo raspi-config and changing the gl driver in advanced.
by Marekkon5
Sat Oct 05, 2019 8:57 pm
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)

try chmod -R 777 ../mmlpi Then python3.7 mmlpi.py (without sudo). same error in orange, when i do python3 mmlpi.py (without sudo) it still gives me no tqdm installed if i do python3.7 mmlpi.py it gives me the no permissions to the /home/****/mmlpi/minecraft directory and with sudo it gives me no tki...
by Marekkon5
Sat Oct 05, 2019 8:40 pm
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)

On Gentoo the pip dependencies have to be installed as user. Try starting python3 mmlpi.py without sudo. If you wish to use Python3.7 run: python3.7 -m pip install --user -r requirements.txt To install the new dependencies. Then try python3.7 mmlpi.py ok, so the install now goes without errors but w...
by Marekkon5
Sat Oct 05, 2019 6:11 pm
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)

No, it doesn't. But it sets Oracle Java as the main Java, so you don't have to uninstall it.
Golden_cookie wrote:
Sat Oct 05, 2019 5:20 pm
Does it delete openjdk?
Marekkon5 wrote:
Sat Oct 05, 2019 2:52 pm
I updated my launcher. Added Gentoo support (including Oracle Java), rewrote whole install script.
by Marekkon5
Sat Oct 05, 2019 2:52 pm
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)

I updated my launcher. Added Gentoo support (including Oracle Java), rewrote whole install script.
by Marekkon5
Wed Oct 02, 2019 9:47 am
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)

Hello. I was successfull installing tkinter by editing /etc/portage/make.conf and inserting dev-lang/python tk to the USE line. nano /etc/portage/make.conf USE="dev-lang/python tk" emerge --newuse It installed tkinter to python3.7 so i had to run then: python3.7 -m pip install --user -r requirements...
by Marekkon5
Tue Oct 01, 2019 4:49 am
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)

Try running sudo python3 -m pip install -r requirements.txt I will clean up the code and make it work on Gentoo later. Maybe localInstall.sh didn't actually complete? It should run pip3 to install everything listed in requirements.txt, including cli_ui. You can try running it again and watch for err...
by Marekkon5
Sun Sep 08, 2019 6:33 pm
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)

Seems like it. The install script wont install Oracle Java if Java already is installed. It can be force-installed by running: cd mmlpi sudo bash installJava.sh arm32 Looks like Oracle Java didn’t install: OpenJDK Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will li...
by Marekkon5
Sun Sep 08, 2019 6:21 pm
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)

Hello. Which version of Minecraft are you trying to run? Could you also please post your java version. Thank you. java -version Can someone please help me, i dont know what i did wrong. I installed the launcher on my RPi4 4gb and when i try to run any version it gives me this error: Please Wait... M...
by Marekkon5
Wed Aug 21, 2019 5:29 pm
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)

I updated the launcher. Added GUI, Most LWJGL2 Versions should work now, Launch Script export option, Oracle Java.
by Marekkon5
Tue Aug 20, 2019 3:52 pm
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.14 (+ OptiFine, Forge)

There isn't currently a simple way to do it, but if you're using my launcher then: 1. Install version 1.14.3 2. Install OptiFine using the Tools/Install Optifine menu 3. Replace the binaries with those jdonald shared: cd ~/mmlpi/minecraft/bin/natives/ rm -rf LWJGL3 wget https://www.dropbox.com/s/y6g...
by Marekkon5
Tue Aug 20, 2019 3:37 pm
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.14 (+ OptiFine, Forge)

That reminded me to try to fix the OptiFine. I will switch to Gentoo for testing on the Pi3B then, but I don't know any Pi4 arm64 OSes which have GPU rendering and all those features. Thank you. Congrats on getting most LWJGL2 versions to run. Hopefully that resolves the 1.12.2 and 1.8.9 problems in...
by Marekkon5
Tue Aug 20, 2019 8:55 am
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.14 (+ OptiFine, Forge)

My setup: RPi 4 with 4GB RAM - Running latest Raspbian (arm32) RPi 3B with Pi64: https://github.com/bamarni/pi64 On both Pis I am running latest Oracle Java, tested LWJGL2 versions work. Lastest LWJGL3 Version (from https://www.lwjgl.org/browse/nightly/linux/) - No versions are working on both (32 a...
by Marekkon5
Mon Aug 19, 2019 3:59 pm
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.14 (+ OptiFine, Forge)

Thank you so much. BTW I just managed to get running LWJGL2 versions on 64bit.
rpiMike wrote:
Mon Aug 19, 2019 3:45 pm
Hopefully this has what you need:

https://www.dropbox.com/s/0x765uoy6ihj3 ... m64.tar.gz
by Marekkon5
Mon Aug 19, 2019 3:41 pm
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.14 (+ OptiFine, Forge)

Could you please share the .so files? I wasn't able to compile the older version from source. Thank you I also get a SIGSEV JVM error with 3.2.3 nightly on Gentoo 64bit. I do have an older lwjgl3 that still works with 1.14.4 and Optifine, however fps is low and sound corrupt. Edit: played for 5 mins...
by Marekkon5
Mon Aug 19, 2019 11:52 am
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.14 (+ OptiFine, Forge)

I was able to run it on arm32 Raspbian using the nightly binaries from: https://www.lwjgl.org/browse/nightly/linux/arm32 . But using the latest version returns a SIGSEV JVM error. Same for arm64 (for me). Please let me know if you have any working libraries. Thanks for building this and sharing. I t...
by Marekkon5
Mon Aug 19, 2019 8:53 am
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.14 (+ OptiFine, Forge)

Hello. Thank you for the info, I'll use that idea. Currently I am unable to get working any lwjgl3 versions so it will be delayed. Awesome, looking forward to trying it out. For getting Oracle Java 8, you can take a look at rpiMike's setupMC1.sh . He stored the .tar.gz in his own Dropbox folder and ...
by Marekkon5
Sat Aug 17, 2019 7:09 pm
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.14 (+ OptiFine, Forge)

Hello. Thank you for the suggestions and info. I am currently working on new big update which will support arm64 (for lwjgl3). About Java - I used OpenJDK because it was easier for me to install and include in the install script. Oracle Java isnt in the apt repositories anymore and if you want to do...
by Marekkon5
Tue Aug 06, 2019 2:58 pm
Forum: Gaming
Topic: Minecraft 1.13 on Raspberry Pi 3
Replies: 17
Views: 14974

Re: Minecraft 1.13 on Raspberry Pi 3

I've managed to get running Minecraft 1.14 on the Raspberry Pi. Due to poor optimalisations it is barely playable. You can try it using my launcher (https://www.raspberrypi.org/forums/viewtopic.php?f=78&t=245947&p=1514233#p1514233) or manually download and rename the libraries from nightly LWJGL3 bu...
by Marekkon5
Tue Aug 06, 2019 2:55 pm
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.14 (+ OptiFine, Forge)

Thanks for building this and sharing. I tried out today on a Pi 3B+ mainly to settle my curiosity around version 1.14 and LWJGL3. To be clear for everyone, this does not require a 64-bit OS. Thoughts: * At first glance your script uses OpenJDK 8's JRE. Won't this make everything 2x slower compared ...
by Marekkon5
Tue Aug 06, 2019 2:52 pm
Forum: Gaming
Topic: Is it possible to run and record Minecraft simultaneously in Raspberry Pie 4?
Replies: 2
Views: 1587

Re: Is it possible to run and record Minecraft simultaneously in Raspberry Pie 4?

If you don't mind lower FPS then you can record the VNC.
by Marekkon5
Wed Jul 17, 2019 6:40 am
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

Re: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.14 (+ OptiFine, Forge)

rpiMike wrote:
Tue Jul 16, 2019 9:13 pm
Might be nice to get a credit as you are linking to files from my dropbox account !
Yes, I am sorry, I've used your files for testing and forgot to replace them with official/own ones. I will fix it

EDIT: Now using my libraries and added credits on GitHub
by Marekkon5
Tue Jul 16, 2019 7:57 pm
Forum: Gaming
Topic: mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)
Replies: 48
Views: 6177

mmlpi - Minecraft Launcher for Raspberry Pi. Versions 1.0 - 1.12+ (+ OptiFine, Forge)

mmlpi - Minecraft Modern (Java Edition) Launcher for Raspberry Pi Supports Versions 1.0 - 1.12 (1.13+ are supported, but aren't working now because of not working LWJGL3 libraries) Both arm32 and arm64 support Raspbian (and any other Debian based distro), Gentoo now supported OptiFine, Forge Suppor...
by Marekkon5
Wed Feb 06, 2019 4:26 pm
Forum: Advanced users
Topic: Diable the device connected dialog
Replies: 0
Views: 103

Diable the device connected dialog

Hello, how do I disable the new device connected dialog? Thank you

https://i.imgur.com/4h7sUyQ.png
Image
by Marekkon5
Wed Jan 20, 2016 7:31 pm
Forum: HATs and other add-ons
Topic: Wi-Fi USB Problem 2
Replies: 2
Views: 681

Wi-Fi USB Problem 2

Hello, some months ago I posted: https://www.raspberrypi.org/forums/viewtopic.php?f=45&t=122028 I had a problem about my Wifi USB Dongle in Raspberry Pi. Evrything worked till now. I purchased a SPI Display for Raspberry Pi and drivers from the display blocks updates for Raspberry Pi, so I am stuck ...

Go to advanced search