Go to advanced search

by castletonroad
Fri Aug 09, 2019 11:25 am
Forum: Networking and servers
Topic: rPi 4 with 4GB as an incoming and outgoing email server?
Replies: 2
Views: 244

Re: rPi 4 with 4GB as an incoming and outgoing email server?

My rpi3B works great with postfix / dovecot / spamassasin / dmarc / fail2ban / apache2 + rainloop. I've all-but-ditched the my gmail account, using instead my private email server. I also run nextcloud on the rpi3, and will be upgrading to a rpi4 soon, as it cannot serve my media fast enough. The rp...
by castletonroad
Fri Jul 19, 2019 9:26 pm
Forum: Raspbian
Topic: How to get latest apache2 and php versions on Raspbian Os
Replies: 21
Views: 3319

Re: How to get latest apache2 and php versions on Raspbian Os

@geev03

Yes, but can you confirm that you have this running successfully on a raspberry pi? The issue is with php-7.3 being difficult on Raspbian...
by castletonroad
Tue Jul 02, 2019 5:42 am
Forum: Networking and servers
Topic: [SOLVED] postfix / dovecot deleted email retention policy / setting
Replies: 3
Views: 180

[SOLVED] Re: postfix / dovecot deleted email retention policy / setting

What a fool I am...

My iPhone had Accounts > Advanced > Deleted Messages: Remove after one week.

And on reflection, I read/delete emails mostly on my iPhone; and my server/email is not an exchange-type account.

Sorted :)
by castletonroad
Mon Jul 01, 2019 9:39 pm
Forum: Networking and servers
Topic: [SOLVED] postfix / dovecot deleted email retention policy / setting
Replies: 3
Views: 180

Re: postfix / dovecot deleted email retention policy / setting

@rpdom, thanks for this.

I use Rainloop as a web client, and Thunderbird as my desktop client.

In Thunderbird, under Account > Properties > Retention Policy, I have 'Use my account settings' checked.

I'm stumped...
by castletonroad
Mon Jul 01, 2019 11:42 am
Forum: Networking and servers
Topic: [SOLVED] postfix / dovecot deleted email retention policy / setting
Replies: 3
Views: 180

[SOLVED] postfix / dovecot deleted email retention policy / setting

I have a postfix / dovecot server configured and running well. Checking my 'Trash' folder, I had expected to see all of my deleted email - but there are only the last five days' worth of deleted emails. I can't seem to figure out which postfix / dovecot .conf file I should tweak (and with what setti...
by castletonroad
Sat Jun 22, 2019 10:55 pm
Forum: Advanced users
Topic: Resize image for use on a smaller sd card
Replies: 34
Views: 91528

Re: Resize image for use on a smaller sd card

paragon backup free version 17 (the current one) only backs up, there is no simple restore functionality. i wasted too much time on this; i'll try version 14. I spent a good while trying to work out v17, before finally realising the restore capability is not there. A Google search located v14, whic...
by castletonroad
Thu May 16, 2019 7:21 am
Forum: General discussion
Topic: Raspberry Pi Zero + old dynadock
Replies: 4
Views: 745

Re: Raspberry Pi Zero + old dynadock

Ah, all good now.

ifconfig shows a 'usb0' device; plugged in a CAT5 cable and we're good.

Not sure why this was not showing when I first hooked up teh dock to the pi...
by castletonroad
Thu May 16, 2019 6:49 am
Forum: General discussion
Topic: Raspberry Pi Zero + old dynadock
Replies: 4
Views: 745

Re: Raspberry Pi Zero + old dynadock

My pi3B does not seem to detect the networking interface of the Toshiba (U3) dock. Currently my pi can use the dock as a powered USB hub, but I would like to get the network on this as well. (It's headless, so I'm not fussed about the display.) Anyone else got their pi working with networking throug...
by castletonroad
Wed May 01, 2019 11:07 am
Forum: Raspbian
Topic: How to get latest apache2 and php versions on Raspbian Os
Replies: 21
Views: 3319

Re: How to get latest apache2 and php versions on Raspbian Os

Hmmm...

I followed OP's advice, but Nextcloud was still reporting PHP7.0xxx, despite php -v showing that PHP7.3 was installed.

I purged 7.0x.... and then my Apache setup stopped working - couldn't process php pages.

Wasn't sure where to go with this, so have reverted to PHP7.0x as per stretch...
by castletonroad
Tue Apr 30, 2019 9:27 am
Forum: Networking and servers
Topic: Nextcloud: help to convert database from SQLite to MySQL
Replies: 6
Views: 674

Re: Nextcloud: help to convert database from SQLite to MySQL [SOLVED]

I'm marking this as solved. All that was required was to: 1. Create the new SQL user 2. Create the new database 3. Run the command 'php occ db:convert-type --all-apps mysql oc_mysql_user 127.0.0.1 new_db_name' See: https://www.a2hosting.com/kb/developer-corner/mysql/managing-mysql-databases-and-user...
by castletonroad
Mon Apr 29, 2019 8:29 pm
Forum: Networking and servers
Topic: Nextcloud: help to convert database from SQLite to MySQL
Replies: 6
Views: 674

Re: Nextcloud: help to convert database from SQLite to MySQL

@bzt Thanks very much for this, I really appreciate you taking the time to document these steps. I am completely inexperienced with SQL, and so even with your clear steps, I'm not confident in getting this to work (without messing my working configuration). Your steps are very different to what Next...
by castletonroad
Mon Apr 29, 2019 9:40 am
Forum: Networking and servers
Topic: Nextcloud: help to convert database from SQLite to MySQL
Replies: 6
Views: 674

Re: Nextcloud: help to convert database from SQLite to MySQL

@DougieLawson - thanks, I'll check this out

@Andyroo - my Nextcloud server admin page 'self-diagnoses' that to improve performance, I should migrate the database. Other than that, it all works fine. Just trying to eek the most performance I can out of the little pi...
by castletonroad
Sun Apr 28, 2019 11:05 am
Forum: Networking and servers
Topic: Nextcloud: help to convert database from SQLite to MySQL
Replies: 6
Views: 674

Nextcloud: help to convert database from SQLite to MySQL

Hi, I have Nextcloud up-and-running perfectly - other than I went (unknowingly) with the default database setup of sqlite, not myql. I am fairly handy with the pi (set up my own magicmirror, and email server) but I have absolutely no experience with mysql. Has anyone successfully converted their Nex...
by castletonroad
Fri Apr 21, 2017 1:10 pm
Forum: Troubleshooting
Topic: OpenVPN tun0 & tun1 problems
Replies: 5
Views: 2505

Re: OpenVPN tun0 & tun1 problems

C'mon. Bump! Please...
by castletonroad
Mon Apr 17, 2017 9:22 am
Forum: Troubleshooting
Topic: OpenVPN tun0 & tun1 problems
Replies: 5
Views: 2505

Re: OpenVPN tun0 & tun1 problems

I'm sorry, I'm not clear what you mean. If I stop the VPN client service, connections to the Server work fine. As soon as I start the VPN client, I can no longer connect tto the server. The client is routing tun1 correctly. I'm sure it's something to do with routing between tun0 and tun1, just not s...
by castletonroad
Mon Apr 17, 2017 7:12 am
Forum: Troubleshooting
Topic: OpenVPN tun0 & tun1 problems
Replies: 5
Views: 2505

Re: OpenVPN tun0 & tun1 problems

Hi, My /etc/network/interfaces file: source-directory /etc/network/interfaces.d auto lo iface lo inet loopback auto eth0 iface eth0 inet manual pre-up /etc/firewall-openvpn-rules.sh allow-hotplug wlan0 iface wlan0 inet manual wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf The /etc/firewall-openvpn...
by castletonroad
Sun Apr 16, 2017 1:10 am
Forum: Troubleshooting
Topic: OpenVPN tun0 & tun1 problems
Replies: 5
Views: 2505

OpenVPN tun0 & tun1 problems

Hi, I have set up an OpenVPN server on my Pi2 so that I can remotely access my home network when away from the house. This uses tun0, and VPN on port 4444. (I followed this tutorial http://readwrite.com/2014/04/10/raspberry-pi-vpn-tutorial-server-secure-web-browsing/ ). This configuration works perf...
by castletonroad
Thu Apr 06, 2017 12:45 am
Forum: Beginners
Topic: New RealVNC server config
Replies: 8
Views: 5101

Re: New RealVNC server config

Set the pi resolution via /boot/config.txt

I then also use 'zoom' in the VNC viewer on the PC to fill the pi screen to the viewer window.
by castletonroad
Sat Nov 19, 2016 10:03 am
Forum: Beginners
Topic: server and access point on same Pi?
Replies: 3
Views: 788

Re: server and access point on same Pi?

My Pi server is just running Raspian Jessie with Samba running with shares defined. I'm going to be getting rid of my cable broadband service due to the cost and bills I need to pay. In another thread people told me about setting up the Pi as an access point so I can still connect all my devices to...
by castletonroad
Sat Nov 19, 2016 9:58 am
Forum: Troubleshooting
Topic: eth0 speed affected by connected USB thumb drives?
Replies: 0
Views: 232

eth0 speed affected by connected USB thumb drives?

My Pi runs Squid web cache, and I thought I'd be smart by caching the files on a connected USB thumb drive. But I now understand that the NIC and USBs share the same bus, and therefore my arrangement may not be so smart. Other than the difference between writing/caching to a USB stick vs. an SD card...
by castletonroad
Thu Nov 17, 2016 8:10 pm
Forum: Networking and servers
Topic: set a new static IP fails
Replies: 7
Views: 1150

Re: set a new static IP fails

Ensure your system is updated (running Jessie, not Wheezey).

Reset the interfaces file to its default configuration.

Configure static IP, instead, via /etc/dhcpcd.conf.

(And/or set static IP on the router)
by castletonroad
Tue Nov 08, 2016 10:13 am
Forum: Beginners
Topic: Pi as "network" (not sure what to say here)
Replies: 19
Views: 3021

Re: Pi as "network" (not sure what to say here)

I used this link to set up my Pi3 as a WiFI AP: http://raspberrypihq.com/how-to-turn-a-raspberry-pi-into-a-wifi-router/ Note, part of the tutorial states: The last step in configuring the DHCP server is to configure a static ip address for the wireless network adapter. This is done in the file /etc/...
by castletonroad
Sun Oct 30, 2016 1:11 am
Forum: Troubleshooting
Topic: DNSMASQ problem
Replies: 4
Views: 6025

[SOLVED] Re: DNSMASQ problem

Code: Select all

allow-hotplug wlan0   << Unhashed this line in /etc/network/interfaces
iface wlan0 inet static
 address 192.168.10.1
 netmask 255.255.255.0
 network 192.168.10.0
 broadcast 192.168.10.255
Works a treat now.
by castletonroad
Sat Oct 29, 2016 11:35 pm
Forum: Troubleshooting
Topic: DNSMASQ problem
Replies: 4
Views: 6025

Re: DNSMASQ problem

Yes. But see the following course of action... 1. '#'d out bind-interfaces, and then rebooted. 2. ifconfig output: wlan0 Link encap:Ethernet HWaddr b8:27:eb:fe:7f:3a inet6 addr: fe80::ba27:ebff:fefe:7f3a/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:120932 errors:0 droppe...

Go to advanced search