Go to advanced search

by joro
Thu Aug 08, 2019 11:37 am
Forum: Troubleshooting
Topic: Old sdcard, New RPI4 -> not booting
Replies: 7
Views: 326

Re: Old sdcard, New RPI4 -> not booting

Starting with a fresh install is also my recommendation, considering the major differences: We do not recommend upgrading an existing Stretch (or earlier) system to Buster – we can’t know what changes everyone has made to their system, and so have no idea what may break when you move to Buster. How...
by joro
Thu Aug 08, 2019 8:10 am
Forum: Troubleshooting
Topic: Old sdcard, New RPI4 -> not booting
Replies: 7
Views: 326

Re: Old sdcard, New RPI4 -> not booting

Have you got the start4.elf and fixup4.dat files in the boot partition? Generally, upgrading is not recommended*. The proper course of action is to start with a fresh copy of Buster. If you've got a spare card it might be worth trying that just to make sure the 4B does boot correctly. It does (I wr...
by joro
Thu Aug 08, 2019 6:16 am
Forum: Troubleshooting
Topic: Old sdcard, New RPI4 -> not booting
Replies: 7
Views: 326

Old sdcard, New RPI4 -> not booting

I have bought an RPI4 and hoped that I could just stick the microsd card from my old system into it and I would be good to go. The old card contains an up-to-date Raspbian Buster (upgraded from Stretch). Yet it fails to boot. The RPI4 boots fine from a fresh Raspbian buster SD card. I have understoo...
by joro
Mon May 18, 2015 1:44 pm
Forum: Troubleshooting
Topic: Boot fails after move to Jessie
Replies: 13
Views: 16409

Re: Boot fails after move to Jessie

Obviously, this is related to cgroups. After removing cgmanager, cgroup-bin and cgroup-tools, things are back to normal. I am not sure what these tools are used for in raspbian. cgmanager is a dependency of systemd-shim, however, without systemd-shim, the system runs just fine.
by joro
Mon May 18, 2015 1:25 pm
Forum: Raspbian
Topic: Systemd Jessie errors
Replies: 29
Views: 21443

[SOLVED] Re: Systemd Jessie errors

The Debian systemd maintainer, Michael Biebl had the solution: Obviously cgmanager somehow messed with systemd. I removed cgmanager, cgroup-bin, cgroup-tools, after which systemd works just fine..
by joro
Sat May 16, 2015 9:40 pm
Forum: Raspbian
Topic: Systemd Jessie errors
Replies: 29
Views: 21443

Re: Systemd Jessie errors

Just for the record, I have submitted a bug report about this to Debian, https://bugs.debian.org/cgi-bin/bugrepo ... bug=785484
by joro
Fri May 15, 2015 11:16 pm
Forum: Raspbian
Topic: Systemd Jessie errors
Replies: 29
Views: 21443

Re: Systemd Jessie errors

But are these problems specific to Raspbian? Because Debian 8 w/systemd on RPi2 seems to have no such problems and this was even when it was still testing and not stable. I am using Jessie on two laptops without issues, and I am using another distro using systemd, namely Arch Linux, on my main Rasp...
by joro
Fri May 15, 2015 11:00 pm
Forum: Troubleshooting
Topic: Boot fails after move to Jessie
Replies: 13
Views: 16409

Re: Boot fails after move to Jessie

Hi, same here, today upgraded from wheezy to jessie and with systemd doing the init, several services fail and one cannot login. Fortunately, there is the systemd-debug-shell command line parameter, which at least allows me to check some of the details of what has failed. My guess is, that all the f...

Go to advanced search