Go to advanced search

by TerryC65
Fri Aug 23, 2019 11:11 am
Forum: Raspbian
Topic: Is there a bug in raspi-config in Buster Lite?
Replies: 5
Views: 237

Re: Is there a bug in raspi-config in Buster Lite?

Wouldn't it be nice if raspi-config had an entry for the 'Official Raspberry Pi Keyboard'? ;)
by TerryC65
Fri Aug 23, 2019 11:08 am
Forum: Raspbian
Topic: Is there a bug in raspi-config in Buster Lite?
Replies: 5
Views: 237

Re: Is there a bug in raspi-config in Buster Lite?

DougieLawson wrote:
Fri Aug 23, 2019 10:47 am
You can make a change with sudo nano /etc/default/keyboard to set the right keyboard definition.
Thanks Dougie. Somewhere in the mists that are all that are left of my memory I remember doing that once before! I can't remember why, but I certainly recall doing it.
by TerryC65
Fri Aug 23, 2019 10:40 am
Forum: Raspbian
Topic: Is there a bug in raspi-config in Buster Lite?
Replies: 5
Views: 237

Re: Is there a bug in raspi-config in Buster Lite?

So there's no way that I can fix this other than to make an new SD Card from the Buster image and set it up with the new KB?
by TerryC65
Fri Aug 23, 2019 10:33 am
Forum: Raspbian
Topic: Is there a bug in raspi-config in Buster Lite?
Replies: 5
Views: 237

Is there a bug in raspi-config in Buster Lite?

Hi, I may have stumbled across this by a round about route, but it is driving me wild. A week or two ago I downloaded the image for Raspbian Lite and set up an SD Card to use with our project. At the time I had an old cheapo US layout keyboard and I remember I had some problems setting it up in rasp...
by TerryC65
Mon May 27, 2019 6:06 am
Forum: Raspbian
Topic: Audio Distortion using mpg321/123 or aplay
Replies: 14
Views: 1097

Re: Audio Distortion using mpg321/123 or aplay

It seems Pulseaudio isn't installed by default on the full fat Raspbian either, but some other software install pulls it in as I found it on my system when the impaired audio started after the Kernel upgrade. Removing Pulseaudio sorted the sound issue out for me without having any other obvious dow...
by TerryC65
Sun May 26, 2019 6:31 pm
Forum: Raspbian
Topic: Audio Distortion using mpg321/123 or aplay
Replies: 14
Views: 1097

Re: Audio Distortion using mpg321/123 or aplay

Chimneyfactory wrote:
Sun May 26, 2019 6:25 pm
The solution/workaround for me was to remove pulseaudio.
Pulseaudio wasn't installed on Raspbian Lite so I tried installing it!

No improvement and no worse either.
by TerryC65
Sun May 26, 2019 12:54 pm
Forum: Raspbian
Topic: Audio Distortion using mpg321/123 or aplay
Replies: 14
Views: 1097

Re: Audio Distortion using mpg321/123 or aplay

So back to the same problem. I'm still not sure if this is a Raspbian problem, an audio driver problem or what. Since I experienced it on the Pi 3 with mpg321 but was able to play the same file OK with omxplayer, I'm leaning towards the audio driver, perhaps being masked with a more powerful proces...
by TerryC65
Sat May 25, 2019 4:08 pm
Forum: Raspbian
Topic: Audio Distortion using mpg321/123 or aplay
Replies: 14
Views: 1097

Re: Audio Distortion using mpg321/123 or aplay

So for anyone who ends up in this situation, this is what worked: omxplayer -o alsa:hw:1,0 01-Giacomo_Puccini-Madama_Butterfly-Un_bel_dì_vedremo.mp3 Actually it didn't. It worked when I ran it on my Pi 3, but when I transferred the SD Card to the target Pi Zero, the problem recurred. This is strang...
by TerryC65
Sat May 25, 2019 1:18 pm
Forum: Raspbian
Topic: Audio Distortion using mpg321/123 or aplay
Replies: 14
Views: 1097

Re: Audio Distortion using mpg321/123 or aplay

DougieLawson wrote:
Sat May 25, 2019 1:10 pm
Have you updated to the 4.19.42 kernel (which is now the stock (apt-get) kernel - there's no need for rpi-update)?
Yes. uname -a gives 4.19.42+
by TerryC65
Sat May 25, 2019 11:33 am
Forum: Raspbian
Topic: Audio Distortion using mpg321/123 or aplay
Replies: 14
Views: 1097

Re: Audio Distortion using mpg321/123 or aplay

I had used alsamixer earlier (I'm fairly sure I was the Raspbian Lite instance) and it worked. I just tried to invoke it now and I get 'cannot open mixer: no such file or directory'. :!: I worked it out :D alsamixer refuses to load if the default sound device is missing. I suppose it was telling me...
by TerryC65
Sat May 25, 2019 10:27 am
Forum: Raspbian
Topic: Audio Distortion using mpg321/123 or aplay
Replies: 14
Views: 1097

Re: Audio Distortion using mpg321/123 or aplay

Try using alsamixer to set the master volume and enjoy the crude terminal graphics. This is weird! I had used alsamixer earlier (I'm fairly sure I was the Raspbian Lite instance) and it worked. I just tried to invoke it now and I get 'cannot open mixer: no such file or directory'. :!: I tried insta...
by TerryC65
Sat May 25, 2019 10:00 am
Forum: Raspbian
Topic: Audio Distortion using mpg321/123 or aplay
Replies: 14
Views: 1097

Re: Audio Distortion using mpg321/123 or aplay

Try using omxplayer. Thanks. That works, although the volume is a bit low. I tried using 'omxplayer --vol' and 'omxplayer --amp' to change it, but it seems to have no effect. I'd still like to know why mpg123 worked in 2017 (and when invoked through mplayer) but not now. (Enquiring minds want to kn...
by TerryC65
Sat May 25, 2019 9:39 am
Forum: Raspbian
Topic: Audio Distortion using mpg321/123 or aplay
Replies: 14
Views: 1097

Audio Distortion using mpg321/123 or aplay

Hi, My latest project is to provide a simple MP3 player to play sound effects at our local Model Town. It is running Raspbian Lite on a Pi Zero with a USB Audio Adaptor to hear the sound, but I've also tested this problem with the full Raspbian installation through the analogue jack socket. Both ins...
by TerryC65
Thu May 16, 2019 6:48 am
Forum: Troubleshooting
Topic: Cannot open nano in boot shell
Replies: 10
Views: 905

Re: Cannot open nano in boot shell

This is completely happening to me as well. What do I type into .bashrc in order to make this change persistent? I tried just adding the language to the bottom of the file and it made my system flicker and was unresponsive. How long ago did you download your copy of Raspbian? I've downloaded it sev...
by TerryC65
Tue May 14, 2019 12:05 pm
Forum: Troubleshooting
Topic: Cannot get xinetd to serve time for rdate
Replies: 1
Views: 115

Re: Cannot get xinetd to serve time for rdate

I've fixed it. :) It was a dumb mistake; the default config files in xinetd.d all have the services disabled. I just had to change 'disabled=yes' to 'no'. I don't remember doing that in 2017, (but then I didn't remember having to install xinetd in the first place). :oops: Hopefully, this posting won...
by TerryC65
Tue May 14, 2019 11:02 am
Forum: Troubleshooting
Topic: Cannot get xinetd to serve time for rdate
Replies: 1
Views: 115

Cannot get xinetd to serve time for rdate

Hi, Back in Sept 2017, I installed a RASClock on the 'master' Pi at our local model town and utilised rdate on all the remote Pis to synchronise the clocks to the master Pi. At the time, I had one or two problems, the worst being that I hadn't realised that the master Pi needed a time server to resp...
by TerryC65
Thu May 09, 2019 2:06 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Pi 3.3 V Specification
Replies: 4
Views: 407

Re: Pi 3.3 V Specification

Why don't you use the DC characteristics and power supply operating range of the Compute Module? In case your GPIO0-27_VDD is 3.3V +/-5% your GPIO output voltage will be the same. https://www.raspberrypi.org/documentation/hardware/computemodule/datasheets/rpi_DATA_CM3plus_1p0.pdf Thanks. That's exa...
by TerryC65
Thu May 09, 2019 2:04 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Pi 3.3 V Specification
Replies: 4
Views: 407

Re: Pi 3.3 V Specification

Assuming a Pi 3B+; looking at the MxL7704-AQB/XQB datasheet the 3V3 voltage which goes to the GPIO connector pins can range from 3V0 to 3V6 in 20mV steps. The MxL7704-R3 has no publicly available datasheet but could be presumed to be similar, approximately 3V3+/-10%. Other Pi would probably be simi...
by TerryC65
Thu May 09, 2019 11:35 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Pi 3.3 V Specification
Replies: 4
Views: 407

Pi 3.3 V Specification

Hi, I'm writing a test spec for a bit of hardware that we will be producing in some quantities for a system that we are installing at a our local model town. In the spec, I am instructing the maker to check the voltage going to a particular IC and this voltage is the 3.3 V from the Pi. I'd like to p...
by TerryC65
Sun Mar 31, 2019 9:02 am
Forum: Other projects
Topic: Problem with False Detection Using wait_for_edge
Replies: 4
Views: 429

Re: Problem with False Detection Using wait_for_edge

Hi, I completed integration of this project yesterday, so I thought I ought to share how I overcame the issue highlighted in this Topic. As I suspected, noise was the problem. The main source of noise turned out to be the PWM controlling the train! When I monitored the sensor signal lines originally...
by TerryC65
Wed Mar 27, 2019 9:15 am
Forum: Other projects
Topic: Problem with False Detection Using wait_for_edge
Replies: 4
Views: 429

Re: Problem with False Detection Using wait_for_edge

Most would suggest putting a simple R-C debounce circuit for the triggers The problem is that it isn't bounce. The sensors haven't activated and when they do it's solid. The false triggers are coming from noise (I think) so I suspect that a debounce circuit, especially one using a Schmitt Trigger, ...
by TerryC65
Tue Mar 26, 2019 5:26 pm
Forum: Other projects
Topic: Problem with False Detection Using wait_for_edge
Replies: 4
Views: 429

Problem with False Detection Using wait_for_edge

Hi, I have an ongoing project which involves controlling a model train which runs backwards and forwards over a short track. The train has to stop at four places over the track. I am using the following circuit (this is a fragment of the full diagram): Underground_Railway_Circuit(V0.6).png The IR se...
by TerryC65
Fri Mar 15, 2019 10:54 am
Forum: Graphics, sound and multimedia
Topic: I'm looking for a reasonable miniature HDMI monitor
Replies: 43
Views: 2756

Re: I'm looking for a reasonable miniature HDMI monitor

k-pi wrote:
Fri Mar 15, 2019 10:52 am
I use all of them with my RPi3B, Rpi3B+, & RPi3A+.

I also use them with my Desktop Intel SOC computer, & the base of a netbook, which I boot from an SDHC card. ;)
Thanks. I feel a Birthday coming on :D
by TerryC65
Fri Mar 15, 2019 9:51 am
Forum: Graphics, sound and multimedia
Topic: I'm looking for a reasonable miniature HDMI monitor
Replies: 43
Views: 2756

Re: I'm looking for a reasonable miniature HDMI monitor

Not sure if this will help you, but I admin a Minecraft SMP server using SSH, and I run the server software with the screen command. .... I can then SSH in later and enter screen -r minecraft to see current and recent output from the sever. Control+A followed by D detaches the screen session and I ...
by TerryC65
Fri Mar 15, 2019 9:41 am
Forum: Graphics, sound and multimedia
Topic: I'm looking for a reasonable miniature HDMI monitor
Replies: 43
Views: 2756

Re: I'm looking for a reasonable miniature HDMI monitor

k-pi wrote:
Thu Mar 14, 2019 7:36 pm
I use Eyoyo small monitors, (built in speakers), with my computers, they have HDMI & VGA connections, & I use both, depending on machine I attach them to.
Just to clarify; do you use these with a Raspberry Pi? If so, which model?

Go to advanced search