Go to advanced search

by dave_p
Sun Nov 03, 2019 1:10 pm
Forum: Advanced users
Topic: Troublesome TCP SYNs
Replies: 2
Views: 749

Re: Troublesome TCP SYNs

I've been seeing these for the last week. The source IPs (presumably spoofed) belong to hosting and cloud providers, and each IP sends roughly one SYN per minute. The largest number of different IPs I've seen at one time is 384. This article suggests a way of automating countermeasures, though facin...
by dave_p
Mon Oct 28, 2019 9:19 pm
Forum: Raspbian
Topic: Raspbian buster bluetooth failure after 2019.09.16 update
Replies: 34
Views: 2829

Re: Raspbian buster bluetooth failure after 2019.09.16 update

@PhilE many thanks for the reply.

Replacing the three brcmfmac43455* files in /lib/firmware/brcm with the previous versions fixes bluetooth keyboard on my test SD - it wasn't necessary to downgrade the bluetooth firmware.

Thanks again.
by dave_p
Mon Oct 28, 2019 2:39 pm
Forum: Raspbian
Topic: Raspbian buster bluetooth failure after 2019.09.16 update
Replies: 34
Views: 2829

Re: Raspbian buster bluetooth failure after 2019.09.16 update

I built a fresh SD card from the current Raspbian image (2019.09.24); the bluetooth keyboard worked. I then upgraded the packages one-by-one to the latest version, testing the bt keyboard each time. The package which 'broke' the keyboard was firmware-brcm80211. OK this may not be a valid test, as th...
by dave_p
Mon Oct 28, 2019 9:59 am
Forum: Troubleshooting
Topic: Bluetooth Devices keep disconnecting
Replies: 4
Views: 354

Re: Bluetooth Devices keep disconnecting

Trying to narrow down the problem... I got my Pi4 on 18/9 and bluetooth was working fine for some time after. Now 'bluez' and the userland bluetooth software haven't been updated in that time, so the problem must presumably lie in the kernel or firmware. Unfortunately I've run 'rpi-update' a couple ...
by dave_p
Sun Oct 27, 2019 8:34 am
Forum: Troubleshooting
Topic: Bluetooth Devices keep disconnecting
Replies: 4
Views: 354

Re: Bluetooth Devices keep disconnecting

There is another thread reporting the same problem here: https://www.raspberrypi.org/forums/view ... 6&t=254523

No solution yet unfortunately.
by dave_p
Sat Oct 26, 2019 7:28 pm
Forum: Raspbian
Topic: Raspbian buster bluetooth failure after 2019.09.16 update
Replies: 34
Views: 2829

Re: Raspbian buster bluetooth failure after 2019.09.16 update

Same problem on a fully-updated Pi4 when trying to use an Apple keyboard. Monitoring the bluetooth status with btmon, the initial pairing works OK, then there is a timeout after 20 seconds and pairing is lost. At this point the bluetoothd process goes to 100% CPU. 30 seconds later the Pi re-tries pa...
by dave_p
Sat Mar 21, 2015 4:47 pm
Forum: Other projects
Topic: {Feasibility] Communicating with elderly hearing-impaired
Replies: 0
Views: 352

{Feasibility] Communicating with elderly hearing-impaired

A friend has caring responsibilities for her mother, who lives on her own a few miles away. They keep in touch by landline telephone, but because of her mother's hearing problems it is very difficult sometimes to pass important messages. What is needed is a way for my friend to type a short message ...
by dave_p
Thu Sep 05, 2013 6:54 am
Forum: Camera board
Topic: Motion - MMAL camera
Replies: 472
Views: 392540

Re: Motion - MMAL camera

I've had the same problem others have reported in not being able to view the .avi files in VLC - only the first frame is shown. The solution in my case was to change the following line in motion-mmalcam.conf: ffmpeg_video_codec mpeg4 to ffmpeg_video_codec msmpeg4 The files now play correctly in VLC ...
by dave_p
Tue Jun 11, 2013 11:57 am
Forum: Troubleshooting
Topic: wifi delays with Raspbian 2013-05-25
Replies: 3
Views: 917

Re: wifi delays with Raspbian 2013-05-25

Yes, my CPC / Farnell 'Wi-Pi' dongle is seeing the same effect from a newly downloaded Rasbian. The fix mentioned in http://www.raspberrypi.org/phpBB3/viewt ... 28&t=44897 seems to fix matters, though I only made the change an hour ago.
by dave_p
Sun Jan 13, 2013 4:11 pm
Forum: Advanced users
Topic: Best place to connect power?
Replies: 8
Views: 2609

Re: Best place to connect power?

I didn't build a power supply, I bought one. Maplin order code L45BL - not the cheapest but Maplin's have a shop just down the road.
by dave_p
Thu Dec 06, 2012 10:19 am
Forum: General discussion
Topic: Forum header glitch Midori or Chromium
Replies: 2
Views: 911

Re: Forum header glitch Midori or Chromium

As you were. I had increased the font size on the browser to read a page on another site and forgotten to put it back. The Forum renders fine on Konqueror at default font sizes. Apologies for the noise.
by dave_p
Thu Dec 06, 2012 10:13 am
Forum: General discussion
Topic: Forum header glitch Midori or Chromium
Replies: 2
Views: 911

Re: Forum header glitch Midori or Chromium

Same problem under Konqueror (KDE 4.8.5 on Mageia 2 x86_64), though I'm fairly sure it was OK yesterday. Firefox is fine.
by dave_p
Thu Oct 18, 2012 7:29 pm
Forum: Troubleshooting
Topic: rootfs out of space
Replies: 4
Views: 1672

Re: rootfs out of space

When you get enough free space to let the system boot properly, here are a couple of ways I've used to keep SD space under control: 1. Run apt-get clean This deletes the package files for updates which you have applied, and which are stored in /var/cache/apt/archives/ - depending on how many updates...
by dave_p
Tue Oct 09, 2012 4:56 pm
Forum: Advanced users
Topic: Best place to connect power?
Replies: 8
Views: 2609

Re: Best place to connect power?

Many thanks for the comments. I've connected my power feed to the 5v and 0v pins of the USB sockets (with a beefy 'idiot diode' upstream to guard against connecting the wrong way round) and everything is working well.
by dave_p
Tue Oct 09, 2012 12:28 pm
Forum: Advanced users
Topic: Best place to connect power?
Replies: 8
Views: 2609

Best place to connect power?

I want to use my (version 2) Pi with a USB disk drive and a USB TV card, powering everything from a single 5v 3A supply. Where is the best place to apply the power? The normal micro-USB has a poly fuse which will blow at the estimated 1.5A drawn by this rig. I could connect to TP1 and TP2, but some ...
by dave_p
Wed Oct 03, 2012 7:47 pm
Forum: General discussion
Topic: CPC Product Recall: Power supply
Replies: 8
Views: 4796

Re: CPC Product Recall: Power supply

My copy of the letter arrived this morning. Within the hour there was a delivery man at the door with the traditional CPC one-foot-cube parcel containing a new power supply. No indication as to what to do with the old one.
by dave_p
Mon Sep 10, 2012 1:52 pm
Forum: General discussion
Topic: CPC have Pis for next day delivery
Replies: 21
Views: 4516

Re: CPC have Pis for next day delivery

The order arrived today and the handling charge has indeed been removed from the invoice.

Thanks for the reassurance and for the prompt delivery.
by dave_p
Fri Sep 07, 2012 5:37 pm
Forum: General discussion
Topic: CPC have Pis for next day delivery
Replies: 21
Views: 4516

Re: CPC have Pis for next day delivery

Just ordered from CPC and they are still quoting ex-stock delivery. However I also ordered a USB power supply from the Accessories page and this seems to have nixed the waiving of the handling charge. The confirmation email includes: "Total discount provided from the promotional code £0.00" If my as...
by dave_p
Wed Aug 01, 2012 4:25 pm
Forum: Media centres
Topic: XBian - Small, Fast, Lightweight XBMC solution
Replies: 612
Views: 231939

Re: XBian - Small, Fast, Lightweight XBMC solution

I can't get xBian to use an NFS share, though I've never used xbmc before so it could be finger-trouble... Browsing for the share (which is on a Mageia Linux server) doesn't work, and if I manually enter the path in the Add Source screen I get an 'unable to connect' error. However exiting XMBC and m...
by dave_p
Fri Jul 20, 2012 12:08 pm
Forum: Graphics, sound and multimedia
Topic: OMXPlayer 0.2 video terminates early
Replies: 8
Views: 4306

Re: OMXPlayer 0.2 video terminates early

Looking at the commits between your working and non-working versions this change looks suspicious: + /* seek behind eof */ + if((seek_pts / AV_TIME_BASE) > (GetStreamLength() / 1000)) + { + m_eof = true; + UnLock(); + return false; + } If I read this correctly the video could be stopped early due to...
by dave_p
Wed Jul 04, 2012 4:54 pm
Forum: Raspbian
Topic: OMXPlayer deb packages for Raspbian
Replies: 34
Views: 18893

Re: OMXPlayer deb packages for Raspbian

I'm a bit confused now apart from purging and installing it again you had to do anything else in order to get omxplayer working? I had the same problem. I downloaded the latest .deb file and updated my system using dpkg -i omxplayer_0.1-aecc18b3-armhf.deb which completed without error, but then fou...
by dave_p
Sun Jun 10, 2012 1:23 pm
Forum: Raspbian
Topic: packages you want to see in raspbian
Replies: 133
Views: 36224

Re: packages you want to see in raspbian

Handbrake.

Since we're not allowed to use the hardware to display MPEG-2 a transcoder is necessary.
by dave_p
Sat May 19, 2012 12:30 pm
Forum: Raspbian
Topic: HISTORY: The start of raspbian (Debian Hard Float (armhf) for RPi)
Replies: 613
Views: 361765

Re: Debian Hard Float (armhf) for RPi

The following command may help. # tasksel install standard This will install packages with a "standard" priority which should make the system a bit more mature and look more like a standard Linux installation. On a minimal Debian Wheezy system it adds about 100 or so more packages. If it works and ...
by dave_p
Fri Mar 23, 2012 11:10 am
Forum: General discussion
Topic: Has anyone actually received a board yet?
Replies: 25
Views: 5696

Re: Has anyone actually received a board yet?

<t>I see a new item has been added to the FAQ on the RS site:<br/> <br/> Q - What is compliance testing and why are you doing it?<br/> <br/> A - Compliance testing is an essential part of bringing any electronic product to market. The Raspberry Pi is being tested to make sure it conforms to all the ...
by dave_p
Sun Mar 04, 2012 3:20 pm
Forum: Off topic discussion
Topic: RS Components
Replies: 175
Views: 32999

Re: RS Components

<t>I was among the '06:10' crowd, but having heard nothing I re-registered on Friday morning under a different email address. Last night I received emails confirming both registrations at exactly the same time and with nothing to show where either of them were in the queue. I suppose time will tell....

Go to advanced search