Go to advanced search

by HypnoToad
Mon Oct 14, 2019 2:15 pm
Forum: Raspbian
Topic: QEmu + Raspbian Stretch + Lite IMG Second Partition Extend Free Space
Replies: 1
Views: 117

Re: QEmu + Raspbian Stretch + Lite IMG Second Partition Extend Free Space

Once the partition is resized, try using this command:

Code: Select all

sudo resize2fs /dev/sda2
where /dev/sda2 is the filesystem you need to resize
by HypnoToad
Mon Oct 14, 2019 3:19 am
Forum: Advanced users
Topic: Running Raspbian from USB Devices : Made Easy
Replies: 132
Views: 40374

Re: Running Raspbian from USB Devices : Made Easy

I installed the latest Raspbian Lite - 2019-09-26-raspbian-buster-lite.zip to an SD card, and ran the script which copied the files to the SSD. I downloaded usb-boot (to make sure I'm using the same one you used) and did the same thing (except I used a USB 3 flash drive as I don't have a spare SSD ...
by HypnoToad
Mon Oct 14, 2019 2:23 am
Forum: Advanced users
Topic: Running Raspbian from USB Devices : Made Easy
Replies: 132
Views: 40374

Re: Running Raspbian from USB Devices : Made Easy

Does this script work OK with the Raspberry Pi 4? ... Have I done somthing wrong here? Yes, it works fine with the Raspberry Pi 4 It appears you removed the SD card: [ TIME ] Timed out waiting for device /dev/mmcblk0p1 That's great that it's OK with the Pi 4 :) I did leave the SD card in while it w...
by HypnoToad
Mon Oct 14, 2019 1:05 am
Forum: Advanced users
Topic: Running Raspbian from USB Devices : Made Easy
Replies: 132
Views: 40374

Re: Running Raspbian from USB Devices : Made Easy

Hi, Does this script work OK with the Raspberry Pi 4? I'm trying to boot from an SSD connected to the USB3 port, I installed the latest Raspbian Lite - 2019-09-26-raspbian-buster-lite.zip to an SD card, and ran the script which copied the files to the SSD. After the first reboot I got the following ...
by HypnoToad
Tue Jul 30, 2019 11:02 am
Forum: Troubleshooting
Topic: Found a RPi2 while cleaning out, however it does not boot!
Replies: 10
Views: 471

Re: Found a RPi2 while cleaning out, however it does not boot!

'First, it uses simple USB code to try to read a file pushed to it through the USB hardware.' That only applies to Pi that can be used as USB device, not host. That means the Zero, CM and A models only. The B models do not support it. Possibly the Pi 4B may support it through the USB2 port on the U...
by HypnoToad
Mon Jul 29, 2019 2:38 pm
Forum: Troubleshooting
Topic: STICKY: Using the Troubleshooting Forum
Replies: 29
Views: 65731

Re: STICKY: Using the Troubleshooting Forum

Hi, I have a question about the contents of the ''STICKY: Is your Pi not booting? (The Boot Problems Sticky)' thread, but I can't reply to it as it's locked. Near the bottom if the first post there is a section which details Boot sequence details - does this information apply to all models or only n...
by HypnoToad
Mon Jul 29, 2019 2:21 pm
Forum: Troubleshooting
Topic: 3B+ suddenly died with no video out and solid act led
Replies: 10
Views: 370

Re: 3B+ suddenly died with no video out and solid act led

What voltage do you get if you measure between GND and PP9?
by HypnoToad
Mon Jul 29, 2019 2:12 pm
Forum: Troubleshooting
Topic: Raspberry PI Model 2B not booting up (Nothing on Monitor display) after installing the latest 'Raspbian Buster w deskto
Replies: 7
Views: 258

Re: Raspberry PI Model 2B not booting up (Nothing on Monitor display) after installing the latest 'Raspbian Buster w des

If you have a spare SD card then flash that with the older Raspbian and see if you get anything on the screen then
by HypnoToad
Mon Jul 29, 2019 2:01 pm
Forum: Troubleshooting
Topic: Found a RPi2 while cleaning out, however it does not boot!
Replies: 10
Views: 471

Re: Found a RPi2 while cleaning out, however it does not boot!

An original versions of the 2B requires boot files on a micro-SD card in the micro-SD slot. Without that it has little more functionality than a red LED. Look at the numbering on the Broadcom chip - the large square one. 2836 is the original. 2837 is the later version. It seems I have the early ver...
by HypnoToad
Mon Jul 29, 2019 12:39 pm
Forum: Troubleshooting
Topic: Found a RPi2 while cleaning out, however it does not boot!
Replies: 10
Views: 471

Re: Found a RPi2 while cleaning out, however it does not boot!

The Pi 2B* doesn't support USB boot without some files on the SD card. Currently only the Pi 3B+ support booting from USB/Network without the SD card. It is optional to set that functionality on the 3B, but is permanent once set. The 4B doesn't have that option yet. * I'm not sure about later versi...
by HypnoToad
Mon Jul 29, 2019 10:42 am
Forum: Troubleshooting
Topic: Found a RPi2 while cleaning out, however it does not boot!
Replies: 10
Views: 471

Re: Found a RPi2 while cleaning out, however it does not boot!

USB power on the Pi 2B is disabled until the Pi has started to boot, so that's not the problem. Have you been through the "Not Booting" Sticky post in troubleshooting? (Which is probably where this post should be moved to). Hi yes I have - basically both LED's on = SD card not found. My SD card and...
by HypnoToad
Mon Jul 29, 2019 2:16 am
Forum: For sale
Topic: 2x 7" 1024x600 screens
Replies: 3
Views: 6848

Re: 2x 7" 1024x600 screens

k-pi wrote:
Tue Mar 05, 2019 4:24 pm
....& might be helpful to know if they are regular screens, or touchscreens.

(At the price, I would imagine regular.)
going by the pics, they are non-touch

Could you post the model number written on the screens, I'd like to find out if they are IPS :)
by HypnoToad
Mon Jul 29, 2019 1:01 am
Forum: Troubleshooting
Topic: Found a RPi2 while cleaning out, however it does not boot!
Replies: 10
Views: 471

Found a RPi2 while cleaning out, however it does not boot!

As soon as I power it up I get both on board LED's light up and stay on. Most info says this is due to the SD card not being found. I've tried the same (official) PSU and SD card in another working RPi3, so it have to be the RPi2 PCB at fault. The SD card slot physically looks good. Using a Multimet...
by HypnoToad
Fri Jun 21, 2019 3:51 pm
Forum: Advanced users
Topic: Moving Linux kernel to 4.19
Replies: 270
Views: 83904

Re: Moving Linux kernel to 4.19

cjan wrote:
Fri Jun 21, 2019 1:15 am
HypnoToad wrote:
Thu Jun 20, 2019 11:39 pm
Is there any change of having the Edimax EW-7811Un USB wifi adaptor work in the 4.19.x kernel?
no problem here, just blacklist rtl8192cu and use 8192cu module.
Ok thanks, I'll look up how to do this and give it a try. :)
by HypnoToad
Thu Jun 20, 2019 11:39 pm
Forum: Advanced users
Topic: Moving Linux kernel to 4.19
Replies: 270
Views: 83904

Re: Moving Linux kernel to 4.19

Is there any change of having the Edimax EW-7811Un USB wifi adaptor work in the 4.19.x kernel? It used to work OK in older kernels but I 4.19 I get a Kernel Panic. I had a serial console cable connected at the time so the dump is here if it helps: https://paste2.org/abJzkwHw As soon as I switch to a...
by HypnoToad
Tue May 21, 2019 10:18 pm
Forum: Networking and servers
Topic: My Rpi wifi access point stops working after 7 days/1 week.
Replies: 8
Views: 632

Re: My Rpi wifi access point stops working after 7 days/1 week.

Raspbian/Debian comes with administrative tasks defined in /etc/cron.hourly | .daily | .weekly | .monthly Most of these tasks run early in the morning. Thanks, I've had a look in these folders and there are quite a few files, mainly related to 'pi-hole' software which is also installed on this Pi; ...
by HypnoToad
Fri May 17, 2019 3:29 pm
Forum: Networking and servers
Topic: My Rpi wifi access point stops working after 7 days/1 week.
Replies: 8
Views: 632

Re: My Rpi wifi access point stops working after 7 days/1 week.

Which OS is that? Raspbian Stretch? Yep, Raspbian GNU/Linux 9 (stretch), I've kept it up to date. Here's the kernel version: Linux 4.14.84-v7+ #1169 SMP Thu Nov 29 16:20:43 GMT 2018 armv7l GNU/Linux I'm using a good SD card and the official PSU. The uptime is around 2 days so will have to wait 5 mo...
by HypnoToad
Fri May 17, 2019 3:18 pm
Forum: Networking and servers
Topic: My Rpi wifi access point stops working after 7 days/1 week.
Replies: 8
Views: 632

Re: My Rpi wifi access point stops working after 7 days/1 week.

Does it happen in the wee hours of day 7? Once the Uptime goes over 7 days, the Wifi devices that are connected to the RPi access point simply disconnect from the LAN, they are no longer accessable. I can still access the RPi over SSH however, the ethernet connection does not fail. I was thinking i...
by HypnoToad
Thu May 16, 2019 2:19 am
Forum: Off topic discussion
Topic: Should the Pi Forum switch to Discourse?
Replies: 42
Views: 4690

Re: Should the Pi Forum switch to Discourse?

I do prefer the older php style forums, but that's mostly due to the fact that it's what I'm used to. I do also use a few Discourse forums, and while they are functional, it still feels off. Maybe it feels slow, or feels confusing as It's not what I"m used to, but if all forums go to Discourse then ...
by HypnoToad
Thu May 16, 2019 1:14 am
Forum: Networking and servers
Topic: My Rpi wifi access point stops working after 7 days/1 week.
Replies: 8
Views: 632

My Rpi wifi access point stops working after 7 days/1 week.

Hi, I've got a bit of an odd issue, I have a RPi2 along with a USB wifi adaptor, and I've got it set up to allow Wifi network access, and the RPi is connected to my LAN with an Ethernet cable. I used the official guide here: https://www.raspberrypi.org/documentation/configuration/wireless/access-poi...
by HypnoToad
Sat Jul 21, 2018 4:27 pm
Forum: Networking and servers
Topic: Is it possible to show wireless clients IP addresses connected to a RPI Hotspot?
Replies: 2
Views: 1472

Is it possible to show wireless clients IP addresses connected to a RPI Hotspot?

I've followed the guide here: https://www.raspberrypi.org/documentation/configuration/wireless/access-point.md to create a wireless access point with internet access, and it's been working well for around 2 weeks now. I'd like to the able to see the IP addresses of the devices connected to the hotsp...
by HypnoToad
Tue Apr 17, 2018 11:13 am
Forum: Raspbian
Topic: Which is the best browser for a node red dashboard in fullscreen mode?
Replies: 0
Views: 880

Which is the best browser for a node red dashboard in fullscreen mode?

Hi, I'm running the latest raspbian stretch on a Pi2, and it works great, and I've recently added the 7" touchscreen. So far I'm playing around with nodered and made a dashboard that works great with the touchscreen, however the bundled browser (chromium) seems a little slow. The people behind noder...
by HypnoToad
Wed May 10, 2017 12:15 am
Forum: Raspbian
Topic: Has anyone managed to use 'avconv' to encode 4k video?
Replies: 2
Views: 613

Re: Has anyone managed to use 'avconv' to encode 4k video?

Thanks, I'll try setting up a swap file and see if I still get the same problem.
by HypnoToad
Mon May 01, 2017 1:07 am
Forum: Raspbian
Topic: Has anyone managed to use 'avconv' to encode 4k video?
Replies: 2
Views: 613

Has anyone managed to use 'avconv' to encode 4k video?

on Jessie? I'm trying to encode some still frames taken from the camera and would like to view them on a 4k display, but I'm getting 'malloc' errors. I've encoded videos in the past at lower resolutions without issue. Here's the command line I'm using: avconv -i %04d.jpg -c:v libx264 -crf 20 -preset...

Go to advanced search