Go to advanced search

by IgorEE
Mon Mar 07, 2016 8:13 pm
Forum: Raspbian
Topic: PowerOff Script execution at shutdown not working
Replies: 17
Views: 6388

Re: PowerOff Script execution at shutdown not working

Hi fanoush,

That makes sense and I expect you are correct. I was just worried that this may eventually result in corruption of the SD card but looking through the setup again I am fairly sure the SD card is unmounted / mounted RO before the power is cut.

Regards,
-Igor
by IgorEE
Sun Mar 06, 2016 9:45 pm
Forum: Raspbian
Topic: PowerOff Script execution at shutdown not working
Replies: 17
Views: 6388

Re: PowerOff Script execution at shutdown not working

Hi Paulv, But what happens if the power is NOT cut? Do you see the message I posted? If I have my power circuit connected, the last thing I see is the poweroff message and the system is then powered off, but if my power circuit is NOT connected, then I see the poweroff message, and after a few secon...
by IgorEE
Sun Feb 28, 2016 12:37 am
Forum: Raspbian
Topic: PowerOff Script execution at shutdown not working
Replies: 17
Views: 6388

Re: PowerOff Script execution at shutdown not working

Hi, First of all I would like to thank you all for the replies that helped me make sense of things. I ended up following paulv's advice and using the dtoverlay. I added the following line to the /boot/config.txt file: dtoverlay=gpio-poweroff,gpiopin=8,active_low and after a reboot, the system functi...
by IgorEE
Fri Feb 26, 2016 8:51 am
Forum: Raspbian
Topic: PowerOff Script execution at shutdown not working
Replies: 17
Views: 6388

PowerOff Script execution at shutdown not working

Hi, I've made an RPi "hat" PCB with various hardware resources on it for RPi 2 Model B. Among other things, there is an external power supply on this board which provides the 5V required to the RPi via the GPIO header. This power supply is controlled via GPIO8 (BCM numbering - this is pin 24 on the ...
by IgorEE
Sun Nov 01, 2015 4:09 am
Forum: Compute Module
Topic: Rpi Cam and RTC
Replies: 1
Views: 593

Rpi Cam and RTC

Hi, I'm making a custom board for the compute module and I've run into a little bit of confusion in regards to pin mappings. I would like to use one RPi camera, but would also like to have a RTC on the board. From what I've gathered, I should make the hardware connections as follows: GPIO0 - Camera ...
by IgorEE
Mon Jan 26, 2015 5:39 pm
Forum: Compute Module
Topic: CM and LAN9514
Replies: 28
Views: 14954

Re: CM and LAN9514

It seems we've managed to get the CM and LAN9514 working correctly the same way they are on the model B+. We needed to output a 25MHz clock on the GPIO44, and all the information on how to do this can be found at the following link: https://github.com/raspberrypi/documentation/blob/master/configurat...
by IgorEE
Sat Jan 24, 2015 6:46 pm
Forum: Compute Module
Topic: CM and LAN9514
Replies: 28
Views: 14954

Re: CM and LAN9514

Hi, I've gotten a board with LAN9514 manufactured and I'm currently booting the compute module successfully, but unfortunately I have no USB not Ethernet - as a matter of fact the LAN9514 is not getting recognized at all. Now this might be due to a number of things, including design and/or assembly ...
by IgorEE
Thu Dec 18, 2014 12:04 pm
Forum: Compute Module
Topic: CM and LAN9514
Replies: 28
Views: 14954

Re: CM and LAN9514

Another quick question, GPIO44 is the clock for the LAN9514 and it is connected to XI pin of the LAN9514. This signal also has a 33ohm resistor between the CM and the XI on LAN9514, it is pulled down by a 100k resistor near the XI pin of the LAN9514, but does it need another 100k pulldown near the C...
by IgorEE
Mon Dec 15, 2014 6:42 pm
Forum: Compute Module
Topic: CM and LAN9514
Replies: 28
Views: 14954

Re: CM and LAN9514

Thanks Gordon,

I have included the 33ohm resistor, but it is on another schematic sheet (with the CM and other stuff) so it doesn't show in the page I posted above.

Any other potential problems anyone has spotted?

Thanks!
-Igor
by IgorEE
Sun Dec 14, 2014 7:45 pm
Forum: Compute Module
Topic: CM and LAN9514
Replies: 28
Views: 14954

Re: CM and LAN9514

Hi gsh, Thanks for the helpful info. I have a final schematic which can be viewed here . It doesn't show an inline 33ohm resistor which is on GPIO44 (CLOCK) close to the CM. If anyone who has time to have a look and notices anything off please let me know as I will commit this to manufacture in a fe...
by IgorEE
Fri Dec 12, 2014 11:35 am
Forum: Compute Module
Topic: CM and LAN9514
Replies: 28
Views: 14954

Re: CM and LAN9514

Hi mahjongg, That was very helpful, especially for the info about the 33Ohm 100k pulldown for the XI pin of the LAN9514. Thank you. With your information and buzzing out the B+ board I came out with the following circuit: USB Power Management Does that seem right? The question still remains though, ...
by IgorEE
Thu Dec 11, 2014 6:11 pm
Forum: Compute Module
Topic: CM and LAN9514
Replies: 28
Views: 14954

Re: CM and LAN9514

Arm2,

The full B+ schematics have not been released and the page of the schematic that has been released does not address any of the mentioned issues.

-Igor
by IgorEE
Thu Dec 11, 2014 12:48 pm
Forum: Compute Module
Topic: CM and LAN9514
Replies: 28
Views: 14954

CM and LAN9514

Hi, I am trying to make my own board to host the CM, and I would like to use the LAN9514 as on the RPi Model B+. I have read all threads on the subject on this forum, and I would like to share my schematic (attached). I would appreciate it if someone has the time to have a look over and point out an...

Go to advanced search