Go to advanced search

by wpt-nathan
Fri Jun 08, 2018 3:12 pm
Forum: OpenMAX
Topic: h264 SPS frame timing info loses precision
Replies: 3
Views: 5937

Re: h264 SPS frame timing info loses precision

I made a mistake in my post. The calculation for xFrametrate I am setting is ( 60000 << 16 ) / 1001 for 59.94. Sorry if that may have caused confusion. While being able to set num_units_in_tick and time_scale to 1001 and 60000 respectively would be ideal, I understand it is not practical. An option ...
by wpt-nathan
Thu Jun 07, 2018 8:47 pm
Forum: OpenMAX
Topic: h264 SPS frame timing info loses precision
Replies: 3
Views: 5937

h264 SPS frame timing info loses precision

Hi All, I'm trying to enable timing info in the h264 SPS via OMX_IndexParamBrcmVideoAVCSPSTimingEnable. The timing info is being emitted, but it is incorrect compared to what is set in xFramerate. I've set xFramerate to 59.94 ( xFramerate = ( 30000 << 16 ) / 1001 ) but the resulting timing shows a f...
by wpt-nathan
Mon Jun 15, 2015 1:51 am
Forum: Advanced users
Topic: hdmi_timings pixel clock constraints
Replies: 2
Views: 5286

Re: hdmi_timings pixel clock constraints

Through some trial and error experimentation I figured out why I couldn't get the pixel clock I wanted. By reading the DPI clock control registers I observed that for low frequencies, such as the 6Mhzish clock I was aiming for, the OSC is used, which is 19.2 Mhz. However, the boot code seems to only...
by wpt-nathan
Mon Jun 08, 2015 10:26 pm
Forum: Advanced users
Topic: hdmi_timings pixel clock constraints
Replies: 2
Views: 5286

hdmi_timings pixel clock constraints

Hi All,

Would someone be able to provide me with the constraints for the values provided to the hdmi_timings configuration option? Specifically the pixel clock. It seems at least that there is a lower limit, or that it must be a multiple of some other reference clock.

Thanks,
Nathan
by wpt-nathan
Fri Oct 24, 2014 12:33 pm
Forum: Advanced users
Topic: GPIO46 Edge Trigger
Replies: 1
Views: 627

GPIO46 Edge Trigger

Hi All, I'm trying to get an edge trigger on GPIO46. GPIO46 is the HDMI hotplug pin. I can read the value, and it is representative of the state of an HDMI connection, but I cannot get edge triggering to work. This is all done via sysfs: echo 46 > /sys/class/gpio/export echo both > /sys/class/gpio/g...

Go to advanced search